medit-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. %define name medit
  2. %define version 0.10.4
  3. Name: %{name}
  4. Version: %{version}
  5. Release: 1%{?_dist_release}
  6. Summary: Multiplatform GTK+2 text editor
  7. Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
  8. Group: Applications/Editors
  9. License: GPLv2+
  10. URL: http://mooedit.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
  12. Source1: medit_ja.po
  13. #Patch1: medit-0.9.2-do-not-update-system-files.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: cmake
  16. BuildRequires: desktop-file-utils
  17. BuildRequires: gtk2-devel glib2-devel
  18. BuildRequires: intltool
  19. BuildRequires: libxml2-devel
  20. BuildRequires: libXext-devel libICE-devel
  21. BuildRequires: pcre-devel
  22. BuildRequires: python-devel
  23. BuildRequires: pygtk2-devel
  24. %description
  25. Medit is a multiplatform GTK+2 text editor.
  26. Features:
  27. * Configurable syntax highlighting.
  28. * Configurable keyboard accelerators.
  29. * Multiplatform - works both on unix and windows.
  30. * Plugins: can be written in C or Python.
  31. * Configurable tools available from the main and context menus.
  32. They can be written in Python or Lua, or it can be a shell script.
  33. * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
  34. %description -l ja
  35. Medit はマルチプラットフォームな GTK+2 テキストエディタです。
  36. 機能一覧:
  37. * 設定可能な構文強調機能。
  38. * 設定可能なキーボードアクセラレータ。
  39. * マルチプラットフォーム - unix と windows の両者で動作。
  40. * プラグイン: C あるいは Python で作成可能。
  41. * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
  42. Python あるいは lua 、シェルスクリプトで作成可能。
  43. * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
  44. %prep
  45. %setup -q
  46. #%patch1 -p1
  47. sed -i 's|fr|fr\nja|g' po/LINGUAS
  48. %__cp -f %{SOURCE1} po/ja.po
  49. %build
  50. cmake -D CMAKE_INSTALL_PREFIX=/usr .
  51. make %{?_smp_mflags}
  52. %install
  53. rm -rf %buildroot
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. desktop-file-install --vendor="" \
  56. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  57. --mode 0644 \
  58. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  59. %post
  60. update-desktop-database %{_datadir}/applications
  61. touch --no-create %{_datadir}/icons/hicolor
  62. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  63. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  64. fi
  65. %postun
  66. update-desktop-database %{_datadir}/applications
  67. touch --no-create %{_datadir}/icons/hicolor
  68. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  69. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  70. fi
  71. %clean
  72. rm -rf %buildroot
  73. %files
  74. %defattr(-,root,root)
  75. %doc COPYING README
  76. %{_bindir}/*
  77. %{_datadir}/applications/%{name}.desktop
  78. %{_datadir}/moo
  79. %{_datadir}/pixmaps/*
  80. %{_datadir}/icons/hicolor/*
  81. %{_datadir}/locale/*
  82. %{_docdir}/%{name}/*
  83. %{_mandir}/man?/
  84. %changelog
  85. * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
  86. - new upstream release
  87. - added Japanese language file
  88. - added man directory in %files
  89. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  90. - new upstream release
  91. - applied new naming policy to spec
  92. * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
  93. - initial build for VineSeed
  94. * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
  95. + Revision: 155675
  96. - New version 0.9.2
  97. - rediff patch0
  98. + Olivier Blin <oblin@mandriva.com>
  99. - restore BuildRoot
  100. + Thierry Vignaud <tvignaud@mandriva.com>
  101. - kill re-definition of %%buildroot on Pixel's request
  102. * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
  103. + Revision: 114221
  104. - New version 0.9.0
  105. * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
  106. + Revision: 109208
  107. - New release 0.8.11
  108. * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
  109. + Revision: 59667
  110. - New version 0.8.10
  111. * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
  112. + Revision: 57568
  113. - New version 0.8.9
  114. * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
  115. + Revision: 51500
  116. - Fix file list
  117. - New version
  118. * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
  119. + Revision: 39539
  120. - SILent renew tarball
  121. - New version
  122. - New version
  123. add dirty patch that skips update-icon-cache and mime database when building
  124. + Jérôme Soyer <saispo@mandriva.org>
  125. - Import medit
  126. * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
  127. - new release
  128. * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
  129. - first spec for Mandriva