wine-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741
  1. %define pkg_major_version 1.2.1
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. # explain how to use wine with pulseaudio
  35. Source402: README-FEDORA-PULSEAUDIO
  36. Patch400: http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
  37. Patch401: http://art.ified.ca/downloads/winepulse-0.30.patch
  38. Patch402: http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
  39. Patch0: wine-prefixfonts.patch
  40. Patch1: wine-1.1.28-rpath.patch
  41. # fix #448338
  42. ## Patch2: wine-desktop-mime.patch
  43. # enable FontSmoothing by deafult
  44. Patch1000: wine-1.1.23-vine.patch
  45. # ADD ja
  46. Source801: wine_README.ja
  47. Source802: README-FEDORA-PULSEAUDIO.ja
  48. Source803: wine-README-Fedora.ja
  49. Source804: wine_README_add.ja
  50. Source805: fonts-replace-list.txt
  51. Source806: ja_fonts_replace-js2ipa.reg
  52. Source807: ja_fonts_replace-js2vl.reg
  53. Source808: ja_fonts_replace-ms2ipa.reg
  54. Source809: ja_fonts_replace-ms2vl.reg
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. Packager: daisuke, Takemikaduchi
  58. ExclusiveArch: %{ix86} x86_64
  59. #--------------------------------------------------------------------
  60. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  61. #--------------------------------------------------------------------
  62. ## FedoraCore ##
  63. BuildRequires: bison, flex
  64. BuildRequires: audiofile, audiofile-devel
  65. BuildRequires: alsa-lib-devel, esound-devel
  66. BuildRequires: freeglut-devel, lcms-devel
  67. ## BuildRequires: libieee1284-devel
  68. BuildRequires: libjpeg-devel, libpng-devel
  69. BuildRequires: libstdc++3-devel, libstdc++34-devel
  70. BuildRequires: libusb-devel
  71. BuildRequires: libxml2-devel, libxslt-devel
  72. BuildRequires: openldap-devel, ncurses-devel
  73. BuildRequires: unixODBC-devel, openssl-devel
  74. BuildRequires: sane-devel
  75. BuildRequires: zlib-devel
  76. BuildRequires: desktop-file-utils
  77. BuildRequires: fontforge
  78. ## BuildRequires: gphoto2, gphoto2-devel
  79. ## BuildRequires: jack-audio-connection-kit-devel
  80. ## BuildRequires: isdn4k-utils-devel
  81. BuildRequires: cups-devel
  82. BuildRequires: dbus-devel, hal-devel
  83. ## Requires: %{_bindir}/xmessage
  84. ## X modular(fc) > X 7.2
  85. BuildRequires: libX11-devel
  86. BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
  87. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  88. BuildRequires: libXrandr-devel
  89. BuildRequires: libXrender-devel
  90. BuildRequires: libXext-devel
  91. BuildRequires: libXinerama-devel
  92. BuildRequires: libXcomposite-devel
  93. BuildRequires: libXmu-devel
  94. BuildRequires: libXi-devel
  95. BuildRequires: libXcursor-devel
  96. BuildRequires: fontconfig-devel
  97. BuildRequires: giflib-devel
  98. BuildRequires: libtiff-devel
  99. BuildRequires: pkgconfig
  100. BuildRequires: libicu-devel
  101. BuildRequires: freetype2-devel
  102. %ifarch x86_64
  103. BuildRequires: compat32-glibc-devel
  104. BuildRequires: compat32-glibc-devel
  105. BuildRequires: compat32-libX11-devel
  106. BuildRequires: compat32-libxcb-devel
  107. BuildRequires: compat32-freetype2-devel
  108. BuildRequires: compat32-libSM-devel
  109. BuildRequires: compat32-libXext-devel
  110. BuildRequires: compat32-libXrender-devel
  111. BuildRequires: compat32-mesa-libGL-devel
  112. BuildRequires: compat32-mesa-libGLU-devel
  113. BuildRequires: compat32-libxml2-devel
  114. BuildRequires: compat32-libxslt-devel
  115. BuildRequires: compat32-openssl-devel
  116. BuildRequires: compat32-libjpeg-devel
  117. BuildRequires: compat32-libpng-devel
  118. BuildRequires: compat32-zlib-devel
  119. ## extension
  120. BuildRequires: compat32-libXcursor-devel
  121. BuildRequires: compat32-libXi-devel
  122. BuildRequires: compat32-libXxf86vm-devel
  123. BuildRequires: compat32-libXrandr-devel
  124. BuildRequires: compat32-libXinerama-devel
  125. BuildRequires: compat32-libXcomposite-devel
  126. BuildRequires: compat32-ncurses-devel
  127. BuildRequires: compat32-fontconfig-devel
  128. BuildRequires: compat32-libtiff-devel
  129. BuildRequires: compat32-openldap-devel
  130. %endif
  131. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  132. Requires(post): desktop-file-utils >= 0.8
  133. Requires(preun): /sbin/chkconfig, /sbin/service
  134. Requires(postun): /sbin/ldconfig
  135. Requires(postun): desktop-file-utils >= 0.8
  136. #--------------------------------------------------------------------
  137. %description
  138. (WINE Is Not an Emulator)
  139. While Wine is usually thought of as a Windows(TM) emulator,
  140. the Wine developers would prefer that users thought of
  141. Wine as a Windows compatibility layer for UNIX.
  142. This package includes a program loader, which allows
  143. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  144. x86_64 Unixes.
  145. Wine does not require MS Windows, but it can use native
  146. system .dll files if they are available.
  147. %description -l ja
  148. (WINE Is Not an Emulator)
  149. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  150. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  151. 互換レイヤー」と考えてくれる事を好むでしょう。
  152. このパッケージはプログラムローダーを含み、これは未修正の
  153. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  154. させます。
  155. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  156. Windows システムの .dll ファイルが存在するのならば、それを使用する
  157. 事もできます
  158. #--------------------------------------------------------------------
  159. %package devel
  160. Summary: Wine development environment
  161. Summary(ja): WINE の開発ファイルです
  162. Group: System Environment/Libraries
  163. Requires: wine = %{version}-%{release}
  164. %description devel
  165. This RPM contains the header files and development tools
  166. for the WINE libraries.
  167. %description devel -l ja
  168. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  169. アプリケーション(例:winebuild)のパッケージです
  170. (development packages)
  171. #--------------------------------------------------------------------
  172. %package init
  173. Summary: WINE binfmt_misc kernel function used for init file.
  174. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  175. Group: System Environment/Libraries
  176. Requires: wine = %{version}-%{release}
  177. %description init
  178. WINE binfmt_misc kernel function used for init file.
  179. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  180. (init.d packages)
  181. ** example **
  182. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  183. from the usual binary Linux as "$ /file/to/path/arege.exe"
  184. and just be able to run.
  185. Of course, please be mindful of security.
  186. %description init -l ja
  187. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  188. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  189. ようにします。
  190. (init.d packages)
  191. ※ 例 ※
  192. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  193. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  194. だけで実行できるようになります。
  195. 無論、セキュリティに留意して下さい。
  196. #--------------------------------------------------------------------
  197. %prep
  198. %setup -q -n %{name}-%{version}
  199. ## %patch0
  200. ## %patch1 -p1
  201. ## %patch400 -p1
  202. %patch401 -p1
  203. ## %patch402 -p1 -b .add-pa-to-winecfg
  204. %patch1000 -p1
  205. %build
  206. %ifarch x86_64
  207. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  208. ./configure \
  209. --prefix=%{_prefix} \
  210. --libdir=%{_libdir} \
  211. --with-x \
  212. --without-jack \
  213. --without-capi
  214. %else
  215. export CFLAGS="$RPM_OPT_FLAGS"
  216. %{configure} \
  217. --prefix=%{_prefix} \
  218. --with-x \
  219. --without-jack \
  220. --without-capi
  221. %endif
  222. grep "have_x=yes" config.log || exit 1
  223. %{__make} depend
  224. %{__make} %{?_smp_mflags}
  225. %install
  226. rm -rf ${RPM_BUILD_ROOT}
  227. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  228. #-----------------------------------------------------------FC9
  229. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  230. # Allow users to launch Windows programs by just clicking on the .exe file...
  231. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  232. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  233. # add wine dir to desktop
  234. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  235. install -p -m 644 %{SOURCE200} \
  236. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  237. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  238. install -p -m 644 %{SOURCE201} \
  239. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  240. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  241. ## %%{_datadir}/applications
  242. # install desktop files
  243. desktop-file-install \
  244. --vendor=vine \
  245. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  246. %{SOURCE100}
  247. desktop-file-install \
  248. --vendor=vine \
  249. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  250. %{SOURCE101}
  251. desktop-file-install \
  252. --vendor=vine \
  253. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  254. %{SOURCE102}
  255. desktop-file-install \
  256. --vendor=vine \
  257. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  258. %{SOURCE103}
  259. desktop-file-install \
  260. --vendor=vine \
  261. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  262. %{SOURCE104}
  263. desktop-file-install \
  264. --vendor=vine \
  265. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  266. %{SOURCE105}
  267. desktop-file-install \
  268. --vendor=vine \
  269. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  270. %{SOURCE106}
  271. desktop-file-install \
  272. --vendor=vine \
  273. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  274. %{SOURCE107}
  275. desktop-file-install \
  276. --vendor=vine \
  277. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  278. --delete-original \
  279. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  280. #mime-types
  281. desktop-file-install \
  282. --vendor=vine \
  283. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  284. %{SOURCE300}
  285. ## other files
  286. cp %{SOURCE3} README-Fedora
  287. cp %{SOURCE803} README-Fedora.ja
  288. cp %{SOURCE801} documentation/README.ja
  289. cp %{SOURCE804} documentation/README_add.ja
  290. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  291. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  292. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  293. # deploy pulseaudio readme (802jp)
  294. cp %{SOURCE402} .
  295. cp %{SOURCE802} .
  296. # check desktop files
  297. %check
  298. desktop-file-validate \
  299. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  300. desktop-file-validate \
  301. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  302. desktop-file-validate \
  303. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  304. desktop-file-validate \
  305. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  306. desktop-file-validate \
  307. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  308. desktop-file-validate \
  309. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  310. desktop-file-validate \
  311. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  312. desktop-file-validate \
  313. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  314. desktop-file-validate \
  315. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  316. #--------------------------------------------------------------------
  317. %clean
  318. rm -rf ${RPM_BUILD_ROOT}
  319. %post
  320. /sbin/ldconfig
  321. update-desktop-database &>/dev/null || :
  322. ### add vinelinux
  323. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  324. echo "WINEのシステムフォントをリプレースするには"
  325. echo " fonts-replace-list.txt をお読み下さい。"
  326. else
  327. echo "You need to Japanese fonts name replace, "
  328. echo "See fonts-replace-list.txt ."
  329. fi
  330. %postun
  331. /sbin/ldconfig
  332. update-desktop-database &>/dev/null || :
  333. %post init
  334. if [ $1 = 1 ]; then
  335. /sbin/chkconfig --add wine
  336. /sbin/chkconfig --level 2345 wine on
  337. /sbin/service wine start &>/dev/null || :
  338. fi
  339. ### add vinelinux
  340. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  341. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  342. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  343. echo "(ファイル名は /etc/init.d/wine です)"
  344. echo "起動時にファイルシステムのマウントが必要です。"
  345. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  346. echo "(削除も手動でお願いします)"
  347. echo ""
  348. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  349. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  350. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  351. else
  352. echo "WINE binfmt_misc feature from the boot files "
  353. echo "to be installed and enabled 2,3,4,5 runlevel."
  354. echo "(File name in the /etc/init.d/wine )"
  355. echo "Filesystem mounted at boot time is required."
  356. echo "Root privileges using the following command in the /etc/fstab"
  357. echo "please Addenda.(Please delete manually.)"
  358. echo ""
  359. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  360. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  361. echo "See also(en)http://www.linux.com/articles/56032 "
  362. fi
  363. %preun init
  364. if [ $1 = 0 ]; then
  365. /sbin/service wine stop >/dev/null 2>&1
  366. /sbin/chkconfig --del wine
  367. fi
  368. #--------------------------------------------------------------------
  369. ## deleted /usr/share/applications/wine.desktop
  370. %files
  371. %defattr(-,root,root,-)
  372. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  373. %doc README VERSION
  374. %doc README-FEDORA-PULSEAUDIO
  375. %doc README-FEDORA-PULSEAUDIO.ja
  376. %doc README-Fedora
  377. %doc README-Fedora.ja
  378. %doc documentation/README* documentation/ChangeLog*
  379. %doc documentation/ja_fonts_replace*
  380. %doc documentation/fonts-replace-list.txt
  381. ### %{_bindir}/*
  382. %{_bindir}/msiexec
  383. %{_bindir}/regedit
  384. %{_bindir}/regsvr32
  385. %{_bindir}/wine
  386. %{_bindir}/wineboot
  387. %{_bindir}/wineconsole
  388. ## %{_bindir}/wineprefixcreate
  389. %{_bindir}/winecfg
  390. %{_bindir}/wine-preloader
  391. # winelauncher --> Remove
  392. %{_bindir}/wineserver
  393. %{_bindir}/notepad
  394. %{_bindir}/winedbg
  395. %{_bindir}/winedump
  396. %{_bindir}/winefile
  397. %{_bindir}/winemaker
  398. %{_bindir}/winemine
  399. %{_bindir}/winepath
  400. ## winhelp -> renamed winhlp32.exe
  401. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  402. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  403. %{_libdir}/libwine.so.1*
  404. %dir %{_libdir}/wine
  405. %{_libdir}/wine/*.cpl.so
  406. %{_libdir}/wine/*.exe.so
  407. %{_libdir}/wine/*.exe16.so
  408. %{_libdir}/wine/*.dll.so
  409. %{_libdir}/wine/*.dll16.so
  410. %{_libdir}/wine/*.drv.so
  411. %{_libdir}/wine/*.drv16.so
  412. %{_libdir}/wine/*.mod16.so
  413. ## %{_libdir}/wine/*.*16
  414. %{_libdir}/wine/*.ds.so
  415. %{_libdir}/wine/*.ocx.so
  416. %{_libdir}/wine/*.vxd.so
  417. %{_libdir}/wine/*.acm.so
  418. %{_libdir}/wine/*.sys.so
  419. %{_libdir}/wine/*.tlb.so
  420. %dir %{_libdir}/wine/fakedlls
  421. %{_libdir}/wine/fakedlls/*
  422. %dir %{_datadir}/wine
  423. %{_datadir}/wine/*
  424. %{_datadir}/applications/vine-wine-mime-msi.desktop
  425. %{_datadir}/applications/vine-wine.desktop
  426. %{_datadir}/applications/vine-wine-regedit.desktop
  427. %{_datadir}/applications/vine-wine-uninstaller.desktop
  428. %{_datadir}/applications/vine-wine-winecfg.desktop
  429. %{_datadir}/applications/vine-wine-wineboot.desktop
  430. %{_datadir}/applications/vine-wine-notepad.desktop
  431. %{_datadir}/applications/vine-wine-winefile.desktop
  432. %{_datadir}/applications/vine-wine-winemine.desktop
  433. %{_datadir}/applications/vine-wine-winhelp.desktop
  434. %{_datadir}/desktop-directories/Wine.directory
  435. %{_mandir}/man1/wine.1.*
  436. %{_mandir}/man1/wineserver.1*
  437. ## %{_mandir}/man1/wineprefixcreate.1*
  438. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  439. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  440. #--------------------------------------------------------------------
  441. %files devel
  442. %defattr(-,root,root,-)
  443. %{_bindir}/function_grep.pl
  444. %{_bindir}/widl
  445. %{_bindir}/winebuild
  446. %{_bindir}/winecpp
  447. %{_bindir}/winedump
  448. %{_bindir}/wineg++
  449. %{_bindir}/winegcc
  450. %{_bindir}/winemaker
  451. %{_bindir}/wmc
  452. %{_bindir}/wrc
  453. %{_includedir}/wine
  454. %{_libdir}/*.so
  455. %{_libdir}/wine/*.a
  456. %{_libdir}/wine/*.def
  457. %{_mandir}/man1/widl.1*
  458. %{_mandir}/man1/winebuild.1*
  459. %{_mandir}/man1/winedump.1*
  460. %{_mandir}/man1/winegcc.1*
  461. %{_mandir}/man1/winemaker.1*
  462. %{_mandir}/man1/winedbg.1*
  463. %{_mandir}/man1/wineg++.1*
  464. %{_mandir}/man1/wmc.1*
  465. %{_mandir}/man1/wrc.1*
  466. #--------------------------------------------------------------------
  467. %files init
  468. %defattr(-,root,root,-)
  469. %{_initrddir}/wine
  470. %doc documentation/README_add.ja
  471. #--------------------------------------------------------------------
  472. %changelog
  473. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  474. - new upstream release
  475. - drop Patch1
  476. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  477. - new upstream release
  478. - fix %configure (add configu:e and gcc option of x86_64)
  479. - fix %install (remove wine.desktop and change make install option)
  480. - add ExclusiveArch: %{ix86} x86_64
  481. - add BuildRequires for x86_64 (compat32 packages)
  482. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  483. - update to 1.2-rc2
  484. - fix spec file
  485. - if [ "$LANG" = "ja_JP.eucJP" ];
  486. + if [ "$LANG" = "ja_JP.UTF-8" ];
  487. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  488. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  489. - fix %files
  490. - drop patches (Patch0, Patch400, Patch402)
  491. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  492. - update BRs
  493. - remove freetype-devel
  494. - remove libungif-devel, add giflib-devel
  495. - remove gphoto2-devel, add libgphoto2-devel
  496. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  497. - update to 1.1.29
  498. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  499. - update to 1.1.28
  500. - update winepulse patches
  501. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  502. - update to 1.1.23
  503. - spec in utf-8
  504. - add patch1000 to enable FontSmoothing by deafult.
  505. - update pulseaudio patches
  506. - remove invalid Provides: Wine HQ
  507. - remove unneeded patches
  508. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  509. - Wine development release 1.1.0.
  510. - Updated specfile (for VineSeed)
  511. #--------------------------------------------------------------------
  512. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  513. - added "ja_fonts_replace-*.reg" files.
  514. - Updated specfile
  515. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  516. - version upgrade
  517. - Updated specfile
  518. - Update to 1.0
  519. - fix wine.desktop mime types (fc)
  520. - add desktop package including desktop files and binary handler (fc)
  521. - pull in some wine alsa/pulseaudio patches (fc)
  522. -- NEWS "June 17, 2008: Wine 1.0 Released"
  523. -- read http://www.winehq.org/?issue=348
  524. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  525. - Updated specfile
  526. - Update to 1.0-rc4
  527. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  528. -- ntdll: Add local defines for VIF and VIP flags.
  529. -- wininet: Include openssl/ssl.h before Windows headers.
  530. -- shell32: Fixed the French about box.
  531. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  532. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  533. -- ....others , read ChangeLog
  534. --- Bug fixes only, we are in code freeze.
  535. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  536. - Updated specfile
  537. - Update to 1.0-rc3
  538. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  539. -- The default version is now Windows XP.
  540. -- Many Richedit improvements.
  541. -- Beginning of jscript dll support.
  542. -- Shell folders now respect XDG directory configuration.
  543. -- Many translation updates.
  544. -- Lots of bug fixes.
  545. -- * Bug fixes only, we are in code freeze.
  546. --- kernel32: Add a builtin 16-bit winhelp.exe.
  547. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  548. --- executables.
  549. ---- winhelp -> renamed winhlp32.exe
  550. ---- programs: Remove winelauncher from install rules.
  551. * Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
  552. - Updated specfile
  553. - Update to 0.9.59
  554. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  555. -- * Improved support for the .NET framework.
  556. -- * Better services handling through a separate services.exe process.
  557. -- * Support for ATI fragment shader.
  558. -- * Better support for http proxies.
  559. -- * Window management fixes.
  560. -- * Pre-compiled fonts are now available in the source tree.
  561. -- * Lots of bug fixes.
  562. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  563. - Updated specfile (split wine-init package)
  564. - Update to 0.9.58
  565. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  566. -- * The default version is now Windows XP.
  567. -- * Many Richedit improvements.
  568. -- * Beginning of jscript dll support.
  569. -- * Shell folders now respect XDG directory configuration.
  570. -- * Many translation updates.
  571. -- * Lots of bug fixes.
  572. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  573. - Updated specfile (*.desktop file %check .)
  574. - Update to 0.9.57
  575. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  576. -- * Support for multiple OpenGL pixel formats.
  577. -- * Improved support for color profiles.
  578. -- * Many window management fixes.
  579. -- * Better fullscreen support.
  580. -- * Lots of bug fixes.
  581. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  582. - Updated specfile
  583. - ("Build Tool" from the wine-package to move to devel-packages)
  584. - Update to 0.9.56
  585. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  586. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  587. -- * Stubs for all the d3dx9_xx dlls.
  588. -- * Several graphics optimizations.
  589. -- * Many installer fixes.
  590. -- * Improved MIME message support.
  591. -- * Lots of bug fixes.
  592. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  593. - Updated specfile (cf. VineLinux .spec file format)
  594. - Add Installed messages for "binfmt_misc" .
  595. - *.desktop file "Name" change to japanese. (UTF8)
  596. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  597. - Import WINE - Packager: Babasaki
  598. - Updated specfile (SUSE base + FC9 cfg)
  599. - Update to 0.9.55
  600. - Update to 0.9.54 from FC9
  601. - Update to 0.9.53 from Private package
  602. # FC9 ------------------------------------------------------------- FC9
  603. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  604. - 0.9.55-1
  605. - version upgrade
  606. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  607. - 0.9.54-1
  608. - version upgrade
  609. - remove default pulseaudio workaround (#429420,#428745)
  610. - improve pulseaudio readme
  611. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  612. - 0.9.53-2
  613. - add some missing BR
  614. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  615. - 0.9.53-1
  616. - version upgrade
  617. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  618. - 0.9.52-2
  619. - fix menu bug (#393641)
  620. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  621. - 0.9.52-1
  622. - version upgrade
  623. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  624. - 0.9.51-3
  625. - add -n Wine to pulseaudio workaround
  626. - try to fix menu bug #393641
  627. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  628. - 0.9.51-2
  629. - add fix for #344281 pulseaudio workaround
  630. - fix #253474: wine-jack should require jack-audio-connection-kit
  631. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  632. - 0.9.51-1
  633. - version upgrade
  634. # ---- abbreviatio ----------------------------------------------------#
  635. # ----------and suse.
  636. # * Fri Mar 17 2006 - meissner@suse.de
  637. # - Avoid ulimit leading to out of memory situations by using
  638. # the compat address space layout personality. #152115