123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109 |
- %global with_python3 0
- %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
- Name: python-markupsafe
- Version: 0.9.2
- Release: 1%{?_dist_release}
- Summary: Implements a XML/HTML/XHTML Markup safe string for Python
- Group: Development/Languages
- License: BSD
- URL: http://pypi.python.org/pypi/MarkupSafe
- Source0: http://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: python-devel python-setuptools
- %if 0%{?with_python3}
- BuildRequires: python3-devel python3-setuptools
- # For /usr/bin/2to3
- BuildRequires: python-tools
- %endif # if with_python3
- %description
- A library for safe markup escaping.
- %if 0%{?with_python3}
- %package -n python3-markupsafe
- Summary: Implements a XML/HTML/XHTML Markup safe string for Python
- Group: Development/Languages
- %description -n python3-markupsafe
- A library for safe markup escaping.
- %endif #if with_python3
- %prep
- %setup -q -n MarkupSafe-%{version}
- %if 0%{?with_python3}
- %__rm -rf %{py3dir}
- %__cp -a . %{py3dir}
- 2to3 --write --nobackups %{py3dir}
- %endif # with_python3
- %build
- CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
- %if 0%{?with_python3}
- pushd %{py3dir}
- CFLAGS="$RPM_OPT_FLAGS" %{__python3} setup.py build
- popd
- %endif # with_python3
- %install
- %__rm -rf $RPM_BUILD_ROOT
- %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
- # C code errantly gets installed
- %__rm $RPM_BUILD_ROOT/%{python_sitearch}/markupsafe/*.c
- %if 0%{?with_python3}
- pushd %{py3dir}
- %{__python3} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
- %__rm $RPM_BUILD_ROOT/%{python3_sitearch}/markupsafe/*.c
- popd
- %endif # with_python3
- %check
- %{__python} setup.py test
- %if 0%{?with_python3}
- pushd %{py3dir}
- %{__python3} setup.py test
- popd
- %endif # with_python3
- %clean
- %__rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS LICENSE README.rst
- %{python_sitearch}/*
- %if 0%{?with_python3}
- %files -n python3-markupsafe
- %defattr(-,root,root,-)
- %doc AUTHORS LICENSE README.rst
- %{python3_sitearch}/*
- %endif # with_python3
- %changelog
- * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.9.2-1
- - initial build based on Fedora development
- * Fri Jul 23 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.2-4
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Thu Jun 24 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-3
- - Fix missing setuptools BuildRequires.
- * Thu Jun 24 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-2
- - Fixed sitearch and python3 definitions to work better with older Fedora/RHEL.
- * Wed Jun 23 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-1
- - Initial version.
|