123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207 |
- %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
- %define pkg_release 2%{?_dist_release}
- Summary: Python wrapper module around the OpenSSL library
- Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
- Name: pyOpenSSL
- Version: 0.7
- Release: %{pkg_release}
- Source0: http://pyopenssl.sf.net/%{name}-%{version}.tar.gz
- Patch0: pyOpenSSL-0.7-openssl.patch
- Patch2: pyOpenSSL-elinks.patch
- Patch3: pyOpenSSL-nopdfout.patch
- Patch4: pyOpenSSL-threadsafe.patch
- License: LGPLv2+
- Group: Development/Libraries
- URL: http://pyopenssl.sourceforge.net/
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: openssl-devel, python-devel
- BuildRequires: tetex, latex2html
- %description
- High-level wrapper around a subset of the OpenSSL library, includes
- * SSL.Connection objects, wrapping the methods of Python's portable
- sockets
- * Callbacks written in Python
- * Extensive error-handling mechanism, mirroring OpenSSL's error codes
- ... and much more ;)
- %prep
- %setup -q
- %patch0 -p1 -b .openssl097
- %patch2 -p1 -b .elinks
- %patch3 -p1 -b .nopdfout
- %patch4 -p1 -b .threadsafe
- # Fix permissions for debuginfo package
- %{__chmod} -x src/ssl/connection.c
- %build
- CFLAGS="%{optflags}" %{__python} setup.py build
- %{__make} -C doc ps
- %{__make} -C doc text html
- %install
- %{__rm} -rf %{buildroot}
- %{__python} setup.py install -O1 --skip-build --root %{buildroot}
- %clean
- %{__rm} -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %doc README doc/pyOpenSSL.ps
- %doc doc/pyOpenSSL.txt doc/html
- %{python_sitearch}/OpenSSL/
- %{python_sitearch}/%{name}*.egg-info
- %changelog
- * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
- - rebuilt with python-2.6.4
- * Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
- - initial build for Vine Linux based on fedora package
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
- - Rebuild for Python 2.6
- * Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
- - update threadsafe patch
- - bug#462807
- * Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
- - bump to new release
- - the inevitable patch fixes
- * Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
- - fix horrific release tag
- - fix license tag
- - add egg-info
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
- - Autorebuild for GCC 4.3
- * Wed Dec 5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
- - rebuild for new openssl
- * Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
- - add missing buildreq latex2html, needed to build HTML docs
- - rewrite to be more in line with Fedora python spec template and use
- %%{python_sitearch} rather than a script-generated %%files list
- - package is not relocatable - drop Prefix: tag
- - buildreq perl not necessary
- - fix permissions for files going into debuginfo package
- * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
- - rebuild for python 2.5
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
- - rebuild
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Wed Nov 9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
- - rebuilt against newer openssl
- * Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
- - add dcbw's patch to fix some threading problems
- * Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
- - current rpm creates .pyo files, include them in filelist
- * Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
- - rebuilt
- * Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
- - rebuilt
- * Mon Mar 7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
- - rebuild with openssl-0.9.7e
- * Tue Nov 9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
- - rebuild
- * Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
- - 0.6 is out
- * Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
- - release candidate
- * Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
- - rebuilt
- * Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
- - rebuilt
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Wed Nov 5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
- - rebuilt against python 2.3.2
- * Fri Aug 8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
- - lynx no longer supported, using elinks instead (patch from
- Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
- * Wed Jun 4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
- - Rebuilt
- * Wed Jun 4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
- - Built on 7.x
- * Mon Mar 3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
- - bug #73967: Added Requires: python
- * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
- - bug #84803: Added patch to expose more flags
- * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
- - installing to %%{_libdir}
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- - rebuilt
- * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
- - rebuild
- * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
- - Add -I and -L flags for finding Kerberos headers and libraries, in case
- they're referenced
- * Tue Dec 3 2002 Mihai Ibanescu <misa@redhat.com>
- - Fix for bug 73967: site-packages/OpenSSL not owned by this package
- - Adding hacks around the lack of latex2html on ia64
- * Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
- - 0.5.1
- * Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
- - Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
- error of pushing 0.5pre previously, since it breaks rpm's version comparison
- algorithm).
- - We use %%{__python}. Too bad I can't pass --define's to distutils.
- * Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
- - Building 0.5
- * Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
- - Added documentation
|