openssl098-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 6
  3. %define version 0.9.8r
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl098
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. # Source6: openssl-%{version}.pc
  14. Patch0: openssl-0.9.8b-soversion.patch
  15. Patch2: openssl-0.9.8e-rpm_opt.patch
  16. Patch4: openssl-0.9.8p-enginesdir.patch
  17. # security fix
  18. # nothing ;-)
  19. License: BSDish
  20. Group: System Environment/Libraries
  21. URL: http://www.openssl.org/
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: perl, sed
  24. Requires: mktemp
  25. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  29. %description
  30. The OpenSSL certificate management tool and the shared libraries that
  31. provide various cryptographic algorithms and protocols.
  32. ## to build compat32 for x86_64 architecture support
  33. %package -n compat32-%{name}
  34. Summary: Secure Sockets Layer Toolkit
  35. Group: System Environment/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. %description -n compat32-%{name}
  38. The OpenSSL certificate management tool and the shared libraries that
  39. provide various cryptographic algorithms and protocols.
  40. %prep
  41. %setup -q -n openssl-%{version}
  42. %patch0 -p1 -b .soversion
  43. %patch2 -p1 -b .rpm_opt
  44. %patch4 -p1 -b .enginesdir
  45. # security fix
  46. # nothing ;-)
  47. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  48. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  49. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  50. chmod 644 doc/ssleay.txt
  51. # Link the configuration header to the one we're going to make.
  52. ln -sf ../../crypto/opensslconf.h include/openssl/
  53. %build
  54. PATH=${PATH}:${PWD}/bin
  55. TOPDIR=${PWD}
  56. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  57. # Figure out which flags we want to use. Can't use assembler because it's
  58. # not lowest-common-denominator in most cases.
  59. perl util/perlpath.pl `dirname %{__perl}`
  60. %ifarch %ix86
  61. sslarch=linux-elf
  62. sslflags="no-asm 386"
  63. %endif
  64. %ifarch ppc
  65. sslarch=linux-ppc
  66. sslflags=no-asm
  67. %endif
  68. %ifarch sparc
  69. sslarch=linux-sparcv9
  70. sslflags=no-asm
  71. %endif
  72. %ifarch ia64
  73. sslarch=linux-ia64
  74. sslflags=no-asm
  75. %endif
  76. %ifarch alpha
  77. sslarch=linux-alpha-gcc
  78. sslflags=no-asm
  79. %endif
  80. %ifarch s390
  81. sslarch=linux-s390
  82. %endif
  83. %ifarch s390x
  84. sslarch=linux-s390x
  85. %endif
  86. %ifarch mipsel
  87. sslarch=linux-mips
  88. sslflags=no-asm
  89. %endif
  90. ## to build for x86_64 architecture support
  91. %ifarch x86_64
  92. sslarch=linux-x86_64
  93. sslflags=no-asm
  94. %endif
  95. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  96. # usable on all platforms. The Configure script already knows to use -fPIC and
  97. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  98. ./Configure \
  99. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  100. --enginesdir=%{_libdir}/openssl/engines \
  101. shared ${sslarch}
  102. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  103. # marked as not requiring an executable stack.
  104. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  105. make depend
  106. make all build-shared
  107. # Generate hashes for the included certs.
  108. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  109. export LD_LIBRARY_PATH
  110. make rehash build-shared
  111. # Verify that what was compiled actually works.
  112. make -C test apps tests
  113. # Relink the main binary to get it dynamically linked.
  114. rm apps/openssl
  115. make all build-shared
  116. %install
  117. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  118. # Install OpenSSL.
  119. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  120. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  121. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  122. # added for lib64
  123. mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  124. mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  125. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  126. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  127. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  128. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  129. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  130. chmod 755 ${lib}
  131. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  132. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  133. done
  134. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  135. # Install a makefile for generating keys and self-signed certs, and a script
  136. # for generating them on the fly.
  137. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  138. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  139. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  140. # Make sure we actually include the headers we built against.
  141. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  142. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  143. install -m644 include/openssl/`basename ${header}` ${header}
  144. fi
  145. done
  146. # Rename man pages so that they don't conflict with system man pages. We used
  147. # to change the file extensions, but that only prevents file conflicts. The
  148. # man viewer still can't select either of the two unless we physically change
  149. # the directory.
  150. for section in 1 2 3 4 5 6 7 8 ; do
  151. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  152. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  153. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  154. fi
  155. done
  156. # Pick a CA script.
  157. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  158. mv CA.sh CA
  159. popd
  160. # Install root CA stuffs.
  161. cat %{SOURCE3} > ca-bundle.crt
  162. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  163. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  164. # Fix libdir.
  165. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  166. # sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  167. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  168. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  169. # cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  170. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  171. # rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  172. %clean
  173. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  174. %files
  175. %defattr(-,root,root)
  176. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  177. %doc doc/README doc/c-indentation.el doc/openssl.txt
  178. %doc doc/openssl_button.html doc/openssl_button.gif
  179. %doc doc/ssleay.txt
  180. # %dir %{_datadir}/ssl
  181. # %{_datadir}/ssl/certs
  182. # %{_datadir}/ssl/cert.pem
  183. # %{_datadir}/ssl/misc/CA
  184. # %{_datadir}/ssl/misc/c_*
  185. # %{_datadir}/ssl/private
  186. # %config(noreplace) %{_datadir}/ssl/openssl.cnf
  187. # %attr(0755,root,root) %{_bindir}/openssl
  188. %attr(0755,root,root) /%{_lib}/*.so.*
  189. # %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  190. # %attr(0755,root,root) %dir %{_mandir}/man1*
  191. # %attr(0644,root,root) %{_mandir}/man1*/*
  192. # %attr(0755,root,root) %dir %{_mandir}/man5*
  193. # %attr(0644,root,root) %{_mandir}/man5*/*
  194. # %attr(0755,root,root) %dir %{_mandir}/man7*
  195. # %attr(0644,root,root) %{_mandir}/man7*/*
  196. ## to build compat32 for x86_64 architecture support
  197. %if %{build_compat32}
  198. %files -n compat32-%{name}
  199. %defattr(-,root,root)
  200. %attr(0755,root,root) /%{_lib}/*.so.*
  201. %endif
  202. %post -p /sbin/ldconfig
  203. %postun -p /sbin/ldconfig
  204. %post -n compat32-%{name} -p /sbin/ldconfig
  205. %postun -n compat32-%{name} -p /sbin/ldconfig
  206. %changelog
  207. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8r-1
  208. - new upstream release with security fix
  209. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  210. - new upstream release with security fix
  211. - update patch4
  212. * Wed Mar 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-2
  213. - fix files list (unneeded files were included in package)
  214. * Tue Mar 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-1
  215. - new compatible package openssl 0.9.8n for upgrade openssl 1.0.0
  216. * Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
  217. - new upstream release
  218. - update enginsdir patch (Patch4)
  219. - drop unnecessary patch: upstream fixed
  220. - dtls dos patch (Patch10)
  221. - CVE-2009-4355 (memory leak) patch (Patch11)
  222. - CVE-2009-3555 (renegotiation) patch (Patch12)
  223. - update SOURCE6 for pkgconfig
  224. - replace BuildPreReq to BuildRequires
  225. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  226. - add patch12 for fix CVE-2009-3555 (renegotiation)
  227. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  228. - add patch11 for fix CVE-2009-4355 (memory leak)
  229. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  230. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  231. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  232. - removed unnecessary %%if %{build_compat32} statements
  233. - removed lib*.a from devel package
  234. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  235. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  236. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  237. - new upstream release with security fix (CVE-2008-5077)
  238. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  239. - new upstream release
  240. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  241. - new upstream release
  242. - new versioning policy
  243. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  244. - new upstream release
  245. - drop patch10,20 which is merged in upstream
  246. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  247. - add security patch in advance for CVE-2007-5135
  248. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  249. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  250. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  251. - add security patch for CVE-2007-3108
  252. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  253. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  254. - new upstream release
  255. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  256. - update (fix) openssl.pc <BTS:437>
  257. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  258. - new upstream release (with security fix)
  259. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  260. - new upstream release
  261. - add patch2 to use RPM_OPT macro
  262. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  263. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  264. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  265. - added compat32-* packages for x86_64 architecture support
  266. - added openssl-0.9.7i.Configure-compat32.patch
  267. - changed '/lib' to '/%{_lib}'
  268. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  269. - new upstream release
  270. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  271. - rebuild on VineSeed
  272. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  273. - added a security patch from Gentoo.
  274. - Patch1: openssl-0.9.7c-tempfile.patch
  275. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  276. - sslarch for ppc was missing... added.
  277. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  278. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  279. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  280. - new upstream version
  281. - clean up of spec file
  282. -- removed old patches
  283. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  284. - new upstream release
  285. - SECURITY fix.
  286. - http://www.openssl.org/news/secadv_20040317.txt
  287. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  288. - new upstream release
  289. - [Security fix]
  290. - Vulnerabilities in ASN.1 parsing
  291. http://www.openssl.org/news/secadv_20030930.txt
  292. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  293. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  294. - add openssl.pc for pkgconfig
  295. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  296. - New upstream version
  297. - dropped patch10, 11
  298. -- merged upstream version
  299. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  300. - rebuild for VineSeed
  301. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  302. - [Security Fix]
  303. - Timing-based attacks on RSA keys
  304. http://www.openssl.org/news/secadv_20030317.txt
  305. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  306. http://www.openssl.org/news/secadv_20030317.txt
  307. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  308. - new upstream release 0.9.6i
  309. - [Security Fix]
  310. - build for Vine Linux 2.6 errata
  311. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  312. - new upstream release 0.9.6h
  313. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  314. - new upstream release 0.9.6g
  315. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  316. - SECURITY: CAN-2002-0659 fixed
  317. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  318. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  319. - update asn patch to fix accidental reversal of a logic check
  320. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  321. - update asn patch to reduce chance that compiler optimization will remove
  322. one of the added tests
  323. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  324. - rebuild
  325. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  326. - add patch to fix ASN.1 vulnerabilities
  327. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  328. - rename spec file name
  329. - SECURITY: CA-2002-23 fixed
  330. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  331. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  332. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  333. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  334. - added ${PATH} in LD_LIBRARY_PATH
  335. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  336. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  337. - remove --no-<cipher>
  338. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  339. - add Patch10 for mipsel shared ( Configure )
  340. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  341. - build for Vine Linux
  342. - use openssl-engine-0.9.6b.tar.gz
  343. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  344. - update to 0.9.6b
  345. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  346. - move .so symlinks back to %%{_libdir}
  347. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  348. - move shared libraries to /lib (#38410)
  349. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  350. - switch to engine code base
  351. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  352. - add a script for creating dummy certificates
  353. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  354. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  355. - add s390x support
  356. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  357. - change two memcpy() calls to memmove()
  358. - don't define L_ENDIAN on alpha
  359. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  360. - make subpackages depend on the main package
  361. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  362. - adjust the hobble script to not disturb symlinks in include/ (fix from
  363. Joe Orton)
  364. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  365. - drop the m2crypo patch we weren't using
  366. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  367. - configure using "shared" as well
  368. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  369. - update to 0.9.6a
  370. - use the build-shared target to build shared libraries
  371. - bump the soversion to 2 because we're no longer compatible with
  372. our 0.9.5a packages or our 0.9.6 packages
  373. - drop the patch for making rsatest a no-op when rsa null support is used
  374. - put all man pages into <section>ssl instead of <section>
  375. - break the m2crypto modules into a separate package
  376. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  377. - use BN_LLONG on s390
  378. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  379. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  380. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  381. - move c_rehash to the perl subpackage, because it's a perl script now
  382. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  383. - update to 0.9.6
  384. - enable MD2
  385. - use the libcrypto.so and libssl.so targets to build shared libs with
  386. - bump the soversion to 1 because we're no longer compatible with any of
  387. the various 0.9.5a packages circulating around, which provide lib*.so.0
  388. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  389. - change hobble-openssl for disabling MD2 again
  390. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  391. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  392. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  393. apps built against a version of the library without it
  394. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  395. - disable some inline assembly, which on x86 is Pentium-specific
  396. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  397. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  398. - fix s390 patch
  399. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  400. - added support s390
  401. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  402. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  403. - add the CA.pl man page to the perl subpackage
  404. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  405. - always build with -mcpu=ev5 on alpha
  406. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  407. - add a symlink from cert.pem to ca-bundle.crt
  408. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  409. - add a ca-bundle file for packages like Samba to reference for CA certificates
  410. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  411. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  412. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  413. - add unzip as a buildprereq (#17662)
  414. - update m2crypto to 0.05-snap4
  415. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  416. - fix some issues in building when it's not installed
  417. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  418. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  419. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  420. - add Richard Henderson's patch for BN on ia64
  421. - clean up the changelog
  422. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  423. - fix the building of python modules without openssl-devel already installed
  424. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  425. - byte-compile python extensions without the build-root
  426. - adjust the makefile to not remove temporary files (like .key files when
  427. building .csr files) by marking them as .PRECIOUS
  428. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  429. - break out python extensions into a subpackage
  430. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  431. - tweak the makefile some more
  432. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  433. - disable MD2 support
  434. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  435. - disable MDC2 support
  436. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  437. - tweak the disabling of RC5, IDEA support
  438. - tweak the makefile
  439. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  440. - strip binaries and libraries
  441. - rework certificate makefile to have the right parts for Apache
  442. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  443. - use %%{_perl} instead of /usr/bin/perl
  444. - disable alpha until it passes its own test suite
  445. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  446. - move the passwd.1 man page out of the passwd package's way
  447. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  448. - update to 0.9.5a, modified for U.S.
  449. - add perl as a build-time requirement
  450. - move certificate makefile to another package
  451. - disable RC5, IDEA, RSA support
  452. - remove optimizations for now
  453. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  454. - Bero told me to move the Makefile into this package
  455. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  456. - add lib*.so symlinks to link dynamically against shared libs
  457. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  458. - update to 0.9.5
  459. - run ldconfig directly in post/postun
  460. - add FAQ
  461. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  462. - Fix build on non-x86 platforms
  463. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  464. - move /usr/share/ssl/* from -devel to main package
  465. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  466. - inital packaging
  467. - changes from base:
  468. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  469. - handle RPM_OPT_FLAGS