self-build-x264-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. %global snapshot_date 20141218
  2. %global snapshot_time 2245
  3. %global branch stable
  4. %global pkgname x264
  5. %global name self-build-%{pkgname}
  6. %global version 0.142
  7. %global release 2.%{snapshot_date}%{?_dist_release}
  8. #define sourceurl0 ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
  9. %define sourceurl0 http://download.videolan.org/pub/x264/snapshots/%{pkgname}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
  10. Summary: Package to automatically build %{pkgname} rpm package
  11. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  12. Name: %{name}
  13. Version: %{version}
  14. Release: %{release}
  15. Source0: %{pkgname}-vl.spec
  16. License: GPLv2+
  17. Group: Restricted Software
  18. Obsoletes: x264 < %{version}, x264-devel < %{version}
  19. Obsoletes: self-build-x264 < %{version}
  20. Requires(post): self-build-setup >= 0.9.9
  21. # (build)requies of target package.
  22. Requires(post): yasm
  23. Requires(post): self-build-gpac >= 0.5.0
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. x264 is a free library for encoding H264/AVC video streams, written from
  29. scratch.
  30. If you install this package, it automaticaly downloads source
  31. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  32. And the created rpm packages are automatically installed
  33. if installation is executed by apt-get command or synaptic
  34. package manager.
  35. [Note]
  36. This package requires many other packages to compile
  37. targetsoftware. So it consume more disk space than usual.
  38. Also installation takes logner time because of compilation.
  39. (This will take a few minutes to quarter or half of an hour,
  40. depends on building environment)
  41. [About self-build package]
  42. For some kind of software, distributing of binary package
  43. may viorate the patent or law. Therefore we chose self-build
  44. packge, create binary package on your machine, for such kind
  45. of softwares instead of distributing binary package.
  46. Please obey the national law when you use the created binary
  47. packages. And if you want to use the softwares using patented
  48. thechnology, it may be required to get a permission, make an
  49. agreement or purchas a license. Please consider it with your
  50. purpose or way of use and take appropriate action.
  51. %description -l ja
  52. x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
  53. コードするためのフリーなライブラリです.
  54. このパッケージをインストールすると、自動的にソースコードを
  55. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  56. パッケージを作成します。
  57. また apt-get コマンドや synaptic パッケージマネージャから実行
  58. した場合は、作成された rpm パッケージのインストールも自動的に
  59. 行います。
  60. [注意]
  61. コンパイルに必要な多くの関連パッケージを要求するので通常より
  62. ディスクの領域を多く消費します。
  63. またインストール時にコンパイルを行うため、通常より時間がかか
  64. る場合があります。(環境にもよりますが数分から数十分程度)
  65. [self-build パッケージについて]
  66. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  67. 違反する可能性があるものがあります。その為、このような問題が
  68. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  69. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  70. ジという方法を採っています。
  71. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  72. アのライセンス、および利用する国の各種法令に従ってください。
  73. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  74. センスの購入などが必要となる場合がありますので、利用する目的
  75. や形態に応じて各自で判断し適切な対応を取ってください。
  76. %prep
  77. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  78. %install
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %posttrans
  85. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 24000
  86. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  87. %{pkgname}-devel-%{version}-%{release}
  88. %files
  89. %defattr(-,root,root)
  90. %{_datadir}/%{name}
  91. %changelog
  92. * Sun Jan 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-2.20141218
  93. - Obsoletes: self-build-x264 < %{version}
  94. * Fri Dec 26 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.142-1.20141218
  95. - updated source snapshot 20141218 stable branch (ABI 0.142)
  96. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.136-1.20130927
  97. - updated source snapshot 20130927 stable branch (ABI 0.136)
  98. * Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.129-1.20130118
  99. - updated source snapshot 20130118 stable branch (ABI 0.129)
  100. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.124-1.20120525
  101. - updated source snapshot 20120525 stable branch (ABI 0.124)
  102. - changed release number; upstream have release numbers at least on stable branch
  103. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
  104. - updated source snapshot 20111216 stable branch (ABI 0.119)
  105. * Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
  106. - updated source snapshot 20111013 stable branch (ABI 0.116)
  107. * Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
  108. - changed to depend on %%{version} for Obsoletes: x264
  109. - added BuildArch: noarch
  110. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
  111. - updated source snapshot 20110322
  112. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
  113. - updated source snapshot 20100625
  114. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
  115. - renamed %%{Source0} to x264-vl.spec
  116. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
  117. - updated source snapshot 20100216
  118. - applied to link x264 binary to the shared library from RPM Fusion development
  119. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
  120. - changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
  121. - check version between original spec and self-build spec in %%prep
  122. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
  123. - dropped BuildArch: noarch
  124. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
  125. - 20090522 snapshot
  126. - updated x264-vine.patch
  127. - added BuildArch: noarch
  128. - avoided to execute self-build-rpm.sh on RPM transaction
  129. - moved %%post actions to %%posttrans
  130. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
  131. - corrected release number in x264.spec
  132. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
  133. - enable asm on x86/x86_64 arch. (fix typo?)
  134. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
  135. - added PreReq: self-build-gpac
  136. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
  137. - dropped PreReq: nasm for x86
  138. - added PreReq: yasm for x86
  139. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
  140. - 20090110 snapshot
  141. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
  142. - fixed License: GPLv2+
  143. - added BuildRequires: gettext
  144. - source updated
  145. - fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
  146. and added x264-vine.patch
  147. #- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
  148. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
  149. - spec in utf8
  150. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
  151. - run pre-allocate-rpm.sh in %%post
  152. - set PreReq: self-build-setup >= 0.8
  153. - apply new versioning policy
  154. * Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
  155. - initial build for Vine Linux 4.2
  156. ### end of file