lua-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. %define name lua
  2. %define version 5.1.4
  3. %define release 6%{?_dist_release}
  4. Summary: Lua is a powerful, light-weight programming language designed for extending applications.
  5. Summary(ja): アプリケーション拡張向けに設計された強力かつ軽量なプログラミング言語
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Source0: http://www.lua.org/ftp/%{name}-%{version}.tar.gz
  10. Patch0: lua-5.1.4-autotoolize.patch
  11. License: MIT (Lua 5.0 license)
  12. Group: Development/Languages
  13. URL: http://www.lua.org/
  14. #Requires:
  15. BuildRequires: readline-devel
  16. BuildRequires: ncurses-devel
  17. # apt-get remove readline-devel
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Provides: lua = 5.1
  20. %description
  21. Lua is an extension programming language designed to support
  22. general procedural programming with data description facilities.
  23. It also offers good support for object-oriented programming,
  24. functional programming, and data-driven programming.
  25. Lua is intended to be used as a powerful, light-weight configuration language
  26. for any program that needs one.
  27. Lua is implemented as a library, written in clean C
  28. (that is, in the common subset of ANSI C and C++).
  29. %description -l ja
  30. Luaは拡張プログラミング言語である。データ記述機能を持ち、
  31. 汎用の手続き型プログラミングをサポートするようデザインされた。
  32. オブジェクト指向プログラミング、関数型プログラミング、
  33. データ駆動型プログラミングもサポートしている。
  34. Luaは、パワフルで軽いコンフィギュレーション言語としての意図もあり、
  35. コンフィギュレーションが必要なあらゆるプログラムに使うことができる。
  36. Luaはクリーンな C (つまり、ANSI C と C++ の共通のサブセット) で書かれ、
  37. ライブラリとして実装されている。
  38. %package devel
  39. Summary: Libraries and include files for Lua.
  40. Summary(ja): Lua の開発用ファイル
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: ncurses-devel
  44. Requires: pkgconfig
  45. %description devel
  46. Libraries and include files for Lua.
  47. %package static
  48. Summary: Static library for Lua
  49. Summary(ja): Lua の静的ライブラリ
  50. Group: Development/Libraries
  51. Requires: %{name}-devel = %{version}-%{release}
  52. %description static
  53. This package contains the static version of liblua for %{name}.
  54. %prep
  55. rm -rf $RPM_BUILD_ROOT
  56. %setup -q
  57. %patch0 -p1 -E
  58. # fix perms on auto files
  59. chmod u+x \
  60. autogen.sh config.guess config.sub configure depcomp install-sh missing
  61. %build
  62. %configure --with-readline
  63. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  64. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  65. # hack so that only /usr/bin/lua gets linked with readline as it is the
  66. # only one which needs this and otherwise we get License troubles
  67. make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
  68. # also remove readline from lua.pc
  69. sed -i 's/-lreadline -lncurses //g' etc/lua.pc
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  74. mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/5.1
  75. mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/5.1
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %post -p /sbin/ldconfig
  79. %postun -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc COPYRIGHT HISTORY README doc/*.html doc/*.gif
  83. %{_bindir}/lua*
  84. %{_libdir}/liblua-*.so
  85. %{_mandir}/man1/lua*.1*
  86. %dir %{_libdir}/lua
  87. %dir %{_libdir}/lua/5.1
  88. %dir %{_datadir}/lua
  89. %dir %{_datadir}/lua/5.1
  90. %files devel
  91. %defattr(-,root,root,-)
  92. %{_includedir}/l*.h
  93. %{_includedir}/l*.hpp
  94. %{_libdir}/liblua.so
  95. %{_libdir}/pkgconfig/*.pc
  96. %files static
  97. %defattr(-,root,root,-)
  98. %{_libdir}/*.a
  99. %changelog
  100. * Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-6
  101. - added Japanese summary
  102. - moved devel and static subpackages to Development/Libraries Group
  103. * Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.1.4-5
  104. - build with current VineSeed
  105. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.4-4
  106. - rebuild with rpm-4.8.1 for pkg-config file
  107. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-3
  108. - rebuilt with gcc-4.4.3-3 on ppc
  109. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-2
  110. - rebuilt with rpm-4.8.0-3 (on ppc)
  111. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1.4-1
  112. - new upstream release
  113. - add lua-static subpackage
  114. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.2-1vl5
  115. - applied new versioning policy and spec in utf-8
  116. * Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl2
  117. - rebuild for VineSeed
  118. * Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl1
  119. - initial build for Vine Linux 4.1
  120. - source update
  121. * Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.1-0vlmp1
  122. - rebuild for Vine Linux 4.1
  123. * Fri Jan 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-3
  124. - Remove "-lreadline -lncurses" from lua.pc (bz 213895)
  125. * Sun Oct 15 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-2
  126. - Only link /usr/bin/lua with readline / do not link %%{_libdir}/liblua-5.1.so
  127. with readline so that we don't cause any License troubles for packages
  128. linking against liblua-5.1.so, otherwise lua could drag the GPL only readline
  129. lib into the linking of non GPL apps.
  130. * Sat Oct 14 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-1
  131. - New upstream release 5.1.1
  132. - Fix detection of readline during compile (iow add readline support back)
  133. * Sat Jul 23 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.0.2vlmp1
  134. - initial build for Vine Linux 3.2