ldns-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. %{?!with_python: %global with_python 1}
  2. %{?!enable_gost: %global enable_gost 0}
  3. %if %{with_python}
  4. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  5. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  6. %endif
  7. %if %{enable_gost}
  8. %define subdir_conf_opt --disable-rpath --disable-static
  9. %else
  10. %define subdir_conf_opt --disable-rpath --disable-static --disable-gost
  11. %endif
  12. Summary: Lowlevel DNS(SEC) library with API
  13. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  14. Name: ldns
  15. Version: 1.6.16
  16. Release: 2%{?_dist_release}
  17. License: BSD
  18. Url: http://www.nlnetlabs.nl/%{name}/
  19. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  20. # from Fedora
  21. Patch1000: ldns-1.6.16-uninitialized-value-compiler-warnings.patch
  22. Group: System Environment/Libraries
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  25. BuildRequires: perl, libpcap-devel
  26. %if %{enable_gost}
  27. BuildRequires: openssl-devel >= 1.0.0
  28. %else
  29. BuildRequires: openssl-devel
  30. %endif
  31. Requires: libpcap, openssl
  32. Distribution: Vine Linux
  33. Vendor: Project Vine
  34. Packager: iwaim
  35. %if %{with_python}
  36. BuildRequires: python-devel, swig
  37. %endif
  38. %description
  39. ldns is a library with the aim to simplify DNS programing in C. All
  40. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  41. level API which allows a programmer to (for instance) create or sign
  42. packets.
  43. %package devel
  44. Summary: Development package that includes the ldns header files
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description devel
  48. The devel package contains the ldns library and the include files
  49. %if %{with_python}
  50. %package python
  51. Summary: Python extensions for ldns
  52. Group: Applications/System
  53. Requires: %{name} = %{version}-%{release}
  54. %description python
  55. Python extensions for ldns
  56. %endif
  57. %prep
  58. %setup -q
  59. %patch1000 -p2
  60. %build
  61. %configure --disable-rpath --disable-static \
  62. %if %{with_python}
  63. --with-pyldns \
  64. %endif
  65. %if !%{enable_gost}
  66. --disable-gost \
  67. %endif
  68. --with-sha2
  69. (cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  70. (cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  71. make %{?_smp_mflags}
  72. ( cd drill ; make %{?_smp_mflags} )
  73. ( cd examples ; make %{?_smp_mflags} )
  74. make %{?_smp_mflags} doc
  75. %install
  76. rm -rf %{buildroot}
  77. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  78. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  79. %if %{with_python}
  80. # remove execute perms from python files
  81. chmod a-x %{buildroot}%{python_sitearch}/*py
  82. %endif
  83. # don't package building script in doc
  84. rm doc/doxyparse.pl
  85. #remove doc stubs
  86. rm -rf doc/.svn
  87. #remove double set of man pages
  88. rm -rf doc/man
  89. # remove .la files
  90. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
  91. (cd drill ; make DESTDIR=%{buildroot} install)
  92. (cd examples; make DESTDIR=%{buildroot} install)
  93. %clean
  94. rm -rf %{buildroot}
  95. %files
  96. %defattr(-,root,root)
  97. %{_libdir}/libldns*so.*
  98. %{_bindir}/drill
  99. %{_bindir}/ldnsd
  100. #%{_bindir}/ldns-*
  101. %{_bindir}/ldns-chaos
  102. %{_bindir}/ldns-compare-zones
  103. %{_bindir}/ldns-[d-z]*
  104. %doc README LICENSE
  105. %{_mandir}/*/*
  106. %files devel
  107. %defattr(-,root,root,-)
  108. %{_libdir}/libldns*so
  109. %{_bindir}/ldns-config
  110. %dir %{_includedir}/ldns
  111. %{_includedir}/ldns/*.h
  112. %doc doc Changelog README
  113. %if %{with_python}
  114. %files python
  115. %defattr(-,root,root)
  116. %{python_sitearch}/*
  117. %endif
  118. %post -p /sbin/ldconfig
  119. %postun -p /sbin/ldconfig
  120. %changelog
  121. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
  122. - add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  123. - from Fedora ldns-1.6.16-6.fc20
  124. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
  125. - new upstream release
  126. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
  127. - new upstream release
  128. - move python files to sitearch from sitelib
  129. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
  130. - rebuild with python-2.7.2
  131. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
  132. - new upstream release
  133. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  134. - new upstream release
  135. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
  136. - new upstream release
  137. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
  138. - new upstream release
  139. - add enable_gost flag: default disable
  140. - defined subdir_conf_opt rpm macro
  141. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  142. - new upstream release
  143. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  144. - new upstream release
  145. - drop unnecessary installfix patch (Patch1): upstream merged
  146. - drop unnecessary rpathfix patch (Patch2): upstream merged
  147. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  148. - rebuild with libpcap 1.1.1 on VineSeed
  149. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  150. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  151. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  152. - Fix missing _ldns.so causing ldns-python to not work
  153. - Patch for installing ldns-python files
  154. - Patch for rpath in ldns-python
  155. - Don't install .a file for ldns-python
  156. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  157. - Upgraded to 1.6.4.
  158. - Added ldns-python sub package
  159. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  160. - Upgraded to 1.6.3, which has minor bugfixes
  161. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  162. - Upgraded to 1.6.2. This fixes various bugs.
  163. (upstream released mostly to default with sha2 for the imminent
  164. signed root, but we already enabled that in our builds)
  165. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  166. - rebuilt with new openssl
  167. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  168. - Added openssl dependancy back in, since we get more functionality
  169. when using openssl. Especially in 'drill'.
  170. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  171. - Updated to 1.6.1
  172. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  174. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  175. - Fixed the ssl patch so it can now compile --without-ssl
  176. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  177. - Added patch to compile with --without-ssl
  178. - Removed openssl dependancies
  179. - Recompiled with --without-ssl
  180. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  181. - Updated to 1.6.0
  182. - (did not yet compile with --without-ssl due to compile failures)
  183. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  184. - Updated to 1.6.0
  185. - Compile without openssl
  186. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  187. - Memory management bug when generating a sha256 key, see:
  188. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  189. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  191. * Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  192. - Updated to new version, 1.5.0 had a bug preventing
  193. zone signing.
  194. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  195. - Updated to new version
  196. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  197. - fixed configure flags
  198. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  199. - rebuild with new openssl
  200. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  201. - Updated to 1.4.0
  202. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  203. - enable SHA2 functionality
  204. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  205. - re-tag (don't do builds while renaming local repo dirs)
  206. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  207. - Updated to latest release
  208. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  209. - Autorebuild for GCC 4.3
  210. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  211. - Rebuild for new libcrypto
  212. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  213. - Upgraded to 1.2.2. Removed no longer needed race workaround
  214. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  215. - Try to fix racing ln -s statements in parallel builds
  216. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  217. - Added patch for ldns-read-zone that does not put @. in RRDATA
  218. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  219. - Use install -p to work around multilib conflicts for .h files
  220. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  221. - Updated to 1.2.1
  222. - Removed patches that got moved into upstream
  223. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  224. - Patch for ldns-key2ds to write to stdout
  225. - Again remove extra set of man pages from doc
  226. - own /usr/include/ldns (bug 233858)
  227. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  228. - Added sha256 DS record patch to ldns-key2ds
  229. - Minor tweaks for proper doc/man page installation.
  230. - Workaround for parallel builds
  231. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  232. - Own the /usr/include/ldns directory (bug #233858)
  233. - Removed obsoleted patch
  234. - Remove files form previous libtool run accidentally packages by upstream
  235. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  236. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  237. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  238. - Fixed changelog typo in date
  239. - Rebuild requested for PT_GNU_HASH support from gcc
  240. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  241. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  242. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  243. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  244. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  245. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  246. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  247. * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  248. - added a make clean for 2.3.3 since .o files were left behind upstream,
  249. causing failure on ppc platform
  250. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  251. - minor cleanups
  252. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  253. - reworked for svn version
  254. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  255. - Initial version