keepassx-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %define ver 0.4.3
  2. %define rel 1
  3. Name: keepassx
  4. Version: %{ver}
  5. Release: %{rel}%{_dist_release}
  6. Summary: Cross-platform password manager
  7. Summary(ja): クロスプラットフォーム パスワードマネージャー
  8. Group: User Interface/Desktops
  9. License: GPLv2+
  10. URL: http://www.keepassx.org/
  11. Source0: http://download.sf.net/keepassx/keepassx-%{version}.tar.gz
  12. Patch1: keepassx-0.3.3-gcc43.patch
  13. Patch2: keepassx-0.4.3-gcc47.patch
  14. BuildRequires: qt4-devel > 4.1, libXtst-devel, ImageMagick, desktop-file-utils
  15. Requires: hicolor-icon-theme
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: iwaim
  19. %description
  20. KeePassX is an application for people with extremly high demands on secure
  21. personal data management.
  22. KeePassX saves many different information e.g. user names, passwords, urls,
  23. attachemts and comments in one single database. For a better management
  24. user-defined titles and icons can be specified for each single entry.
  25. Furthermore the entries are sorted in groups, which are customizable as well.
  26. The integrated search function allows to search in a single group or the
  27. complete database.
  28. KeePassX offers a little utility for secure password generation. The password
  29. generator is very customizable, fast and easy to use. Especially someone who
  30. generates passwords frequently will appreciate this feature.
  31. The complete database is always encrypted either with AES (alias Rijndael) or
  32. Twofish encryption algorithm using a 256 bit key. Therefore the saved
  33. information can be considered as quite safe. KeePassX uses a database format
  34. that is compatible with KeePass Password Safe for MS Windows.
  35. %prep
  36. %setup -q
  37. %patch1 -p0 -b .gcc43
  38. %patch2 -p1 -b .gcc47
  39. %build
  40. export CFLAGS=$RPM_OPT_FLAGS
  41. export CXXFLAGS=$RPM_OPT_FLAGS
  42. qmake PREFIX=%{_prefix}
  43. make %{?_smp_mflags}
  44. %install
  45. make install INSTALL_ROOT=%{buildroot}
  46. # Use png in _datadir/icons/hicolor instead of xpm in pixmaps
  47. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
  48. convert %{buildroot}%{_datadir}/pixmaps/keepassx.xpm \
  49. %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/keepassx.png
  50. rm -f %{buildroot}%{_datadir}/pixmaps/keepassx.xpm
  51. # Menu
  52. sed -i -e 's/^Exec=keepassx$/Exec=keepassx %f/g' \
  53. %{buildroot}%{_datadir}/applications/%{name}.desktop
  54. desktop-file-install --vendor vine\
  55. --dir %{buildroot}%{_datadir}/applications \
  56. --delete-original \
  57. --add-mime-type application/x-keepass \
  58. %{buildroot}%{_datadir}/applications/%{name}.desktop
  59. # Associate KDB files
  60. cat > x-keepass.desktop << EOF
  61. [Desktop Entry]
  62. Comment=
  63. Hidden=false
  64. Icon=keepassx.png
  65. MimeType=application/x-keepass
  66. Patterns=*.kdb;*.KDB
  67. Type=MimeType
  68. EOF
  69. install -D -m 644 -p x-keepass.desktop \
  70. %{buildroot}%{_datadir}/mimelnk/application/x-keepass.desktop
  71. %check
  72. make check
  73. %{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/vine-%{name}.desktop
  74. %post
  75. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  76. if [ -x %{_bindir}/update-desktop-database ] ; then
  77. %{_bindir}/update-desktop-database &> /dev/null ||:
  78. fi
  79. if [ -x %{_bindir}/update-mime-database ] ; then
  80. %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
  81. fi
  82. %postun
  83. if [ $1 -eq 0 ] ; then
  84. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  85. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  86. %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  87. fi
  88. fi
  89. if [ -x %{_bindir}/update-desktop-database ] ; then
  90. %{_bindir}/update-desktop-database &> /dev/null ||:
  91. fi
  92. if [ -x %{_bindir}/update-mime-database ] ; then
  93. %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
  94. fi
  95. %posttrans
  96. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  97. %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  98. fi
  99. %files
  100. %doc share/keepassx/license.html
  101. %{_bindir}/keepassx
  102. %{_datadir}/keepassx
  103. %{_datadir}/applications/*.desktop
  104. %{_datadir}/mimelnk/application/*.desktop
  105. %{_datadir}/mime/packages/*.xml
  106. %{_datadir}/icons/hicolor/*/apps/keepassx.png
  107. %changelog
  108. * Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.3-1
  109. - initial build for Vine Linux
  110. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-6
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  112. * Fri Mar 30 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.3-5
  113. - fix FTBFS on gcc 4.7
  114. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-4
  115. - Rebuilt for c++ ABI breakage
  116. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-3
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  118. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  120. * Sun Mar 14 2010 Aurelien Bompard <abompard@fedoraproject.org> - 0.4.3-1
  121. - version 0.4.3
  122. * Sun Jan 03 2010 Aurelien Bompard <abompard@fedoraproject.org> - 0.4.1-1
  123. - version 0.4.1
  124. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  126. * Sat Apr 18 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-2
  127. - add patch0 to fix bug 496035
  128. * Thu Mar 26 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-1
  129. - version 0.4.0
  130. - drop patch0 (upstream)
  131. * Thu Mar 12 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-3
  132. - backport fix from upstream for bug #489820
  133. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-2
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  135. * Tue Nov 11 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-1
  136. - version 0.3.4
  137. * Sat Aug 23 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-2
  138. - rebase patch for version 0.3.3
  139. * Tue Aug 12 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-1
  140. - version 0.3.3
  141. * Mon Jul 21 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.2-1
  142. - version 0.3.2
  143. * Sun Mar 16 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.1-1
  144. - version 0.3.1
  145. - drop xdg patch, keepassx now uses QDesktopServices
  146. * Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-3.a
  147. - version 0.3.0a
  148. * Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-2
  149. - patch for gcc 4.3
  150. * Sun Mar 02 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-1
  151. - version 0.3.0
  152. - drop helpwindow patch (feature dropped upstream)
  153. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.2-5
  154. - Autorebuild for GCC 4.3
  155. * Sun Oct 07 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-4
  156. - use xdg-open instead of htmlview
  157. * Sat Aug 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-3
  158. - fix license tag
  159. - rebuild for BuildID
  160. * Wed Jun 27 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-2
  161. - fix help button
  162. - use htmlview instead of the hardcoded konqueror
  163. * Sun Mar 04 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-1
  164. - initial package