123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128 |
- %global oname virtualenv
- Summary: Tool to create isolated Python environments
- Summary(ja): 隔離されたPython環境を構築するためのツール
- Name: python-%{oname}
- Version: 1.4.8
- Release: 1%{?_dist_release}
- Group: Development/Languages
- License: MIT
- URL: http://pypi.python.org/pypi/%{oname}
- Source0: http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: python-devel
- Requires: python-setuptools, python-devel
- BuildRequires: python-setuptools
- Requires: python-setuptools
- %description
- virtualenv is a tool to create isolated Python environments. virtualenv
- is a successor to workingenv, and an extension of virtual-python. It is
- written by Ian Bicking, and sponsored by the Open Planning Project. It is
- licensed under an MIT-style permissive license.
- %prep
- %setup -q -n %{oname}-%{version}
- %{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
- %build
- %{__python} setup.py build
- %install
- rm -rf $RPM_BUILD_ROOT
- %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
-
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %doc docs/index.txt docs/license.txt docs/news.txt PKG-INFO
- # For noarch packages: sitelib
- %{python_sitelib}/*
- %attr(755,root,root) %{_bindir}/virtualenv
- %changelog
- * Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
- - initial build for Vine Linux
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Tue Jul 7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
- - Fixed EPEL installation issue from BZ#611536
- * Tue Jun 8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
- - Only replace the python shebang on the first line (Robert Buchholz)
- * Fri Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
- - update pip to 0.7
- - move regen-docs into bin/
- - Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
- unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
- - unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
- - use the activate.sh in virtualenv.py via running bin/rebuild-script.py
- - add warning message if PYTHONHOME is set
- * Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
- - allow script creation without setuptools
- - fix problem with --relocate when bin/ has subdirs (fixes #12)
- - Allow more flexible .pth file fixup
- - make nt a required module, along with posix. it may not be a builtin module on jython
- - don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
- * Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
- - Updated for upstream release.
- * Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
- - Updated for upstream release.
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
- - Updated for upstream release.
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
- - Updated for upstream release.
- * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
- - Rebuild for Python 2.6
- * Mon Dec 1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
- - Added missing dependencies.
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
- - Rebuild for Python 2.6
- * Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
- - Updated for upstream release
- * Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
- - Updated for upstream release
- * Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
- - Updated for upstream release
- * Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
- - Updated from review notes
- * Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
- - Updated from review notes
- * Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
- - Initial Version
|