tmux-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. %define ver 1.8
  2. %define rel 1
  3. Name: tmux
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Summary: A terminal multiplexer
  7. Group: Applications/System
  8. # Most of the source is ISC licensed; some of the files in compat/ are 2 and
  9. # 3 clause BSD licensed.
  10. License: ISC and BSD
  11. URL: http://sourceforge.net/projects/tmux
  12. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  13. BuildRequires: ncurses-devel
  14. BuildRequires: libevent-devel
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. tmux is a "terminal multiplexer." It enables a number of terminals (or
  19. windows) to be accessed and controlled from a single terminal. tmux is
  20. intended to be a simple, modern, BSD-licensed alternative to programs such
  21. as GNU Screen.
  22. %prep
  23. %setup -q
  24. %build
  25. %configure
  26. make %{?_smp_mflags} LDFLAGS="%{optflags}"
  27. %install
  28. rm -rf %{buildroot}
  29. make install DESTDIR=%{buildroot} INSTALLBIN="install -p -m 755" INSTALLMAN="install -p -m 644"
  30. %post
  31. if [ ! -f %{_sysconfdir}/shells ] ; then
  32. echo "%{_bindir}/tmux" > %{_sysconfdir}/shells
  33. else
  34. grep -q "^%{_bindir}/tmux$" %{_sysconfdir}/shells || echo "%{_bindir}/tmux" >> %{_sysconfdir}/shells
  35. fi
  36. %files
  37. %defattr(-,root,root,-)
  38. %doc CHANGES FAQ NOTES TODO examples/
  39. %{_bindir}/tmux
  40. %{_mandir}/man1/tmux.1.*
  41. %changelog
  42. * Fri Oct 4 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8-1
  43. - update to 1.8
  44. * Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.7-1
  45. - initial build for Vine Linux
  46. * Sat Oct 13 2012 Sven Lankes <sven@lank.es> 1.7-1
  47. - New upstream release
  48. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-2
  49. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  50. * Tue Jan 31 2012 Sven Lankes <sven@lank.es> 1.6-1
  51. - New upstream release
  52. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-2
  53. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  54. * Tue Nov 01 2011 Sven Lankes <sven@lank.es> 1.5-1
  55. - New upstream release
  56. - Do the right thing (tm) and revert to $upstream-behaviour:
  57. No longer install tmux setgid and no longer use /var/run/tmux
  58. for sockets. Use "tmux -S /var/run/tmux/tmux-`id -u`/default attach"
  59. if you need to access an "old" tmux session
  60. - tmux can be used as a login shell so add it to /etc/shells
  61. * Sat Apr 16 2011 Sven Lankes <sven@lank.es> 1.4-4
  62. - Add /var/run/tmp to tmpdir.d - fixes rhbz 656704 and 697134
  63. * Sun Apr 10 2011 Sven Lankes <sven@lank.es> 1.4-3
  64. - Fix CVE-2011-1496
  65. - Fixes rhbz #693824
  66. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  68. * Tue Dec 28 2010 Filipe Rosset <rosset.filipe@gmail.com> 1.4-1
  69. - New upstream release
  70. * Fri Aug 06 2010 Filipe Rosset <filiperosset@fedoraproject.org> 1.3-2
  71. - Rebuild for F-13
  72. * Mon Jul 19 2010 Sven Lankes <sven@lank.es> 1.3-1
  73. - New upstream release
  74. * Sun Mar 28 2010 Sven Lankes <sven@lank.es> 1.2-1
  75. - New upstream release
  76. - rediff writehard patch
  77. * Mon Nov 09 2009 Sven Lankes <sven@lank.es> 1.1-1
  78. - New upstream release
  79. * Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2
  80. - Add debian patches
  81. - Add tmux group for improved socket handling
  82. * Sat Oct 24 2009 Sven Lankes <sven@lank.es> 1.0-1
  83. - New upstream release
  84. * Mon Jul 13 2009 Chess Griffin <chess@chessgriffin.com> 0.9-1
  85. - Update to version 0.9.
  86. - Remove sed invocation as this was adopted upstream.
  87. - Remove optflags patch since upstream source now uses ./configure and
  88. detects the flags when passed to make.
  89. * Tue Jun 23 2009 Chess Griffin <chess@chessgriffin.com> 0.8-5
  90. - Note that souce is mostly ISC licensed with some 2 and 3 clause BSD in
  91. compat/.
  92. - Remove fixiquote.patch and instead use a sed invocation in setup.
  93. * Mon Jun 22 2009 Chess Griffin <chess@chessgriffin.com> 0.8-4
  94. - Add optimization flags by patching GNUmakefile and passing LDFLAGS
  95. to make command.
  96. - Use consistent macro format.
  97. - Change examples/* to examples/ and add TODO to docs.
  98. * Sun Jun 21 2009 Chess Griffin <chess@chessgriffin.com> 0.8-3
  99. - Remove fixperms.patch and instead pass them at make install stage.
  100. * Sat Jun 20 2009 Chess Griffin <chess@chessgriffin.com> 0.8-2
  101. - Fix Source0 URL to point to correct upstream source.
  102. - Modify fixperms.patch to set 644 permissions on the tmux.1.gz man page.
  103. - Remove wildcards from 'files' section and replace with specific paths and
  104. filenames.
  105. * Mon Jun 15 2009 Chess Griffin <chess@chessgriffin.com> 0.8-1
  106. - Initial RPM release.