epiphany-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.1.15
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 2.30.2
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,pre,preun): GConf2
  23. Requires(post,postun): scrollkeeper, shared-mime-info
  24. %if %{with_gecko}
  25. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  26. %endif
  27. %if %{with_webkit}
  28. BuildRequires: WebKit-gtk-devel >= %{webkit_version}
  29. %endif
  30. BuildRequires: glib2-devel >= 2.24.0
  31. BuildRequires: gtk2-devel >= 2.20.0
  32. BuildRequires: libxml2-devel >= 2.6.12
  33. BuildRequires: libxslt-devel >= 1.1.7
  34. BuildRequires: libnotify-devel >= 0.4.0
  35. BuildRequires: dbus-glib-devel >= 0.35
  36. BuildRequires: libsoup-devel >= 2.30.0
  37. BuildRequires: gnome-desktop-devel >= 2.30.0
  38. BuildRequires: GConf2-devel
  39. BuildRequires: nss-devel
  40. BuildRequires: avahi-gobject-devel >= 0.6.22
  41. BuildRequires: NetworkManager-devel
  42. BuildRequires: iso-codes
  43. BuildRequires: intltool >= 0.40
  44. BuildRequires: libICE-devel
  45. BuildRequires: libSM-devel
  46. BuildRequires: libgnome-keyring-devel
  47. BuildRequires: gobject-introspection-devel
  48. BuildRequires: gir-repository-devel
  49. BuildRequires: gnome-doc-utils
  50. BuildRequires: gobject-introspection-devel
  51. BuildRequires: seed-devel
  52. %description
  53. epiphany is a simple GNOME web browser based on the Mozilla rendering
  54. engine
  55. %description -l ja
  56. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  57. ウェブブラウザです。
  58. %prep
  59. %setup -q
  60. #patch1 -p1
  61. %build
  62. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  63. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  64. %configure \
  65. %if %{with_gecko}
  66. --with-gecko=libxul-embedding \
  67. %endif
  68. %if %{with_webkit}
  69. --with-engine=webkit \
  70. %endif
  71. --enable-zeroconf \
  72. --enable-network-manager \
  73. --disable-scrollkeeper \
  74. --without-ca-file \
  75. --enable-introspection=yes \
  76. --enable-seed
  77. %__make %{?_smp_mflags}
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  83. %find_lang %{name} --with-gnome
  84. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  86. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  87. %pre
  88. if [ "$1" -gt 1 ]; then
  89. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  90. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  91. for S in $SCHEMAS; do
  92. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  93. done
  94. fi
  95. %post
  96. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  97. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  98. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  99. for S in $SCHEMAS; do
  100. gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
  101. done
  102. %preun
  103. if [ "$1" -eq 0 ]; then
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  106. for S in $SCHEMAS; do
  107. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  108. done
  109. fi
  110. %postun
  111. if [ $1 -eq 0 ] ; then
  112. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  113. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  114. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  115. scrollkeeper-update >& /dev/null ||:
  116. fi
  117. %posttrans
  118. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  119. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  120. scrollkeeper-update >& /dev/null ||:
  121. %clean
  122. rm -rf $RPM_BUILD_ROOT
  123. %files -f %{name}.lang
  124. %defattr(-,root,root,-)
  125. %doc AUTHORS ChangeLog* COPYING* NEWS README
  126. %{_sysconfdir}/gconf/schemas/epiphany*.schemas
  127. %{_bindir}/epiphany
  128. %{_includedir}/epiphany/*
  129. %{_libdir}/pkgconfig/epiphany*.pc
  130. %{_libdir}/girepository-1.0/Epiphany-2.29.typelib
  131. %if %{with_gecko}
  132. %{_libdir}/epiphany
  133. %endif
  134. %{_datadir}/gir-1.0/Epiphany-2.29.gir
  135. #{_datadir}/pygtk/*/defs/*
  136. %{_datadir}/applications/*.desktop
  137. %{_datadir}/epiphany
  138. %{_datadir}/gtk-doc/html/*
  139. %{_datadir}/icons/*
  140. %{_datadir}/aclocal/*
  141. %{_datadir}/dbus-1/services/*
  142. %{_mandir}/man1/epiphany.1*
  143. %changelog
  144. * Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  145. - new upstream release
  146. - add BuildRequires: gobject-introspection-devel, seed-devel
  147. - add configure option (--enable-introspection=yes, --enable-seed)
  148. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  149. - new upstream release
  150. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  151. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  152. - add configure option (--without-ca-file)
  153. - remove unrecognized configure option (--with-engine)
  154. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  155. - new upstream release
  156. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  157. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  158. - new upstream release
  159. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  160. - run gtk-update-icon-cache in %%post/postun script.
  161. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  162. - new upstream release
  163. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  164. - rebuild with gecko-1.9.1
  165. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  166. - new upstream release
  167. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  168. - new upstream release
  169. - build with xulrunner-1.9.0.7
  170. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  171. - new upstream release
  172. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  173. - build with gecko-1.9.0.3 instead of WebKit.
  174. - WebKit port is unstable yet.
  175. - enable zeroconf, NetworkManager support
  176. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  177. - new upstream release
  178. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  179. - build with WebKit instead of gecko.
  180. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  181. - new upstream release
  182. - added %%pre and %%preun section
  183. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  184. - new upstream release
  185. - rebuilt with firefox-2.0.0.6-0vl3
  186. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  187. - add BuildRequires: gnome-python
  188. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  189. - new upstream release
  190. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  191. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  192. - new upstream release
  193. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  194. - source update
  195. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  196. - add BuildRequires: pygtk2-devel
  197. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  198. - new upstream release
  199. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  200. - rebuild with firefox-1.5.0.2-0vl4
  201. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  202. - new upstream release
  203. - build with firefox-1.5.0.2
  204. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  205. - new upstream release
  206. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  207. - new upstream release
  208. - build with firefox-1.5.0.1
  209. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  210. - new upstream release
  211. - build with mozilla-1.7.12
  212. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  213. - rebuild with mozilla-1.7.8
  214. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  215. - new upstream release
  216. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  217. - new upstream release
  218. - build with mozilla-1.7.7
  219. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  220. - rebuild with mozilla-1.7.6
  221. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  222. - new upstream release
  223. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  224. - new upstream release
  225. - build with mozilla-1.7.5
  226. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  227. - new upstream release
  228. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  229. - new upstream release
  230. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  231. - rebuild with mozilla-1.7.3
  232. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  233. - new upstream release
  234. - build with mozilla-1.7.2
  235. - add Patch10 to build with gnome-2.4
  236. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  237. - new upstream version
  238. -- dropped patch10
  239. - changed URL
  240. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  241. - add alpha into ExclusiveArch
  242. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  243. - rebuild with mozilla-1.5.1
  244. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  245. - new upstream release
  246. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  247. - new upstream release
  248. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  249. - fixed missing locale files
  250. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  251. - new upstream release
  252. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  253. - new upstream release
  254. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  255. - new upstream release
  256. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  257. - new upstream release
  258. - build with mozilla 1.4
  259. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  260. - new upstream release
  261. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  262. - build for Vine Linux
  263. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  264. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  265. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  266. - 0.6.1
  267. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  268. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  269. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  270. - only build on arches mozilla is built on
  271. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  272. - rebuild against new mozilla, make mozilla requires dynamic
  273. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  274. - update to 0.6.0
  275. - fix tyop in %%postun
  276. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  277. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  278. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  279. - add some buildrequires, prereq GConf2
  280. - disable building nautilus view
  281. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  282. - Initial build.