xorg-x11-apps-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %define pkgname apps
  2. Summary: X.Org X11 applications
  3. Summary(ja): X.Org X11 アプリケーション
  4. Name: xorg-x11-%{pkgname}
  5. # NOTE: The package version should be set to the X11 major release from which
  6. # the OS release is based upon.
  7. Version: 7.5
  8. Release: 2%{?_dist_release}
  9. License: MIT/X11
  10. Group: User Interface/X
  11. URL: http://www.x.org
  12. # Clock apps
  13. Source0: ftp://ftp.x.org/pub/individual/app/oclock-1.0.1.tar.bz2
  14. Source1: ftp://ftp.x.org/pub/individual/app/xclock-1.0.4.tar.bz2
  15. # X Window Dump (xwd) utilities
  16. Source2: ftp://ftp.x.org/pub/individual/app/xwd-1.0.3.tar.bz2
  17. Source3: ftp://ftp.x.org/pub/individual/app/xwud-1.0.2.tar.bz2
  18. Source4: ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
  19. # Miscellaneous other applications
  20. Source5: ftp://ftp.x.org/pub/individual/app/luit-1.0.5.tar.bz2
  21. Source6: ftp://ftp.x.org/pub/individual/app/x11perf-1.5.1.tar.bz2
  22. Source7: ftp://ftp.x.org/pub/individual/app/xbiff-1.0.1.tar.bz2
  23. Source8: ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.0.tar.bz2
  24. Source9: ftp://ftp.x.org/pub/individual/app/xconsole-1.0.3.tar.bz2
  25. Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.3.tar.bz2
  26. Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.0.tar.bz2
  27. Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.2.tar.bz2
  28. Source13: ftp://ftp.x.org/pub/individual/app/xload-1.0.2.tar.bz2
  29. Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.2.tar.bz2
  30. Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.3.tar.bz2
  31. Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
  32. Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.1.tar.bz2
  33. Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.3.tar.bz2
  34. Patch2: xconsole-1.0.3-streams-me-softer.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  36. BuildRequires: autoconf, automake
  37. BuildRequires: pkgconfig
  38. BuildRequires: xorg-x11-util-macros
  39. BuildRequires: xorg-x11-xbitmaps
  40. BuildRequires: zlib-devel
  41. BuildRequires: libfontenc-devel
  42. BuildRequires: libX11-devel
  43. BuildRequires: libXmu-devel
  44. BuildRequires: libXext-devel
  45. BuildRequires: libXt-devel
  46. BuildRequires: libXaw-devel
  47. BuildRequires: libXpm-devel
  48. BuildRequires: libXft-devel
  49. BuildRequires: libXrender-devel
  50. BuildRequires: libxkbfile-devel
  51. BuildRequires: libXcursor-devel
  52. BuildRequires: libpng-devel
  53. BuildRequires: libXfixes-devel
  54. Requires(pre): xorg-x11-filesystem
  55. Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
  56. Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
  57. # NOTE: xwd, xwud, luit used to be in these.
  58. Obsoletes: XFree86, XOrg
  59. # NOTE: x11perf, xclipboard used to be in these.
  60. Obsoletes: XFree86-tools, XOrg-tools
  61. %description
  62. A collection of common X Window System applications.
  63. %prep
  64. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
  65. %patch2 -p0 -b .streams-me-softer
  66. %build
  67. # Build all apps
  68. {
  69. for app in * ; do
  70. pushd $app
  71. case $app in
  72. x11perf*)
  73. aclocal ; automake ; autoconf
  74. ;;
  75. luit*)
  76. autoconf
  77. ;;
  78. esac
  79. %configure --disable-xprint
  80. make
  81. popd
  82. done
  83. }
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. # Install all apps
  87. {
  88. for app in * ; do
  89. pushd $app
  90. make install DESTDIR=$RPM_BUILD_ROOT
  91. popd
  92. done
  93. }
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %files
  97. %defattr(-,root,root,-)
  98. #%doc
  99. %{_bindir}/luit
  100. %{_bindir}/oclock
  101. %{_bindir}/x11perf
  102. %{_bindir}/x11perfcomp
  103. %{_bindir}/xbiff
  104. %{_bindir}/xcalc
  105. %{_bindir}/xclipboard
  106. %{_bindir}/xclock
  107. %{_bindir}/xconsole
  108. %{_bindir}/xcursorgen
  109. %{_bindir}/xcutsel
  110. %{_bindir}/xdpr
  111. %{_bindir}/xeyes
  112. %{_bindir}/xinput
  113. %{_bindir}/xkill
  114. %{_bindir}/xload
  115. %{_bindir}/xlogo
  116. %{_bindir}/xmag
  117. %{_bindir}/xmessage
  118. %{_bindir}/xpr
  119. %{_bindir}/xwd
  120. %{_bindir}/xwud
  121. %dir %{_datadir}/X11
  122. %{_datadir}/X11/app-defaults/Clock-color
  123. %{_datadir}/X11/app-defaults/XCalc
  124. %{_datadir}/X11/app-defaults/XCalc-color
  125. %{_datadir}/X11/app-defaults/XClipboard
  126. %{_datadir}/X11/app-defaults/XClock
  127. %{_datadir}/X11/app-defaults/XClock-color
  128. %{_datadir}/X11/app-defaults/XConsole
  129. %{_datadir}/X11/app-defaults/XLoad
  130. %{_datadir}/X11/app-defaults/XLogo
  131. %{_datadir}/X11/app-defaults/XLogo-color
  132. %{_datadir}/X11/app-defaults/Xmag
  133. %{_datadir}/X11/app-defaults/Xmessage
  134. %{_datadir}/X11/app-defaults/Xmessage-color
  135. %dir %{_libdir}/X11/x11perfcomp
  136. %{_libdir}/X11/x11perfcomp/Xmark
  137. %{_libdir}/X11/x11perfcomp/fillblnk
  138. %{_libdir}/X11/x11perfcomp/perfboth
  139. %{_libdir}/X11/x11perfcomp/perfratio
  140. #%dir %{_mandir}/man1x
  141. %{_mandir}/man1/xcursorgen.1*
  142. %{_mandir}/man1/Xmark.1*
  143. %{_mandir}/man1/luit.1*
  144. %{_mandir}/man1/oclock.1*
  145. %{_mandir}/man1/x11perf.1*
  146. %{_mandir}/man1/x11perfcomp.1*
  147. %{_mandir}/man1/xbiff.1*
  148. %{_mandir}/man1/xcalc.1*
  149. %{_mandir}/man1/xclipboard.1*
  150. %{_mandir}/man1/xclock.1*
  151. %{_mandir}/man1/xconsole.1*
  152. %{_mandir}/man1/xcutsel.1*
  153. %{_mandir}/man1/xdpr.1*
  154. %{_mandir}/man1/xeyes.1*
  155. %{_mandir}/man1/xinput.1*
  156. %{_mandir}/man1/xkill.1*
  157. %{_mandir}/man1/xload.1*
  158. %{_mandir}/man1/xlogo.1*
  159. %{_mandir}/man1/xmag.1*
  160. %{_mandir}/man1/xmessage.1*
  161. %{_mandir}/man1/xpr.1*
  162. %{_mandir}/man1/xwd.1*
  163. %{_mandir}/man1/xwud.1*
  164. %changelog
  165. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
  166. - luit-1.0.5
  167. - xbiff-1.0.2
  168. - xeyes-1.1.0
  169. - xlogo-1.0.2
  170. - xmessage-1.0.3
  171. - xinput-1.5.1
  172. - added xcalc-1.0.3 <wishes:161>
  173. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  174. - xclock-1.0.4
  175. - xwd-1.0.3
  176. - xwud-1.0.2
  177. - xpr-1.0.3
  178. - luit-1.0.4
  179. - x11perf-1.5.1
  180. - xclipboard-1.1.0
  181. - xcursorgen-1.0.3
  182. - xeyes-1.0.991
  183. - xkill-1.0.2
  184. - xmag-1.0.3
  185. - xinput-1.5.0
  186. * Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
  187. - xinput-1.4.2
  188. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
  189. - xinput-1.4.1
  190. * Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
  191. - bump to 7.4 version
  192. - add xinput-1.3.0
  193. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
  194. - xwd 1.0.2
  195. - luit 1.0.3
  196. - x11perf 1.5
  197. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  198. - new versioning policy
  199. * Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
  200. - initial build for Vine Linux
  201. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
  202. - xconsole 1.0.3
  203. - xmessage 1.0.2
  204. - Bump to 7.3-1
  205. * Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
  206. - luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
  207. - bump to 7.2 version
  208. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
  209. - Fix man page globs and rebuild for FC7.
  210. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
  211. - Fix race condition in luit (Bug 197165).
  212. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
  213. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  214. - Add 'dist' tag to package release string.
  215. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
  216. - rebuild
  217. * Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
  218. - Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
  219. - Artificially inflate package version-release to 7.1 to match the X11R7.1
  220. release that all of the tarballs are taken from.
  221. - Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
  222. - Add temporary dependency on autoconf, automake for brew builds.
  223. * Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
  224. - Add more BuildRequires to fix mock builds. (#191896)
  225. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
  226. - Updated xclock and xconsole
  227. * Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  228. - Bump x11perf to 1.4.1 from upstream.
  229. * Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
  230. - Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
  231. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  232. - bump again for double-long bug on ppc(64)
  233. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  234. - rebuilt for new gcc4.1 snapshot and glibc changes
  235. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  236. - Upgraded all apps to version 1.0.1 from X11R7.0
  237. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  238. - Upgraded all apps to version 1.0.0 from X11R7 RC4.
  239. - Changed manpage dir from man1x to man1 to match upstream default now.
  240. - Dropped all of the datadir-cleanups patches added in the previous build.
  241. - Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
  242. to put the helper scripts in datadir.
  243. - Added --disable-xprint to configure, as a great symbolic jesture.
  244. * Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
  245. - Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
  246. (#173384)
  247. - Added the following patches, and invoke aclocal/automake/autoconf on them
  248. to force app-defaults and other datafiles into _datadir instead of _libdir:
  249. - oclock-0.99.1-oclock-datadir-cleanups.patch
  250. - x11perf-0.99.1-x11perf-datadir-cleanups.patch
  251. - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
  252. - xclock-0.99.1-xclock-datadir-cleanups.patch
  253. - xconsole-0.99.2-xconsole-datadir-cleanups.patch
  254. - xload-0.99.1-xload-datadir-cleanups.patch
  255. - xlogo-0.99.1-xlogo-datadir-cleanups.patch
  256. - xmag-0.99.1-xmag-datadir-cleanups.patch
  257. - xmessage-0.99.1-xmessage-datadir-cleanups.patch
  258. - Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
  259. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  260. - add Requires(pre) on newer filesystem package (#172610)
  261. * Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  262. - Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
  263. various utils have moved here from there in monolithic X packaging.
  264. - Add "BuildRequires: xbitmaps-devel" for xbiff.
  265. - Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
  266. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  267. - Initial build, with all apps taken from X11R7 RC2.
  268. - Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
  269. some packages.
  270. - Temporary hack to move xcursorgen manpage to 'man1' dir.