strigi-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. Name: strigi
  2. Summary: A desktop search program
  3. Summary(ja): デスクトップ検索プログラム
  4. Version: 0.7.5
  5. Release: 3%{?_dist_release}
  6. Group: Applications/Productivity
  7. License: LGPLv2+
  8. #URL: http://strigi.sourceforge.net/
  9. URL: http://www.vandenoever.info/software/strigi/
  10. Source0: http://www.vandenoever.info/software/strigi/strigi-%{version}.tar.bz2
  11. Source1: strigiclient.desktop
  12. Source2: strigi-daemon.desktop
  13. ## upstreamable patches
  14. # exlicitly mark convenience libs static
  15. Patch50: strigi-0.7.5-static_convenience_libs.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: bison
  18. BuildRequires: bzip2-devel
  19. BuildRequires: cmake >= 2.6.0
  20. #BuildRequires: clucene-core-devel
  21. BuildRequires: cppunit-devel
  22. BuildRequires: dbus-devel dbus-x11
  23. BuildRequires: desktop-file-utils
  24. BuildRequires: exiv2-devel
  25. BuildRequires: gamin-devel
  26. BuildRequires: libxml2-devel
  27. BuildRequires: qt4-devel
  28. BuildRequires: zlib-devel
  29. %description
  30. Strigi is a fast and light desktop search engine. It can handle a large range
  31. of file formats such as emails, office documents, media files, and file
  32. archives. It can index files that are embedded in other files. This means email
  33. attachments and files in zip files are searchable as if they were normal files
  34. on your harddisk.
  35. Strigi is normally run as a background daemon that can be accessed by many
  36. other programs at once. In addition to the daemon, Strigi comes with powerful
  37. replacements for the popular unix commands 'find' and 'grep'. These are called
  38. 'deepfind' and 'deepgrep' and can search inside files just like the strigi
  39. daemon can.
  40. %package libs
  41. Summary: Strigi libraries
  42. Summary(ja): Strigi 検索エンジンライブラリ
  43. Group: System Environment/Libraries
  44. %description libs
  45. Strigi search engine libraries
  46. %package devel
  47. Summary: Development files for the strigi desktop search engine
  48. Summary(ja): Strigi デスクトップ検索エンジンの開発用ファイル
  49. Group: Development/Libraries
  50. Requires: %{name}-libs = %{version}-%{release}
  51. %description devel
  52. Development files for the strigi desktop search engine
  53. %prep
  54. %setup -q
  55. %patch50 -p1 -b .static_convenience_libs
  56. %build
  57. mkdir build
  58. cd build
  59. export CFLAGS="%{optflags}"
  60. export CXXFLAGS="%{optflags}"
  61. export FFLAGS="%{optflags}"
  62. %ifarch x86_64 ppc64
  63. %define lib_suffix 64
  64. %else
  65. %define lib_suffix %{nil}
  66. %endif
  67. cmake \
  68. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
  69. -DLIB_DESTINATION=%{_libdir} \
  70. -DLIB_SUFFIX=%{lib_suffix} \
  71. -DENABLE_CLUCENE:BOOL=OFF \
  72. -DENABLE_CLUCENE_NG:BOOL=OFF \
  73. -DENABLE_DBUS:BOOL=ON \
  74. -DENABLE_FAM:BOOL=ON \
  75. -DENABLE_FFMPEG:BOOL=OFF \
  76. -DENABLE_INOTIFY:BOOL=ON \
  77. %{?_cmake_skip_rpath} \
  78. ..
  79. make VERBOSE=1 %{?_smp_mflags}
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. cd build
  83. make DESTDIR=$RPM_BUILD_ROOT install
  84. desktop-file-install \
  85. --vendor="" \
  86. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  87. %{SOURCE1}
  88. # Add an autostart desktop file for the strigi daemon
  89. install -p -m644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post libs -p /sbin/ldconfig
  93. %postun libs -p /sbin/ldconfig
  94. %files
  95. %defattr(-,root,root,-)
  96. %doc AUTHORS COPYING ChangeLog
  97. %{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
  98. %{_bindir}/*
  99. %{_datadir}/applications/strigiclient.desktop
  100. %{_datadir}/dbus-1/services/*
  101. %{_datadir}/strigi
  102. #{_libdir}/strigi/strigiindex_clucene.so
  103. %files libs
  104. %defattr(-,root,root,-)
  105. %{_libdir}/*.so.*
  106. %{_libdir}/strigi
  107. %exclude %{_libdir}/strigi/*.cmake
  108. #exclude %{_libdir}/strigi/strigiindex_clucene.so
  109. %files devel
  110. %defattr(-,root,root,-)
  111. %{_includedir}/strigi
  112. %{_libdir}/*.so
  113. %{_libdir}/pkgconfig/libstream*.pc
  114. %{_libdir}/strigi/*.cmake
  115. %{_libdir}/libsearchclient/*.cmake
  116. %{_libdir}/libstreamanalyzer/*.cmake
  117. %{_libdir}/libstreams/*.cmake
  118. %changelog
  119. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-3
  120. - rebuild with exiv2-0.23
  121. * Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-2
  122. - rebuild with exiv2-0.22
  123. * Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.5-1
  124. - updated to 0.7.5
  125. - dropt clucene support
  126. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-5
  127. - rebuilt with exiv2-0.21.1
  128. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-4
  129. - rebuilt with rpm-4.8.1
  130. - added Japanese summaries
  131. * Wed May 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-3
  132. - rebuilt with exiv2-0.19
  133. * Sun Apr 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.7.2-2
  134. - rebuilt to support strigiclient (x86_64)
  135. * Fri Feb 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-1
  136. - new upstream release
  137. - built with new toolchain
  138. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
  139. - new upstream release
  140. * Mon Apr 13 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-2
  141. - rebuild with exiv2-0.18.1-1
  142. * Tue Feb 17 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-1
  143. - new upstream release
  144. - update Patch0 and delete Patch1
  145. * Wed Jan 21 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-2
  146. - add Patch0 and Patch1
  147. * Sun Dec 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-1
  148. - new upstream release
  149. * Tue Aug 5 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.10-1
  150. - new upstream release
  151. * Sun May 4 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-1
  152. - new upstream release
  153. * Wed Nov 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.7-0vl1
  154. - new upstream release
  155. * Thu Sep 6 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.5-0vl1
  156. - new upstream release
  157. * Thu Aug 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.4-0vl1
  158. - new upstream release
  159. * Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl2
  160. - rebuild with qt4-4.3.0-0vl1
  161. * Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl1
  162. - initial release for VineSeed
  163. * Wed May 16 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-5
  164. - Split out a strigi-libs subpackage as suggested in BZ#223586
  165. _ Include a strigidaemon autostart desktop file
  166. * Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-4
  167. - Add dbus-devel BR.
  168. * Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-3
  169. - Misc. fixes from package review
  170. * Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-2
  171. - Updates from reviews:
  172. - Have the -devel subpackage require pkgconfig
  173. - Add a versioned dependency on cmake and remove dbus-qt buildrequire
  174. * Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  175. - New release
  176. * Wed May 02 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-3
  177. - Allow building on FC6
  178. * Thu Feb 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-2
  179. - Assorted fixed arising from reviews
  180. * Wed Jan 17 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-1
  181. - Initial packaging for Fedora Extras