123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179 |
- Summary: Lightweight library for embedding a webserver in applications
- Name: libmicrohttpd
- Version: 0.9.2
- Release: 1%{?_dist_release}
- Group: Development/Libraries
- License: LGPLv2+
- BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
- URL: http://www.gnu.org/software/libmicrohttpd/
- Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
- #Patch0: %{name}-0.9.2-fix-https-tests.patch
- BuildRequires: autoconf, automake, libtool
- BuildRequires: curl-devel
- BuildRequires: gnutls-devel
- BuildRequires: libgcrypt-devel
- BuildRequires: graphviz
- BuildRequires: doxygen
- Requires(post): info
- Requires(preun): info
- %description
- GNU libmicrohttpd is a small C library that is supposed to make it
- easy to run an HTTP server as part of another application.
- Key features that distinguish libmicrohttpd from other projects are:
- * C library: fast and small
- * API is simple, expressive and fully reentrant
- * Implementation is http 1.1 compliant
- * HTTP server can listen on multiple ports
- * Support for IPv6
- * Support for incremental processing of POST data
- * Creates binary of only 25k (for now)
- * Three different threading models
- %package devel
- Summary: Development files for libmicrohttpd
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- Development files for libmicrohttpd
- %package doc
- Summary: Documentation for libmicrohttpd
- Group: Documentation
- Requires: %{name} = %{version}-%{release}
- %description doc
- Doxygen documentation for libmicrohttpd and some example source code
- %prep
- %setup -q
- #patch0 -p1 -b .explicit-dso
- # The doxygen file contains references to /home/grothoff/svn/libmicrohttpd/... replace these with .
- sed s/\\/home\\/grothoff\\/svn\\/libmicrohttpd/./ doc/Doxyfile > tmp
- unlink doc/Doxyfile
- mv tmp doc/Doxyfile
- %build
- # Required because patches modify .am files
- # autoreconf --force
- %configure --disable-static --with-gnutls
- make %{?_smp_mflags}
- doxygen doc/Doxyfile
- # Disabled for now due to problems reported at
- # https://gnunet.org/bugs/view.php?id=1619
- #check
- #make check %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR=%{buildroot}
- rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
- rm -f %{buildroot}%{_infodir}/dir
- # Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
- mkdir examples
- install -m 644 src/examples/*.c examples
- # Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
- cp -R doc/doxygen/html html
- %clean
- rm -rf %{buildroot}
- %post doc
- /sbin/install-info %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
- /sbin/install-info %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
- %preun doc
- if [ $1 = 0 ] ; then
- /sbin/install-info --delete %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
- /sbin/install-info --delete %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
- fi
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc COPYING
- %{_libdir}/libmicrohttpd.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/microhttpd.h
- %{_libdir}/libmicrohttpd.so
- %{_libdir}/pkgconfig/libmicrohttpd.pc
- %files doc
- %doc AUTHORS README ChangeLog
- %doc examples
- %doc html
- %defattr(-,root,root,-)
- %{_mandir}/man3/libmicrohttpd.3.gz
- %{_infodir}/microhttpd.info.gz
- %{_infodir}/microhttpd-tutorial.info.gz
- %changelog
- * Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
- - initial build for Vine Linux based on fedora development
- * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
- - Add missing BR gnutls-devel and libgcrypt-devel
- - Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
- implicit DSO linking)
- - Disable test cases for now due to false errors, reported upstream
- * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
- - Re-enable HTTPS, configure flags had unexpected result
- * Sun Nov 7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
- - Update to 0.9.2
- * Sun Jun 4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
- - Update to 0.4.6
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
- - Update to version 0.4.2
- - Drop upstreamed patch
- * Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
- - Update to version 0.4.0a
- - Drop upstreamed patch
- - Added a new patch to fix a 64bit issue
- - The -devel package now contains a pkgconfig file
- - The configure script is now run with '--enable-messages --enable-https'
- - Made the -doc subpackage noarch (F11+)
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
- - Update to version 0.4.0
- - This version introduces a API bump (which is required for
- supporting large files on 32bit environments)
- - The license issues we had with version 0.3.1 of this package (as
- discussed in #457924) are resolved in this version. The license
- of this package is now changed to LGPLv2+
- - Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
- * Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
- - Changed license to GPLv3+ and added some comments
- regarding the license issues with this package
- * Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
- - Changed license to LGPLv2+
- - Moved the COPYING file to the main package
- * Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
- - Initial release
|