libcdio-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. Summary: CD-ROM input and control library
  2. Summary(ja): CD-ROM 入力・制御ライブラリ
  3. Name: libcdio
  4. Version: 0.92
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv3+
  8. URL: http://www.gnu.org/software/libcdio/
  9. Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
  10. Source2: libcdio-no_date_footer.hml
  11. Patch1: libcdio-0.80-paranoia-fix.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: pkgconfig doxygen
  14. BuildRequires: ncurses-devel
  15. BuildRequires: libcddb-devel
  16. BuildRequires: help2man
  17. BuildRequires: gcc-c++
  18. Requires(post): /sbin/install-info
  19. Requires(preun): /sbin/install-info
  20. %description
  21. This library provides an interface for CD-ROM access. It can be used
  22. by applications that need OS- and device-independent access to CD-ROM
  23. devices.
  24. %package devel
  25. Summary: Development files for %{name}
  26. Summary(ja): %{name} の開発用ファイル
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. %description devel
  30. This package contains development files for %{name}.
  31. %prep
  32. %setup -q
  33. f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
  34. iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
  35. %build
  36. %configure \
  37. --disable-vcd-info \
  38. --disable-dependency-tracking \
  39. --disable-rpath \
  40. --enable-cddb \
  41. --disable-static
  42. make %{?_smp_mflags}
  43. cd doc/doxygen
  44. sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
  45. cp %{SOURCE2} .
  46. ./run_doxygen
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. make install DESTDIR=$RPM_BUILD_ROOT
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  51. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  52. rm -rf examples
  53. mkdir -p examples/C++
  54. cp -a example/{*.c,README} examples
  55. cp -a example/C++/{*.cpp,README} examples/C++
  56. %check
  57. # disable test using local CDROM
  58. %{__sed} -i -e "s,testiso9660\$(EXEEXT),,g" \
  59. -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
  60. test/Makefile
  61. make check
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %post
  65. /sbin/ldconfig
  66. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
  67. %preun
  68. if [ $1 = 0 ]; then
  69. /sbin/install-info --delete %{_infodir}/%{name}.info \
  70. %{_infodir}/dir 2>/dev/null || :
  71. fi
  72. %postun -p /sbin/ldconfig
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
  76. %{_bindir}/*
  77. %{_libdir}/*.so.*
  78. %{_infodir}/*
  79. %{_mandir}/man1/*
  80. %files devel
  81. %defattr(-,root,root,-)
  82. %doc doc/doxygen/html examples
  83. %{_includedir}/cdio
  84. %{_includedir}/cdio++
  85. %{_libdir}/*.so
  86. %{_libdir}/pkgconfig/*.pc
  87. %changelog
  88. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
  89. - update to 0.92
  90. * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
  91. - rebuilt with rpm-4.8.1 for pkg-config
  92. - added --enable-cddb
  93. * Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
  94. - new upstream release
  95. - dropt Patch1
  96. - removed static libraries from devel package
  97. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
  98. - initial build for Vine Linux
  99. * Wed Jun 4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
  100. - added patch enabling libcdio_paranoia.pc
  101. * Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
  102. - updated to 0.80
  103. - removed upstreamed patches
  104. - last GPLv2+ release
  105. * Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
  106. - added patch to compile with gcc43
  107. * Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
  108. - fixed security fix (was off by two)
  109. * Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
  110. - updated to 0.79
  111. - fixes #427197 (Long Joliet file name overflows cdio's buffer)
  112. - fixes #341981 (multiarch conflicts in libcdio)
  113. * Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
  114. - rebuilt
  115. * Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
  116. - updated to 0.78.2 (#221359) (this time for real)
  117. * Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
  118. - updated to 0.78.2 (#221359)
  119. * Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
  120. - disabled iso9660 test case (fails for some reason with date problems)
  121. this seems to be a known problem according to the ChangeLog
  122. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
  123. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  124. * Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
  125. - Updated to 0.77
  126. * Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
  127. - Rebuilt
  128. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
  129. - Rebuilt
  130. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
  131. - Updated to 0.76.
  132. - Included doxygen generated documentation into -devel
  133. - Included examples into -devel
  134. * Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
  135. - disable test accessing local CDROM drive (#164266)
  136. * Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
  137. - Rebuilt without libcddb dependency (#164270)
  138. * Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
  139. - Rebuilt
  140. * Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
  141. - Updated to 0.75.
  142. * Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
  143. - Updated to 0.74.
  144. * Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
  145. - BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
  146. - Run test suite during build.
  147. - Install Japanese man pages.
  148. * Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
  149. - Updated to 0.73.
  150. * Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
  151. - Fix FC4 build (#151468).
  152. - Build with dependency tracking disabled.
  153. * Sun Sep 5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
  154. - Updated to 0.70.
  155. * Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
  156. - Updated to 0.69.
  157. - Removed broken iso-read.
  158. - Split Requires(pre,post).
  159. - Added BuildReq pkgconfig.
  160. * Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
  161. - Initial RPM release.