skrooge-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. Name: skrooge
  2. Summary: Personal finances manager
  3. Summary(ja): 個人向け財務管理ツール
  4. Version: 0.8.0
  5. Release: 2%{?_dist_release}
  6. Group: Applications/Productivity
  7. License: GPLv3+
  8. URL: http://skrooge.org
  9. Source0: http://skrooge.org/files/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: qca2-devel
  12. BuildRequires: libofx-devel
  13. BuildRequires: sqlite3-devel
  14. BuildRequires: kdelibs4-devel
  15. BuildRequires: soprano-devel
  16. BuildRequires: gettext
  17. Requires: %{name}-libs = %{version}-%{release}
  18. %description
  19. %{name} is a personal finances manager,
  20. aiming at being simple and intuitive.
  21. It allows you to keep track of your expenses and incomes,
  22. categorize them, and build reports of them.
  23. %package libs
  24. Summary: Skrooge libraries
  25. Summary(ja): Skrooge ライブラリ
  26. Group: System Environment/Libraries
  27. #Requires: %{name} = %{version}-%{release}
  28. Requires: kdelibs4 >= 4.4.0
  29. %description libs
  30. %{name} libraries.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name}-libs = %{version}-%{release}
  36. %description devel
  37. The %{name}-devel package contains libraries for
  38. developing applications that use %{name}.
  39. %prep
  40. %setup -q
  41. ## to prevent spurious-executable-perm in -debuginfo
  42. chmod -x skgbasegui/skglineedit.h
  43. chmod -x skgbasegui/skglineedit.cpp
  44. chmod -x skgbasegui/skglineeditdesignerplugin.h
  45. chmod -x skgbasegui/skgtablewidgetdesignerplugin.h
  46. chmod -x skgbasegui/skglineeditdesignerplugin.cpp
  47. chmod -x skgbasegui/skgtablewidgetdesignerplugin.cpp
  48. %build
  49. mkdir -p %{_target_platform}
  50. pushd %{_target_platform}
  51. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  52. ## the -DCMAKE is needed to prevent unused-direct-shlib-dependency in -libs
  53. ## cant be fixed upstream, see: https://bugs.kde.org/show_bug.cgi?id=209912
  54. %{cmake} \
  55. -Wno-dev \
  56. -DCMAKE_BUILD_TYPE=release \
  57. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  58. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  59. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  60. -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed" \
  61. ..
  62. popd
  63. make %{?_smp_mflags} -C %{_target_platform}
  64. %install
  65. rm -rf %{buildroot}
  66. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  67. %find_lang %{name} --with-kde
  68. # hack to support non-oxygen icon users (gnome), drop when/if skrooge
  69. # ever provides hicolor icons (too).
  70. mv %{buildroot}%{_datadir}/icons/oxygen %{buildroot}%{_datadir}/icons/hicolor
  71. %clean
  72. rm -rf %{buildroot}
  73. %check
  74. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/skrooge.desktop
  75. %post
  76. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  77. %postun
  78. if [ $1 -eq 0 ] ; then
  79. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  80. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  81. update-desktop-database -q &> /dev/null
  82. update-mime-database %{_datadir}/mime &> /dev/null
  83. fi
  84. %posttrans
  85. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  86. update-desktop-database -q &> /dev/null
  87. update-mime-database %{_datadir}/mime &> /dev/null
  88. %post libs -p /sbin/ldconfig
  89. %postun libs -p /sbin/ldconfig
  90. %files -f %{name}.lang
  91. %defattr(-,root,root,-)
  92. %doc AUTHORS CHANGELOG COPYING README TODO
  93. %{_bindir}/skrooge
  94. %{_datadir}/applications/kde4/skrooge.desktop
  95. %{_datadir}/config.kcfg/*.kcfg
  96. %{_datadir}/icons/hicolor/*/*/*
  97. %{_datadir}/kde4/apps/skrooge*/
  98. %{_datadir}/kde4/apps/skg*
  99. %{_datadir}/kde4/services/*.desktop
  100. %{_datadir}/kde4/servicetypes/skg-plugin.desktop
  101. %{_datadir}/mime/packages/x-skg.xml
  102. %{_datadir}/doc/HTML/*/skrooge/
  103. %files libs
  104. %defattr(-,root,root,-)
  105. %{_libdir}/kde4/plugins/designer/*.so.*
  106. %{_libdir}/kde4/*.so
  107. %{_libdir}/lib*.so.*
  108. %files devel
  109. %defattr(-,root,root,-)
  110. %{_libdir}/libskg*.so
  111. %{_libdir}/kde4/plugins/designer/libskg*.so
  112. %changelog
  113. * Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  114. - add BuildRequires: soprano-devel
  115. * Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.0-1
  116. - Initial build for Vine Linux
  117. * Mon May 17 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.1-1
  118. - skrooge 0.7.1 bugfix release
  119. * Mon Apr 26 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.7.0-1
  120. - Skrooge 0.7.0
  121. * Wed Feb 10 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.6.0-1
  122. - New upstream source 0.6.0
  123. * Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.5.5-2
  124. - use %%{_kde4_version}, don't rely on kde4-config --version parsing
  125. * Sun Dec 27 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.5-1
  126. - Update to new upstream release
  127. - Corrects a lot of bugs and problems. See the CHANGELOG for details.
  128. * Sun Nov 30 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.4-1
  129. - Update to new upstream version
  130. - Corrects a lot of bugs and problems. See the changelog for details.
  131. * Sun Nov 01 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.3-1
  132. - Updated to new upstream version
  133. - Readded a -DCMAKE workaround (please keep it for now)
  134. - Useing chmod -x to prevent spurious-executable-perm. Bug filed.
  135. * Wed Oct 14 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.2-2
  136. - (HTML) docs patch, use %%find_lang --with-kde
  137. - own %%{_kde4_appsdir}/skrooge*/ dirs
  138. - %%check: omit extraneous desktop-file-validate's
  139. * Thu Oct 08 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-1
  140. - Changed to final 0.5.2 version
  141. - Bugfixes, including a nasty bug where one thinks the data is gone
  142. - added HTML documentation
  143. - added localizations
  144. * Tue Sep 22 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.2-0.1.beta
  145. - Changed to new upstream Version 0.5.2_beta (lots of bugfixes)
  146. * Mon Sep 21 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.5.beta
  147. - Added -libs Requires libofx
  148. * Mon Sep 21 2009 Rex Dieter <rdieter@fedoraproject.org> 0.5.1-0.4.beta
  149. - misc cosmetics
  150. - mime scriptlets
  151. - move icons to hicolor
  152. - -libs: drop dup'd docs, add min kdelibs4 dep
  153. * Thu Sep 17 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-0.3.beta
  154. - Spec file corrections and Version correction
  155. * Wed Sep 16 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta2
  156. - cleaned up desktop files
  157. * Tue Sep 15 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.1-beta1
  158. - changed version to 0.5.1 beta with fixed rpmlint output
  159. * Sun Sep 13 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-2
  160. - Fixed the spec and rpmlintoutput debuginfo-without-source
  161. * Fri Sep 11 2009 Thomas Janssen <thomasj@fedoraproject.org> 0.5.0-1
  162. - Initial Release 0.5.0