OpenIPMI-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479
  1. # TODO: uses private copy of libedit, should be modified to use system one
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  4. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  5. Name: OpenIPMI
  6. Version: 2.0.25
  7. Release: 1%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+ or BSD
  9. Group: System Environment/Base
  10. URL: http://sourceforge.net/projects/openipmi/
  11. Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  12. Source1: openipmi.sysconf
  13. Source2: openipmi.initscript
  14. Source3: openipmigui.desktop
  15. Source4: README.initscript
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: gdbm-devel
  19. BuildRequires: glib2-devel
  20. BuildRequires: libedit-devel
  21. BuildRequires: ncurses-devel
  22. BuildRequires: net-snmp-devel
  23. BuildRequires: openssl-devel
  24. BuildRequires: perl
  25. BuildRequires: popt-devel
  26. BuildRequires: python-devel
  27. BuildRequires: swig
  28. BuildRequires: tcl
  29. BuildRequires: tkinter
  30. Requires(post): chkconfig
  31. Requires(preun): chkconfig
  32. Patch2: 0002-nobundle.patch
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. The Open IPMI project aims to develop an open code base to allow access to
  37. platform information using Intelligent Platform Management Interface (IPMI).
  38. This package contains the tools of the OpenIPMI project.
  39. %package libs
  40. Summary: The OpenIPMI runtime libraries
  41. Summary(ja): OpenIPMI ランタイムライブラリ
  42. Group: System Environment/Libraries
  43. %description libs
  44. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  45. and applications.
  46. %package perl
  47. Summary: IPMI Perl language bindings
  48. Summary(ja): IPMI Perl 言語バインディング
  49. Group: Development/Libraries
  50. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  51. %description perl
  52. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  53. %package python
  54. Group: Development/Libraries
  55. Summary: IPMI Python language bindings
  56. Summary(ja): IPMI Python 言語バインディング
  57. Requires: python
  58. %description python
  59. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  60. %package devel
  61. Summary: The development environment for the OpenIPMI project
  62. Summary(ja): OpenIPMI の開発キット
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: pkgconfig
  66. %description devel
  67. The OpenIPMI-devel package contains the development libraries and header files
  68. of the OpenIPMI project.
  69. %package gui
  70. Summary: IPMI graphical user interface tool
  71. Summary(ja): IPMI GUI ツール
  72. Group: System Environment/Base
  73. Requires: tix
  74. Requires: tkinter
  75. Requires: %{name}-python = %{version}-%{release}
  76. %description gui
  77. The OpenIPMI-gui package contains the graphical user interface to monitor
  78. and control IPMI-enabled devices.
  79. %prep
  80. %setup -q
  81. %patch2 -p1
  82. rm -rf ./libedit
  83. %build
  84. export EDIT_CFLAGS=`pkg-config --cflags libedit`
  85. export EDIT_LIBS=`pkg-config --libs libedit`
  86. export CFLAGS="-fPIC $RPM_OPT_FLAGS"
  87. autoreconf -vif
  88. %configure \
  89. CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
  90. LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
  91. --with-pythoninstall=%{python_sitearch} \
  92. --disable-dependency-tracking \
  93. --with-tcl=no \
  94. --with-glib12=no \
  95. --disable-static
  96. # get rid of rpath
  97. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  98. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  99. make # not %{?_smp_mflags} safe
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. make install DESTDIR=$RPM_BUILD_ROOT
  103. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  104. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  105. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  106. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  107. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  108. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  109. install -m 644 %SOURCE4 .
  110. %post
  111. /sbin/chkconfig --add ipmi
  112. %preun
  113. if [ $1 = 0 ]; then
  114. service ipmi stop >/dev/null 2>&1
  115. /sbin/chkconfig --del ipmi
  116. fi
  117. %postun
  118. if [ "$1" -ge "1" ]; then
  119. service ipmi condrestart >/dev/null 2>&1 || :
  120. fi
  121. %post libs -p /sbin/ldconfig
  122. %postun libs -p /sbin/ldconfig
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %files
  126. %defattr(-,root,root)
  127. %doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
  128. %config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
  129. %config(noreplace) %{_sysconfdir}/ipmi/lan.conf
  130. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  131. %{_initrddir}/ipmi
  132. %{_bindir}/ipmicmd
  133. %{_bindir}/ipmilan
  134. %{_bindir}/ipmish
  135. %{_bindir}/ipmi_sim
  136. %{_bindir}/ipmi_ui
  137. %{_bindir}/openipmicmd
  138. %{_bindir}/openipmish
  139. %{_bindir}/rmcp_ping
  140. %{_bindir}/sdrcomp
  141. %{_bindir}/solterm
  142. %{_bindir}/openipmi_eventd
  143. %{_mandir}/man1/ipmi_*
  144. %{_mandir}/man1/openipmicmd*
  145. %{_mandir}/man1/openipmish*
  146. %{_mandir}/man1/rmcp_ping*
  147. %{_mandir}/man1/solterm*
  148. %{_mandir}/man5/ipmi_*
  149. %{_mandir}/man1/openipmi_eventd*
  150. %{_mandir}/man7/ipmi_cmdlang*
  151. %{_mandir}/man7/openipmi_conparms*
  152. %{_mandir}/man8/ipmilan*
  153. %files perl
  154. %defattr(-,root,root)
  155. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  156. %{perl_vendorarch}/auto/OpenIPMI/
  157. %files python
  158. %defattr(-,root,root)
  159. %{python_sitearch}/*OpenIPMI*
  160. %files libs
  161. %defattr(-,root,root)
  162. %{_libdir}/*.so.*
  163. %files devel
  164. %defattr(-,root,root)
  165. %{_includedir}/OpenIPMI
  166. %{_libdir}/*.so
  167. %{_libdir}/pkgconfig/*.pc
  168. %files gui
  169. %defattr(-,root,root)
  170. %{_bindir}/openipmigui
  171. %{_mandir}/man1/openipmigui*
  172. %{python_sitearch}/openipmigui
  173. %{_datadir}/applications/fedora-openipmigui.desktop
  174. %changelog
  175. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
  176. - updated to 2.0.25.
  177. - dropped Patch1 (fixed in upstream).
  178. - imported Patch2 from rawhide.
  179. - added BR:libedit-devel.
  180. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
  181. - rebuild with openssl-1.0.2
  182. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
  183. - remove *.la files
  184. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
  185. - updated to 2.0.21
  186. - rebuilt with perl-5.16.3
  187. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
  188. - rebuild with net-snmp-5.7.1
  189. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
  190. - rebuild with python-2.7.2
  191. * Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
  192. - build with perl 5.12.3
  193. - add Vendor and Distribution tags
  194. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  195. - rebuild with openssl-1.0.0d
  196. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  197. - initial build for Vine Linux
  198. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  199. - Mass rebuild with perl-5.12.0
  200. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  201. - updated to OpenIPMI-2.0.18
  202. - fixed OpenIPMIpthread pkgconfig file (#468067)
  203. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  204. - updated to OpenIPMI-2.0.17
  205. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  206. - implemented mandatory 'force-reload' command in ipmi service
  207. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  208. - rebuild against new gdbm
  209. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  210. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  211. (#562151)
  212. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  213. - fix package License: field, there *are* sources with BSD header
  214. - distribute README files and COPYING in package
  215. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  216. - fix package License: field, there is no source with BSD header
  217. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  218. - rebuild against perl 5.10.1
  219. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  220. - fix package compilation to remove rpmlint errors
  221. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  222. - rebuilt with new net-snmp
  223. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  224. - rebuilt with new openssl
  225. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  226. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  227. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  228. - fix compilation flags, debuginfo package is correctly generated now
  229. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  230. - new upstream release
  231. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  232. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  233. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  234. - rebuild with new openssl
  235. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  236. - fix linking without rpath, prelink won't screw up the libraries
  237. anymore (#475265)
  238. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  239. - shorter probe interval is used in init script, making the service startup
  240. quicker in most situations (#475101)
  241. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  242. - Rebuild for Python 2.6
  243. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  244. - removed static libraries from the -devel subpackage
  245. - fixed openipmigui.desktop file
  246. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  247. - fixed typos in the descriptions
  248. - added .desktop file for openipmigui tool
  249. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  250. - fixed description of the package
  251. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  252. - split ipmitool to separate package
  253. - added 'reload' functionality to init script
  254. - added seraparate -gui subpackage
  255. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  256. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  257. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  258. - Fixed several specfile problems (#453751)
  259. - Update to OpenIPMI-2.0.14
  260. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  261. - Autorebuild for GCC 4.3
  262. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  263. - Updated to OpenIPMI-2.0.13
  264. - Rebuild due to new openssl
  265. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  266. - Added missing perl-devel buildrequires
  267. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  268. - Added missing popt-devel buildrequires
  269. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  270. - Fix rebuild problems due to glibc change
  271. - License review and fixes
  272. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  273. - Update to OpenIPMI-2.0.11
  274. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  275. - Update for ipmitool-1.8.9
  276. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  277. - rebuild for python 2.5
  278. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  279. - Update due to new net-snmp-5.4
  280. - Some specfile updates
  281. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  282. - Fixed check for udev in initscript (#197956)
  283. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  284. - rebuild
  285. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  286. - don't include <linux/compiler.h>
  287. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  288. - Fix a build requires (needs glibc-kernheaders)
  289. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  290. - Bump for new glib2
  291. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  292. - Fixed bug with type conversion in ipmitool (#191091)
  293. - Added python bindings
  294. - Split off perl and python bindings in separate subpackages
  295. - Dropped obsolete patches
  296. - Added missing buildprereq on readline-devel
  297. - Made it install the python bindings properly on 64bit archs
  298. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  299. - Updated ipmitool to 1.8.8
  300. - Updated OpenIPMI to 2.0.6
  301. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  302. - Added missing PreReq for chkconfig
  303. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  304. - rebump for build order issues during double-long bump
  305. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  306. - bump again for double-long bug on ppc(64)
  307. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  308. - rebuilt for new gcc4.1 snapshot and glibc changes
  309. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  310. - Updated ipmitool to latest upstream version.
  311. - Removed 3 patches for already fixed bugs in latest ipmitool.
  312. - Adapted warning message fix for ipmitool for latest version.
  313. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  314. - Fixed some minor things in initscripts.
  315. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  316. - Included FRU fix for displaying FRUs with ipmitool
  317. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  318. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  319. - Rebuilt against new libnetsnmp
  320. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  321. - rebuilt
  322. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  323. - Some more initscript and sysconfig updates from Dell.
  324. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  325. - Rebuilt to link against latest openssl libs.
  326. - Fixed ipmitool not setting session privilege level (#172312)
  327. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  328. - Rebuild to link against new net-snmp libs.
  329. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  330. - Updated initscript to fix missing redhat-lsb bug (#169901)
  331. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  332. - Another update to latest initscripts from Dell
  333. - Fixed some missing return statements for non-void functions (#164138)
  334. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  335. - Updated initscript to latest version from Dell
  336. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  337. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  338. now like all our other initscripts (#165476)
  339. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  340. - Fixed build problem on 64bit machines
  341. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  342. - Fixed missing change to not autostart in the initscript
  343. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  344. - Made the initscript a replacing configfile
  345. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  346. - Updated versions of the initscripts and sysconf files
  347. - Fixed typo in preun script and changelog
  348. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  349. - Updated to OpenIPMI-1.4.14
  350. - Split the main package into normal and libs package for multilib support
  351. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  352. - Added sysconf and initscript (#158270)
  353. - Fixed oob subscripts (#149142)
  354. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  355. - Correctly put libs in the proper packages
  356. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  357. - gcc4 rebuild fixes
  358. - Added missing gdbm-devel buildprereq
  359. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  360. - bump release and rebuild with gcc 4
  361. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  362. - update
  363. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  364. - Initial version