koffice-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478
  1. %define sourcedir stable/koffice-%{version}/src
  2. Name: koffice
  3. URL: http://koffice.kde.org/
  4. Summary: Integrated office suite for KDE
  5. Summary(ja): KDE 向け統合オフィススイート
  6. Version: 1.6.3
  7. Release: 3%{?_dist_release}
  8. Epoch: 1
  9. Group: Applications/Productivity
  10. License: GPL
  11. Source: ftp://ftp.kde.org/pub/kde/{sourcedir}/%{name}-%{version}.tar.bz2
  12. Source1: %{name}-l10n-ja-%{version}.tar.bz2
  13. Patch0: koffice-1.6.3-gcc43.patch
  14. Patch1: koffice-1.6.3-gcc44-elif.patch
  15. Patch2: koffice-1.6.3-gcc44-glibc210.patch
  16. # security fix
  17. Patch100: koffice-xpdf-CVE-2007-3387.diff
  18. Patch101: koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: qt-devel >= 3.3.2, kdelibs3-devel >= 3.3, arts-devel >= 1:1.3
  21. BuildRequires: aspell-devel >= 0.50.2, wv2-devel >= 0.1.8
  22. BuildRequires: libjpeg-devel libmng-devel libtiff-devel zlib-devel
  23. BuildRequires: libxml2-devel libxslt-devel freetype2-devel libart_lgpl-devel
  24. BuildRequires: jasper-devel doxygen ImageMagick-devel pkgconfig
  25. BuildRequires: libpng-devel libgsf-devel lcms-devel libexif-devel
  26. BuildRequires: MySQL-devel postgresql-devel
  27. BuildRequires: poppler-qt-devel
  28. BuildRequires: python-devel
  29. BuildRequires: libwpd-devel >= 0.8.0
  30. #if %{?_dist_release}
  31. #BuildConflicts: ruby-devel
  32. #else
  33. BuildRequires: libpqxx-devel libtool-ltdl-devel ruby-devel
  34. #endif
  35. Requires: qt >= 3.3.2, kdelibs3 >= 3.3, arts >= 1:1.3
  36. Requires: freetype2 libjpeg libtiff libmng libpng
  37. Requires: zlib audiofile libxml2 libxslt
  38. Requires: libart_lgpl aspell wv2
  39. Requires(post): kdelibs3
  40. Obsoletes: killustrator kivio
  41. %description
  42. KOffice is a collection of office applications linked together by a common
  43. basis. This common basis assures that all office application can work
  44. together. You can, for instance, insert a spreadsheet in your thesis without
  45. leaving your document. Editing the spreadsheet happens _inside_ your thesis.
  46. The applications currently included in KOffice are:
  47. - KWord (Professional text editing)
  48. - KSpread (Professional number cruncher/spreadsheet)
  49. - KPresenter (Professional presentation program)
  50. - KChart (Graphing of your abstract data)
  51. - Karbon (Vector graphics tool)
  52. - Kugar (Database report creation)
  53. - Kivio (Flowcharting program)
  54. - Kexi (a database management tool)
  55. - KOffice Workspace (A combination of all of the above)
  56. %prep
  57. %setup -q -n %{name}-%{version}
  58. %if %{?_dist_release} == "vl6"
  59. %patch0 -p1 -b .gcc43
  60. %patch1 -p1 -b .elif
  61. %patch2 -p3 -b .glibc210
  62. %endif
  63. %patch100 -p0 -b .CVE-2007-3387
  64. %patch101 -p0 -b .xpdf
  65. # for Python 2.6
  66. %if %{?_dist_release} == "vl6"
  67. sed -i -e 's|""2\.5""|""2\.6""|g' configure
  68. %endif
  69. %build
  70. #only for beta
  71. #make -f Makefile.cvs
  72. unset QTDIR || : ; . /etc/profile.d/qt.sh
  73. export KDEDIR=%{_prefix}
  74. ./configure --prefix=%{_prefix} \
  75. --includedir=%{_includedir}/kde \
  76. --with-qt-libraries=$QTDIR/lib \
  77. --disable-rpath --disable-dependency-tracking \
  78. --enable-new-ldflags \
  79. --disable-debug --disable-warnings \
  80. --with-pic --enable-shared --disable-static \
  81. --with-extra-libs=%{_libdir} \
  82. --with-pgsqllibdir=%{_libdir} --with-pgsqlincdir=%{_includedir} \
  83. --with-pqxxlibdir=%{_libdir} --with-pqxxincdir=%{_includedir} \
  84. --disable-final
  85. make %{?_smp_mflags}
  86. tar xjf %{SOURCE1}
  87. cd %{name}-l10n-ja-%{version}
  88. ./configure --prefix=%{_prefix}
  89. make %{?_smp_mflags}
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. make RUN_KAPPFINDER=no DESTDIR=$RPM_BUILD_ROOT install
  93. # Drop -x
  94. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/kross/python/kexiapp/*
  95. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/copycenter/*
  96. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/exportxhtml/*
  97. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/importxhtml/*
  98. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/projectdocumentor/*
  99. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/changecs/*
  100. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/filterstest/*
  101. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertpython/*
  102. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertruby/*
  103. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/randompaint/*
  104. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/reshapehisto/*
  105. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturefilters/*
  106. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturepainting/*
  107. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/*.py
  108. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/RestrictedPython/*.py
  109. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/exporthtml/*
  110. chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/scripteditor/*
  111. # Replace absolute symlinks with relative ones
  112. pushd $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en
  113. for i in *; do
  114. if [ -d $i -a -L $i/common ]; then
  115. rm -f $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i/common
  116. ln -s ../common $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i
  117. fi
  118. done
  119. popd
  120. cd %{name}-l10n-ja-%{version}
  121. make DESTDIR=$RPM_BUILD_ROOT install
  122. %clean
  123. rm -rf $RPM_BUILD_ROOT
  124. %post
  125. /sbin/ldconfig
  126. kbuildsycoca &>/dev/null || :
  127. %postun -p /sbin/ldconfig
  128. %files
  129. %defattr(-,root,root)
  130. %doc AUTHORS COPYING INSTALL README
  131. %doc %{_datadir}/doc/HTML/en/*
  132. %{_bindir}/*
  133. %{_includedir}/kde/*
  134. %{_libdir}/*
  135. %{_datadir}/applications
  136. %{_datadir}/applnk
  137. %{_datadir}/apps
  138. %config %{_datadir}/config
  139. %{_datadir}/config.kcfg
  140. %{_datadir}/icons
  141. %{_datadir}/locale/ja/LC_MESSAGES/*
  142. %{_datadir}/mimelnk
  143. %{_datadir}/services
  144. %{_datadir}/servicetypes
  145. %{_datadir}/templates
  146. %changelog
  147. * Tue May 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-3
  148. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  149. - fixed configure for building with python-2.6
  150. - added Patch0-2 for building new toolchain
  151. (Gentoo#228839, Debian#504870, Gentoo#270960)
  152. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.3-2
  153. - added libtiff(-devel) to dependency.
  154. - rebuilt with MySQL-5.1.34.
  155. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1
  156. - applied new versioning policy
  157. - spec in UTF-8
  158. * Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl6
  159. - rebuild for VineSeed
  160. * Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl5
  161. - add Patch1 (CVE-2007-4352, 5392, 5393)
  162. * Thu Aug 2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl4
  163. - add Patch0 (CVE-2007-3387)
  164. * Sat Jul 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.3-0vl3
  165. - added --with-qt-libraries configure option
  166. * Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl2
  167. - rebuild for VineSeed
  168. * Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl1
  169. - new upstream release
  170. * Tue Oct 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.0-0vl1
  171. - new upstream release
  172. * Mon Sep 11 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.91-0vl1
  173. - new upstream release
  174. * Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
  175. - rebuild for VineSeed
  176. * Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  177. - new upstream release
  178. - drop obsolete patches
  179. * Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
  180. - rebuild for VineSeed
  181. * Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
  182. - new upstream release
  183. - drop obsolete patches
  184. - add BuildPrereq: libexif-devel
  185. - add --disable-final to configure option
  186. - add Patch0 and Patch1
  187. * Tue Apr 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl3
  188. - build with ruby-1.8.4-0vl1 on VineSeed
  189. - add Buildprereq: ruby-devel for VineSeed
  190. * Thu Apr 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
  191. - rebuild for VineSeed
  192. * Thu Apr 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
  193. - new upstream release
  194. - drop Patch1
  195. * Fri Mar 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
  196. - new upstream release
  197. - drop Patch0
  198. - add --disable-pie and --includedir=%%{_includedir}/kde to configure option
  199. - add BuildConflicts: ruby-devel
  200. - add Patch1
  201. - update %%files
  202. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
  203. - rebuild with libgsf-1.14.0-0vl1
  204. - add Japanese summary
  205. * Thu Jan 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl3
  206. - add Patch0 (CAN-2005-3193)
  207. * Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
  208. - rebuild with libgsf-1.13.3-0vl1 and python-2.4.2-0vl4
  209. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
  210. - new upstream release
  211. - remove all patches
  212. - add SOURCE1 from snapshot
  213. * Mon Sep 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
  214. - add Patch0 - Patch8 to build with qt-3.3.5
  215. - add BuildPrereq: libtool-ltdl-devel
  216. * Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  217. - new upstream release
  218. * Thu Jul 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0a-0vl1
  219. - new upstream release
  220. - remove i18n files
  221. - add BuildPrereq: automake17
  222. - add --disable-rpath to configure option
  223. * Tue Apr 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
  224. - new upstream release
  225. - remove all patches
  226. - add BuildPrereq: lcms-devel MySQL-devel postgresql-devel libpqxx-devel
  227. - change Group to Applications/Productivity
  228. - update Summary and description
  229. * Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl8
  230. - rebuild with KDE-3.4.0 (VineSeed)
  231. * Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl7
  232. - rebuild with KDE-3.4.0 (Vine3.1)
  233. - clean up changelog to use (double-percent) everywhere
  234. * Sat Jan 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl6
  235. - rebuild for VineSeed
  236. * Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl5
  237. - add Patch1 (CAN-2005-0064)
  238. * Fri Jan 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl4
  239. - rebuild for VineSeed
  240. * Fri Jan 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl3
  241. - add patch0 (http://www.koffice.org/security/2004_xpdf_integer_overflow_2.php)
  242. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl2
  243. - rebuild for VineSeed
  244. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl1
  245. - new upstream release
  246. - remove about ia64
  247. - remove patch0
  248. * Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.4-0vl1
  249. - source upgrade
  250. - add Patch0 (security patch)
  251. * Thu Aug 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
  252. - source upgrade
  253. - remove lines about vine26
  254. - add BuildPrereq: libgsf-devel
  255. * Thu May 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  256. - source upgrade
  257. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl3
  258. - rebuild with kde-3.2.2
  259. * Wed Mar 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl2
  260. - rebuild with kde-3.2.1
  261. * Wed Jan 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
  262. - source upgrade
  263. * Mon Dec 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.95-0vl1
  264. - source upgrade
  265. - add BuildPrereq: jasper-devel doxygen ImageMagick-devel pkgconfig
  266. * Mon Sep 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.93-0vl1
  267. - source upgrade
  268. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl2
  269. - rebuild with kdelibs-3.1.4 and gcc-3.2.3
  270. * Fri Aug 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl1
  271. - source upgrade
  272. - BuildPrereq: wv2-devel >= 0.1.8 and add Requires: wv2
  273. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.91-0vl1
  274. - source upgrade
  275. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  276. - change spec to build with gcc295
  277. - remove patch
  278. - add BuildPrereq: aspell-devel >= 0.50.2 and Requires: aspell
  279. - add BuildPrereq: wv2-devel
  280. * Mon May 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl4
  281. - rebuild with kdelibs-3.1.2
  282. * Thu Apr 4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl3
  283. - rebuild with kdelibs-3.1.1
  284. * Sat Feb 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl2
  285. - add patch
  286. * Fri Feb 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
  287. - source upgrade
  288. - change spec to build both VineSeed and Vine2.5/2.6
  289. * Wed Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl3
  290. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  291. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl2
  292. - rebuild with qt-3.0.5-0vl1
  293. - BuildPrereq: autoconf253
  294. * Mon Sep 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl1
  295. - source upgrade
  296. - no file conflicts from other package (maybe)
  297. - add BuildPrereq: objprelink2 instead of objprelink (obsolete)
  298. - add BuildPrereq: libart_lgpl-devel and Requires: libart_lgpl
  299. - add %%doc section
  300. * Fri Jul 5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl3
  301. - add koffice-i18n-ja-1.1.1
  302. * Thu May 2 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl2
  303. - source upgrade to 1.1.1
  304. - delete some .desktop files (they conflict files from kdelibs)
  305. * Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl1
  306. - merged with rawhide 1.1-0.cvs20010725.1
  307. - source update to cvs-20020329
  308. - add BuildPrereq: autoconf252 automake15
  309. - add Epoch:1
  310. - There is Vine's previous changes, hacked for Vine
  311. -- Wed Dec 5 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1-6vl1
  312. - Delete Epoch
  313. - Change BuildRequires and Requires
  314. - Build for VineSeed
  315. * Wed Jul 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010725.1
  316. - Increase Epoch
  317. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010724.1
  318. - Don't build kivio on ia64 ATM (compiler bug)
  319. * Tue Feb 20 2001 Than Ngo <than@redhat.com>
  320. - update 2.1
  321. - fix dangling symlinks
  322. * Fri Feb 2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  323. - Add ldconfig in %%post and %%postun, replace absolute symlinks
  324. with relative symlinks (#24878)
  325. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  326. - Update
  327. * Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  328. - Update
  329. - Don't build on sparc and ia64 (Bug #23809)
  330. * Sun Dec 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  331. - 2.0.1
  332. * Fri Nov 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  333. - Update to KDE_2_0_BRANCH
  334. * Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - 2.0 final
  336. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  337. - 2.0
  338. * Mon Oct 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  339. - new CVS
  340. - fix compilation
  341. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  342. - kill dupes from kdelibs
  343. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  344. - 1.93
  345. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  346. - update (fixed compilation with gcc 2.96 in CVS)
  347. - work around compiler bugs on alpha
  348. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  349. - new snapshot
  350. - move to /usr/lib/kde2
  351. * Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  352. - rebuild
  353. * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  354. - new snapshot
  355. * Sun Jul 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  356. - new snapshot, new Qt
  357. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  358. - Don't hardcode Qt version
  359. - obsolete killustrator (powertools 6.x)
  360. - SMPify
  361. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  362. - use gcc 2.96
  363. - new snapshot
  364. * Mon Jul 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  365. - use kernelcc
  366. - new snapshot
  367. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  368. - new snapshot
  369. - ExcludeArch ia64
  370. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  371. - new snapshot
  372. - move it to /usr, where it belongs
  373. * Sat Oct 23 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  374. - Initial RPM