123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217 |
- %define name medit
- %define version 1.2.0
- Name: %{name}
- Version: %{version}
- Release: 2%{?_dist_release}
- Summary: Multiplatform GTK+2 text editor
- Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
- Group: Applications/Editors
- License: GPLv2+
- URL: http://mooedit.sourceforge.net/
- Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
- #Source1: medit_new_ja.po
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Buildrequires: cairo-devel
- BuildRequires: desktop-file-utils
- BuildRequires: gettext
- BuildRequires: gtk2-devel glib2-devel
- BuildRequires: intltool
- BuildRequires: libxml2-devel
- BuildRequires: libX11-devel libXext-devel libICE-devel
- BuildRequires: libSM-devel
- Buildrequires: perl-XML-Parser pango-devel
- BuildRequires: pcre-devel
- BuildRequires: python-devel
- BuildRequires: pygtk2-devel
- %description
- Medit is a multiplatform GTK+2 text editor.
- Features:
- * Configurable syntax highlighting.
- * Configurable keyboard accelerators.
- * Multiplatform - works both on unix and windows.
- * Plugins: can be written in C or Python.
- * Configurable tools available from the main and context menus.
- They can be written in Python or Lua, or it can be a shell script.
- * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
- %description -l ja
- Medit はマルチプラットフォームな GTK+2 テキストエディタです。
- 機能一覧:
- * 設定可能な構文強調機能。
- * 設定可能なキーボードアクセラレータ。
- * マルチプラットフォーム - unix と windows の両者で動作。
- * プラグイン: C あるいは Python で作成可能。
- * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
- Python あるいは lua 、シェルスクリプトで作成可能。
- * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
- %prep
- %setup -q
- #sed -i 's|fr|fr\nja|g' po/LINGUAS
- #%__cp -f %{SOURCE1} po/ja.po
- %build
- %configure
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR=$RPM_BUILD_ROOT
- desktop-file-install --vendor="" \
- --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
- --mode 0644 \
- $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
- %post
- update-desktop-database %{_datadir}/applications
- touch --no-create %{_datadir}/icons/hicolor
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
- fi
- %postun
- update-desktop-database %{_datadir}/applications
- touch --no-create %{_datadir}/icons/hicolor
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
- fi
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root)
- %doc COPYING README
- %{_bindir}/*
- %{_datadir}/applications/%{name}.desktop
- %{_datadir}/%{name}-1/*
- %{_datadir}/icons/hicolor/48x48/
- %exclude %{_datadir}/icons/hicolor/icon-theme.cache
- %{_datadir}/locale/*
- %{_docdir}/%{name}-1/*
- %{_mandir}/man?/
- %changelog
- * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.2.0-2
- - rebuild with gcc-5.4.0
- * Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2.0-1
- - new upstream release
- - dropt Source1 to merge upstream
- * Sat Mar 15 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-2
- - rebuilt with new toolchain
- * Sun Aug 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-1
- - new upstream release
- - added Source1
- * Sat Mar 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-1
- - new upstream release
- - dropt Source1 to merge upstream
- * Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-2
- - rebuilt with python-2.7
- * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-1
- - new upstream release
- * Sun Sep 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
- - new upstream release
- * Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
- - new upstream release
- * Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
- - new upstream release
- * Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
- - new upstream release
- - updated Source1
- - dropt BuildRequires: cmake
- - added BuildRequires: libSM-devel
- - fixed %%files
- * Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
- - updated Source1
- * Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
- - new upstream release
- - cleaned up spec
- * Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
- - updated Source1
- - added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
- - changed BuildRequires: cmake >= 2.6
- * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
- - new upstream release
- - added Japanese language file
- - added man directory in %files
- * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
- - new upstream release
- - applied new naming policy to spec
- * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
- - initial build for VineSeed
- * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
- + Revision: 155675
- - New version 0.9.2
- - rediff patch0
- + Olivier Blin <oblin@mandriva.com>
- - restore BuildRoot
- + Thierry Vignaud <tvignaud@mandriva.com>
- - kill re-definition of %%buildroot on Pixel's request
- * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
- + Revision: 114221
- - New version 0.9.0
- * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
- + Revision: 109208
- - New release 0.8.11
- * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
- + Revision: 59667
- - New version 0.8.10
- * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
- + Revision: 57568
- - New version 0.8.9
- * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
- + Revision: 51500
- - Fix file list
- - New version
- * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
- + Revision: 39539
- - SILent renew tarball
- - New version
- - New version
- add dirty patch that skips update-icon-cache and mime database when building
- + Jérôme Soyer <saispo@mandriva.org>
- - Import medit
- * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
- - new release
- * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
- - first spec for Mandriva
|