123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348 |
- %define pkg_name lyx
- %define pkg_version 2.3.3
- %define pkg_release 1%{?_dist_release}
- %define _fontdir %{_datadir}/fonts/%{name}
- %define texmf %{_datadir}/texmf
- %define build_texmf %{buildroot}%{texmf}
- %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
- Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
- Summary(ja): LaTeX 形式で保存できるワードプロセッサ
- Name: %{pkg_name}
- Version: %{pkg_version}
- Release: %{pkg_release}
- License: GPLv2 or GPLv3
- Group: Applications/Editors
- URL: http://www.lyx.org/
- Source0: ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/lyx-%{version}.tar.xz
- # Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}-2.tar.xz
- Source1: lyxrc.dist
- Source10: lyx.desktop
- ## upstreamable patches
- # submitted, but upstream rejected it. we currently agree to disagree.
- # Patch50: lyx-2.0.6-xdg_open.patch
- Patch50: lyx-2.3.0-xdg_open.patch
- ## vine
- # reverted checkLatex to lyx-1.6.5
- Patch100: lyx-2.3.0-configurepy-vine.patch
- BuildRequires: enchant-devel
- BuildRequires: hunspell-devel
- BuildRequires: libboost-devel
- BuildRequires: libboost-filesystem
- BuildRequires: libboost-signals
- BuildRequires: libboost-regex
- BuildRequires: desktop-file-utils
- BuildRequires: gettext
- BuildRequires: python
- BuildRequires: xorg-x11-devel
- BuildRequires: qt5-qtbase-devel
- BuildRequires: qt5-qtsvg-devel
- BuildRequires: libpng-devel
- BuildRequires: glib2-devel
- BuildRequires: zlib-devel
- BuildRequires: bc
- Requires(post): texlive-common
- Requires(postun): texlive-common
- Requires: ghostscript
- Requires: python
- Requires: %{name}-fonts = %{version}-%{release}
- Requires: xdg-utils
- Requires: rcs
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- LyX is a modern approach to writing documents which breaks with the
- obsolete "typewriter paradigm" of most other document preparation
- systems.
- It is designed for people who want professional quality output
- with a minimum of time and effort, without becoming specialists in
- typesetting.
- The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
- That is, the author focuses on content, not on the details of formatting.
- This allows for greater productivity, and leaves the final typesetting
- to the backends (like LaTeX) that are specifically designed for the task.
- With LyX, the author can concentrate on the contents of his writing,
- and let the computer take care of the rest.
- This is LyX built with the Qt frontend.
- %description -l ja
- LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
- 特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
- してあります。
- %package fonts
- Summary: Lyx/MathML fonts
- Group: User Interface/X
- # The actual license says "The author of these fonts, Basil K. Malyshev, has
- # kindly granted permission to use and modify these fonts."
- # One of the font files (wasy10) is separately licensed GPL+.
- License: Copyright only and GPL+
- Obsoletes: latex-xft-fonts
- BuildArch: noarch
- %description fonts
- A collection of Math symbol fonts for %{name}.
- %prep
- %setup -q
- %patch50 -b .xdg_open
- %patch100 -b .vine
- %build
- %{configure} \
- --disable-dependency-tracking \
- --disable-rpath \
- --enable-build-type=release \
- --disable-debug \
- --enable-optimization="%{optflags}" \
- --without-included-boost \
- --disable-stdlib-debug \
- --with-enchant \
- --with-hunspell \
- --enable-qt5 \
- ;
- %{__make} %{?_smp_mflags}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} install DESTDIR=${RPM_BUILD_ROOT}
- # misc/extras
- %{__install} -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
- # Set up the lyx-specific class files where TeX can see them
- %{__mkdir_p} %{build_texmf}/tex/latex
- %{__mv} %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
- # desktop & icon
- desktop-file-install --vendor="vine" \
- --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
- %__install -p -D -m644 lib/images/lyx.png \
- %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
- %{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/applications/lyx.desktop
- # ghost'd files
- touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
- touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
- # fonts
- %{__install} -m 0755 -d %{buildroot}%{_fontdir}
- %{__mv} %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
- %{__rm} -rf %{buildroot}%{_datadir}/lyx/fonts
- %find_lang %{name}
- %check
- # tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
- %{__make} -k check || :
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %post
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
- %postun
- if [ $1 -eq 0 ] ; then
- %{exec_texhash} >& /dev/null
- update-desktop-database -q &> /dev/null
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- fi
- %posttrans
- %{exec_texhash} >& /dev/null
- update-desktop-database -q &> /dev/null
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- %post fonts
- %{__font_install_post} %{_fontdir}
- %postun fonts
- %{__font_install_postun} %{_fontdir}
- %files -f %{name}.lang
- %defattr(-,root,root,-)
- %doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
- %{_bindir}/*
- %{_datadir}/lyx/
- %{texmf}/tex/latex/lyx/
- %{_datadir}/applications/*.desktop
- %{_datadir}/icons/hicolor/*/*/*
- %{_mandir}/man*/*
- %config(noreplace) %{_datadir}/lyx/lyxrc.dist
- %ghost %{_datadir}/lyx/lyxrc.defaults
- %ghost %{_datadir}/lyx/*.lst
- %ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
- %files fonts
- %defattr(-,root,root,-)
- %dir %{_fontdir}/
- %{_fontdir}/*.ttf
- %changelog
- * Tue Oct 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.3-1
- - update to 2.3.3
- * Tue Jan 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.2-1
- - update to 2.3.2
- * Sun Oct 07 2018 Toshiaki Ara <ara_t@384.jp> 2.3.1-1
- - update to 2.3.1
- * Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 2.3.0-1
- - update to 2.3.0
- - update Patch50 and Patch100
- * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
- - new upstream release
- - update Patch50 (lyx-2.2.3-xdg_open.patch)
- - add BuildRequires: bc
- - use qt5 instead of qt4
- - add --enable-qt5 option
- - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
- - drop BuildRequires: qt4-devel
- - delete unused options
- * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
- - update to 2.0.6
- - update Patch50 (lyx-2.0.6-xdg_open.patch)
- * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
- - rebuild with hunspell-devel
- * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
- - new upstream release
- - added subpackage "lyx-fonts"
- - added Obsoletes: latex-xft-fonts
- * Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
- - applied lyx-2.0.1-configurepy-vine.patch
- - reverted checkLatex to lyx-1.6.5
- * Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
- - new upstream release
- * Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
- - new upstream release
- - dropped BuildRequires: aspell-devel
- - added BuildRequires:
- - libboost-regex
- - enchant-devel
- - hunspell-devel
- * Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
- - new upstream release
- * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
- - new upstream release
- - TeX Live 2009
- - dropped Requires: xdvik, dvipdfmx
- * Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
- - new upstream release
- - updated Patch0: lyx-1.6.5-xdg_open.patch
- * Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
- - new upstream release
- - dropped old source files
- - change License: GPLv2+
- - added lyx.desktop
- - added BuildRequires:
- - aspell-devel
- - desktop-file-utils
- - gettext
- - python
- - qt4-devel
- - zlib-devel
- - libboost-devel
- - libboost-filesystem
- - libboost-signals
- - libpng-devel
- - glib2-devel
- - added Requires:
- - ghostscript
- - dvipdfmx
- - xdvik
- - qt4
- - xdg-utils
- - optimized some configure options
- * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
- - applied new versioning policy, spec in utf-8
- * Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
- - updated to 1.4.4 with the most recent CJK patch
- - updated Patch1
- * Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
- - base spec file : Vine Linux BTS #219
- * Mon Nov 6 2006 M.H
- - new upstream release
- - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
- * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
- - changed Group to Applications/Editors
- * Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
- - rebuild with qt-3.3.5
- * Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
- - new upstream version
- - change frontend, xforms -> qt
- - require tetex, qt, latex-xft-fonts
- - change applnk file
- - change Group
- * Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
- - new upstream version
- - add mime-info
- - minor change in spec file
- * Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
- - 1.0.3_jp-4
- - added BuildPrereq:
- * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
- - 1.0.3_jp-3
- - minor change in spec file
- - build for Vine Linux 2.1
- * Wed Jan 5 2000 Jun Nishii <jun@vinelinux.org>
- - change group
- * Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
- - updated to lyx-1.0.3
- - rebuild for Vine Linux 2.0
- * Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
- - merged Japanese Documents
- * Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
- - first build
|