python-pillow-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584
  1. %global with_python3 1
  2. %global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  3. %global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  4. %global srcname pillow
  5. # bootstrap building docs (pillow is required by docutils, docutils are
  6. # required by sphinx; pillow build-requires sphinx)
  7. %global with_docs 0
  8. Name: python-%{srcname}
  9. Version: 7.2.0
  10. Release: 2%{?_dist_release}
  11. Summary: Python image processing library
  12. Group: programming
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # License: see http://www.pythonware.com/products/pil/license.htm
  16. License: MIT
  17. URL: http://python-pillow.github.io/
  18. Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
  19. BuildRequires: freetype2-devel
  20. BuildRequires: gcc
  21. BuildRequires: ghostscript
  22. BuildRequires: lcms2-devel
  23. #BuildRequires: libimagequant-devel
  24. BuildRequires: libjpeg-devel
  25. #BuildRequires: libraqm-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libwebp-devel
  28. BuildRequires: openjpeg2-devel
  29. BuildRequires: tk-devel
  30. BuildRequires: zlib-devel
  31. %if 0%{?with_python3}
  32. BuildRequires: python3-rpm-macros
  33. BuildRequires: python3-cffi
  34. BuildRequires: python3-devel
  35. BuildRequires: python3-numpy
  36. #BuildRequires: python3-olefile
  37. BuildRequires: python3-qt5
  38. BuildRequires: python3-setuptools
  39. %if 0%{?with_docs}
  40. BuildRequires: python3-sphinx
  41. BuildRequires: python3-sphinx_rtd_theme
  42. %endif
  43. BuildRequires: python3-tkinter
  44. %endif
  45. %global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
  46. %description
  47. Python image processing library, fork of the Python Imaging Library (PIL)
  48. This library provides extensive file format support, an efficient
  49. internal representation, and powerful image processing capabilities.
  50. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  51. devel (development) and doc (documentation).
  52. %if 0%{?with_python3}
  53. %package -n python3-%{srcname}
  54. Summary: Python 3 image processing library
  55. Group: programming
  56. Requires: ghostscript
  57. %{?python_provide:%python_provide python3-%{srcname}}
  58. Provides: python3-imaging = %{version}-%{release}
  59. %description -n python3-%{srcname}
  60. Python image processing library, fork of the Python Imaging Library (PIL)
  61. This library provides extensive file format support, an efficient
  62. internal representation, and powerful image processing capabilities.
  63. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  64. devel (development) and doc (documentation).
  65. %package -n python3-%{srcname}-devel
  66. Summary: Development files for %{srcname}
  67. Group: programming
  68. Requires: python3-devel, libjpeg-devel, zlib-devel
  69. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  70. %{?python_provide:%python_provide python3-%{srcname}-devel}
  71. Provides: python3-imaging-devel = %{version}-%{release}
  72. %description -n python3-%{srcname}-devel
  73. Development files for %{srcname}.
  74. %package -n python3-%{srcname}-doc
  75. Summary: Documentation for %{srcname}
  76. Group: documentation
  77. BuildArch: noarch
  78. Requires: python3-%{srcname} = %{version}-%{release}
  79. %{?python_provide:%python_provide python3-%{srcname}-doc}
  80. Provides: python3-imaging-doc = %{version}-%{release}
  81. Obsoletes: python-%{srcname}-doc < 5.4.1-4
  82. %description -n python3-%{srcname}-doc
  83. Documentation for %{srcname}.
  84. %package -n python3-%{srcname}-tk
  85. Summary: Tk interface for %{srcname}
  86. Group: programming
  87. Requires: python3-tkinter
  88. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  89. %{?python_provide:%python_provide python3-%{srcname}-tk}
  90. Provides: python3-imaging-tk = %{version}-%{release}
  91. %description -n python3-%{srcname}-tk
  92. Tk interface for %{name}.
  93. %package -n python3-%{srcname}-qt
  94. Summary: Qt %{srcname} image wrapper
  95. Group: programming
  96. Requires: python3-qt5
  97. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  98. %{?python_provide:%python_provide python3-%{srcname}-qt}
  99. Provides: python3-imaging-qt = %{version}-%{release}
  100. %description -n python3-%{srcname}-qt
  101. Qt %{srcname} image wrapper.
  102. %endif
  103. %prep
  104. %autosetup -p1 -n Pillow-%{version}
  105. %build
  106. %if 0%{?with_python3}
  107. # Build Python 3 modules
  108. %py3_build
  109. %ifarch x86_64
  110. %if 0%{?with_docs}
  111. PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
  112. rm -f docs/_build_py3/html/.buildinfo
  113. %endif
  114. %endif
  115. %endif
  116. %install
  117. %if 0%{?with_python3}
  118. # Install Python 3 modules
  119. install -d %{buildroot}/%{py3_incdir}/Imaging
  120. install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
  121. %py3_install
  122. %endif
  123. %check
  124. %if 0%{?with_python3}
  125. # Check Python 3 modules
  126. ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
  127. cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
  128. cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
  129. pushd build/%py3_libbuilddir
  130. PYTHONPATH=$PWD %{__python3} selftest.py
  131. popd
  132. %endif
  133. %if 0%{?with_python3}
  134. %files -n python3-%{srcname}
  135. %doc README.rst CHANGES.rst
  136. %license docs/COPYING
  137. %{python3_sitearch}/*
  138. # These are in subpackages
  139. %exclude %{python3_sitearch}/PIL/_imagingtk*
  140. %exclude %{python3_sitearch}/PIL/ImageTk*
  141. %exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
  142. %exclude %{python3_sitearch}/PIL/ImageQt*
  143. %exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
  144. %exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  145. %exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
  146. %files -n python3-%{srcname}-devel
  147. %{py3_incdir}/Imaging/
  148. %ifarch x86_64
  149. %files -n python3-%{srcname}-doc
  150. %if 0%{?with_docs}
  151. %doc docs/_build_py3/html
  152. %endif
  153. %endif
  154. %files -n python3-%{srcname}-tk
  155. %{python3_sitearch}/PIL/_imagingtk*
  156. %{python3_sitearch}/PIL/ImageTk*
  157. %{python3_sitearch}/PIL/SpiderImagePlugin*
  158. %{python3_sitearch}/PIL/__pycache__/ImageTk*
  159. %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  160. %files -n python3-%{srcname}-qt
  161. %{python3_sitearch}/PIL/ImageQt*
  162. %{python3_sitearch}/PIL/__pycache__/ImageQt*
  163. %endif
  164. %changelog
  165. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-2
  166. - built with python-3.8.
  167. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
  168. - new upstream release.
  169. - dropped python2 support.
  170. * Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
  171. - new upstream release.
  172. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  173. - initial build for Vine Linux.
  174. * Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
  175. - Remove optional build dependency on python2-cffi
  176. * Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
  177. - Update to 6.2.0
  178. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
  179. - Rebuilt for Python 3.8
  180. * Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
  181. - Drop python2-pillow-qt, python2-pillow-tk
  182. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  184. * Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
  185. - Update to 6.1.0
  186. * Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
  187. - Fix broken Python/C interop on s390x
  188. * Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
  189. - Update to 6.0.0
  190. * Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  191. - Drop python2-pillow-doc
  192. * Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
  193. - Fix python3 conditional
  194. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
  195. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  196. * Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
  197. - Update to 5.4.1
  198. * Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
  199. - Update to 5.3.0
  200. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
  201. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  202. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
  203. - Rebuilt for Python 3.7
  204. * Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
  205. - Update to 5.2.0
  206. * Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
  207. - Fix the tkinter dependency
  208. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
  209. - Rebuilt for Python 3.7
  210. * Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
  211. - Update to 5.1.1
  212. * Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
  213. - Update to 5.1.0
  214. * Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
  215. - Add missing BR: gcc
  216. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
  217. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  218. * Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
  219. - Update to 5.0.0
  220. * Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
  221. - Update to 4.3.0
  222. * Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
  223. - Cleanup spec file conditionals
  224. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
  225. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  226. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
  227. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  228. * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
  229. - Rebuild due to bug in RPM (RHBZ #1468476)
  230. * Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
  231. - Update to 4.2.1
  232. * Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
  233. - Update to 4.2.0
  234. * Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
  235. - Update to 4.1.1
  236. * Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
  237. - Update to 4.1.0
  238. * Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
  239. - Fix some __pycache__ files in wrong subpackage (#1422606)
  240. * Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
  241. - Rebuild (libwebp)
  242. * Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
  243. - Update to 4.0.0
  244. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
  245. - Enable docs build
  246. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
  247. - Rebuild for Python 3.6
  248. * Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
  249. - Update to 3.4.2
  250. * Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
  251. - Update to 3.4.1
  252. * Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
  253. - Update to 3.4.0
  254. * Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
  255. - Update to 3.3.1
  256. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
  257. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  258. * Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
  259. - Update to 3.3.0
  260. - Modernize spec
  261. * Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
  262. - Update to 3.2.0
  263. * Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
  264. - Fix broken python3-pillow package description
  265. * Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
  266. - Fix provides
  267. * Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
  268. - Update to 3.1.1
  269. - Fixes CVE-2016-0740, CVE-2016-0775
  270. * Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
  271. - Fix executable files in doc package bringing in python 2 for the python3 doc
  272. packages
  273. * Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
  274. - Update to 3.1.0
  275. * Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
  276. - Build with docs
  277. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
  278. - Rebuilt for libwebp soname bump
  279. * Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
  280. - Rebuilt for Python3.5 rebuild with docs
  281. * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
  282. - Rebuilt for Python3.5 rebuild without docs
  283. * Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
  284. - Update to 3.0.0
  285. * Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
  286. - Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
  287. * Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
  288. - Update to 2.9.0
  289. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
  290. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  291. * Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
  292. - Update to 2.8.2
  293. * Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
  294. - Update to 2.8.1
  295. * Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
  296. - Update to 2.8.0
  297. * Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
  298. - Update to 2.7.0
  299. - Drop sane subpackage, is in python-sane now
  300. - Fix python3 headers directory
  301. - Drop Obsoletes: python3-pillow on python3-pillow-qt
  302. * Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
  303. - Update to 2.6.1
  304. * Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
  305. - Update to 2.6.0
  306. * Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
  307. - Rebuilding again to resolve transient build error that caused BZ#1131723
  308. * Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
  309. - Rebuilding to resolve transient build error that caused BZ#1131723
  310. * Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
  311. - Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
  312. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
  313. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  314. * Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
  315. - Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
  316. * Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
  317. - Reenable jpeg2k tests on big endian arches
  318. * Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
  319. - Update to 2.5.1
  320. * Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
  321. - Update to 2.5.0
  322. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
  323. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  324. * Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
  325. - Rebuild with docs enabled
  326. - Update python-pillow_openjpeg-2.1.0.patch
  327. * Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
  328. - Rebuild against openjpeg-2.1.0
  329. * Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
  330. - skip jpeg2k tests on big endian arches (#1100762)
  331. * Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
  332. - Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
  333. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
  334. - Set with_docs to 1 to build docs.
  335. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
  336. - Bootstrap building sphinx docs because of circular dependency with sphinx.
  337. * Fri May 9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
  338. - Rebuild for Python 3.4
  339. * Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
  340. - Add patch: Have the tempfile use a suffix with a dot
  341. * Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
  342. - Enable Jpeg2000 support
  343. - Enable webp support also on s390* archs, bug #962091 is now fixed
  344. - Add upstream patch for ghostscript detection
  345. * Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
  346. - Update to 2.4.0
  347. * Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
  348. - Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
  349. * Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
  350. - python-pillow does not provide python3-imaging
  351. (python3-pillow does)
  352. * Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
  353. - Add missing ghostscript Requires and BuildRequires
  354. * Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
  355. - Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
  356. * Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
  357. - Rebuild with docs enabled
  358. - Change lcms BR to lcms2
  359. * Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
  360. - Update to 2.3.0
  361. - Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
  362. * Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
  363. - Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
  364. * Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
  365. - Update to 2.2.1
  366. - Really enable webp on ppc, but leave disabled on s390
  367. * Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
  368. - Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
  369. - Renable webp support on bigendian arches
  370. * Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
  371. - Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
  372. * Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
  373. - Build without webp support on ppc* archs (#988767)
  374. * Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
  375. - Update to 2.1.0
  376. - Run tests in builddir, not installroot
  377. - Build python3-pillow docs with python3
  378. - python-pillow_endian.patch upstreamed
  379. * Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
  380. - Build without webp support on s390* archs
  381. Resolves: rhbz#962059
  382. * Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
  383. - Conditionaly disable build of python3 parts on RHEL system
  384. * Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
  385. - Add patch to fix test failure on big-endian
  386. * Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
  387. - Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
  388. appropriate since qt support didn't exist in the previous python-pillow
  389. package so there's no reason to drag in python-pillow-qt when updating
  390. python-pillow.
  391. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
  392. - Update to latest git
  393. - python-pillow_quantization.patch now upstream
  394. - python-pillow_endianness.patch now upstream
  395. - Add subpackage for ImageQt module, with correct dependencies
  396. - Add PyQt4 and numpy BR (for generating docs / running tests)
  397. * Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
  398. - Reenable tests on bigendian, add patches for #928927
  399. * Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
  400. - Update to latest git
  401. - disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
  402. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
  403. - python-pillow_tempfile.patch now upstream
  404. - Add python3-imaging provides (bug #924867)
  405. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
  406. - Update to latest git
  407. - Remove python-pillow-disable-test.patch, gcc is now fixed
  408. - Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
  409. * Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
  410. - Update to 2.0.0 git snapshot
  411. - Enable python3 packages
  412. - Add libwebp-devel BR for Pillow 2.0.0
  413. * Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
  414. - Add ARM support
  415. * Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
  416. - add s390* and ppc* to arch detection
  417. * Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
  418. - Update to latest git snapshot
  419. - 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
  420. - Pillow-1.7.8-selftest.patch now upstream
  421. * Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
  422. - Really remove -fno-strict-aliasing
  423. - Place comment on how to retreive source just above the Source0 line
  424. * Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
  425. - Rebuild without -fno-strict-aliasing
  426. - Add patch for upstream issue #52
  427. * Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
  428. - Initial RPM package