rrdtool-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248
  1. # Basic Information
  2. Name: rrdtool
  3. Version: 1.7.1
  4. Release: 1%{?_dist_release}
  5. License: GPLv2+ with exceptions
  6. Group: Applications/Databases
  7. URL: http://oss.oetiker.ch/rrdtool/
  8. Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
  9. Patch3: rrdtool-1.6.0-ruby-2-fix.patch
  10. Summary: RRDtool - Round Robin Database tool
  11. Summary(ja): RRDtool - ラウンドロビンデータベースツール
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # Dependency
  14. BuildRequires: glib2-devel
  15. BuildRequires: glibc-devel
  16. BuildRequires: libdbi-devel
  17. BuildRequires: libxml2-devel
  18. BuildRequires: lua-devel
  19. BuildRequires: pango-devel
  20. BuildRequires: perl(ExtUtils::MakeMaker)
  21. BuildRequires: python-devel
  22. BuildRequires: python-setuptools
  23. BuildRequires: ruby-devel
  24. BuildRequires: tcl-devel
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: yasumichi
  28. %description
  29. It is pretty easy to gather status information from all sorts of things,
  30. ranging from the temperature in your office to the number of octets which
  31. have passed through the FDDI interface of your router. But it is not so
  32. trivial to store this data in a efficient and systematic manner. This is
  33. where RRDtool kicks in. It lets you log and analyze the data you gather from
  34. all kinds of data-sources (DS). The data analysis part of RRDtool is based
  35. on the ability to quickly generate graphical representations of the data
  36. values collected over a definable time period.
  37. #%%description -l ja
  38. %package devel
  39. Summary: Libraries and include files of RRDtool
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description devel
  43. Libraries and include files of RRDtool
  44. %package doc
  45. Summary: RRDtool documentation
  46. Summary(ja): RRDtool のドキュメント
  47. Group: Applications/Documentation
  48. BuildArch: noarch
  49. %description doc
  50. RRD is the Acronym for Round Robin Database. RRD is a system to store and
  51. display time-series data (i.e. network bandwidth, machine-room temperature,
  52. server load average). This package contains documentation on using RRD.
  53. %package tcl
  54. Summary: RRDTool modules for tcl
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. %description tcl
  58. RRDTool bindings for Tcl.
  59. %package -n perl-rrdtool
  60. Summary: Perl RRDtool bindings
  61. Summary(ja): RRDTool の perl バインディング
  62. Group: Development/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  65. %description -n perl-rrdtool
  66. The Perl RRDTool bindings.
  67. %package -n python-rrdtool
  68. Summary: Python RRDTool bindings
  69. Summary(ja): RRDTool の Python バインディング
  70. Group: Development/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. %description -n python-rrdtool
  73. RDTool bindings for python.
  74. %package -n ruby-rrdtool
  75. Summary: Ruby RRDTool bindings
  76. Summary(ja): RRDTool の ruby バインディング
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. %description -n ruby-rrdtool
  80. RRDtool bindings for Ruby.
  81. %prep
  82. %setup -q
  83. %patch3 -p1 -b .ruby-2-fix
  84. autoreconf -vif
  85. %build
  86. %configure \
  87. --disable-rpath \
  88. --disable-static \
  89. --enable-perl-site-install \
  90. --with-perl-options="INSTALLDIRS=vendor" \
  91. --enable-ruby \
  92. --enable-ruby-site-install \
  93. --with-pic
  94. # Fix another rpath issue
  95. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
  96. bindings/perl-shared/Makefile.PL
  97. # Remove Rpath from Ruby
  98. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
  99. bindings/ruby/extconf.rb
  100. sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
  101. perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
  102. %{__make} %{?_smp_mflags}
  103. %install
  104. %{__rm} -rf ${RPM_BUILD_ROOT}
  105. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  106. # Install ruby module by force
  107. mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
  108. make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
  109. # We only want .txt and .html files for the main documentation
  110. rm -rf docs_to_be_included
  111. mkdir -p docs_to_be_included/html docs_to_be_included/txt
  112. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
  113. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
  114. # Put perl docs in perl package
  115. rm -rf docs_perl
  116. mkdir -p docs_perl/html
  117. mv docs_to_be_included/html/RRD*.html docs_perl/html/
  118. # Clean up
  119. %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
  120. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
  121. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
  122. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  123. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
  124. %find_lang %{name}
  125. %clean
  126. %{__rm} -rf ${RPM_BUILD_ROOT}
  127. %post -p /sbin/ldconfig
  128. %postun -p /sbin/ldconfig
  129. %files -f %{name}.lang
  130. %defattr(-,root,root)
  131. #doc COPYING NEWS README TODO
  132. %{_bindir}/rrd*
  133. %{_libdir}/lua/*/rrd.so.*
  134. %{_libdir}/librrd*.so.*
  135. %{_mandir}/man1/*.1*
  136. %{_datadir}/rrdtool/examples/cgi-demo.cgi
  137. %files devel
  138. %defattr(-,root,root)
  139. %{_includedir}/rrd*.h
  140. %{_libdir}/lua/*/rrd.so
  141. %{_libdir}/librrd.so
  142. %{_libdir}/pkgconfig/librrd.pc
  143. %{_mandir}/man3/librrd.3*
  144. %files doc
  145. %defattr(-,root,root,-)
  146. %license COPYRIGHT LICENSE
  147. %doc CONTRIBUTORS TODO NEWS THREADS
  148. %doc docs_to_be_included/html docs_to_be_included/txt
  149. %files tcl
  150. %defattr(-,root,root)
  151. %doc bindings/tcl/README
  152. #%{_datadir}/rrdtool/ifOctets.tcl
  153. #%{_datadir}/rrdtool/pkgIndex.tcl
  154. %{_libdir}/tclrrd*.so
  155. %{_libdir}/rrdtool/*.tcl
  156. %files -n perl-rrdtool
  157. %defattr(-,root,root)
  158. %{perl_vendorlib}/RRDp.pm
  159. %{perl_vendorarch}/RRDs.pm
  160. %{perl_vendorarch}/auto/RRDs/RRDs.so
  161. %{_datadir}/rrdtool/examples/*.pl
  162. %{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
  163. %{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
  164. %{_mandir}/man3/RRD?.3pm*
  165. %files -n python-rrdtool
  166. %defattr(-,root,root)
  167. %doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
  168. %{python_sitearch}/rrdtool-*-py*.egg-info
  169. %{python_sitearch}/rrdtool.so
  170. %{_datadir}/rrdtool/examples/*.py
  171. %files -n ruby-rrdtool
  172. %defattr(-,root,root,-)
  173. %doc bindings/ruby/README
  174. %{ruby_vendorarchdir}/RRD.so
  175. %changelog
  176. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  177. - new upstream release.
  178. - rebuilt with perl-5.26.
  179. - rebuilt with ruby-2.4.6.
  180. - updated Patch3.
  181. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
  182. - rebuild with ruby-2.2.3
  183. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
  184. - rebuild with libdbi-0.9.0
  185. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
  186. - new upstream release.
  187. - added Group tag to subpackages
  188. - added ruby subpackages
  189. - split documents into subpackages
  190. - added %%post and %%postun section
  191. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
  192. - new upstream release.
  193. * Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
  194. - initial build for Vine Linux