libtalloc-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libtalloc
  3. Version: 2.1.14
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Summary: The talloc library
  7. License: LGPLv3+
  8. URL: http://talloc.samba.org/
  9. Source: http://samba.org/ftp/talloc/talloc-%{version}.tar.gz
  10. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  11. BuildRequires: autoconf
  12. BuildRequires: libxslt
  13. BuildRequires: docbook-style-xsl
  14. BuildRequires: doxygen
  15. BuildRequires: python-devel python-rpm-macros
  16. BuildRequires: python3-devel python3-rpm-macros
  17. Provides: bundled(libreplace)
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: tomop
  21. %description
  22. A library that implements a hierarchical allocator with destructors.
  23. %package devel
  24. Group: Development/Libraries
  25. Summary: Developer tools for the Talloc library
  26. Requires: libtalloc = %{version}-%{release}
  27. %description devel
  28. Header files needed to develop programs that link against the Talloc library.
  29. %package -n python-talloc
  30. Group: Development/Libraries
  31. Summary: Python bindings for the Talloc library
  32. Requires: libtalloc = %{version}-%{release}
  33. Obsoletes: pytalloc < 2.1.11
  34. Provides: pytalloc = %{version}
  35. %description -n python-talloc
  36. Python libraries for creating bindings using talloc
  37. %package -n python-talloc-devel
  38. Group: Development/Libraries
  39. Summary: Development libraries for python-talloc
  40. Requires: python-talloc = %{version}-%{release}
  41. Obsoletes: pytalloc-devel < 2.1.11
  42. Provides: pytalloc-devel = %{version}
  43. %description -n python-talloc-devel
  44. Development libraries for python-talloc
  45. %package -n python3-talloc
  46. Group: Development/Libraries
  47. Summary: Python3 bindings for the Talloc library
  48. Requires: libtalloc = %{version}-%{release}
  49. %description -n python3-talloc
  50. Python3 libraries for creating bindings using talloc
  51. %package -n python3-talloc-devel
  52. Group: Development/Libraries
  53. Summary: Development libraries for python3-talloc
  54. Requires: python3-talloc = %{version}-%{release}
  55. %description -n python3-talloc-devel
  56. Development libraries for python3-talloc
  57. %if %{build_compat32}
  58. %package -n compat32-libtalloc
  59. Summary: The talloc library
  60. Group: System Environment/Libraries
  61. %description -n compat32-libtalloc
  62. A library that implements a hierarchical allocator with destructors.
  63. %endif
  64. %prep
  65. %setup -q -n talloc-%{version}
  66. %build
  67. #./autogen.sh
  68. %configure --disable-rpath \
  69. --disable-rpath-install \
  70. --bundled-libraries=NONE \
  71. --builtin-libraries=replace \
  72. --disable-silent-rules \
  73. --extra-python=%{__python3}
  74. make %{?_smp_mflags} V=1
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. # Shared libraries need to be marked executable for
  79. # rpmbuild to strip them and include them in debuginfo
  80. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/libtalloc.a
  82. rm -f $RPM_BUILD_ROOT/usr/share/swig/*/talloc.i
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files
  86. %defattr(-,root,root,-)
  87. %{_libdir}/libtalloc.so.*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %{_includedir}/talloc.h
  91. %{_libdir}/libtalloc.so
  92. %{_libdir}/pkgconfig/talloc.pc
  93. %{_mandir}/man3/talloc.3.gz
  94. %files -n python-talloc
  95. %defattr(-,root,root,-)
  96. %{_libdir}/libpytalloc-util.so.*
  97. %{python_sitearch}/talloc.so
  98. %files -n python-talloc-devel
  99. %defattr(-,root,root,-)
  100. %{_includedir}/pytalloc.h
  101. %{_libdir}/pkgconfig/pytalloc-util.pc
  102. %{_libdir}/libpytalloc-util.so
  103. %files -n python3-talloc
  104. %defattr(-,root,root,-)
  105. %{_libdir}/libpytalloc-util.cpython*.so.*
  106. %{python3_sitearch}/talloc.cpython*.so
  107. %files -n python3-talloc-devel
  108. %defattr(-,root,root,-)
  109. %{_includedir}/pytalloc.h
  110. %{_libdir}/pkgconfig/pytalloc-util.cpython-*.pc
  111. %{_libdir}/libpytalloc-util.cpython*.so
  112. %if %{build_compat32}
  113. %files -n compat32-libtalloc
  114. %attr(755,root,root) %{_libdir}/libtalloc.so.*
  115. %endif
  116. %post -p /sbin/ldconfig
  117. %postun -p /sbin/ldconfig
  118. %post -n python-talloc -p /sbin/ldconfig
  119. %postun -n python-talloc -p /sbin/ldconfig
  120. %post -n python3-talloc -p /sbin/ldconfig
  121. %postun -n python3-talloc -p /sbin/ldconfig
  122. %if %{build_compat32}
  123. %post -n compat32-libtalloc -p /sbin/ldconfig
  124. %postun -n compat32-libtalloc -p /sbin/ldconfig
  125. %endif
  126. %changelog
  127. * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.14-1
  128. - new upstream release.
  129. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.11-1
  130. - new upstream release.
  131. - enabled python3 modules.
  132. - renamed python packages.
  133. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.8-1
  134. - new upstream release.
  135. * Wed Jun 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.7-1
  136. - new upstream release.
  137. * Thu Mar 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  138. - new upstream release.
  139. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.5-1
  140. - new upstream release.
  141. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.4-1
  142. - new upstream release.
  143. * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.3-1
  144. - new upstream release.
  145. * Fri Apr 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
  146. - new upstream release.
  147. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  148. - new upstream release.
  149. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
  150. - rebuilt with current environment.
  151. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  152. - new upstream release.
  153. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
  154. - new upstream release.
  155. * Sat Apr 14 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
  156. - new upstream release.
  157. - updated Patch0001.
  158. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.5-10
  159. - rebuild with python-2.7.2
  160. * Thu Mar 24 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-9
  161. - initial build for Vine Linux.
  162. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.5-8
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  164. * Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-7
  165. - Let rpmbuild strip binaries, make build more verbose.
  166. - Resolves rhbz#669477 - libtalloc 2.0.5-6 binaries not stripped,
  167. - empty -debuginfo
  168. - Original patch by Ville Skyttä <ville.skytta@iki.fi>
  169. * Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-6
  170. - Install python bindings in the correct location
  171. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-5
  172. - Run ldconfig on pytalloc
  173. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-4
  174. - Fix build failure on 32-bit platforms
  175. * Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-3
  176. - New version from upstream
  177. - Add support for pytalloc
  178. - Convert to new WAF build-system
  179. * Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 2.0.1-1
  180. - New version from upstream
  181. - Also stop building the compat lib, it is not necessary anymore
  182. * Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 2.0.0-0
  183. - New version from upstream.
  184. - Build also sover 1 compat library to ease packages migration
  185. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  187. * Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-1
  188. - Original tarballs had a screw-up, rebuild with new fixed tarballs from
  189. upstream.
  190. * Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-0
  191. - New Upstream release.
  192. * Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.3.0-0
  193. - First public independent release from upstream