libidn-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libidn
  3. Summary: Internationalized Domain Name support library
  4. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  5. Version: 1.29
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv3+ and LGPLv3+
  9. URL: http://www.gnu.org/software/libidn/
  10. Source0: http://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gettext
  13. BuildRequires: pkgconfig
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. %description
  17. GNU Libidn is an implementation of the Stringprep, Punycode and
  18. IDNA specifications defined by the IETF Internationalized Domain
  19. Names (IDN) working group, used for internationalized domain
  20. names.
  21. %package devel
  22. Summary: Development files for the libidn library
  23. Summary(ja): libidn ライブラリの開発用ファイル
  24. Group: Development/Libraries
  25. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  26. Requires: %{name} = %{version}-%{release}
  27. %description devel
  28. This package includes header files and libraries necessary for
  29. developing programs which use the GNU libidn library.
  30. # compat32
  31. %package -n compat32-%{name}
  32. Summary: Internationalized Domain Name support library
  33. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  34. Group: System Environment/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description -n compat32-%{name}
  37. GNU Libidn is an implementation of the Stringprep, Punycode and
  38. IDNA specifications defined by the IETF Internationalized Domain
  39. Names (IDN) working group, used for internationalized domain
  40. names.
  41. %package -n compat32-%{name}-devel
  42. Summary: Development files for the libidn library
  43. Summary(ja): libidn ライブラリの開発用ファイル
  44. Group: Development/Libraries
  45. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  46. Requires: compat32-%{name} = %{version}-%{release}
  47. Requires: %{name}-devel = %{version}-%{release}
  48. %description -n compat32-%{name}-devel
  49. This package includes header files and libraries necessary for
  50. developing programs which use the GNU libidn library.
  51. %prep
  52. %setup -q
  53. # Disable static library creation by default.
  54. %define with_static 0
  55. %build
  56. %configure --disable-csharp --disable-java \
  57. %if ! %{with_static}
  58. --disable-static
  59. %endif
  60. make %{?_smp_mflags}
  61. make %{?_smp_mflags} -C tests check
  62. %install
  63. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  64. %makeinstall
  65. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
  66. # provide more examples
  67. make %{?_smp_mflags} -C examples distclean
  68. # clean up docs
  69. find doc -name "Makefile*" | xargs rm
  70. rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
  71. %find_lang %{name}
  72. %post
  73. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
  74. /sbin/ldconfig
  75. %preun
  76. if [ $1 = 0 ]; then
  77. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
  78. fi
  79. %postun -p /sbin/ldconfig
  80. %if %{build_compat32}
  81. %post -n compat32-%{name} -p /sbin/ldconfig
  82. %postun -n compat32-%{name} -p /sbin/ldconfig
  83. %endif
  84. %clean
  85. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  86. %files -f %{name}.lang
  87. %defattr(-,root,root)
  88. %doc ChangeLog NEWS FAQ README THANKS COPYING*
  89. %{_bindir}/idn
  90. %{_mandir}/man1/idn.1*
  91. %{_datadir}/emacs/site-lisp
  92. %{_libdir}/libidn.so.*
  93. #{_libdir}/libidn.la
  94. %{_infodir}/*
  95. %files devel
  96. %defattr(0644,root,root,755)
  97. %doc doc/libidn.html doc/libidn-components.png examples contrib
  98. %{_libdir}/libidn.so
  99. %if %{with_static}
  100. %{_libdir}/libidn.a
  101. %endif
  102. %{_includedir}/*.h
  103. %{_libdir}/pkgconfig/*.pc
  104. %{_mandir}/man3/*
  105. # compat32
  106. %if %{build_compat32}
  107. %files -n compat32-%{name}
  108. %defattr(-,root,root)
  109. %{_libdir}/libidn.so.*
  110. #{_libdir}/libidn.la
  111. %files -n compat32-%{name}-devel
  112. %defattr(0644,root,root,755)
  113. %{_libdir}/libidn.so
  114. %if %{with_static}
  115. %{_libdir}/libidn.a
  116. %endif
  117. %{_libdir}/pkgconfig/*.pc
  118. %endif
  119. %changelog
  120. * Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.29-1
  121. - new upstream release
  122. - added Japanese summary
  123. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
  124. - new upstream release
  125. * Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
  126. - new upstream release
  127. - built with rpm-4.8.1
  128. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
  129. - added compat32 package for x86_64 arch support.
  130. - disabled static library creation by default.
  131. * Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
  132. - new upstream release
  133. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
  134. - new upstream release
  135. - applied new versioning policy
  136. - added --disable-csharp and --disable-java options to %%configure
  137. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
  138. - new upstream release
  139. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
  140. - new upstream release
  141. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
  142. - rebuild for VineSeed
  143. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
  144. - new upstream release
  145. * Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
  146. - rebuild for VineSeed
  147. * Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
  148. - new upstream release
  149. - build for Vine Linux 3.1
  150. * Thu Oct 7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
  151. - update to 0.5.6 (#134343)
  152. * Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
  153. - Fix Group: (#134068)
  154. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
  155. - move ldconfig from preun to postun (#131280)
  156. * Sun Aug 8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
  157. - update to 0.5.4 (#129341)
  158. * Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
  159. - upgrade to 0.5.2, enabled i18n support and info files (#127906)
  160. * Fri Jul 9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
  161. - update to 0.5.1 (#127496)
  162. * Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
  163. - update to 0.5.0 (#126836)
  164. * Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
  165. - add prereq: /sbin/ldconfig
  166. - move la file in main package
  167. * Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
  168. - upgrade to 0.4.9 (#126353)
  169. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  170. - rebuilt
  171. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
  172. - update to 0.4.4; remove contrib from -devel docs
  173. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
  174. - update to 0.4.3, remove -rpath patch
  175. * Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
  176. - update to 0.3.7, simplify
  177. * Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
  178. - 0.3.6
  179. * Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
  180. - 0.3.5
  181. * Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
  182. - drop the "soname fix" and use the correct way...
  183. * Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
  184. - 0.3.3
  185. * Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
  186. - initial cooker contrib
  187. - used the package from PLD as a start point