bind-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755
  1. %bcond_with python
  2. %define python_executable %{__python}
  3. %define _localstatedir /var
  4. %define _unpackaged_files_terminate_build 1
  5. %define sname bind
  6. %define pname bind
  7. # example: 9.9.13.P1
  8. %define pversion 9.11.5
  9. # example: 9.9.13-P1
  10. %define sversion 9.11.5
  11. %define bind_epoch 1
  12. # fixed <BTS:VineLinux:1139>
  13. %define old_bind_version 1:9.9.2p2-1vl7
  14. %define bind_uid 25
  15. %define bind_gid 25
  16. %bcond_with readline
  17. Summary: A DNS (Domain Name System) server.
  18. Summary(ja): DNS (Domain Name System) サーバ
  19. Name: %{pname}
  20. Version: %{pversion}
  21. Release: 1%{?_dist_release}
  22. Epoch: %{bind_epoch}
  23. License: ISC and BSD and Public Domain
  24. Group: System Environment/Daemons
  25. URL: http://www.isc.org/bind.html
  26. Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
  27. Source1: bind-manpages.tar.bz2
  28. Source2: named.sysconfig
  29. Source3: named.init
  30. Source4: named.logrotate
  31. Source5: keygen.c
  32. Patch1: bind-9.11.5-rndckey.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. %if %{with python}
  35. BuildRequires: python
  36. BuildRequires: python-rpm-macros
  37. BuildRequires: python-ply
  38. %endif
  39. BuildRequires: openssl-devel glibc-devel libtool
  40. BuildRequires: libxml2-devel
  41. BuildRequires: libcap-devel
  42. %if %{with readline}
  43. BuildRequires: readline-devel
  44. %endif
  45. Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  46. Requires(pre): shadow-utils
  47. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  48. Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  49. Requires(post): coreutils, chkconfig
  50. Requires(preun): initscripts, chkconfig
  51. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  52. Obsoletes: bind9 <= 9.2.1-0vl5
  53. Obsoletes: bind-current < 1:9.9.4-1
  54. Vendor: Project Vine
  55. Distribution: Vine Linux
  56. Packager: daisuke
  57. %description
  58. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  59. (Domain Name System) protocols. BIND includes a DNS server (named),
  60. which resolves host names to IP addresses, and a resolver library
  61. (routines for applications to use when interfacing with DNS). A DNS
  62. server allows clients to name resources or objects and share the
  63. information with other network machines. The named DNS server can be
  64. used on workstations as a caching name server, but is generally only
  65. needed on one machine for an entire network. Note that the
  66. configuration files for making BIND act as a simple caching nameserver
  67. are included in the caching-nameserver package.
  68. Install the bind package if you need a DNS server for your network. If
  69. you want bind to act a caching name server, you will also need to install
  70. the caching-nameserver package.
  71. %package libs
  72. Summary: Libraries used by various DNS packages
  73. Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
  74. Group: System Environment/Libraries
  75. Obsoletes: bind-current-libs <= %{old_bind_version}
  76. %description libs
  77. Contains libraries used by both the bind server package as well as the utils packages.
  78. %package utils
  79. Summary: Utilities for querying DNS name servers.
  80. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  81. Group: Applications/System
  82. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  83. Conflicts: bind9-utils <= 9.2.1-0vl5
  84. Conflicts: bind-current-utils
  85. Obsoletes: bind9-utils <= 9.2.1-0vl5
  86. Obsoletes: bind-current-utils <= %{old_bind_version}
  87. %description utils
  88. Bind-utils contains a collection of utilities for querying DNS (Domain
  89. Name Service) name servers to find out information about Internet hosts.
  90. These tools will provide you with the IP addresses for given host names,
  91. as well as other information about registered domains and network
  92. addresses.
  93. You should install bind-utils if you need to get information from DNS name
  94. servers.
  95. %package devel
  96. Summary: Include files and libraries needed for bind DNS development.
  97. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  98. Group: Development/Libraries
  99. Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
  100. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  101. Conflicts: bind9-devel <= 9.2.1-0vl5
  102. Conflicts: bind-current-devel
  103. Obsoletes: bind9-devel <= 9.2.1-0vl5
  104. Obsoletes: bind-current-devel <= %{old_bind_version}
  105. %description devel
  106. The bind-devel package contains all the include files and the
  107. library required for DNS (Domain Name Service) development for
  108. BIND versions 9.x.x.
  109. You should install bind-devel if you want to develop bind DNS
  110. applications. If you install bind-devel, you'll also need to install
  111. bind.
  112. #'
  113. %prep
  114. %setup -n bind-%{sversion} -q
  115. %patch1 -p1 -b .key
  116. perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
  117. %build
  118. libtoolize --copy --force
  119. aclocal
  120. autoconf
  121. %configure \
  122. --with-libtool \
  123. --with-openssl=/usr \
  124. %if %{without readline}
  125. --without-readline \
  126. %endif
  127. --disable-openssl-version-ceck \
  128. --enable-threads \
  129. --enable-ipv6 \
  130. --with-pic \
  131. --with-dlz-dlopen \
  132. %if %{with python}
  133. --with-python=%{python_executable} \
  134. %else
  135. --with-python=no \
  136. %endif
  137. --enable-filter-aaaa \
  138. --enable-fixed-rrset
  139. make %{?_smp_mflags}
  140. %install
  141. rm -rf $RPM_BUILD_ROOT
  142. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
  143. mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
  144. mkdir -p ${RPM_BUILD_ROOT}/var/named
  145. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
  146. mkdir -p ${RPM_BUILD_ROOT}/var/run/named
  147. make DESTDIR=$RPM_BUILD_ROOT install
  148. install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
  149. install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
  150. install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
  151. touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
  152. gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
  153. cd $RPM_BUILD_ROOT%{_mandir}
  154. tar xjf %{SOURCE1}
  155. # newer version is contained in source
  156. rm -f man5/named.conf.5.gz
  157. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  158. cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
  159. chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
  160. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  161. %clean
  162. rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
  163. %pre
  164. if [ "$1" -eq 1 ]; then
  165. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  166. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  167. fi;
  168. :;
  169. %post
  170. /sbin/ldconfig
  171. /sbin/chkconfig --add named
  172. if [ "$1" -eq 1 ]; then
  173. if [ ! -e /etc/rndc.key ]; then
  174. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  175. fi
  176. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  177. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  178. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  179. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  180. # Check DNSSEC settings if this is a fresh install
  181. if [ -r /etc/sysconfig/dnssec ]; then
  182. . /etc/sysconfig/dnssec
  183. [ -x /usr/sbin/dnssec-configure ] && \
  184. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  185. /dev/null 2>&1
  186. fi;
  187. fi
  188. :;
  189. %preun
  190. if [ "$1" -eq 0 ]; then
  191. /sbin/service named stop >/dev/null 2>&1 || :
  192. /sbin/chkconfig --del named ||:
  193. fi
  194. exit 0
  195. %postun
  196. if [ "$1" -ge 1 ]; then
  197. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  198. fi
  199. /sbin/ldconfig
  200. %triggerpostun -- bind < 8.2.2_P5-15
  201. /sbin/chkconfig --add named
  202. /sbin/ldconfig
  203. %triggerpostun -- bind-current < 1:9.9.4-1
  204. /sbin/chkconfig --add named
  205. /sbin/ldconfig
  206. %post libs -p /sbin/ldconfig
  207. %postun libs -p /sbin/ldconfig
  208. %files
  209. %defattr(-,root,root)
  210. %doc CHANGES README
  211. %doc doc/arm doc/misc
  212. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  213. %config %{_sysconfdir}/rc.d/init.d/named
  214. %config(noreplace) %{_sysconfdir}/sysconfig/named
  215. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  216. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  217. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
  218. %{_sbindir}/dnssec*
  219. %{_sbindir}/lwresd
  220. %{_sbindir}/named
  221. %{_sbindir}/named-check*
  222. %{_sbindir}/named-compilezone
  223. %{_sbindir}/rndc*
  224. %{_sbindir}/dns-keygen
  225. %{_bindir}/arpaname
  226. %{_sbindir}/ddns-confgen
  227. %{_sbindir}/genrandom
  228. %{_sbindir}/isc-hmac-fixup
  229. %{_sbindir}/named-journalprint
  230. %{_sbindir}/nsec3hash
  231. %{_sbindir}/tsig-keygen
  232. %if %{with python}
  233. %{python_sitelib}/*
  234. %endif
  235. %{_mandir}/man1/arpaname.1*
  236. %{_mandir}/man5/resolv.conf.5*
  237. %{_mandir}/man5/named.conf.5*
  238. %{_mandir}/man5/rndc.conf.5*
  239. %{_mandir}/man8/rndc.8*
  240. %{_mandir}/man8/named.8*
  241. %{_mandir}/man8/lwresd.8*
  242. %{_mandir}/man8/dnssec*.8*
  243. %{_mandir}/man8/named-checkconf.8*
  244. %{_mandir}/man8/named-checkzone.8*
  245. %{_mandir}/man8/named-compilezone.8*
  246. %{_mandir}/man8/rndc-confgen.8*
  247. %{_mandir}/man8/ddns-confgen.8*
  248. %{_mandir}/man8/genrandom.8*
  249. %{_mandir}/man8/isc-hmac-fixup.8*
  250. %{_mandir}/man8/named-journalprint.8*
  251. %{_mandir}/man8/nsec3hash.8*
  252. %{_mandir}/man8/tsig-keygen.8*
  253. %attr(-,named,named) %dir %{_var}/named
  254. %attr(-,named,named) %dir %{_var}/run/named
  255. %files libs
  256. %defattr(-,root,root)
  257. %{_libdir}/*.so.*
  258. %files utils
  259. %defattr(-,root,root)
  260. %{_bindir}/delv
  261. %{_bindir}/dig
  262. %{_bindir}/host
  263. %{_bindir}/mdig
  264. %{_bindir}/named-rrchecker
  265. %{_bindir}/nslookup
  266. %{_bindir}/nsupdate
  267. %{_mandir}/man1/delv.1*
  268. %{_mandir}/man1/dig.1*
  269. %{_mandir}/man1/host.1*
  270. %{_mandir}/man1/mdig.1*
  271. %{_mandir}/man1/named-rrchecker.1*
  272. %{_mandir}/man1/nslookup.1*
  273. %{_mandir}/man1/nsupdate.1*
  274. %{_mandir}/man5/resolver.5*
  275. %{_mandir}/man8/nslookup.8*
  276. %files devel
  277. %defattr(-,root,root)
  278. %{_libdir}/*.so
  279. %{_libdir}/*.a
  280. %{_includedir}/*
  281. %{_mandir}/man3/*
  282. %{_mandir}/man1/bind9-config.1*
  283. %{_mandir}/man1/isc-config.sh.1*
  284. %{_bindir}/bind9-config
  285. %{_bindir}/isc-config.sh
  286. %changelog
  287. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
  288. - updated to 9.11.5 (new ESV).
  289. - updated Patch1.
  290. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
  291. - updated to 9.9.13.P1.
  292. - updated Patch1.
  293. * Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
  294. - update to 9.9.9.P8
  295. * Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
  296. - new upstream release.
  297. * Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
  298. - new upstream release.
  299. * Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
  300. - new upstream release.
  301. * Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
  302. - new upstream release with secrity fix (CVE-2016-1285,1286)
  303. - built with openssl 1.0.2g
  304. * Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
  305. - new upstream release with secrity fix (CVE-2015-4620)
  306. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
  307. - new upstream release with secrity fix (CVE-2015-4620)
  308. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
  309. - rebuilt without readline to avoid GPL infection
  310. * Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
  311. - new upstream release with secrity fix (CVE-2015-1349)
  312. - added BR: readline-devel
  313. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
  314. - new upstream release with secrity fix (CVE-2014-8500)
  315. - used "3" as release number because of being newer than Vine Linux/6 updates
  316. * Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
  317. - update to 9.9.4(ESV)
  318. * Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
  319. - update to 9.9.2-P2
  320. - remove .la
  321. - remove Conflicts/Obsoletes from libs subpackage.
  322. - add configure options
  323. --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
  324. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
  325. - new upstream release.
  326. - added an option "--with-dlz-dlopen".
  327. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
  328. - Obosoletes: bind.* < 1:9.6.ESV.R1
  329. - fixed <BTS:VineLinux:1139>
  330. * Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
  331. - new upstream release with security fix (CVE-2011-1910)
  332. * Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
  333. - add BuildRequires: libxml2-devel, libcap-devel
  334. * Mon May 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
  335. - new upstream release with security fix (CVE-2011-1907)
  336. - fix changelog typo
  337. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
  338. - Obosoletes: bind.* < 1:9.6.ESV.R1
  339. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
  340. - update to 9.8.0
  341. - remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
  342. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
  343. - rebuild with openssl-1.0.0c
  344. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
  345. - fix Req: in bind package
  346. * Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
  347. - change package name bind -> bind-current
  348. - add epoch 1
  349. - new upstream release
  350. * Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
  351. - new upstream release
  352. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
  353. - rebuilt with gcc-4.4.3-3 on ppc
  354. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
  355. - rebuilt with new toolchains (for VineSeed)
  356. - s/BuildPrereq/BuildRequires/
  357. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  358. - add man1/isc-config.sh.1 into devel file list
  359. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  360. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  361. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  362. - new upstream release with security fix (CVE-2009-4022)
  363. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  364. - new upstream release with security fix
  365. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  366. - new upstream release
  367. - clean up %%post/%%pre scriptlet
  368. - create named user and group in %%pre
  369. - don't remove named user/group in %%preun
  370. - use rndc-confgen to create rndc.key
  371. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  372. - new upstream release
  373. - drop patch0 and patch14, merged in upstream
  374. * Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  375. - new upstream release with security fix
  376. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  377. - new upstream release with security fix
  378. - new versioning policy
  379. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  380. - new upstream release with security fix
  381. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  382. - new upstream release
  383. - build with new openssl/toolchain
  384. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  385. - new upstream release with security fix
  386. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  387. - new upstream release
  388. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  389. - add Prereq sed
  390. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  391. - new upstream release for security fix (CVE-2006-4095,4096)
  392. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  393. - separate -libs package
  394. - remove old named.conf.5.gz
  395. - newer version is contained in source
  396. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  397. - add bsdcompat patch (Patch4)
  398. - add fix_h_errno patch from FC
  399. - h_errno not being accessed / set correctly in libbind
  400. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  401. - new upstream release
  402. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  403. - added PreReq to bind-utils (see: [VineSeed:09555])
  404. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  405. - new upstream release
  406. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  407. - fix /etc/init.d/named to use rndc
  408. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  409. - rebuild to remove unneeded dependancy
  410. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  411. - new upstream release
  412. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  413. - new upstream release
  414. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  415. - fix dependancies.
  416. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  417. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  418. - change package name to bind for VineSeed.
  419. - use more macros.
  420. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  421. - fixed some macros
  422. - add conflicts: to bind-* in bind9-devel and bind9-utils
  423. - add provides: bind = %%{version}
  424. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  425. - use %%configure macros
  426. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  427. - fixed inconsistent dependency
  428. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  429. - updated to 9.2.2rc1
  430. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  431. - updated to bind9(9.2.1), test packages ;)
  432. -- based on Rawhide's bind-9.2.0-8
  433. -- changed name bind9
  434. -- added Conflicts: bind
  435. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  436. - release 8.3.1 includes security fixes
  437. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  438. - Upgraded to current stable release 8.3.0
  439. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  440. - 8.2.5-0vl0: Upgraded to new upstream version.
  441. * Thu May 24 2001 <sagami@vinelinux.org>
  442. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  443. * Thu May 17 2001 <sagami@vinelinux.org>
  444. - 8.2.4-0vl0
  445. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  446. - 8.2.3-1vl2
  447. - built on VineSeed
  448. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  449. - add doc/old
  450. - build for Vine 2.1
  451. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  452. - 8.2.3, fixes several security problems
  453. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  454. - static libraries may be used in shared objects. Build with -fPIC on ia64
  455. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  456. - 8.2.2-P7 (fixes Bug #20546)
  457. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  458. - condrestart fixes
  459. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  460. - change the init script to take condrestart, not cond-restart
  461. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  462. the %pre and %post scripts
  463. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  464. - Don't prereq /etc/init.d
  465. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  466. - move initscript back
  467. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  468. - automatic rebuild
  469. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  470. - add "exit 0" for uninstall case
  471. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  472. - add prereq init.d and cleanup install section
  473. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  474. - fix the init script
  475. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  476. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  477. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  478. - Fix up the initscript (Bug #13033)
  479. - Fix build with current glibc (Bug #12755)
  480. - /etc/rc.d/init.d -> /etc/init.d
  481. - use %%{_mandir} rather than /usr/share/man
  482. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  483. - fix conflict with man-pages
  484. - remove compatibilty chkconfig links
  485. - initscript munging
  486. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  487. - modify logrotate setup to use PID file
  488. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  489. - actually bump the release this time
  490. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  491. - FHS compliance
  492. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  493. - clean up restart patch
  494. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  495. - provide /var/named (fix for bugs #9847, #10205)
  496. - preserve args when restarted via ndc(8) (bug #10227)
  497. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  498. - fix SYSTYPE bug in all makefiles
  499. - move creation of named user from %%post into %%pre
  500. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  501. - Fix TTL (patch from ISC, Bug #9820)
  502. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  503. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  504. - change SYSTYPE to linux
  505. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  506. - pick a standard < 100 uid/gid for named
  507. * Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  508. - Pass named a '-u named' parameter by default, and add/remove user.
  509. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  510. - fix host mx bug (Bug #9021)
  511. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  512. - rebuild to fix dependencies
  513. - man pages are compressed
  514. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  515. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  516. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  517. - Fix up location of named-bootconf.pl and make it executable
  518. (Bug #8028)
  519. - bind-devel requires bind
  520. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  521. - update to 8.2.2-P5
  522. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  523. - update to 8.2.2-P3
  524. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  525. - add patch to stop a cache only server from complaining about lame servers
  526. on every request.
  527. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  528. - use real stop and start in named.init for restart, not ndc restart, it has
  529. problems when named has changed during a package update... (# 4890)
  530. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  531. - chkconfig --del in %preun, not %postun
  532. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  533. - initscript munging
  534. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  535. - fix installed chkconfig links to match init file
  536. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  537. - conflict with new (in man-1.24) man pages (#3876,#3877).
  538. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  539. - fix named.logrotate (wrong %SOURCE)
  540. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  541. - update to 8.2.1.
  542. - add named.logrotate (#3571).
  543. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  544. - vet file list.
  545. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  546. - don't run by default
  547. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  548. - nslookup fixes (#2463).
  549. - missing files (#3152).
  550. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  551. - nslookup patched:
  552. to count numRecords properly
  553. to fix subsequent calls to ls -d
  554. to parse "view" and "finger" commands properly
  555. the view hack updated for bind-8 (using sed)
  556. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  557. - add ISC patch
  558. - add quick hack to make host not crash
  559. - add more docs
  560. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  561. - add probing information in the init file to keep linuxconf happy
  562. - dont strip libbind
  563. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  564. - auto rebuild in the new build environment (release 3)
  565. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  566. - removed 'done' output at named shutdown.
  567. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  568. - version 8.2
  569. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  570. - patch to use the __FDS_BITS macro
  571. - build for glibc 2.1
  572. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  573. - change named.restart to /usr/sbin/ndc restart
  574. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  575. - install man pages correctly.
  576. - change K10named to K45named.
  577. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  578. - don't start if /etc/named.conf doesn't exist.
  579. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  580. - autmagically create /etc/named.conf from /etc/named.boot in %post
  581. - remove echo in %post
  582. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  583. - merge in 5.1 mods
  584. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  585. - Several essential modifications to build and install correctly.
  586. - Modified 'ndc' to avoid deprecated use of '-'
  587. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  588. - Used buildroot
  589. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  590. on Redhat 5.0 instead of <nlist.h>