asymptote-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define texmf %{_datadir}/texmf
  4. %define build_texmf %{buildroot}%{texmf}
  5. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  6. %define emacspkg asy-mode
  7. Name: asymptote
  8. Version: 2.38
  9. Release: 2%{?_dist_release}
  10. Summary: Descriptive vector graphics language
  11. Summary(ja): MetaPost に触発されたスクリプトベースのベクターグラフィック言語
  12. Group: Applications/Publishing
  13. License: GPLv3+
  14. URL: http://asymptote.sourceforge.net/
  15. Source0: http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
  16. Source1: asy.gif
  17. Source2: xasy.desktop
  18. #Source3: asymptote.sty.204
  19. Source11: %{emacspkg}-install.sh
  20. Source12: %{emacspkg}-remove.sh
  21. #Source13: %{name}-init.el
  22. #Patch0: asymptote-2.00-settings.patch
  23. %if %{?_dist_release} == "vl6"
  24. Patch0: asymptote-2.00-settings-vine-vl6.patch
  25. %else
  26. Patch0: asymptote-2.00-settings-vine-vl7.patch
  27. %endif
  28. Patch2: asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
  29. # This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
  30. Patch3: asymptote-2.08-info-path-fix.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. BuildRequires: ncurses-devel
  33. BuildRequires: readline-devel
  34. BuildRequires: fftw3-devel >= 3.0
  35. BuildRequires: gc-devel >= 6.8
  36. BuildRequires: gsl-devel
  37. BuildRequires: texlive-common
  38. %if %{?_dist_release} == "vl6"
  39. BuildRequires: texlive-collection-texinfo
  40. BuildRequires: texlive-collection-genericrecommended
  41. %else
  42. BuildRequires: texlive-collection-plaingeneric
  43. BuildRequires: texlive-collection-fontsrecommended
  44. BuildRequires: texlive-collection-latexrecommended
  45. %endif
  46. BuildRequires: ghostscript >= 9.14
  47. BuildRequires: texinfo
  48. BuildRequires: ImageMagick
  49. BuildRequires: desktop-file-utils
  50. BuildRequires: freeglut-devel
  51. BuildRequires: zlib-devel
  52. BuildRequires: libtool
  53. Requires: texlive-common
  54. Requires(post): desktop-file-utils
  55. Requires(postun): desktop-file-utils
  56. # for /usr/bin/texhash and /sbin/install-info
  57. Requires(post): texlive, info
  58. Requires(postun): texlive, info
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. %define texpkgdir %{texmf}/tex/latex/%{name}
  62. %description
  63. Asymptote is a powerful descriptive vector graphics language for technical
  64. drawings, inspired by MetaPost but with an improved C++-like syntax.
  65. Asymptote provides for figures the same high-quality level of typesetting
  66. that LaTeX does for scientific text.
  67. This package is custmized for Japanese.
  68. - added eplatex, platex to latex engines
  69. - use pdvips as dvips command
  70. %description -l ja
  71. Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
  72. テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
  73. Asymptote は科学的なテキストに対して LaTeX がしている組版のと
  74. 同じくらい高品質なレベルの図を提供します.
  75. このパッケージは日本語向けにカスタマイズされています.
  76. - latex エンジンに eplatex, platex を追加
  77. - dvips コマンドとして pdvips を使う
  78. %package gui
  79. Summary: A graphical interface for Asymptote
  80. Summary(ja): Asymptote のためのグラフィカルインターフェース
  81. Group: Applications/Graphics
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: tkinter
  84. Requires: python-imaging
  85. BuildArch: noarch
  86. %description gui
  87. A graphical interface for Asymptote
  88. %package -n %{emacspkg}
  89. Summary: Emacs mode for editing Asymptote source code
  90. Summary(ja): Asymptote ソースコードを編集するための Emacs モード
  91. Group: Applications/Editors/Emacs
  92. Requires: %{name} = %{version}-%{release}
  93. BuildRequires: emacsen
  94. %prereq_ge emacsen-common
  95. BuildArch: noarch
  96. %description -n %{emacspkg}
  97. Emacs mode for editing Asymptote source code
  98. %prep
  99. %setup -q
  100. %patch0 -b .settings
  101. %patch2 -p1 -b .DSO
  102. %patch3 -p1 -b .path-fix
  103. %{__sed} -i 's/\r//' doc/CAD1.asy
  104. # convert to UTF-8
  105. iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
  106. %__mv examples/interpolate1.asy{.utf8,}
  107. autoreconf -i
  108. %build
  109. %configure \
  110. --enable-gc=system \
  111. --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
  112. --with-latex=%{texmf}/tex/latex \
  113. --with-context=%{texmf}/tex/context \
  114. ;
  115. %__make %{?_smp_mflags}
  116. cd doc/
  117. %__make asy-latex.pdf
  118. %__make all
  119. %install
  120. %__rm -rf $RPM_BUILD_ROOT
  121. %__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
  122. %__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
  123. $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
  124. # # Vim syntax file
  125. # for vimver in 63 64 70 71 ; do
  126. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  127. # cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  128. # ln -s ../../../%{name}/asy.vim .
  129. # done
  130. # Move info file
  131. %__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
  132. # copy icon to pixmaps dir
  133. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  134. %__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  135. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
  136. desktop-file-install --vendor "vine" \
  137. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  138. %{SOURCE2}
  139. # Clean up symlink
  140. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
  141. cd $RPM_BUILD_ROOT%{_bindir}
  142. %__ln_s ../share/%{name}/GUI/xasy.py xasy
  143. ## <asy-mode>
  144. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
  145. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  146. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  147. #
  148. # install el files
  149. #
  150. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  151. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  152. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  153. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  154. # ln -s ../../../%{name}/asy-init.el .
  155. %__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
  156. $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
  157. #
  158. # install script (bytecompile el and install elc, remove)
  159. #
  160. %_installemacsenscript %{name} %{SOURCE11}
  161. %_removeemacsenscript %{name} %{SOURCE12}
  162. ## </asy-mode>
  163. %clean
  164. %__rm -rf $RPM_BUILD_ROOT
  165. %post
  166. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
  167. /sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
  168. %{exec_texhash}
  169. %post -n %{emacspkg}
  170. if [ "$1" = 2 ]; then
  171. %_emacsenPackageRemove %{name}
  172. fi
  173. %_addemacsenlist %{name}
  174. %_emacsenPackageInstall %{name}
  175. %postun
  176. if [ $1 = 0 ]; then
  177. /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
  178. /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
  179. %{exec_texhash}
  180. fi
  181. %preun -n %{emacspkg}
  182. if [ "$1" = 0 ]; then
  183. %_emacsenPackageRemove %{name}
  184. %_removeemacsenlist %{name}
  185. fi
  186. %files
  187. %defattr(-,root,root,-)
  188. %doc %{_defaultdocdir}/%{name}-%{version}/
  189. %{_bindir}/asy
  190. %{_datadir}/%{name}/
  191. %exclude %{_datadir}/asymptote/GUI/
  192. %{texpkgdir}/
  193. %{texmf}/tex/context/
  194. %{_mandir}/man1/*.1*
  195. %{_infodir}/*.info*
  196. ##%{_datadir}/vim/vim*/syntax/asy.vim
  197. %files gui
  198. %{_bindir}/xasy
  199. %{_datadir}/applications/vine-xasy.desktop
  200. %{_datadir}/pixmaps/asy.gif
  201. %{_datadir}/asymptote/GUI/
  202. %{_mandir}/man*/xasy.*
  203. %files -n %{emacspkg}
  204. %defattr(-,root,root)
  205. %{_datadir}/emacs/site-lisp/%{name}
  206. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  207. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  208. %changelog
  209. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 2.38-2
  210. - build under gsl-2.4
  211. - change BuildRequires: texlive-collection-plaingeneric
  212. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 2.38-1
  213. - new upstream release
  214. - renew Patch0: asymptote-2.00-settings-vine-vl7.patch
  215. - build under gsl-2.2.1
  216. - add BuildRequires:
  217. texlive-collection-{plainextra,fontsrecommended,latexrecommended}
  218. for VineSeed instead of texlive-collection-texinfo for Vine6
  219. - add Vendor and Distribution
  220. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
  221. - new upstream release
  222. - added asymptote-2.00-settings-vine-vl7.patch (vl7)
  223. - For vl6, renamed asymptote-2.00-settings-vine.patch as
  224. asymptote-2.00-settings-vine-vl6.patch
  225. - TeX Live 2011
  226. * Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
  227. - new upstream release
  228. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
  229. - TeX Live 2009
  230. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
  231. - rebuilt with new toolchain, libsigsegv-2.8
  232. - appled Patch1 again
  233. * Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
  234. - don't apply Patch1 until gcc44 comes to VineSeed
  235. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
  236. - separated Xasy to gui subpackage
  237. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
  238. - initial build based on Fedora Development (fc11) package
  239. - applied asymptote-1.70-settings-vine.patch
  240. * Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
  241. - update to 1.70
  242. * Tue Apr 7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
  243. - update to 1.69
  244. * Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
  245. - update to 1.68
  246. * Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
  247. - update to 1.67
  248. * Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
  249. - update to 1.66
  250. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
  251. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  252. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
  253. - more gcc44 fixes with BIG_ENDIAN platforms
  254. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
  255. - fix gcc44 issue with BIG_ENDIAN platforms
  256. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
  257. - forgot to put in new source
  258. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
  259. - 1.63
  260. * Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
  261. - 1.60
  262. * Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
  263. - 1.59
  264. * Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
  265. - 1.58
  266. * Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
  267. - 1.57
  268. * Tue Dec 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
  269. - 1.56
  270. * Tue Dec 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
  271. - 1.54
  272. * Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
  273. - 1.52
  274. * Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
  275. - update to 1.51
  276. * Mon Nov 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
  277. - update to 1.49
  278. * Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
  279. - update to 1.47
  280. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
  281. - update to 1.46
  282. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
  283. - add missing BuildRequires
  284. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
  285. - update to 1.44
  286. * Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
  287. - update to 1.43
  288. * Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
  289. - explicitly call "make asymptote.pdf" in doc/
  290. * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
  291. - fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
  292. * Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
  293. - update to 1.42
  294. * Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
  295. - update to 1.41
  296. - enable desktop file for xasy
  297. * Thu Jan 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
  298. - bump to 1.37
  299. - fix gcc43 failures
  300. - drop triggers
  301. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
  302. - Rebuild for selinux ppc32 issue.
  303. * Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
  304. - Update 1.33.
  305. * Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
  306. - Update to 1.32.
  307. - vim-common triggers: correction and improvements (#246131).
  308. * Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
  309. - Update to 1.31.
  310. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  311. - Update to 1.30.
  312. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
  313. - Using "evince" as the default PS and PDF viewers (#244151).
  314. (patch file: asymptote-1.29-settings.patch)
  315. - Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
  316. - Use relative symbolic links in the vim-common triggers.
  317. * Sat Jun 2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
  318. - Add asy-faq to install-info (#155750).
  319. - Add support for vim 7.1.
  320. * Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
  321. - Update to 1.29.
  322. * Tue May 8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
  323. - Update to 1.28.
  324. * Sat May 5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
  325. - Update to 1.27.
  326. * Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
  327. - Update to 1.26.
  328. * Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
  329. - Update to 1.25.
  330. * Sun Apr 1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  331. - Update to 1.24.
  332. * Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
  333. - Update to 1.23.
  334. * Tue Mar 6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  335. - Update to 1.22.
  336. * Sat Mar 3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
  337. - Update to 1.21.
  338. * Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  339. - Update to 1.20.
  340. * Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
  341. - Update to 1.19.
  342. * Sun Nov 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  343. - Update to 1.18.
  344. * Wed Nov 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
  345. - Update to 1.17.
  346. * Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  347. - Update to 1.16.
  348. * Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  349. - Update to 1.15.
  350. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
  351. - Update to 1.13.
  352. * Thu Aug 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
  353. - Update to 1.12.
  354. * Thu Jul 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
  355. - Update to 1.11.
  356. * Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
  357. - Update to 1.10.
  358. * Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
  359. - Update to 1.09.
  360. * Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
  361. - Update to 1.08.
  362. - Also installs the info file.
  363. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
  364. - Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
  365. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
  366. - Group: Development/Tools -> Applications/Publishing (#193154).
  367. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
  368. - Emacs/Xemacs init file (#193154 comment 6).
  369. * Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
  370. - Directories ownership (#193154).
  371. * Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  372. - Update to 1.06.
  373. - Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
  374. * Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  375. - Update to 1.05.
  376. * Sun May 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
  377. - Update to 1.04.
  378. * Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  379. - Update to 1.03.
  380. * Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
  381. - First build.
  382. # vim:set ai ts=4 sw=4 sts=4 et: