xorg-x11-xfs-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. Summary: X.Org X11 xfs font server
  2. Summary(ja): X.Org X11 xfs フォントサーバ
  3. Name: xorg-x11-xfs
  4. Version: 1.1.1
  5. Release: 1%{?_dist_release}
  6. License: MIT/X11
  7. Group: System Environment/Daemons
  8. URL: http://www.x.org
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. Source0: ftp://ftp.x.org/pub/individual/app/xfs-%{version}.tar.bz2
  11. Source1: ftp://ftp.x.org/pub/individual/app/xfsinfo-1.0.3.tar.bz2
  12. Source2: ftp://ftp.x.org/pub/individual/app/fslsfonts-1.0.3.tar.bz2
  13. Source3: ftp://ftp.x.org/pub/individual/app/fstobdf-1.0.4.tar.bz2
  14. Source4: ftp://ftp.x.org/pub/individual/app/showfont-1.0.3.tar.bz2
  15. Source10: xfs.init
  16. Source11: xfs.config
  17. BuildRequires: pkgconfig
  18. # xfs needs 'fontsproto' to build, as indicated by ./configure
  19. BuildRequires: xorg-x11-proto-devel
  20. # FIXME: xfs needs xtrans to build, but autotools doesn't detect it missing
  21. BuildRequires: xorg-x11-xtrans-devel
  22. BuildRequires: libFS-devel
  23. BuildRequires: libXfont-devel
  24. BuildRequires: libX11-devel
  25. # FIXME: xfs needs freetype-devel to build, but autotools doesn't detect it missing
  26. BuildRequires: freetype2-devel
  27. BuildRequires: libfontenc-devel
  28. # Make sure libXfont provides the catalogue FPE.
  29. Requires: libXfont
  30. Obsoletes: XFree86-xfs, XOrg-xfs
  31. Provides: xfs
  32. Provides: XOrg-xfs = 7.0
  33. Requires(pre): util-linux, shadow-utils
  34. Requires(post): initscripts, grep, sed, coreutils
  35. Requires(preun): initscripts, chkconfig
  36. Requires(postun): initscripts
  37. # xfs initscript runtime dependencies
  38. Requires: initscripts, fontconfig, sed, findutils
  39. Requires: coreutils
  40. Requires: mkfontdir, mkfontscale, ttmkfdir
  41. # end of xfs initscript runtime dependencies
  42. %description
  43. X.Org X11 xfs font server
  44. %package utils
  45. Summary: X.Org X11 font server utilities
  46. Summary(ja): X.Org X11 フォントサーバユーティリティ
  47. Group: User Interface/X
  48. Conflicts: XOrg-xfs < 7.0
  49. %description utils
  50. X.Org X11 font server utilities
  51. %prep
  52. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  53. %build
  54. # Build xfs
  55. {
  56. pushd xfs-*
  57. %configure --disable-devel-docs
  58. make configdir=%{_sysconfdir}/X11/fs
  59. popd
  60. }
  61. for pkg in xfsinfo fslsfonts fstobdf showfont ; do
  62. pushd ${pkg}-*
  63. %configure
  64. make
  65. popd
  66. done
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. # Install xfs
  70. {
  71. pushd xfs-*
  72. %makeinstall configdir=$RPM_BUILD_ROOT%{_sysconfdir}/X11/fs
  73. popd
  74. }
  75. for pkg in xfsinfo fslsfonts fstobdf showfont ; do
  76. pushd ${pkg}-*
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. popd
  79. done
  80. # Install the modified xfs config file and initscript
  81. {
  82. mkdir -p $RPM_BUILD_ROOT/etc/{X11/fs,rc.d/init.d}
  83. install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/xfs
  84. install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fs/config
  85. }
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %triggerpostun -- XFree86-xfs
  89. {
  90. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  91. /sbin/chkconfig --add xfs
  92. /sbin/service xfs condrestart || :
  93. } &> /dev/null || :
  94. %triggerpostun -- XOrg-xfs
  95. {
  96. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  97. /sbin/chkconfig --add xfs
  98. /sbin/service xfs condrestart || :
  99. } &> /dev/null || :
  100. %pre
  101. {
  102. /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
  103. # Upgrade path:
  104. if [ "$1" -gt "1" ] ; then
  105. if [ -e "/usr/X11R6/lib/X11/fs/config" ] ; then
  106. cat <<-EOF > "/etc/X11/fs/xfs-migrate"
  107. On upgrades, we now must determine if we are upgrading from monolithic
  108. xfs or modular xfs by checking for the existance of the old monolithic
  109. xfs config file. If found, we know it is a monolith->modular upgrade,
  110. so we set this flag file in order for xfs.init to perform a "restart"
  111. instead of a "reload" in the 'condrestart'. See bug #173271 for
  112. details.
  113. EOF
  114. fi
  115. fi
  116. } &> /dev/null || : # Silence output, and ignore errors (Bug #91822)
  117. %post
  118. {
  119. # Install section
  120. /sbin/chkconfig --add xfs
  121. #------------------------------------------------------------------------
  122. # Upgrade section
  123. if [ "$1" -gt "1" ] ; then
  124. XORG_CONFIG=/etc/X11/xorg.conf
  125. XFSCONFIG=/etc/X11/fs/config
  126. # XFS config file upgrade munging
  127. if [ -f $XFSCONFIG ] ; then
  128. # Remove Speedo font directories from xfs config if present to avoid
  129. # bug reports about xfs complaining about empty directories in syslog.
  130. perl -p -i -e 's#^.*/.*/Speedo.*\n##' $XFSCONFIG
  131. # On upgrades, remove /usr/X11R6 font path elements from the XFS config file
  132. if grep -q "/usr/X11R6/lib/X11/fonts" $XFSCONFIG &> /dev/null ; then
  133. for fpe in misc:unscaled 75dpi:unscaled 100dpi:unscaled Type1 ; do
  134. perl -p -i -e "s#/usr/X11R6/lib/X11/fonts/${fpe}#%{_x11fontdir}/${fpe}#g" $XFSCONFIG
  135. done
  136. fi
  137. fi
  138. fi ; # End Upgrade section
  139. }
  140. %preun
  141. {
  142. if [ "$1" = "0" ]; then
  143. /sbin/service xfs stop &> /dev/null || :
  144. /sbin/chkconfig --del xfs || :
  145. fi
  146. }
  147. %postun
  148. {
  149. if [ "$1" -gt "1" ]; then
  150. /sbin/service xfs condrestart &> /dev/null || :
  151. fi
  152. }
  153. %files
  154. %defattr(-,root,root,-)
  155. %doc xfs-%{version}/AUTHORS xfs-%{version}/COPYING
  156. %doc xfs-%{version}/NEWS xfs-%{version}/README xfs-%{version}/ChangeLog
  157. %{_bindir}/xfs
  158. %dir %{_sysconfdir}/X11
  159. %dir %{_sysconfdir}/X11/fs
  160. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/fs/config
  161. %{_mandir}/man1/xfs.1*
  162. %{_sysconfdir}/rc.d/init.d/xfs
  163. %files utils
  164. %{_bindir}/fslsfonts
  165. %{_bindir}/fstobdf
  166. %{_bindir}/showfont
  167. %{_bindir}/xfsinfo
  168. %{_mandir}/man1/fslsfonts.1*
  169. %{_mandir}/man1/fstobdf.1*
  170. %{_mandir}/man1/showfont.1*
  171. %{_mandir}/man1/xfsinfo.1*
  172. %changelog
  173. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
  174. - xfs-1.1.1
  175. - xfsinfo-1.0.3
  176. - fslsfonts-1.0.3
  177. - fstobdf-1.0.4
  178. - showfont-1.0.3
  179. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  180. - xfs-1.1.0
  181. * Sun May 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-1
  182. - new upstream release
  183. - xfs-1.0.8, xfsinfo-1.0.2, fslsfont-1.0.2,
  184. fstobdf-1.0.3, showfont-1.0.2
  185. * Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
  186. - add version-release to Obsoletes: XOrg-xfs
  187. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
  188. - add version-release to Provides: XOrg-xfs
  189. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
  190. - add Provides: XOrg-xfs for compatibility
  191. * Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
  192. - initial build for Vine Linux
  193. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.0.5-2
  194. - Autorebuild for GCC 4.3
  195. * Tue Oct 02 2007 Adam Jackson <ajax@redhat.com> 1:1.0.5-1
  196. - xfs 1.0.5
  197. * Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.0.4-2
  198. - Rebuild for ppc toolchain bug
  199. * Fri Jul 27 2007 Bill Nottingham <notting@redhat.com> - 1:1.0.4-2
  200. - don't run by default any more, as it's not used by default
  201. - remove explicit restorecon dependency (#215142)
  202. * Fri Jun 22 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 1:1.0.4-1
  203. - Require catalogue capable libXfont.
  204. - Drop xfs.config.in, just use catalogue font path.
  205. - Stop xorg.conf munging madness.
  206. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1:1.0.2-4
  207. - Don't install INSTALL
  208. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.0.2-3.1
  209. - rebuild
  210. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.2-3
  211. - Added xfs documentation to doc macro.
  212. - Use "make install" instead of makeinstall macro.
  213. - Clean up source file URLs.
  214. * Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
  215. - Fix BuildRequires (#191856).
  216. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-1
  217. - Update xfs and fstobdf
  218. * Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-4
  219. - Fix all rpm scriptlets "upgrade" tests to only execute on upgrades.
  220. * Sat Feb 25 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
  221. - Redirect output of "rm -rf fonts.dir" to /dev/null in xfs.init
  222. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-2.1
  223. - bump again for double-long bug on ppc(64)
  224. * Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
  225. - Removed invocation of fc-cache from xfs initscript for bug (#179362)
  226. - Redirect stderr to /dev/null to squelch an unwanted error xfs.init (#155349)
  227. - Replace "s#^/.*:[a-z]*$##g" with "s#:unscaled$##g" in xfs.init for (#179491)
  228. - Cosmetic cleanups to spec file to satiate the banshees.
  229. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
  230. - rebuilt for new gcc4.1 snapshot and glibc changes
  231. * Wed Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
  232. - Updated all tarballs to version 1.0.1 from X11R7.0
  233. * Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> 1:1.0.0-2
  234. - fix rpm post script (#176009, <ville.skytta@iki.fi>)
  235. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
  236. - Updated all tarballs to version 1.0.0 from X11R7 RC4.
  237. - Get default X font directory with font-utils package 'fontdir' pkgconfig
  238. variable.
  239. - Change manpage dir from man1x back to man1 to match upstream.
  240. * Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.2-4
  241. - require initscripts instead of /etc/init.d/functions
  242. * Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
  243. - Updated xfs pre script to check for the existance of the old monolithic
  244. /usr/X11R6/lib/X11/fs/config xfs config file, and set a migration flag
  245. file.
  246. - Updated xfs.init to check for the existance of the migration flag file,
  247. and perform an xfs 'restart' instead of a 'reload' if migrating. Users
  248. will now have to restart their X server, or reconnect the xfs server to
  249. the X server after a migration to modular X.
  250. - Changed upgrade comparison typo from 2 to 1 in xfs post script.
  251. * Mon Nov 14 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  252. - Added temporary "BuildRequires: libXfont-devel >= 0.99.2-3" and
  253. "Requires: libXfont-devel >= 0.99.2-3" to ensure early-testers of
  254. pre-rawhide modular X have installed the work around for (#172997).
  255. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  256. - Updated to xfs-0.99.2 and fstobdf-0.99.2 from X11R7 RC2
  257. - Added Epoch 1 to package, and set the version number to the xfs 0.99.2
  258. version.
  259. * Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
  260. - Added showfont-0.99.1 from X11R7 RC1 release.
  261. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
  262. - Updated all packages to version 0.99.1 from X11R7 RC1.
  263. - Bump package version to 6.99.99.901 (the RC1 CVS tag).
  264. - Change manpage location to 'man1x' in file manifest.
  265. - Converted xfs.config to xfs.config.in, and added code to spec file to
  266. generate xfs.config depending on what the system _x11fontdir is.
  267. - Complete and total rewrite of xfs postinstall script to use "sed -i"
  268. and complete restructuring, which removed a lot of the super craptasticness
  269. that had been sitting there for years.
  270. * Wed Oct 03 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-4
  271. - Use Fedora-Extras style BuildRoot tag
  272. - Update BuildRequires to use new library package names
  273. - Remove unnecessary BuildRequires on 'install', and fix pkgconfig dep
  274. * Thu Aug 25 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-3
  275. - Install the initscript and xfs config file in the correct location as they
  276. were inadvertently interchanged in previous builds.
  277. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
  278. - Ported the xfs related rpm scripts over from monolithic packaging, and
  279. added up to date Requires(*) dependencies for all of them.
  280. - Flagged xfs config file as config(noreplace)
  281. - Added build and runtime dependencies to xfs subpackage as best as could be
  282. determined by analyzing ./configure output, and building in minimalized
  283. build root environment.
  284. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
  285. - Initial build.