ffmpeg-vl5.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265
  1. #TODO: Build with openjpeg
  2. %define name ffmpeg
  3. %define version 0.5.3
  4. #% define svndate 20090227
  5. %define release 1%{?svndate:.%svndate}%{?_dist_release}
  6. Summary: Digital VCR and streaming server
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
  11. #Source1: %{name}-snapshot.sh
  12. # For no texi2html
  13. # these man files for ffmpeg-0.5 are genereted with texi2html
  14. Source90: ffmpeg.1.gz
  15. Source91: ffplay.1.gz
  16. Source92: ffserver.1.gz
  17. # get rid of textrels on x86_64 in yasm code (from RPM Fusion)
  18. Patch0: %{name}-textrel.patch
  19. Patch10: ffmpeg-0.5-disable-texi2html.patch
  20. License: GPLv2+
  21. Group: Applications/Multimedia
  22. URL: http://ffmpeg.org/
  23. BuildRequires: bzip2-devel
  24. BuildRequires: zlib-devel
  25. BuildRequires: SDL-devel
  26. BuildRequires: imlib2-devel
  27. BuildRequires: speex-devel
  28. #BuildRequires: texi2html
  29. BuildRequires: libogg-devel
  30. BuildRequires: libvorbis-devel
  31. #BuildRequires: openjpeg-devel
  32. BuildRequires: libtheora-devel
  33. BuildRequires: gsm-devel
  34. BuildRequires: libdc1394-devel
  35. BuildRequires: libraw1394-devel
  36. %ifarch %{ix86} x86_64
  37. BuildRequires: yasm
  38. %endif
  39. # *-devel packages provided by other self-build-* should only be listed
  40. # in self-build-%{name}.spec as PreReq.
  41. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  42. #BuildRequires: x264-devel, libdca-devel, a52dec-devel
  43. #BuildRequires: faad2-devel
  44. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. %description
  47. FFMpeg is a complete and free Internet live audio and video
  48. broadcasting solution for Linux/Unix. It also includes a digital
  49. VCR. It can encode in real time in many formats including MPEG1 audio
  50. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  51. %package libs
  52. Group: System Environment/Libraries
  53. Summary: Libraries for %{name}
  54. Group: System Environment/Libraries
  55. #Requires: a52dec, faad2
  56. %description libs
  57. FFMpeg is a complete and free Internet live audio and video
  58. broadcasting solution for Linux/Unix. It also includes a digital
  59. VCR. It can encode in real time in many formats including MPEG1 audio
  60. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  61. This package contains the libraries for %{name}.
  62. %package devel
  63. Summary: Development package for %{name}
  64. Group: Development/Libraries
  65. Requires: %{name}-libs = %{version}-%{release}
  66. Requires: pkgconfig
  67. %description devel
  68. FFMpeg is a complete and free Internet live audio and video
  69. broadcasting solution for Linux/Unix. It also includes a digital
  70. VCR. It can encode in real time in many formats including MPEG1 audio
  71. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  72. This package contains development files for %{name}.
  73. %prep
  74. #% setup -q -n %{name}-%{svndate}
  75. %setup -q
  76. %patch0 -p1 -b .textrel
  77. %patch10 -p1 -b .texi2html
  78. %build
  79. %ifarch ppc
  80. # compile with -mlongcall on ppc/ppc64 (rf804)
  81. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  82. %endif
  83. ./configure \
  84. --prefix=%{_prefix} \
  85. --incdir=%{_includedir}/%{name} \
  86. --shlibdir=%{_libdir} \
  87. --libdir=%{_libdir} \
  88. --mandir=%{_mandir} \
  89. --arch=%{_target_cpu} \
  90. %ifarch %{ix86}
  91. --cpu=%{_target_cpu} \
  92. %endif
  93. %ifarch ppc
  94. --cpu=g3 \
  95. %endif
  96. --enable-runtime-cpudetect \
  97. --extra-cflags="$RPM_OPT_FLAGS" \
  98. %{?_with_amr:--enable-libamr-nb --enable-libamr-wb --enable-nonfree} \
  99. --enable-bzlib \
  100. --enable-libdc1394 \
  101. --enable-libfaac --enable-nonfree \
  102. --enable-libfaad \
  103. --enable-libgsm \
  104. --enable-libmp3lame \
  105. %{?_with_openjpeg:--enable-libopenjpeg} \
  106. --enable-libtheora \
  107. --enable-libvorbis \
  108. --enable-libx264 \
  109. --enable-libxvid \
  110. --enable-x11grab \
  111. --enable-avfilter \
  112. --enable-avfilter-lavf \
  113. --enable-postproc \
  114. --enable-swscale \
  115. --enable-pthreads \
  116. --disable-static \
  117. --enable-shared \
  118. --enable-gpl \
  119. --disable-debug \
  120. --disable-stripping
  121. #% {__make} %{?_smp_mflags}
  122. %{__make}
  123. %install
  124. %__make install DESTDIR=$RPM_BUILD_ROOT
  125. ## install man
  126. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1
  127. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
  128. %clean
  129. %{__rm} -rf $RPM_BUILD_ROOT
  130. %post libs -p /sbin/ldconfig
  131. %postun libs -p /sbin/ldconfig
  132. %files
  133. %defattr(-,root,root,-)
  134. %doc COPYING.GPL CREDITS Changelog README RELEASE doc/*.*
  135. %{_prefix}/bin/ffmpeg
  136. %{_prefix}/bin/ffplay
  137. %{_prefix}/bin/ffserver
  138. %{_mandir}/man1/ffmpeg.1*
  139. %{_mandir}/man1/ffplay.1*
  140. %{_mandir}/man1/ffserver.1*
  141. %{_datadir}/ffmpeg
  142. %{?_with_amr:%{_datadir}/%{name}}
  143. %files libs
  144. %defattr(-,root,root,-)
  145. %{_libdir}/lib*.so.*
  146. %{_libdir}/vhook/
  147. %files devel
  148. %defattr(-,root,root,-)
  149. %{_includedir}/ffmpeg
  150. %{_libdir}/pkgconfig/lib*.pc
  151. %{_libdir}/lib*.so
  152. %changelog
  153. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-1
  154. - new upstream release
  155. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
  156. - change release to sync with self-build-ffmpeg
  157. * Thu Jun 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-1
  158. - new upstream release
  159. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-1
  160. - new upstream release
  161. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  162. - applied ffmpeg-0.5-disable-texi2html.patch, return
  163. (in face, no ffmpeg-0.5-disable-texi2html.patch applied for 0.5-4)
  164. - added ffmpeg.1, ffplay.1, ffserver.1
  165. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  166. - change release to sync with self-build-ffmpeg
  167. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  168. - applied ffmpeg-0.5-disable-texi2html.patch
  169. - dropped BuildRequires: texi2html
  170. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  171. - change release to sync with self-build-ffmpeg
  172. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  173. - corrected release number
  174. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  175. - new upstream release
  176. - added BuildRequires:
  177. - speex-devel
  178. - bzip2-devel
  179. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  180. - 20090227 snapshot
  181. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  182. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  183. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  184. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  185. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  186. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  187. - 20090202 snapshot
  188. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  189. - 20090110 snapshot
  190. - dropped some patches
  191. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  192. - source updated (r15488)
  193. - fixed License: GPLv2+
  194. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  195. - added BuildRequires: yasm (only %%ix86)
  196. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  197. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  198. - spec in utf8
  199. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  200. - change release to sync with self-build-ffmpeg
  201. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  202. - drop "Patch100: ffmpeg-vine.patch".
  203. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  204. - build with new versioning policy
  205. - change to use svn export from svn checkout on post install
  206. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  207. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  208. - [self-build-ffmpeg.spec]
  209. For all pre-required package that is provied by self-build,
  210. changed to its self-build package
  211. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  212. - initial build for Vine Linux 4.2
  213. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  214. ### end of file