123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333 |
- # Note that this is NOT a relocatable package
- %define glib2_base_version 2.28.5
- %define glib2_version %{glib2_base_version}-1
- %define pango_base_version 1.28.3
- %define pango_version %{pango_base_version}-1
- %define atk_base_version 1.32.0
- %define atk_version %{atk_base_version}-1
- %define cairo_base_version 1.10.0
- %define cairo_version %{cairo_base_version}-1
- %define gdkpixbuf2_base_version 2.22.1
- %define gdkpixbuf2_version %{gdkpixbuf2_base_version}-1
- %define gobject_introspection_version 0.10.0
- %define base_version 3.0.8
- %define bin_version 3.0.0
- # biarch support
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- %define _query_suffix %{nil}
- %if %{build_compat32}
- %define _query_suffix -32
- %endif
- Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
- Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
- Name: gtk3
- Version: %{base_version}
- Release: 1%{?_dist_release}
- License: LGPL
- Group: System Environment/Libraries
- Source: gtk+-%{version}.tar.bz2
- Patch100: gtk+-2.99.3-vine-default-theme.patch
- BuildRequires: atk-devel >= %{atk_version}
- BuildRequires: pango-devel >= %{pango_version}
- BuildRequires: glib2-devel >= %{glib2_version}
- BuildRequires: cairo-devel >= %{cairo_version}
- BuildRequires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
- BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
- BuildRequires: libtiff-devel >= 3.7
- BuildRequires: libjpeg-turbo-devel
- BuildRequires: libpng-devel
- BuildRequires: jasper-devel
- BuildRequires: gtk-doc
- #BuildRequires: automake17, autoconf
- BuildRequires: gamin-devel
- BuildRequires: cups-devel
- BuildRequires: libICE-devel
- BuildRequires: libXext-devel
- BuildRequires: libXi-devel
- BuildRequires: libXrandr-devel >= 1.3.0
- BuildRequires: libXrender-devel
- BuildRequires: libXcursor-devel
- BuildRequires: libXfixes-devel
- BuildRequires: libXinerama-devel
- BuildRequires: libXcomposite-devel
- BuildRequires: libXdamage-devel
- BuildRoot: %{_tmppath}/gtk-%{version}-root
- URL: http://www.gtk.org
- # required for icon themes apis to work
- Requires: hicolor-icon-theme
- # We need to prereq these so we can run gtk-query-immodules-2.0
- Requires(post): glib2 >= %{glib2_version}
- Requires(post): atk >= %{atk_version}
- Requires(post): pango >= %{pango_version}
- Requires(post): libSM >= 1.1.0
- # We need to prereq libtiff >= 3.7 to run gdk-pixbuf-query-loaders
- Requires(post): libtiff >= 3.7
- Requires: libXrandr >= 1.3.0
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: Takemikaduchi
- %description
- GTK+ is a multi-platform toolkit for creating graphical user
- interfaces. Offering a complete set of widgets, GTK+ is suitable for
- projects ranging from small one-off tools to complete application
- suites.
- %package devel
- Summary: Development tools for GTK+ applications.
- Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pango-devel >= %{pango_version}
- Requires: atk-devel >= %{atk_version}
- Requires: glib2-devel >= %{glib2_version}
- Requires: gdk-pixbuf2-devel >= %{gdkpixbuf2_version}
- Requires: libX11-devel, libXcursor-devel, libXinerama-devel
- Requires: libXext-devel, libXi-devel, libXrandr-devel
- Requires: libXfixes-devel, libXcomposite-devel
- Requires: libpng-devel
- %description devel
- The gtk+-devel package contains the header files and developer
- docs for the GTK+ widget toolkit.
- #######################################################################
- # compat32
- %package -n compat32-%{name}
- Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
- Summary(ja): X 用 GUI 作成ライブラリ: GIMP ツールキット(GTK+)
- Group: System Environment/Libraries
- Requires(post): compat32-glib2 >= %{glib2_version}
- Requires(post): compat32-atk >= %{atk_version}
- Requires(post): compat32-pango >= %{pango_version}
- Requires(post): compat32-libSM >= 1.1.0
- Requires(post): compat32-libtiff >= 3.7
- Requires: compat32-libXrandr >= 1.3.0
- %description -n compat32-%{name}
- GTK+ is a multi-platform toolkit for creating graphical user
- interfaces. Offering a complete set of widgets, GTK+ is suitable for
- projects ranging from small one-off tools to complete application
- suites.
- %package -n compat32-%{name}-devel
- Summary: Development tools for GTK+ applications.
- Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
- Group: Development/Libraries
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: %{name}-devel = %{version}
- Requires: compat32-libX11-devel, compat32-libXcursor-devel, compat32-libXinerama-devel
- Requires: compat32-libXext-devel, compat32-libXi-devel, compat32-libXrandr-devel
- Requires: compat32-libXfixes-devel, compat32-libXcomposite-devel
- Requires: compat32-libpng-devel
- %description -n compat32-%{name}-devel
- The gtk+-devel package contains the header files and developer
- docs for the GTK+ widget toolkit.
- %prep
- %setup -q -n gtk+-%{version}
- %patch100 -p1 -b .vine-default-theme
- #for i in config.guess config.sub ; do
- # test -f %{_datadir}/libtool/$i && cp %{_datadir}/libtool/$i .
- #done
- %build
- # if ! pkg-config --exists pangoxft ; then
- # echo "No pangoxft.pc!"
- # exit 1
- # fi
- #libtoolize --force --copy
- #autoreconf -i
- %configure --enable-gtk-doc \
- --enable-man \
- --enable-debug=minimum \
- --disable-rebuilds \
- --disable-glibtest \
- --enable-introspection=yes \
- --enable-xrandr \
- --enable-xfixes \
- --enable-xcomposite \
- --enable-xdamage \
- --enable-x11-backend
- make ARCH=%{_arch}
- #make
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
- %find_lang gtk30
- %find_lang gtk30-properties
- cat gtk30.lang gtk30-properties.lang > all.lang
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gtk-3.0
- #
- # Make cleaned-up versions of examples and tutorial for installation
- #
- mkdir -p tmpdocs/tutorial
- # install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
- for dir in examples/* ; do
- if [ -d $dir ] ; then
- mkdir -p tmpdocs/$dir
- for file in $dir/* ; do
- case $file in
- *pre1.2.7)
- ;;
- *)
- install -m 0644 $file tmpdocs/$dir
- ;;
- esac
- done
- fi
- done
- # We need to have separate 32-bit and 64-bit binaries
- # for places where we have two copies of the GTK+ package installed.
- # (we might have x86_64 and i686 packages on the same system, for example.)
- %if %{build_compat32}
- cp $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0 \
- $RPM_BUILD_ROOT%{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
- %endif
- touch $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{bin_version}/immodules.cache
- mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules
- mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/immodules
- # Remove unpackaged files
- rm $RPM_BUILD_ROOT%{_libdir}/*.la
- rm -rf $RPM_BUILD_ROOT%{_datadir}/themes/Raleigh
- rm $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/modules/lib*.la
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
- %postun
- /sbin/ldconfig
- if [ $1 -gt 0 ]; then
- %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
- fi
- glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
- %posttrans
- glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
- %if %{build_compat32}
- %post -n compat32-%{name}
- /sbin/ldconfig
- %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
- %postun -n compat32-%{name}
- /sbin/ldconfig
- if [ $1 = 0 ]; then
- %{_bindir}/gtk-query-immodules-3.0%{_query_suffix} --update-cache || : > /dev/null 2>&1
- fi
- %endif
- %files -f all.lang
- %defattr(-, root, root)
- %doc AUTHORS COPYING ChangeLog NEWS README
- %{_bindir}/gtk3-demo
- %{_bindir}/gtk-query-immodules-3.0
- %exclude %{_bindir}/gtk-update-icon-cache
- %{_libdir}/libgtk-3.so.*
- %{_libdir}/libgdk-3.so.*
- %{_libdir}/libgailutil-3.so.*
- %dir %{_libdir}/gtk-3.0
- %{_libdir}/gtk-3.0/%{bin_version}
- %dir %{_libdir}/gtk-3.0/modules
- %{_libdir}/gtk-3.0/modules/lib*.so
- %{_libdir}/girepository-1.0/*.typelib
- %{_datadir}/gtk-3.0
- %{_datadir}/themes/Default
- %{_datadir}/themes/Emacs
- %dir %{_sysconfdir}/gtk-3.0
- %{_sysconfdir}/gtk-3.0/im-multipress.conf
- %{_datadir}/glib-2.0/schemas/*.xml
- %files devel
- %defattr(-, root, root)
- %{_libdir}/lib*.so
- %dir %{_libdir}/gtk-3.0
- %{_datadir}/gtk-doc/
- %{_datadir}/gir-1.0/*.gir
- %{_mandir}/man1/*
- %exclude %{_mandir}/man1/gtk-update-icon-cache.1.gz
- %{_includedir}/*
- %{_datadir}/aclocal/*
- %{_libdir}/pkgconfig/*
- %doc tmpdocs/tutorial
- # compat32
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-, root, root)
- %{_bindir}/gtk-query-immodules-3.0%{_query_suffix}
- %{_libdir}/libgtk-3.so.*
- %{_libdir}/libgdk-3.so.*
- %{_libdir}/libgailutil-3.so.*
- %dir %{_libdir}/gtk-3.0
- %{_libdir}/gtk-3.0/%{bin_version}
- %dir %{_libdir}/gtk-3.0/modules
- %{_libdir}/gtk-3.0/modules/lib*.so
- %dir %{_sysconfdir}/gtk-3.0
- %files -n compat32-%{name}-devel
- %defattr(-, root, root)
- %{_libdir}/lib*.so
- %dir %{_libdir}/gtk-3.0
- %{_libdir}/pkgconfig/*
- %endif
- %changelog
- * Sun Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8-1
- - new upstream release
- * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
- - new upstream release
- * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
- - new upstream release
- * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.4-1
- - new upstream release
- * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
- - new upstream release
- * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
- - new upstream release
- * Fri Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
- - new upstream release
- * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
- - initial build for Vine Linux
|