nspluginwrapper-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Compile as a debug package
  3. %define make_debug_package 0
  4. # What gecko we use
  5. %define gecko_flavour "mozilla"
  6. %define plugin_config_version 1.9
  7. %define plugin_config_name plugin-config-%{plugin_config_version}
  8. %define plugin_config_binary plugin-config
  9. # Excluded plugins (separated by ':')
  10. %define exclude_list "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*"
  11. # Target defines
  12. %if "%{_target_cpu}" == "i386"
  13. %define target_bits 32
  14. %endif
  15. %if "%{_target_cpu}" == "i586"
  16. %define target_bits 32
  17. %endif
  18. %if "%{_target_cpu}" == "i686"
  19. %define target_bits 32
  20. %endif
  21. %if "%{_target_cpu}" == "ppc"
  22. %define target_bits 32
  23. %endif
  24. %if "%{_target_cpu}" == "x86_64"
  25. %define target_bits 64
  26. %endif
  27. %if "%{_target_cpu}" == "ppc64"
  28. %define target_bits 64
  29. %endif
  30. # Define libraries for 32/64 arches
  31. %define lib32 lib
  32. %define lib64 lib64
  33. %define libdir32 /usr/lib
  34. %define libdir64 /usr/lib64
  35. # define nspluginswrapper libdir (invariant, including libdir)
  36. %define pkgdir32 %{libdir32}/%{name}
  37. %define pkgdir64 %{libdir64}/%{name}
  38. # define mozilla plugin dir and back up dir for 32-bit browsers
  39. %define pluginsourcedir32 %{libdir32}/mozilla/plugins
  40. %define plugindir32 %{libdir32}/mozilla/plugins-wrapped
  41. # define mozilla plugin dir and back up dir for 64-bit browsers
  42. %define pluginsourcedir64 %{libdir64}/mozilla/plugins
  43. %define plugindir64 %{libdir64}/mozilla/plugins-wrapped
  44. %define build_dir objs-%{target_bits}
  45. %if "%{target_bits}" == "32"
  46. %define lib %{lib32}
  47. %define libdir %{libdir32}
  48. %define pkgdir %{pkgdir32}
  49. %define plugindir %{plugindir32}
  50. %define pluginsourcedir %{pluginsourcedir32}
  51. %else
  52. %define lib %{lib64}
  53. %define libdir %{libdir64}
  54. %define pkgdir %{pkgdir64}
  55. %define plugindir %{plugindir64}
  56. %define pluginsourcedir %{pluginsourcedir64}
  57. %endif
  58. Summary: A compatibility layer for Netscape 4 plugins
  59. Name: nspluginwrapper
  60. Version: 1.3.0
  61. Release: 2%{?_dist_release}
  62. Source0: %{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
  63. Source1: %{plugin_config_name}.tar.gz
  64. Source2: plugin-config.sh.in
  65. Source3: %{name}.sh.in
  66. Patch1: nspluginwrapper-1.3.0-make.patch
  67. Patch2: nspluginwrapper-1.3.0-configure.patch
  68. Patch3: nspluginwrapper-1.3.0-directory.patch
  69. Patch100: plugin-config-setuid.patch
  70. Patch101: plugin-config-umask.patch
  71. Patch102: plugin-config-print.patch
  72. Patch103: plugin-config-native.patch
  73. License: GPLv2+
  74. Group: Applications/Internet
  75. URL: http://gwenole.beauchesne.info/projects/nspluginwrapper/
  76. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  77. Provides: %{name} = %{version}-%{release}
  78. #Requires: mozilla-filesystem
  79. %ifarch x86_64
  80. Requires: compat32-%{name} = %{version}-%{release}
  81. %endif
  82. BuildRequires: pkgconfig gtk2-devel glib2-devel nspr-devel
  83. BuildRequires: libX11-devel libXt-devel cairo-devel pango-devel curl-devel
  84. BuildRequires: gecko-devel
  85. ExclusiveArch: %{ix86} x86_64 ppc
  86. %description
  87. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  88. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  89. This package consists in:
  90. * npviewer: the plugin viewer
  91. * npwrapper.so: the browser-side plugin
  92. * nspluginplayer: stand-alone NPAPI plugin player
  93. * mozilla-plugin-config: a tool to manage plugins installation and update
  94. ## to build compat32 for x86_64 architecture support
  95. %package -n compat32-%{name}
  96. Summary: A compatibility layer for Netscape 4 plugins
  97. Group: System Environment/Libraries
  98. %description -n compat32-%{name}
  99. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  100. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  101. This package consists in:
  102. * npviewer: the plugin viewer
  103. * npwrapper.so: the browser-side plugin
  104. * nspluginplayer: stand-alone NPAPI plugin player
  105. * mozilla-plugin-config: a tool to manage plugins installation and update
  106. %prep
  107. %setup -q -a 1
  108. # Installation & build patches
  109. %patch1 -p1 -b .make
  110. %patch2 -p1 -b .conf
  111. %patch3 -p1 -b .dir
  112. # Plugin-config patches
  113. pushd %plugin_config_name
  114. %patch100 -p2
  115. %patch101 -p2 -b .umask
  116. %patch102 -p2 -b .print
  117. %patch103 -p2 -b .native
  118. popd
  119. %build
  120. # Build wrapper
  121. # set the propper built options
  122. %if %{make_debug_package}
  123. %if "%{target_bits}" == "64"
  124. export CFLAGS="-g -m64 -DDEBUG"
  125. %else
  126. export CFLAGS="-g -m32 -DDEBUG"
  127. %endif
  128. %else
  129. export CFLAGS="$RPM_OPT_FLAGS"
  130. %endif
  131. # set the propper built options
  132. %if "%{target_bits}" == "64"
  133. export LDFLAGS="-m64 -L%{libdir64}"
  134. %else
  135. export LDFLAGS="-m32 -L%{libdir32}"
  136. %endif
  137. mkdir %{build_dir}
  138. pushd %{build_dir}
  139. ../configure \
  140. --prefix=%{_prefix} \
  141. --target-cpu=%{_target_cpu} \
  142. --pkgdir=%{name} \
  143. --pkglibdir=%{pkgdir} \
  144. --with-lib32=%{lib32} \
  145. --with-lib64=%{lib64} \
  146. --with-base-lib=%{lib} \
  147. --with-base-libdir=%{libdir} \
  148. --viewer-paths=%{pkgdir} \
  149. --with-x11-prefix=/usr \
  150. --with-gecko=%{gecko_flavour} \
  151. --enable-viewer \
  152. --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
  153. --disable-biarch
  154. make
  155. popd
  156. #Build plugin configuration utility
  157. pushd %{plugin_config_name}
  158. ./configure --prefix=/usr CFLAGS="$RPM_OPT_FLAGS"
  159. make
  160. popd
  161. %install
  162. rm -rf $RPM_BUILD_ROOT
  163. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  164. mkdir -p $RPM_BUILD_ROOT%{plugindir}
  165. mkdir -p $RPM_BUILD_ROOT%{pluginsourcedir}
  166. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  167. make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
  168. ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
  169. # Install plugin-config utility
  170. pushd %{plugin_config_name}
  171. DESTDIR=$RPM_BUILD_ROOT make install
  172. popd
  173. cd $RPM_BUILD_ROOT/usr/bin
  174. mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
  175. cd -
  176. rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
  177. cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  178. chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  179. cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
  180. > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  181. chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  182. # set up nsplugin player starting script
  183. %{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
  184. export MOZ_PLUGIN_PATH=%{pluginsourcedir}
  185. %{pkgdir}/npplayer "$@"
  186. EOF
  187. chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
  188. # Remove conflicting files
  189. rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
  190. rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
  191. ## <mozilla-filesystem>
  192. mkdir -p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
  193. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
  194. mkdir -p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
  195. ## </mozilla-filesystem>
  196. %clean
  197. rm -rf $RPM_BUILD_ROOT
  198. %post
  199. /usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
  200. %preun
  201. if [ "$1" == "0" ]; then
  202. /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
  203. fi;
  204. %files
  205. %defattr(-,root,root)
  206. %doc README COPYING NEWS
  207. %dir %{pkgdir}
  208. %dir %{plugindir}
  209. %{pkgdir}/%{plugin_config_binary}
  210. %{pkgdir}/npconfig
  211. %{pkgdir}/npwrapper.so
  212. %{pkgdir}/npviewer.bin
  213. %{pkgdir}/npviewer.sh
  214. %{pkgdir}/npviewer
  215. %{pkgdir}/npplayer
  216. %{pkgdir}/libxpcom.so
  217. %{pkgdir}/libnoxshm.so
  218. %{pkgdir}/nspluginplayer
  219. %{plugindir}/npwrapper.so
  220. %{_bindir}/mozilla-plugin-config
  221. %config %{_sysconfdir}/sysconfig/%{name}
  222. ## <mozilla-filesystem>
  223. /usr/lib*/mozilla
  224. %{_datadir}/mozilla
  225. /etc/skel/.mozilla
  226. ## </mozilla-filesystem>
  227. ## to build compat32 for x86_64 architecture support
  228. %if %{build_compat32}
  229. %files -n compat32-%{name}
  230. %defattr(-,root,root)
  231. %dir %{pkgdir}
  232. %dir %{plugindir}
  233. %{pkgdir}/%{plugin_config_binary}
  234. %{pkgdir}/npconfig
  235. %{pkgdir}/npwrapper.so
  236. %{pkgdir}/npviewer.bin
  237. %{pkgdir}/npviewer.sh
  238. %{pkgdir}/npviewer
  239. %{pkgdir}/npplayer
  240. %{pkgdir}/libxpcom.so
  241. %{pkgdir}/libnoxshm.so
  242. %{pkgdir}/nspluginplayer
  243. %{plugindir}/npwrapper.so
  244. %endif
  245. %changelog
  246. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
  247. - changed Group to System Environment/Libraries
  248. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
  249. - initial release
  250. - ported from Fedora development package
  251. * Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
  252. - Really Fix x86 32bit build (#488308)
  253. * Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
  254. - Fix x86 32bit build
  255. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  256. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  257. * Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
  258. - Fixed multilib conflicts
  259. * Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
  260. - Updated to 1.3.0 and removed some fedora build patches
  261. * Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
  262. - fix-invalid-RPC-after-NPP_Destroy fixes a crasher
  263. * Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
  264. - Updated to 1.1.8
  265. - Removed already upstreamed patches
  266. * Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
  267. - Updated to 1.1.4
  268. - Consolidated build patches
  269. * Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
  270. - Fixed #449338 - mozilla-plugin-config segfaults with -v argument
  271. * Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
  272. - Removed event patch, it blocks X events and breaks Adobe pdf plugin
  273. - Removed event limit in xt_event_polling_timer_callback
  274. * Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
  275. - added umask to plugin config (#463736)
  276. * Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
  277. - updated to 1.1.12
  278. - added librhythmbox* to ignored plugins (#467187)
  279. - removed debug prints (#467090)
  280. * Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
  281. - Unrevert patch from -7 because Warren was wrong
  282. - Concurrent rpc_method_invoke() patch
  283. * Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
  284. - Revert libcurl requires because it was done in an incorrect way
  285. - Revert patch from -7 because it made things worse
  286. * Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
  287. - Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  288. * Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
  289. - Added libcurl to requires (#460988)
  290. * Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
  291. - Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  292. * Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
  293. - Removed gecko-libs from requieres (it's not needed now)
  294. * Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
  295. - Enabled experimental stand-alone plugin player
  296. * Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
  297. - Fixed build warnings in our patches
  298. * Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
  299. - update to latest upstream version (1.1.0)
  300. * Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
  301. - link pluginwrapper with stdc++ lib
  302. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
  303. - mozilla-filesystem now owns the plugin source dir
  304. * Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
  305. - /etc/sysconfig/nspluginwrapper marked as config file
  306. - exclude some player plugins
  307. * Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
  308. - updated the sleep patch
  309. * Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
  310. - added experimental patch for #426968 - nspluginwrapper wakes up too much
  311. * Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
  312. - merged exclude patch with main tarball
  313. - fixed #431095 - Typo in mozilla-plugin-config verbose output
  314. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
  315. - Autorebuild for GCC 4.3
  316. * Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
  317. - fixed #426618 - gcjwebplugin error: Failed to run
  318. (added to ignored plugins)
  319. * Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
  320. - fixed #426176 - Orphaned npviewer.bin processes
  321. * Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
  322. - xulrunner rebuild
  323. - fixed build script, added gthread-2.0
  324. * Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
  325. - Make nsviewer.bin initialized for multithreading, fixes #360891
  326. * Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
  327. - disabled xpcom support - it causes more troubles than advantages
  328. * Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
  329. - spec fixes
  330. - fixed xulrunner support
  331. * Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
  332. - updated configure script - gecko selection
  333. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
  334. - enabled xpcom support
  335. - added fix for #393541 - scripts will never fail
  336. * Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
  337. - rebuilt against xulrunner
  338. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
  339. - more fixes from review by security standards team
  340. * Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
  341. - added fixes from review by security standards team
  342. * Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
  343. - mozilla-plugin-config can be run by normal user now
  344. * Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
  345. - Updated config utility - removes dangling symlinks and
  346. wrapped plugins
  347. * Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
  348. - Rebuild against new firefox
  349. * Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
  350. - added a fix for #281061 - gnash fails when wrapped, works when native
  351. * Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
  352. - removed possibble deadlock during plugin restart
  353. * Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
  354. - fixed browser crashes (#290901)
  355. * Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
  356. - quit the plugin when browser crashes (#290901)
  357. * Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
  358. - added original plugin dir to the package
  359. * Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
  360. - added upstream patches - RPC error handling and plugin restart
  361. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
  362. - update to the latest upstream
  363. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
  364. - converted rpc error handling code to a thread-safe variant
  365. - added a time limit to plugin restart
  366. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
  367. - implemented plugin restart (#251530)
  368. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
  369. - fixed an installation script (#251698)
  370. * Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
  371. - fixed plugins check
  372. - minor spec fixes
  373. * Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
  374. - removed mozembeded dependency
  375. - excluded totem plugins from wrapping
  376. - xpcom support is optional now
  377. * Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
  378. - Rebuild against newer gecko
  379. * Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
  380. - removed unsafe plugins probe
  381. - added agruments to mozilla-plugin-config
  382. * Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
  383. - removed fake libxpcom
  384. * Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
  385. - added gecko dependency
  386. - added plugin configuration utility
  387. * Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
  388. - fixed totem-complex plugin wrapping
  389. * Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
  390. - added plugin dirs
  391. * Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
  392. - added switch for creating debug packages
  393. * Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
  394. - integrated with firefox / seamonkey
  395. * Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
  396. - added new options to the configuration utility
  397. - modified along new plug-ins concept
  398. * Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
  399. - updated nspluginsetup script
  400. - added support for x86_64 plug-ins
  401. * Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
  402. - added ppc arch
  403. - silenced installation scripts
  404. - moved configuration to /etc/sysconfig
  405. * Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
  406. - updated nspluginsetup script and package install/uninstall scripts
  407. - added cross-compilation support
  408. - removed binaries stripping
  409. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
  410. - added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
  411. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
  412. - initial build