nasm-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. %define nasm_version 2.09.01
  2. %define download http://www.nasm.us/pub/nasm/releasebuilds
  3. Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
  4. Summary(ja): Netwide アセンブラ: Intel ライクなシンタックスのポータブル x86 アセンブラ
  5. Name: nasm
  6. Version: %{nasm_version}
  7. Release: 1%{?_dist_release}
  8. License: LGPL
  9. Group: Development/Languages
  10. URL: http://nasm.sourceforge.net/
  11. Source0: %{download}/%{nasm_version}/nasm-%{nasm_version}.tar.bz2
  12. Source1: %{download}/%{nasm_version}/nasm-%{nasm_version}-xdoc.tar.bz2
  13. BuildPrereq: perl, ghostscript, texinfo
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: owa
  18. %package doc
  19. Summary: Extensive documentation for NASM
  20. SUmmary(ja): NASM のドキュメント
  21. Group: Applications/Documentation
  22. PreReq: install-info
  23. %package rdoff
  24. Summary: Tools for the RDOFF binary format, sometimes used with NASM.
  25. Summary(ja): NASM で使われる RDOFF バイナリフォーマット用ツール
  26. Group: Development/Tools
  27. %description
  28. NASM is the Netwide Assembler, a free portable assembler for the Intel
  29. 80x86 microprocessor series, using primarily the traditional Intel
  30. instruction mnemonics and syntax.
  31. %description -l ja
  32. NASM は Netwide アセンブラです。Intel 80x86 プロセッサシリーズ用の
  33. フリーでポータブルなアセンブラで、基本的に伝統的な Intel インストラクション
  34. ニーモニックと文法を使います。
  35. %description doc
  36. Extensive documentation for the Netwide Assembler, NASM, in HTML,
  37. info, PostScript and text formats.
  38. %description doc -l ja
  39. Netwide アセンブラ NASM のドキュメントです。
  40. HTML、Info、ポストスクリプト、テキスト形式です。
  41. %description rdoff
  42. Tools for the operating-system independent RDOFF binary format, which
  43. is sometimes used with the Netwide Assembler (NASM). These tools
  44. include linker, library manager, loader, and information dump.
  45. %description rdoff -l ja
  46. RDOFF バイナリフォーマットの OS 用のツールで、NASM が使います。
  47. ここには、リンカ、ライブラリマネージャ、ローダ、ダンプが入っています。
  48. %prep
  49. %setup -q -n nasm-%{nasm_version} -b 1
  50. %build
  51. LDFLAGS=-s %configure
  52. ## don't use _smp_mflags (at 2.07.00)
  53. #make %{?_smp_mflags} everything
  54. make everything
  55. %install
  56. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  57. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  58. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  59. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  60. make INSTALLROOT="$RPM_BUILD_ROOT" docdir=%{_docdir}/nasm-doc install_everything
  61. mkdir -p included-docs
  62. cp -pr $RPM_BUILD_ROOT%{_docdir}/nasm-doc/* included-docs/
  63. rm -rf $RPM_BUILD_ROOT%{_docdir}/nasm-doc
  64. %clean
  65. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  66. %post doc
  67. /sbin/install-info %{_infodir}/nasm.info.gz %{_infodir}/dir
  68. %preun doc
  69. if [ $1 = 0 ]; then
  70. /sbin/install-info --delete %{_infodir}/nasm.info.gz %{_infodir}/dir
  71. fi
  72. %files
  73. %defattr(-,root,root)
  74. %doc AUTHORS CHANGES ChangeLog INSTALL LICENSE README TODO
  75. %{_bindir}/nasm
  76. %{_bindir}/ndisasm
  77. %{_mandir}/man1/*.1.gz
  78. %files doc
  79. %defattr(-,root,root)
  80. %doc included-docs/*
  81. %{_infodir}/nasm.info*
  82. %files rdoff
  83. %defattr(-,root,root)
  84. %doc rdoff/README
  85. %{_bindir}/ldrdf
  86. %{_bindir}/rdf2bin
  87. %{_bindir}/rdf2com
  88. %{_bindir}/rdf2ihx
  89. %{_bindir}/rdf2ith
  90. %{_bindir}/rdf2srec
  91. %{_bindir}/rdfdump
  92. %{_bindir}/rdflib
  93. %{_bindir}/rdx
  94. %changelog
  95. * Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.01-1
  96. - updated nasm to nasm-2.09.01
  97. - updated xdoc to nasm-2.09.01-xdoc
  98. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09-1
  99. - updated nasm to nasm-2.09
  100. - updated xdoc to nasm-2.09-xdoc
  101. * Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.08.01-1
  102. - updated nasm to nasm-2.08.01
  103. - updated xdoc to nasm-2.08.01-xdoc
  104. * Sat Sep 05 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.07.00-1
  105. - updated nasm to nasm-2.07
  106. * Mon Jul 13 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.06.00-1
  107. - updated nasm to nasm-2.06
  108. - added nasm-2.06-xdoc
  109. - changed download url
  110. * Tue Sep 30 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.04.00-1vl5
  111. - updated nasm to nasm-2.04
  112. - fixed typo of changelog version
  113. * Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.03.00-1vl5
  114. - updated nasm to nasm-2.03
  115. - applied new versioning policy and spec in utf-8
  116. * Fri Feb 22 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.02.00-0vl1
  117. - updated nasm to nasm-2.02
  118. * Mon Jan 28 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.01.00-0vl1
  119. - updated nasm to nasm-2.01
  120. * Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0.0-0vl1
  121. - updated nasm to nasm-2.00
  122. * Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0-0vl0rc1
  123. - updated nasm to nasm-2.00rc1
  124. * Sun Aug 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.98.39-0vl2
  125. - drop stupid macros
  126. - fix dependencies
  127. - add BuildRequires: texinfo
  128. - add BuildRequires: ghostscript instead of /usr/bin/ps2pdf
  129. - doc: add PreReq: install-info instead of /sbin/install-info
  130. - chande doc's group to Applications/Documentation
  131. * Sat Jun 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.39-0vl1
  132. - new upstream release
  133. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.38-0vl1
  134. - updated to 0.98.38
  135. - fixed %doc of nasm-doc
  136. * Thu Jul 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl3
  137. - fixed nasm-doc Group: Documentation
  138. - changed URL:
  139. - s/Copyright/License/
  140. * Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl2
  141. - merged Vine Plus spec file and Vine Seed Plus spec file (sorry....)
  142. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl1
  143. - update 0.98.36 based on sourceforge
  144. - change licence to LGPL
  145. - change URL
  146. - add BuildPrereq: perl
  147. * Tue Jan 27 2003 Masaki Shinomiya <shino@pos.to> 0.98.35-0vl1
  148. - source upstream, new URL, doc files
  149. * Sat Apr 14 2001 Shoji Matsumoto <shom@vinelinux.org> 0.98-0vl2
  150. - add ja desc
  151. - modify %files
  152. - use %configure
  153. - build for Seed
  154. * Fri Dec 15 2000 Hirotaka Mizutani
  155. - 0.98-0vl1
  156. - updated for VineLinux2.1