minitube-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. # Qt4 version auto-detection -- inagaki
  2. %define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
  3. %define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
  4. # Move original binary to libexec dir and replace it by wrapper script
  5. %define MINITUBE_BIN %{_libexecdir}/%{name}
  6. Summary: Native YouTube Client
  7. Summary(ja): YouTube 専用クライアント
  8. Name: minitube
  9. Version: 1.1
  10. Release: 1%{?_dist_release}
  11. Source0: %{name}-%{version}.tar.gz
  12. Source10: minitube.sh
  13. Source20: minitube-ja.desktop
  14. License: GPLv3+
  15. Group: Applications/Multimedia
  16. URL: http://flavio.tordini.org/minitube
  17. Requires: phonon-backend-gstreamer
  18. Requires(post): desktop-file-utils
  19. Requires(postun):desktop-file-utils
  20. BuildRequires: qt4-devel > 4.5
  21. BuildRequires: qt4-designer
  22. BuildRequires: phonon-devel
  23. BuildRequires: python-devel
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. %description
  26. Minitube is a native YouTube client. With it you can watch
  27. YouTube videos in a new way: you type a keyword, Minitube
  28. gives you an endless video stream. Minitube does not require
  29. the Flash Player.
  30. Minitube is not about cloning the original YouTube web interface,
  31. it aims to create a new TV-like experience.
  32. You should install following packages to play videos.
  33. - self-build-gstreamer-plugins-bad
  34. - self-build-gstreamer-plugins-ffmpeg
  35. %description -l ja
  36. Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
  37. アントソフトウェアです。キーワードを入力すると、Minitube は
  38. 関連する動画をエンドレスで再生します。
  39. また Minitube を使うと Flash Player 無しでビデオが再生できます。
  40. Minitube は YouTube のウェブインターフェースのクローンでは無
  41. く、新たなテレビ風の視聴スタイルを目指しています。
  42. ビデオの再生には以下のパッケージが必要となります。併せてイン
  43. ストールしてください。
  44. - self-build-gstreamer-plugins-bad
  45. - self-build-gstreamer-plugins-ffmpeg
  46. %prep
  47. %setup -q -n %{name}
  48. %build
  49. %{qt4qmake} prefix=%{_prefix}
  50. %{__make} %{?_smp_mflags}
  51. %install
  52. %{__rm} -rf $RPM_BUILD_ROOT
  53. %{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
  54. ## wrapper
  55. %{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
  56. %{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
  57. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  58. # desktop file with japanese messages
  59. %{__install} -m 644 %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  60. %clean
  61. %{__rm} -rf $RPM_BUILD_ROOT
  62. %post
  63. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  64. touch --no-create %{_datadir}/icons/hicolor
  65. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  66. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  67. fi
  68. %postun
  69. update-desktop-database %{_datadir}/applications>& /dev/null ||:
  70. touch --no-create %{_datadir}/icons/hicolor
  71. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  72. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %doc AUTHORS COPYING CHANGES INSTALL TODO
  77. %{MINITUBE_BIN}
  78. %{_bindir}/%{name}
  79. %{_datadir}/applications/%{name}.desktop
  80. %{_datadir}/icons/hicolor
  81. %{_datadir}/%{name}/locale
  82. %changelog
  83. * Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
  84. - new upstream release
  85. * Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
  86. - initial build for Vine Linux
  87. - add minitube.desktop with japanese translation
  88. - add wrapper script to check necessary packages at runtime