medit-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. %define name medit
  2. %define version 0.10.4
  3. Name: %{name}
  4. Version: %{version}
  5. Release: 2%{?_dist_release}
  6. Summary: Multiplatform GTK+2 text editor
  7. Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
  8. Group: Applications/Editors
  9. License: GPLv2+
  10. URL: http://mooedit.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
  12. Source1: medit_ja.po
  13. #Patch1: medit-0.9.2-do-not-update-system-files.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Buildrequires: cairo-devel
  16. BuildRequires: cmake >= 2.6
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: gettext
  19. BuildRequires: gtk2-devel glib2-devel
  20. BuildRequires: intltool
  21. BuildRequires: libxml2-devel
  22. BuildRequires: libX11-devel libXext-devel libICE-devel
  23. Buildrequires: perl-XML-Parser pango-devel
  24. BuildRequires: pcre-devel
  25. BuildRequires: python-devel
  26. BuildRequires: pygtk2-devel
  27. %description
  28. Medit is a multiplatform GTK+2 text editor.
  29. Features:
  30. * Configurable syntax highlighting.
  31. * Configurable keyboard accelerators.
  32. * Multiplatform - works both on unix and windows.
  33. * Plugins: can be written in C or Python.
  34. * Configurable tools available from the main and context menus.
  35. They can be written in Python or Lua, or it can be a shell script.
  36. * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
  37. %description -l ja
  38. Medit はマルチプラットフォームな GTK+2 テキストエディタです。
  39. 機能一覧:
  40. * 設定可能な構文強調機能。
  41. * 設定可能なキーボードアクセラレータ。
  42. * マルチプラットフォーム - unix と windows の両者で動作。
  43. * プラグイン: C あるいは Python で作成可能。
  44. * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
  45. Python あるいは lua 、シェルスクリプトで作成可能。
  46. * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
  47. %prep
  48. %setup -q
  49. #%patch1 -p1
  50. sed -i 's|fr|fr\nja|g' po/LINGUAS
  51. %__cp -f %{SOURCE1} po/ja.po
  52. %build
  53. cmake -D CMAKE_INSTALL_PREFIX=/usr .
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf %buildroot
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. desktop-file-install --vendor="" \
  59. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  60. --mode 0644 \
  61. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  62. %post
  63. update-desktop-database %{_datadir}/applications
  64. touch --no-create %{_datadir}/icons/hicolor
  65. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  66. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  67. fi
  68. %postun
  69. update-desktop-database %{_datadir}/applications
  70. touch --no-create %{_datadir}/icons/hicolor
  71. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  72. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  73. fi
  74. %clean
  75. rm -rf %buildroot
  76. %files
  77. %defattr(-,root,root)
  78. %doc COPYING README
  79. %{_bindir}/*
  80. %{_datadir}/applications/%{name}.desktop
  81. %{_datadir}/moo
  82. %{_datadir}/pixmaps/*
  83. %{_datadir}/icons/hicolor/*
  84. %{_datadir}/locale/*
  85. %{_docdir}/%{name}/*
  86. %{_mandir}/man?/
  87. %changelog
  88. * Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
  89. - updated Source1
  90. - added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
  91. - changed BuildRequires: cmake >= 2.6
  92. * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
  93. - new upstream release
  94. - added Japanese language file
  95. - added man directory in %files
  96. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  97. - new upstream release
  98. - applied new naming policy to spec
  99. * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
  100. - initial build for VineSeed
  101. * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
  102. + Revision: 155675
  103. - New version 0.9.2
  104. - rediff patch0
  105. + Olivier Blin <oblin@mandriva.com>
  106. - restore BuildRoot
  107. + Thierry Vignaud <tvignaud@mandriva.com>
  108. - kill re-definition of %%buildroot on Pixel's request
  109. * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
  110. + Revision: 114221
  111. - New version 0.9.0
  112. * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
  113. + Revision: 109208
  114. - New release 0.8.11
  115. * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
  116. + Revision: 59667
  117. - New version 0.8.10
  118. * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
  119. + Revision: 57568
  120. - New version 0.8.9
  121. * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
  122. + Revision: 51500
  123. - Fix file list
  124. - New version
  125. * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
  126. + Revision: 39539
  127. - SILent renew tarball
  128. - New version
  129. - New version
  130. add dirty patch that skips update-icon-cache and mime database when building
  131. + Jérôme Soyer <saispo@mandriva.org>
  132. - Import medit
  133. * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
  134. - new release
  135. * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
  136. - first spec for Mandriva