jd-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245
  1. ### for Vine Linux 4.x / 5.x ###
  2. %define pkg_version 2.6.5
  3. %define strtag 100425
  4. %define repoid 40140
  5. %define vendor_rel 3
  6. %define pre_release 0
  7. %if %{pre_release}
  8. %define pkg_release %{vendor_rel}.%{strtag}%{?_dist_release}
  9. %else
  10. %define pkg_release %{vendor_rel}%{?_dist_release}
  11. %endif
  12. ## icon install dist dir
  13. %define icondir %{_datadir}/icons/hicolor
  14. ## enable/disable sound (0:disable 1:enable)
  15. %define sound 1
  16. Summary: A 2ch browser
  17. Summary(ja): 2ちゃんねる用ブラウザ
  18. Name: jd
  19. Version: %{pkg_version}
  20. Release: %{pkg_release}
  21. Source0: http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
  22. Source1: jd-vl.desktop
  23. # upstream svn patches
  24. # Patch100: jd-2.5.0_http_201.patch
  25. # Patch100: jd-2.4.0_close_err_image.patch
  26. # Patch110: jd-2.4.0_tag_drawing_fix.patch
  27. # Patch100: jd-2.6.0_gtkmm28.patch
  28. Patch110: jd-2.6.5_vine4.patch
  29. License: GPL
  30. Group: Applications/Internet
  31. URL: http://jd4linux.sourceforge.jp/
  32. Requires: gtkmm2 >= 2.8
  33. Requires: glibmm
  34. Requires: zlib >= 1.2
  35. Requires: pango
  36. Requires: gnutls >= 1.2
  37. Requires(pre): desktop-file-utils
  38. # Prereq: desktop-file-utils
  39. BuildRequires: libtool, automake, autoconf
  40. BuildRequires: gtkmm2-devel >= 2.8
  41. BuildRequires: glibmm-devel
  42. BuildRequires: zlib-devel >= 1.2
  43. BuildRequires: XOrg-devel
  44. BuildRequires: pango-devel
  45. BuildRequires: gnutls-devel >= 1.2
  46. BuildRequires: libgpg-error-devel
  47. %if %{sound}
  48. BuildRequires: alsa-lib-devel
  49. %endif
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  51. Packager: tomcat, iwamoto
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. %description
  55. JD is a 2ch browser based on gtkmm2.
  56. %description -l ja
  57. JD は gtkmm2 ベースの2ちゃんねる用ブラウザです。
  58. %prep
  59. %setup -q -n %{name}-%{version}-%{strtag}
  60. # find . -name .svn | sort -r | xargs %{__rm} -rf
  61. # Patch 100 - 200 are upstream patches
  62. # %patch100 -p2 -b .close_err_image
  63. # %patch100 -p2 -b .gtkmm28
  64. %if %{?_dist_release} == "vl4"
  65. %patch110 -p1 -b .vine4
  66. %endif
  67. %build
  68. autoreconf -i
  69. ## set TZ for __TIME__
  70. export TZ='Asia/Tokyo'
  71. %if %{sound}
  72. %configure --with-alsa
  73. %else
  74. %configure
  75. %endif
  76. %{__make} %{?_smp_mflags}
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  80. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  81. %{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
  82. for i in 16 32 48 96;do \
  83. %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
  84. %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
  85. done
  86. %clean
  87. %{__rm} -rf ${RPM_BUILD_ROOT}
  88. %post
  89. update-desktop-database %{_datadir}/applications
  90. %postun
  91. update-desktop-database %{_datadir}/applications
  92. %files
  93. %defattr(-,root,root)
  94. %doc COPYING ChangeLog README
  95. %{_bindir}/%{name}
  96. %{_datadir}/applications/%{name}.desktop
  97. %{_datadir}/pixmaps/%{name}.png
  98. %{icondir}/*/apps/%{name}.png
  99. %changelog
  100. * Sun May 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-3
  101. - chaneg tag Prereq: -> Requires(pre):
  102. * Thu Apr 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-2
  103. - add patch110 to fix build error on Vine4
  104. - add BR: libgpg-error-devel
  105. * Wed Apr 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-1
  106. - new upstream release
  107. - drop Patch100 (is included in new release)
  108. * Mon Mar 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-2
  109. - add Patch100 to build fix with <= gtkmm28 (Vine 4.x env)
  110. * Mon Feb 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
  111. - new upstream release
  112. * Sat Feb 6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
  113. - 2.6.0 rc1 (not for release)
  114. * Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
  115. - new upstream release
  116. * Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
  117. - 2.5.5 rc1 (not for release)
  118. * Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
  119. - 2.5.5 beta (not for release)
  120. - drop patch100 (included in new release)
  121. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
  122. - new upstream release
  123. * Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
  124. - new upstream release
  125. * Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  126. - 2.4.2-rc090921-0
  127. - for test
  128. * Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
  129. - new upstream release
  130. * Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  131. - 2.4.1-rc090705-1
  132. - new upstream rc release for testing
  133. - drop patch100, 110 (included in new release)
  134. * Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
  135. - Merge spec file for vl4 and for vl5
  136. - add patch100, 110 from upstream svn
  137. * Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
  138. - new upstream release
  139. * Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
  140. - new upstream release
  141. * Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
  142. - fix icon file install method
  143. * Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
  144. - new upstream release
  145. * Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
  146. - new upstream release
  147. * Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
  148. - rebuild for official
  149. * Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
  150. - update to 2.0.2
  151. * Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
  152. - build with gnutls-1.4.1(official package)
  153. * Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
  154. - build with gnutls-1.6.3(unofficial package)
  155. * Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
  156. - new upstream release
  157. - drop Patch0 (jd-1.9.5-desktop-vi.patch)
  158. - add Source1 (jd-vi.desktop)
  159. * Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
  160. - new upstream release
  161. * Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
  162. - new upstream release
  163. * Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
  164. - modified jd-vi.spec
  165. - add patch0
  166. * Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
  167. - new upstream release
  168. * Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
  169. - fix the Help file is not installed
  170. * Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
  171. - new upstream release
  172. * Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
  173. - new upstream release
  174. * Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
  175. - new upstream release
  176. * Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
  177. - initial build for Vine Linux
  178. * Sun Mar 9 2006 Houritsuchu <houritsuchu@hotmail.com>
  179. - Version up.
  180. - add icon
  181. * Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
  182. - first