audit-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599
  1. %define sca_version 0.4.8
  2. %define sca_release 6
  3. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  4. Summary: User space tools for 2.6 kernel auditing
  5. Name: audit
  6. Version: 1.7.6
  7. Release: 6%{?_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. URL: http://people.redhat.com/sgrubb/audit/
  11. Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
  12. Source1: system-config-audit-ja.po
  13. Patch1: audit-1.7.5-policy.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: gettext intltool libtool swig python-devel
  16. BuildRequires: tcp_wrappers
  17. BuildRequires: kernel-headers >= 2.6.18
  18. BuildRequires: automake >= 1.9
  19. BuildRequires: autoconf >= 2.59
  20. Requires: %{name}-libs = %{version}-%{release}
  21. Requires: chkconfig
  22. Requires(pre): coreutils
  23. %description
  24. The audit package contains the user space utilities for
  25. storing and searching the audit records generate by
  26. the audit subsystem in the Linux 2.6 kernel.
  27. %package libs
  28. Summary: Dynamic library for libaudit
  29. License: LGPLv2+
  30. Group: Development/Libraries
  31. %description libs
  32. The audit-libs package contains the dynamic libraries needed for
  33. applications to use the audit framework.
  34. %package libs-devel
  35. Summary: Header files and static library for libaudit
  36. License: LGPLv2+
  37. Group: Development/Libraries
  38. Requires: %{name}-libs = %{version}-%{release}
  39. Requires: kernel-headers >= 2.6.18
  40. %description libs-devel
  41. The audit-libs-devel package contains the static libraries and header
  42. files needed for developing applications that need to use the audit
  43. framework libraries.
  44. %package libs-python
  45. Summary: Python bindings for libaudit
  46. License: LGPLv2+
  47. Group: Development/Libraries
  48. Requires: %{name}-libs = %{version}-%{release}
  49. %description libs-python
  50. The audit-libs-python package contains the bindings so that libaudit
  51. and libauparse can be used by python.
  52. %package -n audispd-plugins
  53. Summary: Plugins for the audit event dispatcher
  54. License: GPLv2+
  55. Group: System Environment/Daemons
  56. BuildRequires: openldap-devel
  57. Requires: %{name} = %{version}-%{release}
  58. Requires: %{name}-libs = %{version}-%{release}
  59. Requires: openldap
  60. %description -n audispd-plugins
  61. The audispd-plugins package provides plugins for the real-time
  62. interface to the audit system, audispd. These plugins can do things
  63. like relay events to remote machines or analyze events for suspicious
  64. behavior.
  65. %package -n system-config-audit
  66. Summary: Utility for editing audit configuration
  67. Version: %{sca_version}
  68. Release: %{sca_release}%{?_dist_release}
  69. License: GPLv2+
  70. Group: Applications/System
  71. BuildRequires: desktop-file-utils
  72. Requires: pygtk2-libglade usermode usermode-gtk
  73. %description -n system-config-audit
  74. A graphical utility for editing audit configuration.
  75. %prep
  76. %setup -q
  77. %patch1 -p1
  78. cp -f %{SOURCE1} system-config-audit/po/ja.po
  79. %build
  80. (cd system-config-audit; ./autogen.sh)
  81. %configure --sbindir=/sbin --libdir=/%{_lib} --with-libwrap
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d}}
  86. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  87. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  88. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  89. mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
  90. make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
  91. make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
  92. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  93. # This winds up in the wrong place when libtool is involved
  94. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  95. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  96. curdir=`pwd`
  97. cd $RPM_BUILD_ROOT/%{_libdir}
  98. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  99. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  100. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  101. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  102. cd $curdir
  103. # Remove these items so they don't get picked up.
  104. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  105. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  106. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.la
  107. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.la
  108. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.a
  109. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_audit.la
  110. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.a
  111. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
  112. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.a
  113. rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/auparse.la
  114. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  115. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  116. %find_lang system-config-audit
  117. desktop-file-install \
  118. --dir $RPM_BUILD_ROOT/%{_datadir}/applications \
  119. --delete-original \
  120. system-config-audit/system-config-audit.desktop
  121. #% check
  122. #make check
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. rm -rf zos-remote-policy
  126. %post libs -p /sbin/ldconfig
  127. %post
  128. /sbin/chkconfig --add auditd
  129. # This is to migrate users from audit-1.0.x installations
  130. if [ -f /etc/auditd.conf ]; then
  131. mv /etc/auditd.conf /etc/audit/auditd.conf
  132. fi
  133. if [ -f /etc/audit.rules ]; then
  134. mv /etc/audit.rules /etc/audit/audit.rules
  135. fi
  136. # This is to enable the dispatcher option which was commented out
  137. if [ -f /etc/audit/auditd.conf ]; then
  138. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  139. if [ $? -eq 1 ] ; then
  140. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  141. if [ -n $tmp ]; then
  142. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  143. cat $tmp > /etc/audit/auditd.conf
  144. rm -f $tmp
  145. fi
  146. fi
  147. fi
  148. %preun
  149. if [ $1 -eq 0 ]; then
  150. /sbin/service auditd stop > /dev/null 2>&1
  151. /sbin/chkconfig --del auditd
  152. fi
  153. %postun libs -p /sbin/ldconfig
  154. %postun
  155. if [ $1 -ge 1 ]; then
  156. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  157. fi
  158. %files libs
  159. %defattr(-,root,root)
  160. %attr(755,root,root) /%{_lib}/libaudit.*
  161. %attr(755,root,root) /%{_lib}/libauparse.*
  162. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  163. %files libs-devel
  164. %defattr(-,root,root)
  165. %doc contrib/skeleton.c contrib/plugin
  166. %{_libdir}/libaudit.a
  167. %{_libdir}/libauparse.a
  168. %{_libdir}/libaudit.so
  169. %{_libdir}/libauparse.so
  170. %{_includedir}/libaudit.h
  171. %{_includedir}/auparse.h
  172. %{_includedir}/auparse-defs.h
  173. %{_mandir}/man3/*
  174. %files libs-python
  175. %defattr(-,root,root)
  176. %attr(755,root,root) %{_libdir}/python?.?/site-packages/_audit.so
  177. %attr(755,root,root) %{_libdir}/python?.?/site-packages/auparse.so
  178. #%{_libdir}/python?.?/site-packages/auparse-*.egg-info
  179. %{python_sitelib}/audit.py*
  180. %files
  181. %defattr(-,root,root,-)
  182. %doc README COPYING ChangeLog contrib/capp.rules contrib/nispom.rules contrib/lspp.rules contrib/stig.rules init.d/auditd.cron
  183. %attr(644,root,root) %{_mandir}/man8/audispd.8.gz
  184. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  185. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  186. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  187. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  188. %attr(644,root,root) %{_mandir}/man8/autrace.8.gz
  189. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  190. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  191. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  192. %attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
  193. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  194. %attr(750,root,root) /sbin/auditctl
  195. %attr(750,root,root) /sbin/auditd
  196. %attr(755,root,root) /sbin/ausearch
  197. %attr(755,root,root) /sbin/aureport
  198. %attr(750,root,root) /sbin/autrace
  199. %attr(750,root,root) /sbin/audispd
  200. %attr(750,root,root) %{_bindir}/aulastlog
  201. %attr(755,root,root) %{_bindir}/ausyscall
  202. %attr(755,root,root) /etc/rc.d/init.d/auditd
  203. %attr(750,root,root) %{_var}/log/audit
  204. %attr(750,root,root) %dir /etc/audit
  205. %attr(750,root,root) %dir /etc/audisp
  206. %attr(750,root,root) %dir /etc/audisp/plugins.d
  207. %attr(750,root,root) %dir %{_libdir}/audit
  208. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  209. %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  210. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  211. %config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
  212. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
  213. %files -n audispd-plugins
  214. %defattr(-,root,root,-)
  215. %attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
  216. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  217. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  218. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
  219. %config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
  220. %attr(750,root,root) /sbin/audispd-zos-remote
  221. %config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
  222. %config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
  223. %attr(750,root,root) /sbin/audisp-remote
  224. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  225. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  226. %files -n system-config-audit -f system-config-audit.lang
  227. %defattr(-,root,root,-)
  228. %doc system-config-audit/AUTHORS
  229. %doc system-config-audit/COPYING
  230. %doc system-config-audit/ChangeLog
  231. %doc system-config-audit/NEWS
  232. %doc system-config-audit/README
  233. %{_bindir}/system-config-audit
  234. %{_datadir}/applications/system-config-audit.desktop
  235. %{_datadir}/system-config-audit
  236. %{_libexecdir}/system-config-audit-server-real
  237. %{_libexecdir}/system-config-audit-server
  238. %config(noreplace) %{_sysconfdir}/pam.d/system-config-audit-server
  239. %config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
  240. %changelog
  241. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  242. - forgot to increment sca_release macro (why on earth is sca_release
  243. individually defined from main package's release number anyway?)
  244. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  245. - rebuilt with gcc-4.4.3-3 on ppc
  246. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  247. - rebuilt with rpm-4.8.0-3 (on ppc)
  248. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  249. - rebuild with python-2.6
  250. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  251. - rebuild with openldap-2.4.11
  252. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  253. - initial build for Vine Linux
  254. - disable krb5, prelude and selinux
  255. - add ja.po (XXX: minimal)
  256. * Wed Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  257. - Add subject to audit daemon events (Chu Li)
  258. - Add tcp_wrappers support for auditd
  259. - Updated syscall tables for 2.6.27 kernel
  260. - Audit connect/disconnect of remote clients
  261. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  262. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  263. - Update system-config-audit to 0.4.8
  264. - Whole lot of bug fixes - see ChangeLog for details
  265. - Reimplement auditd main loop using libev
  266. - Add TCP listener to auditd to receive remote events
  267. - Fix scheduler problem (#457061)
  268. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  269. - Move ausearch-expression to main package (#453437)
  270. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  271. - Fix interpreting of keys in syscall records
  272. - Don't error on name=(null) PATH records in ausearch/report
  273. - Add key report to aureport
  274. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  275. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  276. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  277. - Fix output of keys in ausearch interpretted mode
  278. - Fix ausearch/report --start now to not be reset to midnight
  279. - audispd now has a priority boost config option
  280. - Look for laddr in avcs reported via prelude
  281. - Detect page 0 mmaps and alert via prelude
  282. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  283. - Fix overflow in audit_log_user_command, better (#438840)
  284. - ausearch was not matching path in avc records
  285. - audisp-prelude attempt to reposition index after examining each type
  286. - correct building of mls policy
  287. - Fix auparse iterating in auparse_find_field and next_field
  288. - Don't alert on USER_AVC's - they are not quite right
  289. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  290. - Fix buffer overflow in audit_log_user_command, again (#438840)
  291. - Fix memory leak in EOE code in auditd (#440075)
  292. - In auditctl, don't use new operators in legacy rule format
  293. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  294. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  295. - Fix memleak in auditd eoe code
  296. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  297. - Remove LSB headers from init scripts
  298. - Fix buffer overflow in audit_log_user_command again
  299. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  300. - Handle user space avcs in prelude plugin
  301. - Fix watched account login detection for some failed login attempts
  302. - Couple fixups in audit logging functions (Miloslav Trmac)
  303. - Add support in auditctl for virtual keys
  304. - auparse_find_field_next was not iterating correctly, fixed it
  305. - Add idmef alerts for access or execution of watched file
  306. - Fix buffer overflow in audit_log_user_command
  307. - Add basic remote logging plugin - only sends & no flow control
  308. - Update ausearch with interpret fixes from auparse
  309. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  310. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  311. - Apply auparse expression interface patch (Miloslav Trmac)
  312. - Fix potential memleak in audit event dispatcher
  313. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  314. - audisp-prelude alerts now controlled by config file
  315. - Updated syscall table for 2.6.25 kernel
  316. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  317. - Added watched account login detection for prelude plugin
  318. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  319. - Update for gcc 4.3
  320. - Cleanup descriptors in audispd before running plugin
  321. - Fix 'recent' keyword for aureport/search
  322. - Fix SE Linux policy for zos_remote plugin
  323. - Add event type for group password authentication attempts
  324. - Couple of updates to the translation tables
  325. - Add detection of failed group authentication to audisp-prelude
  326. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  327. - In ausearch/report, prefer -if to stdin
  328. - In ausearch/report, add new command line option --input-logs (#428860)
  329. - Updated audisp-prelude based on feedback from prelude-devel
  330. - Added prelude alert for promiscuous socket being opened
  331. - Added prelude alert for SE Linux policy enforcement changes
  332. - Added prelude alerts for Forbidden Login Locations and Time
  333. - Applied patch to auparse fixing error handling of searching by
  334. interpreted value (Miloslav Trmac)
  335. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  336. - Add prelude IDS plugin for IDMEF alerts
  337. - Add --user option to aulastlog command
  338. - Use desktop-file-install for system-config-audit
  339. - Avoid touching auditd.conf most of the time (#408501)
  340. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  341. - Updates for spec file review
  342. - Adjust permission on selinux policy file
  343. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  344. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  345. - Check for audit log being writable by owner in auditd
  346. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  347. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  348. - Added aulastlog utility
  349. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  350. - Allow 0600 file perms for audit logs
  351. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  352. - fchmod of log file was on wrong variable (#426934)
  353. - Allow use of errno strings for exit codes in audit rules
  354. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  355. - Don't fchmod() /dev/null to mode 0400 (#426934)
  356. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  357. - Add kernel release string to DEAMON_START events
  358. - Fix keep_logs when num_logs option disabled (#325561)
  359. - Fix auparse to handle node fields for syscall records
  360. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  361. - Add keyword week-ago to aureport & ausearch start/end times
  362. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  363. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  364. - Add event queue overflow action to audispd
  365. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  366. - Don't retry if the rt queue is full.
  367. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  368. - Add support for searching by posix regular expressions in auparse
  369. - Route DEAMON events into rt interface
  370. - If event pipe is full, try again after doing local logging
  371. - Optionally add node/machine name to records in audit daemon
  372. - Update ausearch/aureport to specify nodes to search on
  373. - Fix segfault interpretting saddr fields in avcs
  374. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  375. - Fix uninitialized variable in auparse (John Dennis)
  376. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  377. - External plugin support in place
  378. - Fix reference counting in auparse python bindings (#263961)
  379. - Moved default af_unix plugin socket to /var/run/audispd_events
  380. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  381. - Add newline to audispd string formatted events
  382. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  383. - spec file cleanups
  384. - Update to s-c-audit 0.4.3
  385. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  386. - Update Licence tags
  387. - Adding perm field should not set syscall added flag in auditctl
  388. - Fix segfault when aureport -if option is used
  389. - Fix auditctl to better check keys on rule lines
  390. - Add support for audit by TTY and other new event types
  391. - Auditd config option for group permission of audit logs
  392. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  393. - New audit event dispatcher
  394. - Update syscall tables for 2.6.23 kernel
  395. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  396. - Fix potential buffer overflow in print clone flags of auparse
  397. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  398. - Update auditctl to handle legacy kernels when putting a watch on a dir
  399. - Fix acct interpretation in auparse
  400. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  401. - Fix a double free when auditd receives SIGHUP
  402. - Move the system-config-audit menu entry to the Administration menu
  403. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  404. - Add system-config-audit (Miloslav Trmac)
  405. - Correct bug in audit_make_equivalent function (Al Viro)
  406. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  407. - Add feed interface to auparse library (John Dennis)
  408. - Apply patch to libauparse for unresolved symbols (#241178)
  409. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  410. - Change seresults to seresult in libauparse (John Dennis)
  411. - Add unit32_t definition to swig (#244210)
  412. - Add support for directory auditing
  413. - Update acct field to be escaped
  414. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  415. - Change buffer size to prevent truncation of DAEMON events with large labels
  416. - Fix memory leaks in auparse (John Dennis)
  417. - Update syscall tables for 2.6.21 kernel
  418. - Update capp & lspp rules
  419. - New python bindings for libauparse (John Dennis)
  420. * Thu Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  421. - New event dispatcher (James Antill)
  422. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  423. - Apply patch correcting python libs permissions (Philipp Hahn)
  424. - Fix auditd segfault on reload
  425. - Fix bug in auparse library for file pointers and descriptors
  426. - Extract subject information out of daemon events for ausearch
  427. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  428. - Remove requires kernel-headers for python-libs
  429. - Apply patch to prevent segfaults on auditd reload
  430. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  431. - Updated autrace to monitor *at syscalls
  432. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  433. - Finish reworking auditd config parser
  434. - In auparse, interpret open, fcntl, and clone flags
  435. - In auparse, when interpreting execve record types, run args through unencode
  436. - Add support for OBJ_PID message type
  437. - Event dispatcher updates
  438. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  439. - rebuild
  440. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  441. - NEW audit dispatcher program & plugin framework
  442. - Correct hidden variables in libauparse
  443. - Added NISPOM sample rules
  444. - Verify accessibility of files passed in auparse_init
  445. - Fix bug in parser library interpreting socketcalls
  446. - Add support for stdio FILE pointer in auparse_init
  447. - Adjust init script to allow anyone to status auditd (#230626)
  448. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  449. - Add man pages
  450. - Reduce text relocations in parser library
  451. - Add -n option to auditd for no fork
  452. - Add exec option to space_left, admin_space_left, disk_full,
  453. and disk_error - eg EXEC /usr/local/script
  454. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  455. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  456. - Finished search options for audit parsing library
  457. - Fix ausearch -se to work correctly
  458. - Fix auditd init script for /usr on netdev (#228528)
  459. - Parse avc seperms better when there are more than one
  460. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  461. - New report about authentication attempts
  462. - Updates for python 2.5
  463. - update autrace to have resource usage mode
  464. - update auditctl to support immutable config
  465. - added audit_log_user_command function to libaudit api
  466. - interpret capabilities
  467. - added audit event parsing library
  468. - updates for 2.6.20 kernel
  469. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  470. - Make more adjustments for python 2.5
  471. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  472. - Fix a couple parsing problems (#217952)
  473. - Add tgkill to S390* syscall tables (#218484)
  474. - Fix error messages in ausearch/aureport
  475. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  476. - rebuild against python 2.5
  477. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  478. - Fix timestamp for libaudit.conf (#218053)
  479. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  480. - Fix minor parsing problem and add new msg types
  481. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  482. - ausearch & aureport implement uid/gid caching
  483. - In ausearch & aureport, extract addr when hostname is unknown
  484. - In ausearch & aureport, test audit log presence O_RDONLY
  485. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  486. - Added --add & --delete option to aureport
  487. - Update res parsing in config change events
  488. - Increase the size on audit daemon buffers
  489. - Parse avc_path records in ausearch/aureport
  490. - ausearch has new output mode, raw, for extracting events
  491. - ausearch/aureport can now read stdin
  492. - Rework AVC processing in ausearch/aureport
  493. - Added long options to ausearch and aureport
  494. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  495. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  496. - Fix some defines in libaudit.h
  497. - Some auditd config strings were not initialized in aureport (#211443)
  498. - Updated man pages
  499. - Add Netlabel event types to libaudit
  500. - Update aureports to current audit event types
  501. - Update autrace a little
  502. - Deprecated all the old audit_rule functions from public API
  503. - Drop auparse library for the moment
  504. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  505. - Add dist tag and bump version (#208532)
  506. - Make internal auditd buffers bigger for context info
  507. - Correct address resolving of hostname in logging functions
  508. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  509. - Only =, != operators for arch & inode fields in auditctl (#206427)
  510. - Updated audit message type table
  511. - Remove watches from aureport since FS_WATCH is deprecated
  512. - Add audit_log_avc back temporarily (#208152)