djvulibre-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. Summary: DjVu viewers, encoders and utilities.
  2. Summary(ja): DjVu 画像形式ファイル操作用ライブラリ、ツール
  3. Name: djvulibre
  4. Version: 3.5.28
  5. Release: 1%{?_dist_release}
  6. Group: graphics
  7. Distribution: Project Vine
  8. Vendor: Vine Linux
  9. Packager: owa
  10. License: GPLv2
  11. URL: http://djvu.sourceforge.net
  12. Source0: http://prdownloads.sourceforge.net/djvu/djvulibre-%{version}.tar.gz
  13. Patch0: djvulibre-3.5.22-cdefs.patch
  14. Patch6: djvulibre-3.5.27-export-file.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libtiff-devel
  17. BuildRequires: libjpeg-devel
  18. BuildRequires: glibc-devel
  19. BuildRequires: inkscape
  20. BuildRequires: xdg-utils chrpath
  21. BuildRequires: hicolor-icon-theme
  22. Requires(post): xdg-utils
  23. Requires(preun): xdg-utils
  24. %description
  25. DjVu is a web-centric format and software platform for distributing documents
  26. and images. DjVu content downloads faster, displays and renders faster, looks
  27. nicer on a screen, and consume less client resources than competing formats.
  28. DjVu was originally developed at AT&T Labs-Research by Leon Bottou, Yann
  29. LeCun, Patrick Haffner, and many others. In March 2000, AT&T sold DjVu to
  30. LizardTech Inc. who now distributes Windows/Mac plug-ins, and commercial
  31. encoders (mostly on Windows)
  32. In an effort to promote DjVu as a Web standard, the LizardTech management was
  33. enlightened enough to release the reference implementation of DjVu under the
  34. GNU GPL in October 2000. DjVuLibre (which means free DjVu), is an enhanced
  35. version of that code maintained by the original inventors of DjVu. It is
  36. compatible with version 3.5 of the LizardTech DjVu software suite.
  37. DjVulibre-3.5 contains:
  38. - a standalone DjVu viewer based on the Qt library.
  39. - A browser plugin that works with most Unix browsers.
  40. - A full-fledged wavelet-based compressor for pictures.
  41. - A simple compressor for bitonal (black and white) scanned pages.
  42. - A compressor for palettized images (a la GIF/PNG).
  43. - A set of utilities to manipulate and assemble DjVu images and documents.
  44. - A set of decoders to convert DjVu to a number of other formats.
  45. - An up-to-date version of the C++ DjVu Reference Library.
  46. %package libs
  47. Summary: Library files for DjVuLibre
  48. Group: programming
  49. %description libs
  50. Library files for DjVuLibre.
  51. %package devel
  52. Summary: The libraries and header files needed for djvulibre development.
  53. Group: programming
  54. Requires: %{name}-libs = %{version}-%{release}
  55. %description devel
  56. DjVulibre libraries and header files for development.
  57. %debug_package
  58. %prep
  59. %setup -q -n %{name}-%{version}
  60. %autopatch -p1
  61. %build
  62. %configure --enable-threads
  63. make %{?_smp_mflags} V=1
  64. %install
  65. rm -rf %{buildroot}
  66. make DESTDIR=%{buildroot} install
  67. # fix to stop ldconfig from complaining
  68. find %{buildroot}%{_libdir} -name "*.so*" -exec chmod 755 {} \;
  69. # Remove rpath
  70. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutoxml
  71. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvused
  72. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cjb2
  73. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/csepdjvu
  74. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuserve
  75. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvm
  76. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuxmlparser
  77. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutxt
  78. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/ddjvu
  79. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvumake
  80. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cpaldjvu
  81. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuextract
  82. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/c44
  83. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvups
  84. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvudump
  85. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvmcvt
  86. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/bzz
  87. # This XML file does not differentiate between DjVu Image and DjVu Document
  88. # MIME types, the default one in shared-mime-info does.
  89. rm -f $RPM_BUILD_ROOT%{_datadir}/mime/packages/djvulibre-mime.xml
  90. # MIME types (icons and desktop file) - this installs icon files under
  91. # /usr/share/icons/hicolor/ and an xml file under /usr/share/mime/image/
  92. # Taken from {_datadir}/djvu/osi/desktop/register-djvu-mime install
  93. # See also the README file in the desktopfiles directory of the source distribution
  94. pushd desktopfiles
  95. for i in 22 32 48 64 ; do
  96. install -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/
  97. cp -a ./prebuilt-hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/image-vnd.djvu.mime.png
  98. # cp -a ./hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-image-vnd.djvu.png
  99. done
  100. popd
  101. %ldconfig_scriptlets libs
  102. %clean
  103. rm -rf %{buildroot}
  104. %files
  105. %defattr(-, root, root)
  106. %license COPYRIGHT COPYING
  107. %doc README NEWS
  108. %{_bindir}/*
  109. %exclude %{_datadir}/djvu/osi/de/*
  110. %exclude %{_datadir}/djvu/osi/fr/*
  111. %exclude %{_datadir}/djvu/osi/zh/*
  112. %dir %{_datadir}/djvu
  113. %{_datadir}/djvu/pubtext
  114. %dir %{_datadir}/djvu/osi
  115. %{_datadir}/djvu/osi/languages.xml
  116. %{_datadir}/djvu/osi/en
  117. %{_datadir}/djvu/osi/cs
  118. %lang(ja) %{_datadir}/djvu/osi/ja*
  119. %{_datadir}/icons/hicolor/*/mimetypes/*
  120. %{_mandir}/man?
  121. %files libs
  122. %license COPYRIGHT COPYING
  123. %doc README NEWS
  124. %{_libdir}/*.so.*
  125. %files devel
  126. %defattr(-, root, root)
  127. %doc doc
  128. %{_includedir}/libdjvu
  129. %{_libdir}/lib*.so
  130. %exclude %{_libdir}/*.la
  131. %{_libdir}/pkgconfig/ddjvuapi.pc
  132. %changelog
  133. * Wed Mar 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.28-1
  134. - new upstream release.
  135. - added a subpackage: djvulibre-libs.
  136. - dropped Patch2-5 and 7: fixed in upstream.
  137. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.27-1
  138. - new upstream release.
  139. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.25.3-3
  140. - rebuilt with new toolchain.
  141. * Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.25.3-2
  142. - rebuilt on current VineSeed
  143. - moved %{_libdir}/lib*.so to devel subpackage
  144. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.25.3-1
  145. - update to 3.5.25.3
  146. - remove BuildRequires: qt-devel
  147. - add BuildRequires: inkscape
  148. * Sun May 01 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.24-1
  149. - updated djvulibre to 3.5.24
  150. - obsoletes djvulibre-plugin (new is djview-plugin)
  151. * Sat Apr 30 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.22-4
  152. - installed djview3.png
  153. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.5.22-3
  154. - rebuilt with rpm-4.8.1 for pkg-config
  155. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-2
  156. - rebuilt with new toolchain
  157. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-1
  158. - updated djvulibre to 3.5.22
  159. * Tue Dec 30 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.21-1
  160. - initial build for VineSeed
  161. - spec in utf-8, and applied vine versioning policy
  162. - updated djvulibre to 3.5.21
  163. - added CXXFLAG="-march=i686" if i386
  164. - added djview desktop file
  165. * Tue Apr 03 2007 Shu KONNO <owa@bg.wakwak.com> 3.5.19-uvl1
  166. - updated djvulibre to 3.5.19
  167. - added scripts to alternative djview at %%post, %%preun
  168. * Thu Dec 01 2005 Shu KONNO <owa@bg.wakwak.com> 3.5.16-uvl1
  169. - updated djvulibre to 3.5.16
  170. - changed suffix
  171. - divided into djvulibre, djvulibre-devel, djvulibre-plugin
  172. * Tue Nov 09 2004 Shu KONNO <owa@bg.wakwak.com> 3.5.14-uvl2
  173. - updated djvulibre to 3.5.14 (realese 2)
  174. * Thu Jun 17 2004 Leon Bottou <leon@bottou.org> 3.5.13-4
  175. - changed runtime generation of file list.
  176. * Mon May 31 2004 Leon Bottou <leon@bottou.org> 3.5.13-3
  177. - removed 'make install-desktop-files'
  178. * Wed May 5 2004 Leon Bottou <leon@bottou.org> 3.5.13-2
  179. * Fri Apr 9 2004 Leon Bottou <leon@bottou.org> 3.5.13-1
  180. - added runtime generation of file list.
  181. - using DESTDIR instead of %makeinstall.
  182. - added 'make install-desktop-files'
  183. * Wed Nov 5 2003 Leon Bottou <leon@bottou.org> 3.5.12-3
  184. - added support for i18n
  185. - renamed symlink in mozilla plugin dirs.
  186. * Mon Jul 7 2003 Leon Bottou <leon@bottou.org> 3.5.12-1
  187. * Thu Apr 24 2003 Leon Bottou <leon@bottou.org> 3.5.11-1
  188. * Thu Feb 6 2003 Leon Bottou <leon@bottou.org> 3.5.10-2
  189. * Fri Jan 24 2003 Leon Bottou <leon@bottou.org> 3.5.10-1
  190. * Wed Oct 9 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-2
  191. - fixed logic for uninstalling nsdejavu links.
  192. - learned a few tricks from the freshrpms spec file.
  193. * Sun Oct 6 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-1
  194. - added logic to install nsdejavu for mozilla.
  195. * Wed May 29 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.6-1
  196. * Mon Apr 1 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  197. - changed group to Applications/Publishing.
  198. * Mon Mar 25 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  199. * Tue Jan 22 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.4-2
  200. - added macros to locate man directory.
  201. * Wed Jan 16 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.3-1
  202. * Fri Dec 7 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.2-1
  203. * Wed Dec 5 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.1-1
  204. - created initial file.