123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230 |
- Name: freerdp
- Summary: Remote Desktop Protocol client
- Summary(ja): リモートデスクトッププロトコルクライアント
- Version: 1.0.2
- Release: 1%{?_dist_release}
- Group: Applications/Internet
- License: GPLv2+
- URL: http://www.freerdp.com/
- Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
- # https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
- Patch0: fastpath_send_input_pdu-sec_bytes.patch
- Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
- Patch2: freerdp-1.0.2_xmlto.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: cmake
- BuildRequires: xmlto
- BuildRequires: openssl-devel
- BuildRequires: libX11-devel
- BuildRequires: libXext-devel
- BuildRequires: libXinerama-devel
- BuildRequires: libXcursor-devel
- BuildRequires: libXdamage-devel
- BuildRequires: libXv-devel
- BuildRequires: libxkbfile-devel
- BuildRequires: pulseaudio-libs-devel
- BuildRequires: cups-devel
- BuildRequires: pcsc-lite-devel
- BuildRequires: desktop-file-utils
- Provides: xfreerdp = %{version}-%{release}
- Requires: %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
- Requires: %{name}-plugins = %{version}-%{release}
- %description
- The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
- project.
- xfreerdp can connect to RDP servers such as Microsoft Windows
- machines, xrdp and VirtualBox.
- %package libs
- Summary: Core libraries implementing the RDP protocol
- Summary(ja): RDPプロトコル実装のコアライブラリ
- Group: System Environment/Libraries
- %description libs
- libfreerdp implements the core of the RDP protocol.
- libfreerdpchanman can be used to load plugins that can handle channels
- in the RDP protocol.
- libfreerdpkbd implements functionality for handling keyboards in X.
- %package plugins
- Summary: Plugins for handling the standard RDP channels
- Summary(ja): 標準RDPチャンネルを扱うためのプラグイン
- Group: System Environment/Libraries
- Requires: %{name}-libs = %{version}-%{release}
- %description plugins
- A set of plugins to the channel manager implementing the standard virtual
- channels extending RDP core functionality. For example, sounds, clipboard
- sync, disk/printer redirection, etc.
- %package devel
- Summary: Development files for %{name}
- Summary(ja): %{name}の開発ファイル
- Group: Development/Libraries
- Requires: %{name}-libs = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- The %{name}-devel package contains libraries and header files for
- developing applications that use %{name}-libs.
- %prep
- %setup -q -n FreeRDP-%{version}
- #patch0 -p1
- #patch1 -p1
- %patch2 -p1
- cat << EOF > xfreerdp.desktop
- [Desktop Entry]
- Type=Application
- Name=X FreeRDP
- NoDisplay=true
- Comment=Connect to RDP server and display remote desktop
- Icon=%{name}
- Exec=/usr/bin/xfreerdp
- Terminal=false
- Categories=Network;RemoteAccess;
- EOF
- %build
- %cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DWITH_CUPS=ON \
- -DWITH_PCSC=ON \
- -DWITH_PULSEAUDIO=ON \
- -DWITH_X11=ON \
- -DWITH_XCURSOR=ON \
- -DWITH_XEXT=ON \
- -DWITH_XINERAMA=ON \
- -DWITH_XKBFILE=ON \
- -DWITH_XV=ON \
- -DWITH_ALSA=OFF \
- -DWITH_CUNIT=OFF \
- -DWITH_DIRECTFB=OFF \
- -DWITH_FFMPEG=OFF \
- -DWITH_SSE2=OFF \
- -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
- .
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
- # No need for keymap files when using xkbfile
- rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
- desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
- install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- # This is no gtk application, but try to integrate nicely with GNOME if it is available
- gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- %post libs -p /sbin/ldconfig
- %postun libs -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %{_bindir}/xfreerdp
- %{_mandir}/man1/xfreerdp.*
- %{_datadir}/applications/xfreerdp.desktop
- %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
- %files libs
- %defattr(-,root,root,-)
- %doc LICENSE README ChangeLog
- %{_libdir}/lib%{name}-*.so.*
- %dir %{_libdir}/%{name}/
- %files plugins
- %defattr(-,root,root,-)
- %{_libdir}/%{name}/*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/%{name}/
- %{_libdir}/lib%{name}-*.so
- %{_libdir}/pkgconfig/%{name}.pc
- %changelog
- * Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
- - update to 1.0.2
- - fixed typo in Group
- - dropped Patch0 and Patch1
- - added Patch2 to build with current xmlto
- * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
- - update to 1.0.1
- - import patches from fedora package.
- - add BRs.
- * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
- - initial build for Vine Linux
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
- - rebuild on rawhide because of broken dependencies
- * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
- - freerdp-0.8.2
- * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
- - make -devel require pkgconfig
- - first official Fedora package
- * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
- - freerdp-0.8.1
- * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
- - hack the generated libtool to not set rpath on x86_64
- - configure with alsa explicitly
- * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
- - freerdp-0.7.4
- - cleanup of packaging structure
- * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
- - 0.7.3
- - fix some minor pylint warnings
- * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
- - 0.7.2
- - Address many comments from cwickert:
- - - cleanup of old formatting, alignment with spectemplate-lib.spec and
- cwickert spec from #616193
- - - add alsa as build requirement
- - - remove superfluous configure options and disable static libs
- - - add missing rpm groups
- * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
- - First official release, first review request
|