clutter-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383
  1. %define clutter_version 1.20.0
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.20/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: mesa-libEGL-devel
  20. BuildRequires: gdk-pixbuf2-devel
  21. BuildRequires: atk-devel
  22. BuildRequires: pkgconfig
  23. BuildRequires: pango-devel
  24. BuildRequires: libXdamage-devel
  25. BuildRequires: libXcomposite-devel
  26. BuildRequires: libXi-devel
  27. BuildRequires: gettext
  28. BuildRequires: gtk-doc
  29. BuildRequires: gobject-introspection-devel >= 0.9.5
  30. BuildRequires: json-glib-devel
  31. BuildRequires: cogl-devel >= 1.18.0
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: Takemikaduchi
  35. %description
  36. Clutter is an open source software library for creating fast,
  37. visually rich graphical user interfaces. The most obvious example
  38. of potential usage is in media center type applications.
  39. We hope however it can be used for a lot more.
  40. %description -l ja
  41. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  42. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  43. しかしながら、我々はいろいろな分野で使用されることを願っています。
  44. %package devel
  45. Summary: Clutter development environment
  46. Summary(ja): Clutterの開発環境
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  50. Requires: mesa-libGL-devel
  51. Requires: mesa-libEGL-devel
  52. Requires: gobject-introspection-devel
  53. Requires: json-glib-devel
  54. Requires: libXcomposite-devel
  55. Requires: libXi-devel
  56. %description devel
  57. Header files and libraries for building a extension library for the
  58. clutter
  59. %package docs
  60. Summary: Documentation for %{name}
  61. Summary(ja): %{name}用のドキュメント
  62. Group: Documentation
  63. Provides: %{name}-doc = %{version}-%{release}
  64. BuildArch: noarch
  65. Requires: %{name} = %{version}-%{release}
  66. %description docs
  67. Clutter is an open source software library for creating fast,
  68. visually rich graphical user interfaces. The most obvious example
  69. of potential usage is in media center type applications.
  70. We hope however it can be used for a lot more.
  71. This package contains documentation for clutter.
  72. %prep
  73. %setup -q
  74. %patch0 -p1 -b .dso
  75. %build
  76. #%configure --enable-gtk-doc \
  77. # --enable-introspection=yes \
  78. # --disable-silent-rules \
  79. # --enable-xinput \
  80. # --disable-static
  81. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  82. %configure $CONFIGFLAGS \
  83. --enable-introspection=yes \
  84. --disable-silent-rules \
  85. --enable-xinput \
  86. --disable-static \
  87. --enable-egl-backend=yes
  88. # clutter git ships with some magic to put the git log in shipped tarballs
  89. # which gets listed in files; don't blow up if it's missing
  90. if ! test -f ChangeLog; then
  91. echo "Created from snapshot" > ChangeLog
  92. fi
  93. )
  94. make V=0
  95. %install
  96. rm -rf $RPM_BUILD_ROOT
  97. #make DESTDIR=$RPM_BUILD_ROOT install
  98. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  99. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  100. %find_lang %{name}-1.0
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files -f %{name}-1.0.lang
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS COPYING NEWS README
  108. %{_libdir}/*.so.*
  109. %{_libdir}/girepository-1.0/*.typelib
  110. %files devel
  111. %defattr(-, root, root)
  112. %doc ChangeLog
  113. %{_includedir}/clutter-1.0
  114. %{_libdir}/*.so
  115. %{_libdir}/pkgconfig/*.pc
  116. %{_datadir}/gir-1.0/*.gir
  117. %files docs
  118. %defattr(-, root, root)
  119. %{_datadir}/gtk-doc/html/clutter
  120. %{_datadir}/gtk-doc/html/cally
  121. %changelog
  122. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  123. - new upstream release
  124. - add BuildRequires: mesa-libEGL-devel
  125. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  126. - new upstream release
  127. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  128. - new upstream release
  129. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  130. - new upstream release
  131. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  132. - new upstream release
  133. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  134. - new upstream release
  135. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  136. - new upstream release
  137. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  138. - new upstream release
  139. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  140. - new upstream release
  141. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  142. - new upstream release
  143. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  144. - new upstream release
  145. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  146. - new upstream release
  147. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  148. - new upstream release
  149. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  150. - new upstream release
  151. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  152. - new upstream release
  153. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  154. - new upstream release
  155. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  156. - new upstream release
  157. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  158. - new upstream release
  159. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  160. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  161. - new upstream release
  162. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  163. - new upstream release
  164. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  165. - new upstream release
  166. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  167. - new upstream release
  168. - add BuildRequires: cogl-devel
  169. - add "BuildArch: noarch" to doc sub package
  170. - add Patch0 (clutter-fixdso.patch)
  171. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  172. - new upstream release
  173. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  174. - new upstream release
  175. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  176. - new upstream release
  177. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  178. - new upstream release
  179. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  180. - new upstream release
  181. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  182. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  183. - drop Patch0
  184. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  185. - new upstream release
  186. - drop Patch1
  187. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  188. - new upstream release
  189. - add BuildRequires: json-glib-devel
  190. - delete Requires: gir-repository
  191. - delete BuildRequires: gir-repository-devel
  192. - add Requires: json-glib-devel (devel package)
  193. - add Patch0, Patch1
  194. - fix %build
  195. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  196. - rebuild with rpm-4.8.1 for pkg-config file
  197. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  198. - new upstream release
  199. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  200. - new upstream release
  201. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  202. - new upstream release
  203. - add configure option (--enable-xinput)
  204. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  205. - new upstream release
  206. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  207. - new upstream release
  208. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  209. - new upstream release
  210. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  211. - new upstream release
  212. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  213. - new upstream release
  214. - build for Vine Linux
  215. - add Summary(ja)
  216. - fix BuildRoot
  217. - remove Obsolete and Provides
  218. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  219. - Update to 1.0.6
  220. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  221. - Update to 1.0.4, update gobject-introspection requirement
  222. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  223. - Update to 1.0.2
  224. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  225. - Move ChangeLog to -devel to save some space
  226. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  227. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  228. onto the live cd
  229. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  230. - Update to 1.0.0
  231. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  232. - fix bz #507389
  233. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  235. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  236. - Update to 0.9.8
  237. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  238. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  239. introspection support to clutter (#512260)
  240. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  241. - Update to 0.9.6
  242. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  243. - Update to 0.9.4
  244. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  245. - Update to 0.9.2
  246. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  247. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  248. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  249. - Remove noarch from doc subpackage
  250. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  251. - Added gtk-doc for cogl
  252. - Created doc subpackage
  253. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  254. - Update to 0.8.6
  255. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  256. - Update to 0.8.2
  257. - Removed clutter-0.8.0-clutter-fixed.patch
  258. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  259. - Update to 0.8.0
  260. - Added clutter-0.8.0-clutter-fixed.patch
  261. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  262. - Update to 0.6.4
  263. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  264. - Update to 0.6.2
  265. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  266. - Update to 0.6.0
  267. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  268. - Autorebuild for GCC 4.3
  269. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  270. - Update to 0.4.2
  271. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  272. - Update to 0.4.1
  273. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  274. - Update to 0.3.1
  275. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  276. - Update to 0.2.3
  277. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  278. - Changed buildrequires and requires
  279. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  280. - Fix .spec
  281. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  282. - Fix .spec
  283. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  284. - Initial RPM release