ModemManager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. #define ppp_version 2.4.7
  4. %define glib2_version 2.40
  5. Name: ModemManager
  6. Summary: Mobile broadband modem management service
  7. Summary(ja): Mobile broadband modem management service
  8. Version: 1.4.2
  9. Release: 1%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: eudev-libgudev1-devel
  25. BuildRequires: automake autoconf intltool libtool
  26. BuildRequires: gtk-doc
  27. # for xsltproc
  28. BuildRequires: libxslt
  29. Requires: dbus-glib
  30. %description
  31. The ModemManager service manages WWAN modems and provides a consistent API for
  32. interacting with these devices to client applications.
  33. %package devel
  34. Summary: Development tools for %{name}
  35. Summary(ja): %{name} の開発環境
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. %description devel
  40. Header files and libraries for building a extension library for the %{name}.
  41. %package glib
  42. Summary: Libraries for adding ModemManager support to applications that use glib.
  43. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  44. Group: System Environment/Libraries
  45. Requires: glib2 >= %{glib2_version}
  46. %description glib
  47. This package contains the libraries that make it easier to use some ModemManager
  48. functionality from applications that use glib.
  49. %package glib-devel
  50. Summary: Development tools for %{name}-glib
  51. Summary(ja): %{name}-glib の開発環境
  52. Group: Development/Libraries
  53. Requires: %{name}-glib = %{version}-%{release}
  54. Requires: %{name}-devel = %{version}-%{release}
  55. Requires: glib2-devel
  56. Requires: pkgconfig
  57. %description glib-devel
  58. Header files and libraries for building a extension library for the %{name}-glib.
  59. %prep
  60. %setup -q
  61. %patch0 -p1 -b .pty
  62. %build
  63. autoreconf -if
  64. intltoolize --force
  65. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  66. %configure \
  67. --disable-static \
  68. --enable-gtk-doc=yes \
  69. --enable-introspection=no \
  70. --enable-vala=no \
  71. --enable-more-warnings=yes \
  72. --with-udev-base-dir=/lib/udev \
  73. --with-polkit=none \
  74. --without-mbim \
  75. --without-qmi \
  76. --with-dist-version=%{version}-%{release}
  77. make %{?_smp_mflags}
  78. %check
  79. make check
  80. %install
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  83. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  84. %find_lang %{name}
  85. %post
  86. /sbin/ldconfig
  87. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  88. %postun
  89. /sbin/ldconfig
  90. if [ $1 -eq 0 ]; then
  91. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  92. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  93. fi
  94. %posttrans
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  96. %post glib -p /sbin/ldconfig
  97. %postun glib -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(0644, root, root, 0755)
  100. %doc COPYING README
  101. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  102. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  103. %attr(0755,root,root) %{_sbindir}/ModemManager
  104. %attr(0755,root,root) %{_bindir}/mmcli
  105. %dir %{_libdir}/%{name}
  106. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  107. /lib/udev/rules.d/*
  108. %{_datadir}/dbus-1/interfaces/*.xml
  109. %{_datadir}/icons/hicolor/22x22/apps/*.png
  110. %{_mandir}/man8/*
  111. %files devel
  112. %defattr(0644, root, root, 0755)
  113. %{_includedir}/ModemManager/*.h
  114. %dir %{_datadir}/gtk-doc/html/%{name}
  115. %{_datadir}/gtk-doc/html/%{name}/*
  116. %{_libdir}/pkgconfig/%{name}.pc
  117. %files glib
  118. %defattr(0644, root, root, 0755)
  119. %{_libdir}/libmm-glib.so.*
  120. %files glib-devel
  121. %defattr(0644, root, root, 0755)
  122. %{_libdir}/libmm-glib.so
  123. %dir %{_includedir}/libmm-glib
  124. %{_includedir}/libmm-glib/*.h
  125. %{_libdir}/pkgconfig/mm-glib.pc
  126. %dir %{_datadir}/gtk-doc/html/libmm-glib
  127. %{_datadir}/gtk-doc/html/libmm-glib/*
  128. %changelog
  129. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  130. - new upstream release
  131. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  132. - new upstream release
  133. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  134. - moved ModemManager-glib to System Environment/Libraries Group
  135. - removed BR: ppp, ppp-devel and dbus-glib-devel
  136. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  137. - new upstream release
  138. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  139. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  140. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  141. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  142. - new upstream release
  143. - update Patch0
  144. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  145. - update to 0.7.991 snapshot
  146. - fix spec file based on FC package
  147. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  148. - Update to 0.7.991 snapshot
  149. - Fix SMS validity parsing
  150. - Allow registration changes to 'searching' without disconnecting
  151. - Fix reading SMS messages from some QMI-based devices
  152. - Increase connection timeout for Novatel E362
  153. - Fix PIN retries checking when unlocking Ericsson devices
  154. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  155. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  156. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  157. - new upstream release
  158. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  159. - new upstream release
  160. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  161. - delete Patch20
  162. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  163. - update Patch20 (ModemManager-0.4-git20110428.patch)
  164. - delete Patch21,22
  165. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  166. - update to 0.4
  167. - add Patch20 (ModemManager-0.4-git20100720.patch)
  168. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  169. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  170. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  171. - initial build for Vine Linux
  172. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  173. - core: ignore some failures on disconnect (rh #578280)
  174. - core: add support for platform serial devices
  175. - gsm: better Blackberry DUN support
  176. - gsm: periodically poll access technology
  177. - cdma: prevent crash on modem removal (rh #571921)
  178. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  179. - novatel: better signal strength reporting on CDMA cards
  180. - novatel: add access technology and mode preference support on GSM cards
  181. - zte: fix mode preference retrieval
  182. - longcheer: add support for Zoom modems (4595, 4596, etc)
  183. - longcheer: add access technology and mode preference support
  184. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  185. - Silence %%post
  186. - Update scripts
  187. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  188. - gsm: fix parsing Blackberry supported character sets response
  189. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  190. - mbm: fix retrieval of current allowed mode
  191. - gsm: fix initialization issues with some devices (like Blackberries)
  192. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  193. - core: fix detection of some generic devices (rh #579247)
  194. - core: fix detection regression of some Huawei devices in 0.3-5
  195. - cdma: periodically poll registration state and signal quality
  196. - cdma: really fix registration detection on various devices (rh #569067)
  197. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  198. - core: fix PPC/SPARC/etc builds
  199. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  200. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  201. - cdma: handle signal quality requests while connected for more devices
  202. - cdma: handle serving system requests while connected for more devices
  203. - gsm: determine current access technology earlier
  204. - huawei: work around automatic registration issues on some devices
  205. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  206. - core: ensure enabled modems are disabled when MM stops
  207. - core: better capability detection for Blackberry devices (rh #573510)
  208. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  209. - gsm: don't block modem when it requires PIN2
  210. - option: fix access technology updates
  211. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  212. - mbm: add device IDs for C3607w
  213. - mbm: fail earlier during connection failures
  214. - mbm: fix username/password authentication when checked by the network
  215. - hso: implement asynchronous signal quality updates
  216. - option: implement asynchronous signal quality updates
  217. - novatel: correctly handle CDMA signal quality
  218. - core: basic PolicyKit support
  219. - core: fix direct GSM registration information requests
  220. - core: general GSM PIN/PUK unlock fixes
  221. - core: poll GSM registration state internally for quicker status updates
  222. - core: implement GSM 2G/3G preference
  223. - core: implement GSM roaming allowed/disallowed preference
  224. - core: emit signals on access technology changes
  225. - core: better handling of disconnections
  226. - core: fix simple CDMA status requests
  227. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  228. - core: startup speed improvements
  229. - core: GSM PIN checking improvements
  230. - huawei: fix EVDO-only connections on various devices (rh #553199)
  231. - longcheer: add support for more devices
  232. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  233. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  234. - core: fix crashes when devices are unplugged during operation (rh #553953)
  235. - cdma: prefer primary port for status/registration queries
  236. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  237. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  238. - gsm: fix Nokia N80 network scan parsing
  239. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  240. - core: fix apparent hangs by limiting retried serial writes
  241. - gsm: ensure modem state is reset when disabled
  242. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  243. - sierra: fix CDMA registration detection in some cases (rh #547513)
  244. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  245. - sierra: ensure CDMA device is powered up when trying to use it
  246. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  247. - zte: handle unsolicited messages better during probing
  248. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  249. - cdma: fix signal strength reporting on some devices
  250. - cdma: better registration state detection when dialing (ex Sierra 5275)
  251. - option: always use the correct tty for dialing commands
  252. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  253. - core: fix reconnect after manual disconnect (rh #541314)
  254. - core: fix various segfaults during registration
  255. - core: fix probing of various modems on big-endian architectures (ie PPC)
  256. - core: implement modem states to avoid duplicate operations
  257. - hso: fix authentication for Icera-based devices like iCON 505
  258. - zte: use correct port for new devices
  259. - nozomi: fix detection
  260. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  261. - Update to latest git
  262. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  263. - cdma: wait for network registration before trying to connect
  264. - gsm: add cell access technology reporting
  265. - gsm: allow longer-running network scans
  266. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  267. - nokia: don't power down phones on disconnect
  268. - hso: fix disconnection/disable
  269. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  270. - Fixes for Motorola and Ericsson devices
  271. - Fixes for CDMA "serving-system" command parsing
  272. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  273. - Fix a typo in one of the udev rules files
  274. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  275. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  276. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  277. - Fix source repo location
  278. - Fix directory ownership
  279. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  280. - Initial version