perl-Test-Warnings-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. Name: perl-Test-Warnings
  2. Version: 0.016
  3. Release: 3%{?_dist_release}
  4. Summary: Test for warnings and the lack of them
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Test-Warnings
  8. Source0: http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Warnings-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. # Build
  12. BuildRequires: perl
  13. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  14. # Module
  15. BuildRequires: perl(Exporter)
  16. BuildRequires: perl(Test::Builder)
  17. BuildRequires: perl(parent)
  18. BuildRequires: perl(strict)
  19. BuildRequires: perl(warnings)
  20. # Test Suite
  21. BuildRequires: perl(CPAN::Meta)
  22. BuildRequires: perl(CPAN::Meta::Requirements)
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. BuildRequires: perl(File::Spec::Functions)
  25. BuildRequires: perl(if)
  26. BuildRequires: perl(List::Util)
  27. BuildRequires: perl(Test::More) >= 0.94
  28. BuildRequires: perl(Test::Tester) >= 0.108
  29. BuildRequires: perl(version)
  30. # Runtime
  31. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. If you've ever tried to use Test::NoWarnings to confirm there are no warnings
  36. generated by your tests, combined with the convenience of done_testing to not
  37. have to declare a test count, you'll have discovered that these two features do
  38. not play well together, as the test count will be calculated before the
  39. warnings test is run, resulting in a TAP error (see examples/test_nowarnings.pl
  40. in this distribution for a demonstration).
  41. This module is intended to be used as a drop-in replacement for
  42. Test::NoWarnings: it also adds an extra test, but runs this test before
  43. done_testing calculates the test count, rather than after. It does this by
  44. hooking into done_testing as well as via an END block. You can declare a plan,
  45. or not, and things will still Just Work.
  46. It is actually equivalent to:
  47. use Test::NoWarnings 1.04 ':early';
  48. as warnings are still printed normally as they occur. You are safe, and
  49. enthusiastically encouraged, to perform a global search-replace of the above
  50. with use Test::Warnings; whether or not your tests have a plan.
  51. %prep
  52. %setup -q -n Test-Warnings-%{version}
  53. %build
  54. perl Makefile.PL INSTALLDIRS=vendor
  55. make %{?_smp_mflags}
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make pure_install DESTDIR=$RPM_BUILD_ROOT
  59. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  60. %{_fixperms} $RPM_BUILD_ROOT
  61. %check
  62. make test
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %files
  66. %doc Changes CONTRIBUTING LICENSE README README.md examples/
  67. %{perl_vendorlib}/Test/
  68. %{_mandir}/man3/Test::Warnings.3pm*
  69. %changelog
  70. * Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.016-3
  71. - inital build for Vine Linux
  72. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.016-2
  73. - Perl 5.20 rebuild
  74. * Sun Jun 22 2014 Paul Howarth <paul@city-fan.org> - 0.016-1
  75. - Update to 0.16
  76. - Fix prereq problem with last release - now no longer testing the example
  77. scripts for user installs
  78. * Fri Jun 20 2014 Paul Howarth <paul@city-fan.org> - 0.015-1
  79. - Update to 0.15
  80. - Adjusted packaging and tests to become perl-5.6 friendly, including only
  81. using core or dual-lifed prerequisites
  82. - Switch to ExtUtils::MakeMaker flow
  83. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.014-2
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  85. * Mon Mar 3 2014 Paul Howarth <paul@city-fan.org> - 0.014-1
  86. - Update to 0.014
  87. - Fix test that fails when FOO or BAR environment variables are set
  88. (CPAN RT#93447)
  89. * Mon Dec 16 2013 Paul Howarth <paul@city-fan.org> - 0.013-1
  90. - Update to 0.013
  91. - Update configure_requires checking in Makefile.PL
  92. * Mon Oct 14 2013 Paul Howarth <paul@city-fan.org> - 0.012-1
  93. - Update to 0.012
  94. - Re-release to fix t/00-report-prereqs.t use of CPAN::Meta::Requirements
  95. * Sun Oct 13 2013 Paul Howarth <paul@city-fan.org> - 0.011-1
  96. - Update to 0.011
  97. - Unnecessary tests removed
  98. - CONTRIBUTING file added
  99. - Drop buildreqs only needed for removed tests
  100. - BR: optional test requirement perl(CPAN::Meta::Requirements)
  101. * Wed Sep 25 2013 Paul Howarth <paul@city-fan.org> - 0.010-1
  102. - Update to 0.010
  103. - Re-release with fixed compile test
  104. - Update dependencies
  105. - Package examples
  106. * Wed Sep 11 2013 Paul Howarth <paul@city-fan.org> - 0.009-1
  107. - Update to 0.009
  108. - Fixed error in synopsis (we do not export anything by default)
  109. - A caveat added to the documentation regarding embedding warning checks
  110. inside another sub
  111. - ':no_end_test' now also covers side effects of done_testing, as well as
  112. END blocks, making it possible to use the warning(s) subs without having an
  113. end warning test while using done_testing (necessary when combining with
  114. the 'if' pragma)
  115. - END tests will not be added by a subequent use of Test::Warnings if a
  116. previous one passed ':no_end_test'
  117. - Update dependencies
  118. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.008-3
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  120. * Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.008-2
  121. - Perl 5.18 rebuild
  122. * Mon Jul 15 2013 Paul Howarth <paul@city-fan.org> - 0.008-1
  123. - Update to 0.008
  124. - Compile test updated, to hopefully fix mswin32 parsing issues
  125. * Wed Jul 10 2013 Paul Howarth <paul@city-fan.org> - 0.007-1
  126. - Update to 0.007
  127. - Fix subtest tests to work on Test::More before 0.95_01 (CPAN RT#86802)
  128. - BR: perl(Capture::Tiny)
  129. - Bump perl(Module::Build::Tiny) version requirement to 0.024
  130. - Bump perl(Test::CheckDeps) version requirement to 0.006
  131. - Drop perl(Test::More) version requirement to 0.94
  132. * Tue Jul 9 2013 Paul Howarth <paul@city-fan.org> - 0.006-2
  133. - Sanitize for Fedora submission
  134. * Tue Jul 9 2013 Paul Howarth <paul@city-fan.org> - 0.006-1
  135. - Initial RPM version