123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110 |
- Name: facile
- Summary: Functional Constraint Library implemented in Objective Caml
- Summary(ja): OCaml で実装された関数制約ライブラリ
- Version: 1.1
- Release: 12%{?_dist_release}
- License: LGPL
- Group: System Environment/Libraries
- URL: http://www.recherche.enac.fr/opti/facile/
- Source: http://www.recherche.enac.fr/opti/facile/distrib/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: ocaml >= 3.02
- Requires: ocaml >= 3.02
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: inagaki
- %description
- FaCiLe is a constraint programming library on integer and integer set
- finite domains written in OCaml. It offers all usual facilities to create and
- manipulate finite domain variables, arithmetic expressions and constraints
- (possibly non-linear), built-in global constraints (difference, cardinality,
- sorting etc.) and search and optimization goals. FaCiLe allows as well to
- build easily user-defined constraints and goals (including recursive ones),
- making pervasive use of OCaml higher-order functionals to provide a simple
- and flexible interface for the user. As FaCiLe is an OCaml library and not
- "yet another language", the user benefits from type inference and strong
- typing discipline, high level of abstraction, modules and objects system,
- as well as native code compilation efficiency, garbage collection and replay
- debugger, all features of OCaml (among many others) that allow to prototype
- and experiment quickly: modeling, data processing and interface are
- implemented with the same powerful and efficient language. For a more
- complete description, you may consult the preface and foreword of the online
- documentation
- %prep
- %setup -q
- %build
- ./configure
- make
- %install
- rm -rf $RPM_BUILD_ROOT
- mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
- cp src/facile.cmi src/facile.cma src/facile.cmxa src/facile.a $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
- chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cmi
- chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cma
- chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cmxa
- chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.a
- %clean
- rm -rf $RPM_BUILD_ROOT
- %check
- make check
- %files
- %defattr(-,root,root)
- %doc LICENSE README
- %{_libdir}/ocaml/facile
|