xulrunner-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826
  1. %define nspr_version 4.8.6
  2. %define nss_version 3.12
  3. %define cairo_version 1.8.6
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-1.9.2
  6. %define build_vine6 0
  7. %define build_vine5 0
  8. %if "%{?_dist_release}" == "vl6"
  9. %define build_vine6 1
  10. %define build_vine5 1
  11. %endif
  12. %if "%{?_dist_release}" == "vl5"
  13. %define build_vine5 1
  14. %endif
  15. %if %build_vine6
  16. %define sqlite_version 3.7.2
  17. %endif
  18. %define version_internal 1.9.2
  19. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  20. # Separated plugins are supported on x86(64) only
  21. %ifarch %{ix86} x86_64
  22. %define separated_plugins 1
  23. %else
  24. %define separated_plugins 0
  25. %endif
  26. Summary: XUL Runtime for Gecko Applications
  27. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  28. Name: xulrunner
  29. Version: 1.9.2.9
  30. Release: 2%{?_dist_release}
  31. URL: http://www.mozilla.org/projects/xulrunner/
  32. License: MPLv1.1 or GPLv2+ or LGPLv2+
  33. Group: Applications/Internet
  34. Source0: %{name}-%{version}.source.tar.bz2
  35. Source10: %{name}-mozconfig
  36. Source11: %{name}-mozconfig-vine5
  37. Source12: %{name}-vine-default-prefs.js
  38. Source21: %{name}.sh.in
  39. Source23: %{name}.1
  40. # locale sources
  41. %define MOZ_BUILD_LOCALES "ja"
  42. Source1000: xulrunner-%{version}-ja.tar.bz2
  43. # build patches
  44. Patch0: xulrunner-version.patch
  45. Patch1: mozilla-build.patch
  46. Patch3: mozilla-jemalloc.patch
  47. Patch7: xulrunner-1.9.2.1-build.patch
  48. Patch8: mozilla-plugin.patch
  49. Patch9: mozilla-build-sbrk.patch
  50. Patch10: mozilla-libjpeg-turbo.patch
  51. # patches from Fedora
  52. Patch100: mozilla-192-pkgconfig.patch
  53. # Upstream patches
  54. Patch200: mozilla-ps-pdf-simplify-operators.patch
  55. # ---------------------------------------------------
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  57. BuildRequires: nspr-devel >= %{nspr_version}
  58. BuildRequires: nss-devel >= %{nss_version}
  59. BuildRequires: cairo-devel >= %{cairo_version}
  60. BuildRequires: libpng-devel
  61. BuildRequires: libjpeg-turbo-devel
  62. BuildRequires: bzip2-devel
  63. BuildRequires: zlib-devel
  64. BuildRequires: lcms-devel
  65. BuildRequires: libIDL-devel
  66. BuildRequires: gtk2-devel
  67. BuildRequires: gnome-vfs2-devel
  68. BuildRequires: libgnome-devel
  69. BuildRequires: libgnomeui-devel
  70. BuildRequires: pango-devel
  71. BuildRequires: freetype2-devel >= 2.1.9
  72. BuildRequires: libXt-devel
  73. BuildRequires: libXrender-devel
  74. %if %{build_vine6}
  75. BuildRequires: sqlite3-devel >= %{sqlite_version}
  76. %endif
  77. BuildRequires: libnotify-devel >= %{libnotify_version}
  78. BuildRequires: startup-notification-devel
  79. BuildRequires: alsa-lib-devel
  80. BuildRequires: lcms-devel
  81. BuildRequires: zip
  82. # For -sqlite.patch
  83. BuildRequires: autoconf213
  84. Requires: nspr >= %{nspr_version}
  85. Requires: nss >= %{nss_version}
  86. Provides: gecko-libs = %{version}
  87. %description
  88. XULRunner provides the XUL Runtime environment for Gecko applications.
  89. %package devel
  90. Summary: Development files for Gecko
  91. Group: Development/Libraries
  92. Obsoletes: mozilla-devel
  93. Obsoletes: firefox-devel < 2.1
  94. Obsoletes: xulrunner-devel-unstable
  95. Provides: gecko-devel = %{version}
  96. Provides: gecko-devel-unstable = %{version}
  97. Requires: xulrunner = %{version}-%{release}
  98. Requires: nspr-devel >= %{nspr_version}
  99. Requires: nss-devel >= %{nss_version}
  100. Requires: cairo-devel >= %{cairo_version}
  101. Requires: libjpeg-turbo-devel
  102. Requires: zip
  103. Requires: bzip2-devel
  104. Requires: zlib-devel
  105. Requires: lcms-devel
  106. Requires: libIDL-devel
  107. Requires: gtk2-devel
  108. Requires: gnome-vfs2-devel
  109. Requires: libgnome-devel
  110. Requires: libgnomeui-devel
  111. Requires: pango-devel
  112. Requires: freetype2-devel >= 2.1.9
  113. Requires: libXt-devel
  114. Requires: libXrender-devel
  115. %if %{build_vine6}
  116. Requires: sqlite3-devel >= %{sqlite_version}
  117. %endif
  118. Requires: startup-notification-devel
  119. Requires: alsa-lib-devel
  120. %description devel
  121. Gecko development files.
  122. #---------------------------------------------------------------------
  123. %prep
  124. %setup -q -c -b 1000
  125. cd %{tarballdir}
  126. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  127. %{P:%%PATCH0} > version.patch
  128. %{__patch} -p1 -b --suffix .version < version.patch
  129. %patch1 -p1 -b .build
  130. %patch3 -p1 -b .jemalloc
  131. %patch7 -p2 -b .del
  132. %patch8 -p1 -b .plugin
  133. %patch9 -p2 -b .sbrk
  134. %patch10 -p1 -b .libjpeg-turbo
  135. %patch100 -p1 -b .pkgconfig
  136. %patch200 -p1 -b .ps-pdf-simplify-operators
  137. %{__rm} -f .mozconfig
  138. %if %{build_vine6}
  139. %{__cp} %{SOURCE10} .mozconfig
  140. %else
  141. %{__cp} %{SOURCE11} .mozconfig
  142. %endif
  143. %if !%{?separated_plugins}
  144. echo "ac_add_options --disable-ipc" >> .mozconfig
  145. %endif
  146. #---------------------------------------------------------------------
  147. %build
  148. cd %{tarballdir}
  149. INTERNAL_GECKO=%{version_internal}
  150. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  151. # Mozilla builds with -Wall with exception of a few warnings which show up
  152. # everywhere in the code; so, don't override that.
  153. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  154. export CFLAGS=$MOZ_OPT_FLAGS
  155. export CXXFLAGS=$MOZ_OPT_FLAGS
  156. export PREFIX='%{_prefix}'
  157. export LIBDIR='%{_libdir}'
  158. MOZ_SMP_FLAGS=-j1
  159. %ifnarch ppc ppc64 s390 s390x
  160. [ -z "$RPM_BUILD_NCPUS" ] && \
  161. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  162. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  163. %endif
  164. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  165. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  166. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  167. # build locales
  168. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  169. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  170. for dir in $LOCALEDIRS
  171. do
  172. for lang in %{MOZ_BUILD_LOCALES} ; do
  173. make -C $dir/locales AB_CD=$lang
  174. done
  175. done
  176. #---------------------------------------------------------------------
  177. %install
  178. cd %{tarballdir}
  179. %{__rm} -rf $RPM_BUILD_ROOT
  180. INTERNAL_GECKO=%{version_internal}
  181. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  182. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  183. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  184. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  185. #DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  186. DESTDIR=$RPM_BUILD_ROOT make install
  187. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  188. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  189. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  190. %{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
  191. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  192. # set up our default preferences
  193. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  194. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  195. %{__rm} vl-default-prefs
  196. # Start script install
  197. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  198. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  199. $RPM_BUILD_ROOT%{_bindir}/%{name}
  200. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  201. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  202. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  203. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  204. cd -
  205. # install locales
  206. for lang in %{MOZ_BUILD_LOCALES} ; do
  207. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  208. done
  209. # Prepare our devel package
  210. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  211. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  212. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  213. %{__cp} -rL dist/include/* \
  214. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  215. # Copy pc files (for compatibility with 1.9.1)
  216. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  217. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  218. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  219. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  220. # Fix multilib devel conflicts...
  221. %ifarch x86_64 ia64 s390x ppc64
  222. %define mozbits 64
  223. %else
  224. %define mozbits 32
  225. %endif
  226. function install_file() {
  227. genheader=$*
  228. mv ${genheader}.h ${genheader}%{mozbits}.h
  229. cat > ${genheader}.h << EOF
  230. // This file exists to fix multilib conflicts
  231. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  232. #include "${genheader}64.h"
  233. #else
  234. #include "${genheader}32.h"
  235. #endif
  236. EOF
  237. }
  238. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  239. install_file "mozilla-config"
  240. popd
  241. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  242. install_file "jsautocfg"
  243. popd
  244. %{__install} -p -c -m 755 dist/bin/xpcshell \
  245. dist/bin/xpidl \
  246. dist/bin/xpt_dump \
  247. dist/bin/xpt_link \
  248. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  249. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  250. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  251. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  252. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  253. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  254. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  255. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  256. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  257. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  258. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  259. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  260. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  261. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  262. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  263. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  264. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  265. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  266. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  267. for i in *.so; do
  268. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  269. done
  270. popd
  271. # GRE stuff
  272. %ifarch x86_64 ia64 ppc64 s390x
  273. %define gre_conf_file gre64.conf
  274. %else
  275. %define gre_conf_file gre.conf
  276. %endif
  277. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  278. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  279. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  280. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  281. # Library path
  282. %ifarch x86_64 ia64 ppc64 s390x
  283. %define ld_conf_file xulrunner-64.conf
  284. %else
  285. %define ld_conf_file xulrunner-32.conf
  286. %endif
  287. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  288. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  289. ${MOZ_APP_DIR}
  290. EOF
  291. # Copy over the LICENSE
  292. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  293. # Use the system hunspell dictionaries
  294. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  295. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  296. # ghost files
  297. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  298. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  299. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  300. #---------------------------------------------------------------------
  301. %clean
  302. %{__rm} -rf $RPM_BUILD_ROOT
  303. #---------------------------------------------------------------------
  304. %post
  305. /sbin/ldconfig
  306. %postun
  307. /sbin/ldconfig
  308. %preun
  309. # is it a final removal?
  310. if [ $1 -eq 0 ]; then
  311. %{__rm} -rf ${MOZ_APP_DIR}/components
  312. fi
  313. %files
  314. %defattr(-,root,root,-)
  315. %{_bindir}/xulrunner
  316. %dir /etc/gre.d
  317. /etc/gre.d/%{gre_conf_file}
  318. %dir %{mozappdir}
  319. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  320. %doc %attr(644, root, root) %{mozappdir}/README.txt
  321. %{mozappdir}/chrome
  322. %{mozappdir}/dictionaries
  323. %dir %{mozappdir}/components
  324. %ghost %{mozappdir}/components/compreg.dat
  325. %ghost %{mozappdir}/components/xpti.dat
  326. %{mozappdir}/components/*.so
  327. %{mozappdir}/components/*.xpt
  328. %attr(644, root, root) %{mozappdir}/components/*.js
  329. %{mozappdir}/defaults
  330. %{mozappdir}/greprefs
  331. %dir %{mozappdir}/icons
  332. %attr(644, root, root) %{mozappdir}/icons/*
  333. %{mozappdir}/modules
  334. %{mozappdir}/plugins
  335. %{mozappdir}/res
  336. %{mozappdir}/*.so
  337. %{mozappdir}/mozilla-xremote-client
  338. %{mozappdir}/run-mozilla.sh
  339. %{mozappdir}/regxpcom
  340. %{mozappdir}/xulrunner
  341. %{mozappdir}/xulrunner-bin
  342. %{mozappdir}/xulrunner-stub
  343. %if %{?separated_plugins}
  344. %{mozappdir}/plugin-container
  345. %endif
  346. %{mozappdir}/platform.ini
  347. %{mozappdir}/dependentlibs.list
  348. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  349. # XXX See if these are needed still
  350. %{mozappdir}/updater*
  351. %exclude %{mozappdir}/update.locale
  352. %exclude %{mozappdir}/components/components.list
  353. %files devel
  354. %defattr(-,root,root,-)
  355. %dir %{_datadir}/idl/%{name}*%{version_internal}
  356. %{_datadir}/idl/%{name}*%{version_internal}/*
  357. %{_includedir}/%{name}*%{version_internal}
  358. %dir %{_libdir}/%{name}-sdk-*
  359. %dir %{_libdir}/%{name}-sdk-*/sdk
  360. %{_libdir}/%{name}-sdk-*/*
  361. %{_libdir}/%{name}-sdk-*/sdk/*
  362. %{_libdir}/pkgconfig/*.pc
  363. %{mozappdir}/xpcshell
  364. %{mozappdir}/xpidl
  365. %{mozappdir}/xpt_dump
  366. %{mozappdir}/xpt_link
  367. #---------------------------------------------------------------------
  368. %changelog
  369. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  370. - rebuild with rpm-4.8.1 for pkg-config file
  371. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  372. - update to 1.9.2.9 (sync with firefox-3.6.9)
  373. - add patch10 to build with libjpeg-turbo
  374. - build with sqlite-3.7.2
  375. - BR: nspr >= 4.8.6
  376. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  377. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  378. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  379. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  380. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  381. - enable ipc only on ix86/x86_64 arches
  382. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  383. - update to 1.9.2.4 (sync with firefox-3.6.4)
  384. - add patch10 to fix build failure
  385. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  386. - update to 1.9.2.3 (sync with firefox-3.6.3)
  387. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  388. - update to 1.9.2.2 (sync with firefox-3.6.2)
  389. - add patch7,9 for fix build failure
  390. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  391. - enable libnotify support
  392. - add ac_add_options --enable-libnotify
  393. - disable Necko wifi monitor
  394. - add ac_add_options --disable-necko-wifi
  395. - remove BR: wireless-tools-devel
  396. - fix %%files devel
  397. - add patch3,5 to fix jemalloc alignment assertion
  398. - add Patch8 to fix mozilla-plugin.pc
  399. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  400. - add BR: libnotify-devel, wireless-tools-devel
  401. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  402. - update to 1.9.2 (sync with firefox-3.6)
  403. - obsoletes xulrunner-devel-unstable
  404. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  405. - use internal sqlite3 on vine5
  406. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  407. - update to 1.9.1.7
  408. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  409. - update to 1.9.1.6
  410. - build with sqlite3-3.6.21
  411. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  412. - update to 1.9.1.5
  413. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  414. - update to 1.9.1.3
  415. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  416. - really update to 1.9.1.2 (<BTS:0748>)
  417. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  418. - update to 1.9.1.2 (sync with firefox-3.5.2)
  419. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  420. - update to 1.9.1.1 (sync with firefox-3.5.1)
  421. - add missing Requires to -devel
  422. - add missing BR
  423. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  424. - enable-system-cairo
  425. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  426. - update to 1.9.1 (based on firefox 3.5)
  427. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  428. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  429. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  430. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  431. - remove old patches
  432. - require nspr >= 4.8
  433. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  434. - new upstream release
  435. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  436. - update mozconfig
  437. - disable-system-cairo for stability
  438. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  439. - new upstream release
  440. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  441. - new upstream release
  442. - add ja locale
  443. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  444. - new upstream release
  445. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  446. - new upstream release
  447. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  448. - add Patch3
  449. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  450. - update to xulrunner 1.9.0.2 byild 6
  451. - build with gnome-2.24
  452. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  453. - new upstream release
  454. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  455. - initial build for Vine Linux
  456. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  457. - Update to 1.9 final
  458. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  459. - Simplify PS/PDF operators
  460. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  461. - Upstream patch to fsync() less
  462. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  463. - Ensure we enable startup notification; add BR and modify config
  464. (bug #445543)
  465. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  466. - Some files moved to mozilla-filesystem; kill them and add the Req
  467. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  468. - Clean up the %%files list and get rid of the executable bit on some files
  469. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  470. - Fix font scaling
  471. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  472. - Enabled phishing protection (#443403)
  473. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  474. - Changed "__ppc64__" to "__powerpc64__",
  475. "__ppc64__" doesn't work anymore
  476. - Added fix for #443725 - Critical hanging bug with fix
  477. available upstream (mozbz#429903)
  478. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  479. - Fixed multilib issues, added starting script instead of a symlink
  480. to binary (#436393)
  481. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  482. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  483. - Re-enable system cairo
  484. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  485. - Spec cleanups
  486. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  487. - Beta 5
  488. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  489. - Beta 5 RC2
  490. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  491. - Update to latest trunk (2008-03-27)
  492. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  493. - Update to latest trunk (2008-03-26)
  494. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  495. - Update to latest trunk (2008-03-25)
  496. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  497. - Update to latest trunk (2008-03-24)
  498. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  499. - Update to latest trunk (2008-03-20)
  500. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  501. - Update to latest trunk (2008-03-17)
  502. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  503. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  504. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  505. - Update to latest trunk (2008-03-16)
  506. - Add patch to negate a11y slowdown on some pages (#431162)
  507. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  508. - Update to latest trunk (2008-03-15)
  509. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  510. - Avoid conflicts between gecko debuginfo packages
  511. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  512. - Update to latest trunk (2008-03-12)
  513. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  514. - Update to latest trunk (2008-03-11)
  515. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  516. - Update to latest trunk (2008-03-10)
  517. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  518. - Update to latest trunk (2008-03-09)
  519. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  520. - Update to latest trunk (2008-03-07)
  521. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  522. - Update to latest trunk (2008-03-06)
  523. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  524. - Update to latest trunk (2008-03-04)
  525. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  526. - Update to latest trunk (2008-03-02)
  527. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  528. - Update to latest trunk (2008-03-01)
  529. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  530. - Update to latest trunk (2008-02-29)
  531. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  532. - Update to latest trunk (2008-02-28)
  533. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  534. - Update to latest trunk (2008-02-27)
  535. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  536. - Update to latest trunk (2008-02-26)
  537. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  538. - Update to latest trunk (2008-02-23)
  539. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  540. - Update to latest trunk (2008-02-22)
  541. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  542. - Update to latest trunk (2008-02-21)
  543. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  544. - Update to latest trunk (2008-02-20)
  545. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  546. - Update to latest trunk (2008-02-17)
  547. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  548. - Update to latest trunk (2008-02-15)
  549. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  550. - Update to latest trunk (2008-02-14)
  551. - Use system hunspell
  552. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  553. - Update to latest trunk (2008-02-11)
  554. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  555. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  556. you know, debuginfo.
  557. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  558. - Update to latest trunk (2008-02-10)
  559. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  560. - Update to latest trunk (2008-02-09)
  561. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  562. - Update to latest trunk (2008-02-06)
  563. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  564. - Update to latest trunk (2008-01-30)
  565. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  566. - rebuild agains new nss
  567. - enabled gnome vfs
  568. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  569. - fixed stable pkg-config files (#429654)
  570. - removed sqlite patch
  571. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  572. - Update to latest trunk (2008-01-21)
  573. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  574. - Update to latest trunk (2008-01-15)
  575. - Now with system extensions directory support
  576. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  577. - Update to latest trunk (2008-01-13)
  578. - Use CFLAGS instead of configure arguments
  579. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  580. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  581. - Provide gecko-devel-unstable as well
  582. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  583. - divided devel package to devel and devel-unstable
  584. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  585. - removed fedora specific pkg-config files
  586. - updated to the latest trunk (2008-01-07)
  587. - removed unnecessary patches
  588. - fixed idl dir (#427965)
  589. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  590. - Re-enable camellia256 support now that NSS supports it
  591. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  592. - updated to the latest trunk (2008-01-03)
  593. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  594. - Don't Provide webclient (xulrunner is not itself a webclient)
  595. - Don't Obsolete old firefox, only firefox-devel
  596. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  597. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  598. - added java and plugin subdirs to plugin includes
  599. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  600. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  601. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  602. - updated to Beta 2.
  603. - moved SDK to xulrunner-sdk
  604. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  605. - fixed mozilla-plugin.pc (#412971)
  606. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  607. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  608. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  609. - added xulrunner/js include dir to xulrunner-js
  610. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  611. - update to beta 1
  612. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  613. - packed all gecko libraries (#389391)
  614. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  615. - registered xulrunner libs system-wide
  616. - added xulrunner-gtkmozembed.pc
  617. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  618. - added proper nss/nspr dependencies
  619. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  620. - more build fixes, use system nss libraries
  621. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  622. - build fixes
  623. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  624. - updated to the latest trunk
  625. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  626. - build fixes for ppc/ppc64
  627. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  628. - removed conflicts with the current gecko-based apps
  629. - added updated ppc64 patch
  630. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  631. - build fixes
  632. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  633. - Initial cut at XULRunner 1.9 Alpha 7
  634. - Temporarily revert camellia 256 support since our nss doesn't support it yet