parted-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. %define _sbindir /sbin
  2. Summary: The GNU disk partition manipulation program.
  3. Summary(ja): ディスクパーティション操作ツール
  4. Name: parted
  5. Version: 3.3
  6. Release: 1%{?_dist_release}
  7. Group: admin-tools,system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv3
  11. URL: http://www.gnu.org/software/parted/
  12. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  13. # Upstream still uses python2 for these scripts
  14. Patch0000: 0092-Switch-gpt-header-move-and-msdos-overlap-to-python3.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
  17. BuildRequires: python3-devel, ncurses-devel
  18. BuildRequires: device-mapper-devel
  19. BuildRequires: libtool, automake, autoconf
  20. BuildRequires: gettext-devel >= 0.18
  21. BuildRequires: texinfo
  22. BuildRequires: libuuid-devel
  23. BuildRequires: libblkid-devel >= 2.17
  24. BuildRequires: gnupg
  25. Provides: libparted = %{version}-%{release}
  26. %description
  27. GNU Parted is a program that allows you to create, destroy,
  28. resize, move and copy hard disk partitions. This is useful for
  29. creating space for new operating systems, reorganising disk
  30. usage, and copying data to new hard disks.
  31. %description -l ja
  32. GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
  33. 移動/コピーすることが出来るプログラムです.新しいオペレーティング
  34. システムをインストールするスペースを確保したり,ディスクのパーティションを
  35. 整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
  36. %package devel
  37. Summary: Files for developing apps which will manipulate disk partitions.
  38. Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
  39. Group: programming
  40. Requires: parted = %{version}-%{release}
  41. Provides: libparted-devel = %{version}-%{release}
  42. %description devel
  43. The GNU Parted library is a set of routines for hard disk partition
  44. manipulation. If you want to develop programs that manipulate disk
  45. partitions and filesystems using the routines provided by the GNU
  46. Parted library, you need to install this package.
  47. %description devel -l ja
  48. GNU Parted ライブラリにはハードディスクのパーティションを操作する
  49. 関数が用意されています。GNU Parted ライブラリが提供する関数を使って
  50. ディスクパーティションやファイルシステムを操作するプログラムを開発
  51. したいのであれば、このパッケージをインストールして下さい。
  52. %prep
  53. %setup -q
  54. %patch0 -p1 -b .python3
  55. iconv -f ISO-8859-1 -t UTF8 AUTHORS > tmp; touch -r AUTHORS tmp; mv tmp AUTHORS
  56. %build
  57. autoreconf
  58. autoconf
  59. CFLAGS="$RPM_OPT_FLAGS -Wno-unused-but-set-variable"; export CFLAGS
  60. %configure \
  61. --enable-device-mapper \
  62. --enable-shared
  63. # Don't use rpath!
  64. %{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  65. %{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  66. %__make %{?_smp_mflags}
  67. %install
  68. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  69. %__make install DESTDIR=$RPM_BUILD_ROOT
  70. # Remove components we do not ship
  71. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  72. %{__rm} -rf %{buildroot}%{_infodir}/dir
  73. %{__rm} -rf %{buildroot}%{_bindir}/label
  74. %find_lang %{name}
  75. %post
  76. /sbin/ldconfig
  77. /sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
  78. %postun
  79. /sbin/ldconfig
  80. %preun
  81. if [ $1 = 0 ]; then
  82. /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
  83. fi
  84. %clean
  85. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  86. %files -f %{name}.lang
  87. %defattr(-,root,root)
  88. %license COPYING
  89. %doc AUTHORS BUGS ChangeLog* NEWS README* THANKS TODO
  90. %doc doc/FAT doc/USER.jp
  91. %{_sbindir}/*
  92. %{_mandir}/man8/*
  93. %{_libdir}/lib*.so.*
  94. %{_infodir}/parted.info*
  95. %files devel
  96. %defattr(-,root,root)
  97. %doc doc/API
  98. %{_includedir}/*
  99. %{_libdir}/lib*.so
  100. %{_libdir}/*.a
  101. %{_libdir}/pkgconfig/libparted*.pc
  102. %changelog
  103. * Mon Aug 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  104. - new upstream release.
  105. * Mon Sep 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.153-1
  106. - new upstream release.
  107. - built with readline-8.0.
  108. * Thu Apr 2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2-2
  109. - rebuilt with readline 6.3
  110. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
  111. - new upstream release
  112. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-2
  113. - rebuild with VineSeed environment
  114. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1
  115. - new upstream release
  116. - remove Patch1
  117. * Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  118. - new upstream release
  119. - remove Patch0
  120. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3-1
  121. - new upstream release
  122. - drop old patches
  123. - new patch for 2.3 from fc14
  124. - add BRs: libuuid-devel, libblkid-devel >= 2.17, gnupg
  125. - change BR: gettext -> gettext-devel >= 0.18
  126. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.8-2
  127. - rebuilt with rpm-4.8.1 for pkg-config
  128. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  129. - new upstream release
  130. - import patch[1-8] from fedora
  131. * Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
  132. - rebuild with new environment/toolchain.
  133. * Fri Dec 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
  134. - new upstream release
  135. - remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
  136. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
  137. - changed Group to Applications/Administration
  138. * Wed May 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
  139. - new upstream release
  140. * Thu Dec 1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
  141. - new upstream release
  142. - updated Patch3, 100, 150 and 151 from Fedora
  143. * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
  144. - Update DASD, iseries, and SX8 patches.
  145. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
  146. - new upstream release
  147. - updated Patch100, 151
  148. * Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
  149. - new upstream release
  150. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
  151. - new upstream release
  152. - added Patch3 and Patch152, updated Patch150 (from Fedora)
  153. * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
  154. - add support for Promise SX8 devices
  155. * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
  156. - add patch from Matt Domsch to fix consistency of GPT disk labels
  157. with the EFI specification for disks > 2TB (#138480)
  158. * Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
  159. - new upstream release
  160. * Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
  161. - new upstream release
  162. * Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
  163. - new upstream release
  164. - added BuildRequires: automake autoconf gettext
  165. - patches from Fedora development
  166. * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
  167. - fix assertion error when checking flags on non-active partition (#130692)
  168. - buildrequires: gettext-devel
  169. * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
  170. - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
  171. - adjust dasd patch accordingly, drop some included patches
  172. * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
  173. - update dasd patch for dos-type partitions on mainframes (scsi disks)
  174. * Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
  175. - new upstream release
  176. - removed BuildRequires: automake17 autoconf
  177. - updated %post %postun section to install .info file
  178. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
  179. - dropped BuildRequires: libunicode-devel
  180. * Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
  181. - updated to current stable release 1.6.10
  182. - changed BuildRequires: automake17
  183. - added compile optioin -Os
  184. - dropped patch1
  185. * Fri Jun 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
  186. - updated to current stable release 1.6.5
  187. - changed summay and description based on Rawhide specfile
  188. * Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
  189. - updated to current stable release 1.4.24
  190. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  191. - 1.4.21-0vl1
  192. - enable __libtoolize
  193. * Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
  194. - 1.4.19-0vl1
  195. * Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
  196. - 1.4.19-0vl1
  197. * Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
  198. - 1.4.18-0vl1
  199. - Where did any python related files go? Erase'em.
  200. * Wed Aug 15 2001 <sagami@vinelinux.org>
  201. - 1.4.16-0vl1
  202. - build w/ --enable-shared --enable-all-static, instead of --disable-shared
  203. - consequently, eliminate Requires against e2fsprogs, readline
  204. - ldconfig at post/postun
  205. * Mon Jul 09 2001 <sagami@vinelinux.org>
  206. - 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
  207. - %%define __libtoolize /bin/true
  208. * Mon May 28 2001 <sagami@vinelinux.org>
  209. - 1.4.13-0vl1
  210. * Wed Apr 18 2001 <sagami@vinelinux.org>
  211. - 1.4.10-0vl1
  212. * Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  213. - updated to 1.4.7-0vl1
  214. - changed Group for devel subpackage
  215. - added USER.jp in %doc
  216. * Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  217. - 1.4.2-1vl2
  218. - partially used rpmmacros
  219. * Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  220. - 1.4.2-1vl1
  221. - build for Vine Linux
  222. - added Japanese summary and description
  223. * Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
  224. - changed "unset LINGUAS" line
  225. - reintroduced %build section ;)
  226. - started changelog