curl-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.28.0
  6. Release: 1%{?_dist_release}
  7. License: MIT/X
  8. Group: Applications/Internet
  9. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
  10. URL: http://curl.haxx.se/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: openssl-devel libidn-devel zlib-devel
  13. BuildRequires: openldap-devel gnutls-devel
  14. BuildRequires: libssh2-devel
  15. BuildRequires: openssh-clients
  16. BuildRequires: openssh-server
  17. BuildRequires: pkgconfig
  18. Requires: ca-certificates
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: daisuke
  22. %description
  23. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  24. Dict servers, using any of the supported protocols. cURL is designed
  25. to work without user interaction or any kind of interactivity. cURL
  26. offers many useful capabilities, like proxy support, user
  27. authentication, FTP upload, HTTP post, and file transfer resume.
  28. %package devel
  29. Summary: Files needed for building applications with libcurl.
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. Requires: openssl-devel libidn-devel zlib-devel
  33. %description devel
  34. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  35. Dict servers, using any of the supported protocols. The curl-devel
  36. package includes files needed for developing applications which can
  37. use cURL's capabilities internally.
  38. #'
  39. ## to build compat32 for x86_64 architecture support
  40. %package -n compat32-%{name}
  41. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  42. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  46. Dict servers, using any of the supported protocols. cURL is designed
  47. to work without user interaction or any kind of interactivity. cURL
  48. offers many useful capabilities, like proxy support, user
  49. authentication, FTP upload, HTTP post, and file transfer resume.
  50. %package -n compat32-%{name}-devel
  51. Summary: Files needed for building applications with libcurl.
  52. Group: Development/Libraries
  53. %description -n compat32-%{name}-devel
  54. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  55. Dict servers, using any of the supported protocols. The curl-devel
  56. package includes files needed for developing applications which can
  57. use cURL's capabilities internally.
  58. #'
  59. %prep
  60. %setup -q
  61. %build
  62. %configure \
  63. --with-ssl=%{_prefix} \
  64. --with-gnutls \
  65. --with-libidn \
  66. --enable-ipv6 \
  67. --enable-threaded-resolver \
  68. --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  69. --with-libssh2 \
  70. --enable-ldaps \
  71. --disable-static
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. make DESTDIR=$RPM_BUILD_ROOT install
  76. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %files
  82. %defattr(-,root,root)
  83. %doc CHANGES COPYING README
  84. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  85. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  86. %doc docs/TheArtOfHttpScripting docs/TODO
  87. %{_bindir}/curl
  88. #{_datadir}/curl/*
  89. %{_libdir}/*.so.*
  90. %{_mandir}/man1/*.1*
  91. %files devel
  92. %defattr(-,root,root)
  93. %{_bindir}/curl-config
  94. %{_includedir}/curl
  95. %{_libdir}/*.so
  96. %{_libdir}/pkgconfig/*.pc
  97. %{_mandir}/man1/curl-config.1*
  98. %{_mandir}/man3/*
  99. ## to build compat32 for x86_64 architecture support
  100. %if %{build_compat32}
  101. %files -n compat32-%{name}
  102. %defattr(-,root,root)
  103. %{_libdir}/*.so.*
  104. %files -n compat32-%{name}-devel
  105. %defattr(-,root,root)
  106. %{_libdir}/*.so
  107. %{_libdir}/pkgconfig/*.pc
  108. %endif
  109. %changelog
  110. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  111. - update to 7.28.0
  112. - add configure options
  113. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  114. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  115. - use ca-certificates package
  116. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  117. - R: ca-certificates
  118. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  119. - new upstream release
  120. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  121. - add patch100 for fix CVE-2011-2192 (gssapi)
  122. - add Vendor/Distri tags
  123. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  124. - rebuild with openssl-1.0.0c
  125. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  126. - rebuilt with rpm-4.8.1 for pkg-config
  127. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  128. - new upstream release
  129. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  130. - new upstream release with security fix
  131. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  132. - added compat32 subpackages
  133. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  134. - new upstream release
  135. - use "_smp_mflags" flag
  136. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  137. - rebuild with openldap-2.4.11
  138. - add BR: openldap-devel
  139. - remove static library
  140. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  141. - new upstream release with security fix (CVE-2009-0037)
  142. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  143. - new upstream release
  144. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  145. - new upstream release
  146. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  147. - new upstream release
  148. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  149. - new upstream release
  150. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  151. - new upstream release
  152. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  153. - rebuilt with openssl-0.9.8e
  154. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  155. - new upstream release
  156. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  157. - new upstream release
  158. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  159. - new upstream release
  160. - add pkgconfig file to devel package
  161. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  162. - new upstream release
  163. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  164. - new upstream release
  165. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  166. - new upstream release
  167. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  168. - added libidn, zlib in Requires
  169. - added libidn-devel, zlib-devel in BuildPrereq
  170. - added zlib-devel in curl-devel's Requires
  171. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  172. - added openssl-devel, libidn-devel in curl-devel's Requires
  173. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  174. - new upstream release
  175. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  176. - new upstream release
  177. - rebuild with openssl-0.9.7d
  178. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  179. - upstream release
  180. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  181. - add %%{_datadir}/curl/* to %%files section
  182. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  183. - source upgrade
  184. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  185. - source upgrade
  186. - add PreReq: ldconfig
  187. - add %%{_libdir}/*.la to %%files devel section
  188. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  189. - build for VineSeed
  190. - add Requires: openssl
  191. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  192. - automated rebuild
  193. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  194. - 7.9.2
  195. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  196. - include curl-config in curl-devel
  197. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  198. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  199. - added openssl-devel build req
  200. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  201. - built for the distro
  202. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  203. - upgrade to curl-7.7.2.
  204. - enable IPv6.
  205. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  206. - rebuilt against openssl-0.9.6-1
  207. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  208. - fixed mising ldconfigs
  209. - updated to 7.5.2, bug fixes
  210. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  211. - updated to 7.5.1
  212. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  213. - update to 7.4.1 to fix bug #20337, problems with curl -c
  214. - not using patch anymore, it's included in the new source. Keeping
  215. for reference
  216. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  217. - fix bogus req in -devel package
  218. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  219. - devel package needed defattr so that root owns the files
  220. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  221. - update to 7.3
  222. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  223. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - enable SSL support
  225. - fix packager tag
  226. - move buildroot to %%{_tmppath}
  227. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  228. - fixed vendor tag for bug #15028
  229. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  230. - rebuilt
  231. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  232. - workaround alpha build problems with optimizations
  233. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  234. - rebuilt
  235. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  236. - put man pages in correct place
  237. - use %%makeinstall
  238. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  239. - updated to 6.5.2
  240. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  241. - updated sources to 6.2
  242. - gzip man page
  243. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  244. - changed group
  245. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  246. - changelog started
  247. - general cleanups, changed prefix to /usr, added manpage to files section
  248. - including in Powertools