make-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. Summary: A GNU tool which simplifies the build process for users.
  2. Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
  3. Name: make
  4. Epoch: 1
  5. Version: 4.1
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.gnu.org/software/make/
  10. Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
  11. Patch0: make-4.0-getcwd.patch
  12. Patch1: make-4.0-newlines.patch
  13. # Assume we don't have clock_gettime in configure, so that
  14. # make is not linked against -lpthread (and thus does not
  15. # limit stack to 2MB).
  16. Patch2: make-4.0-noclock_gettime.patch
  17. # BZs #142691, #17374
  18. Patch3: make-4.0-j8k.patch
  19. # make sure errno for error reporting is not lost accross _() calls
  20. Patch4: make-4.0-err-reporting.patch
  21. # Upstream: https://savannah.gnu.org/bugs/?30748
  22. # The default value of .SHELL_FLAGS is -c.
  23. Patch5: make-4.0-weird-shell.patch
  24. # make seg faults when run with no arguments
  25. Patch6: make-4.1-rh1277968.patch
  26. # fix ja.po
  27. Patch1000: make-4.1-ja.po.patch
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. Requires(post): /sbin/install-info
  30. Requires(preun): /sbin/install-info
  31. BuildRequires: automake >= 1.7.3
  32. BuildRequires: guile-devel
  33. BuildRequires: perl
  34. BuildRequires: procps
  35. BuildRequires: texinfo
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. %description
  39. A GNU tool for controlling the generation of executables and other
  40. non-source files of a program from the program's source files. Make
  41. allows users to build and install packages without any significant
  42. knowledge about the details of the build process. The details about
  43. how the program should be built are provided for make in the program's
  44. makefile.
  45. The GNU make tool should be installed on your system because it is
  46. commonly used to simplify the process of installing programs.
  47. %description -l ja
  48. プログラムのソースファイルから実行ファイル及びその他のファイルを
  49. 生成する GNU ツールです.Make を使うことでユーザは build 時の
  50. 細かいプロセスを気にせず build しインストールすることが出来ます.
  51. プログラムがどの様に build されるのかは,プログラムの Makefile に
  52. 書かれています.
  53. GNU make ツールは,プログラムのインストールを容易にするのに
  54. 非常によく使われますので,このパッケージは是非インストールして下さい.
  55. %prep
  56. %setup -q
  57. %patch0 -p1
  58. %patch1 -p1
  59. %patch2 -p1
  60. %patch3 -p1
  61. %patch4 -p1
  62. %patch5 -p1
  63. %patch6 -p1
  64. rm -f tests/scripts/features/parallelism.orig
  65. %patch1000 -p1 -b .po
  66. %build
  67. %if %{?_dist_release} == "vl6"
  68. %configure
  69. %else
  70. %configure --with-guile
  71. %endif
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf ${RPM_BUILD_ROOT}
  75. make DESTDIR=$RPM_BUILD_ROOT install
  76. ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
  77. ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
  78. rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
  79. %find_lang %name
  80. %check
  81. echo ============TESTING===============
  82. /usr/bin/env LANG=C make check
  83. echo ============END TESTING===========
  84. %clean
  85. rm -rf ${RPM_BUILD_ROOT}
  86. %post
  87. /sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  88. %preun
  89. if [ $1 = 0 ]; then
  90. /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make). The GNU make utility." || :
  91. fi
  92. %files -f %{name}.lang
  93. %defattr(-,root,root)
  94. %doc NEWS README COPYING AUTHORS
  95. %{_bindir}/*
  96. %{_mandir}/man*/*
  97. %{_infodir}/*.info*
  98. %{_includedir}/gnumake.h
  99. %changelog
  100. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
  101. - new upstream release.
  102. - dropped all patches.
  103. - imported patches from rawhide.
  104. - added Patch1000 to fix ja.po.
  105. * Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
  106. - rebuild with VineSeed environment
  107. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
  108. - new upstream release
  109. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
  110. - rebuild for Vine6
  111. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
  112. - applied new versioning policy
  113. - added BuildRequires: perl (for %%check)
  114. - spec in UTF-8
  115. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
  116. - updated to 3.81 based on Fedora packages
  117. * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
  118. - Always run testsuite with C locale.
  119. - Resolves: #232607
  120. * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
  121. - Fix newline handling for quoted SHELL.
  122. - Resolves: #219409
  123. * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
  124. - Upstream 3.81:
  125. - Contains several backwards incompatible changes. See NEWS inside
  126. the source package to find out more.
  127. - memory patch and error reporting patch were ported to this version.
  128. - updated ja.po
  129. * Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
  130. - added URL
  131. - s/Copyright/License/
  132. - added some patches from fedora development 3.80-8
  133. * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
  134. - make sure errno for error reporting is not lost accross _() calls
  135. - report EOF on read pipe differently from read returning < 0 reporting
  136. * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
  137. - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
  138. * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  139. - add important bug-fixes from make home-page
  140. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
  141. - some patches was included from 3.79.1-17
  142. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
  143. - update ja.po
  144. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
  145. - new upstream release
  146. * Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  147. - 3.79.1-5vl1
  148. - based on 3.79.1-5 from Rawhide
  149. - rebuilt for Vine Linux
  150. - added Japanese summary and description
  151. * Mon Aug 7 2000 Tim Waugh <twaugh@redhat.com>
  152. - change info-dir entry so that 'info make' works (#15029).
  153. * Tue Aug 1 2000 Jakub Jelinek <jakub@redhat.com>
  154. - assume we don't have clock_gettime in configure, so that
  155. make is not linked against -lpthread (and thus does not
  156. limit stack to 2MB).
  157. * Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
  158. - add locale files (#14362).
  159. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  160. - automatic rebuild
  161. * Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
  162. - 3.79.1 bugfix release
  163. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  164. - FHS packaging.
  165. * Sun May 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  166. - Fix build for some odd situations, such as
  167. - previously installed make != GNU make
  168. - /bin/sh != bash
  169. * Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  170. - update to 3.79
  171. * Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
  172. - add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
  173. builds)
  174. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  175. - compress man page.
  176. * Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
  177. - apply patch to fix a /tmp race condition from Thomas Biege
  178. - simplify %install
  179. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  180. - update to 3.78.1.
  181. * Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
  182. - added a serial tag so it upgrades right
  183. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  184. - auto rebuild in the new build environment (release 5)
  185. * Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
  186. - added a patch for large file support in glob
  187. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  188. - update to 3.77
  189. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  190. - translations modified for de, fr, tr
  191. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  192. - udpated from 3.75 to 3.76
  193. - various spec file cleanups
  194. - added install-info support
  195. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  196. - built against glibc