elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define eu_version 0.170
  3. %define eu_release 3
  4. %global nocheck true
  5. Summary: A collection of utilities and DSOs to handle compiled objects
  6. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  7. Name: elfutils
  8. Version: %{eu_version}
  9. Release: %{eu_release}%{?_dist_release}
  10. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  11. Group: Development/Tools
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: flex >= 2.5.4a
  19. BuildRequires: bzip2
  20. BuildRequires: bzip2-devel
  21. BuildRequires: zlib-devel
  22. BuildRequires: xz-devel
  23. BuildRequires: gettext
  24. BuildRequires: m4
  25. BuildRequires: gcc >= 3.4
  26. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  27. BuildRequires: glibc-headers >= 2.3.4-11
  28. %define _gnu %{nil}
  29. %define _program_prefix eu-
  30. %description
  31. Elfutils is a collection of utilities, including ld (a linker),
  32. nm (for listing symbols from object files), size (for listing the
  33. section sizes of an object or archive file), strip (for discarding
  34. symbols), readelf (to see the raw ELF file structures), and elflint
  35. (to check for well-formed ELF files).
  36. %package libs
  37. Summary: Libraries to handle compiled objects
  38. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  39. License: GPLv2+ or LGPLv3+
  40. Group: System Environment/Libraries
  41. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  42. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  43. Conflicts: elfutils < %{version}-%{release}
  44. Conflicts: elfutils > %{version}-%{release}
  45. Conflicts: elfutils-devel < %{version}-%{release}
  46. Conflicts: elfutils-devel > %{version}-%{release}
  47. %description libs
  48. The elfutils-libs package contains libraries which implement DWARF, ELF,
  49. and machine-specific ELF handling. These libraries are used by the programs
  50. in the elfutils package. The elfutils-devel package enables building
  51. other programs using these libraries.
  52. %package devel
  53. Summary: Development libraries to handle compiled objects
  54. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  55. License: GPLv2+ or LGPLv3+
  56. Group: Development/Libraries
  57. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  58. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  59. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  60. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  61. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  62. %description devel
  63. The elfutils-devel package contains the libraries to create
  64. applications for handling compiled objects. libebl provides some
  65. higher-level ELF access functionality. libdw provides access to
  66. the DWARF debugging information. libasm provides a programmable
  67. assembler interface.
  68. %package devel-static
  69. Summary: Static archives to handle compiled objects
  70. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  71. License: GPLv2+ or LGPLv3+
  72. Group: Development/Libraries
  73. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  74. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  75. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  76. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  77. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  78. %description devel-static
  79. The elfutils-devel-static package contains the static archives
  80. with the code to handle compiled objects.
  81. %package libelf
  82. Summary: Library to read and write ELF files
  83. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  84. License: GPLv2+ or LGPLv3+
  85. Group: System Environment/Libraries
  86. Provides: libelf = %{version}-%{release}
  87. Obsoletes: libelf <= 0.8.2-2
  88. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  89. Conflicts: elfutils < %{version}-%{release}
  90. Conflicts: elfutils > %{version}-%{release}
  91. Conflicts: elfutils-libs < %{version}-%{release}
  92. Conflicts: elfutils-libs > %{version}-%{release}
  93. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  94. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  95. %description libelf
  96. The elfutils-libelf package provides a DSO which allows reading and
  97. writing ELF files on a high level. Third party programs depend on
  98. this package to read internals of ELF files. The programs of the
  99. elfutils package use it also to generate new ELF files.
  100. %package libelf-devel
  101. Summary: Development support for libelf
  102. Summary(ja): libelf の開発用ライブラリ
  103. License: GPLv2+ or LGPLv3+
  104. Group: Development/Libraries
  105. Provides: libelf-devel = %{version}-%{release}
  106. Obsoletes: libelf-devel <= 0.8.2-2
  107. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  108. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  109. Conflicts: libelf-devel < %{version}-%{release}
  110. %description libelf-devel
  111. The elfutils-libelf-devel package contains the libraries to create
  112. applications for handling compiled objects. libelf allows you to
  113. access the internals of the ELF object file format, so you can see the
  114. different sections of an ELF file.
  115. %package libelf-devel-static
  116. Summary: Static archive of libelf
  117. Summary(ja): libelf の静的ライブラリ
  118. License: GPLv2+ or LGPLv3+
  119. Group: Development/Libraries
  120. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  121. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  122. %description libelf-devel-static
  123. The elfutils-libelf-static package contains the static archive
  124. for libelf.
  125. # compat32
  126. %package -n compat32-%{name}-libelf
  127. Summary: Library to read and write ELF files
  128. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  129. License: GPLv2+ or LGPLv3+
  130. Group: System Environment/Libraries
  131. Provides: compat32-libelf = %{version}-%{release}
  132. %description -n compat32-%{name}-libelf
  133. The elfutils-libelf package provides a DSO which allows reading and
  134. writing ELF files on a high level. Third party programs depend on
  135. this package to read internals of ELF files. The programs of the
  136. elfutils package use it also to generate new ELF files.
  137. %prep
  138. %setup -q
  139. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  140. %build
  141. # Remove -Wall from default flags. The makefiles enable enough warnings
  142. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  143. # the makefiles disable some specific warnings for specific code.
  144. # But add -Wformat explicitly for use with -Werror=format-security which
  145. # doesn't work without -Wformat (enabled by -Wall).
  146. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  147. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  148. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  149. make -s %{?_smp_mflags}
  150. %install
  151. rm -rf ${RPM_BUILD_ROOT}
  152. make -s install DESTDIR=${RPM_BUILD_ROOT}
  153. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  154. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  155. %find_lang %{name}
  156. # XXX Nuke unpackaged files
  157. { cd ${RPM_BUILD_ROOT}
  158. rm -f .%{_bindir}/eu-ld
  159. }
  160. %check
  161. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  162. %clean
  163. rm -rf ${RPM_BUILD_ROOT}
  164. %post libs -p /sbin/ldconfig
  165. %postun libs -p /sbin/ldconfig
  166. %post libelf -p /sbin/ldconfig
  167. %postun libelf -p /sbin/ldconfig
  168. %post -n compat32-%{name}-libelf -p /sbin/ldconfig
  169. %postun -n compat32-%{name}-libelf -p /sbin/ldconfig
  170. %files -f %{name}.lang
  171. %defattr(-,root,root)
  172. %doc README TODO
  173. %{_bindir}/eu-addr2line
  174. %{_bindir}/eu-ar
  175. %{_bindir}/eu-elfcmp
  176. %{_bindir}/eu-elflint
  177. %{_bindir}/eu-findtextrel
  178. %{_bindir}/eu-nm
  179. %{_bindir}/eu-objdump
  180. %{_bindir}/eu-ranlib
  181. %{_bindir}/eu-readelf
  182. %{_bindir}/eu-size
  183. %{_bindir}/eu-stack
  184. %{_bindir}/eu-strings
  185. %{_bindir}/eu-strip
  186. #%{_bindir}/eu-ld
  187. %{_bindir}/eu-unstrip
  188. %{_bindir}/eu-make-debug-archive
  189. %{_bindir}/eu-elfcompress
  190. %files libs
  191. %defattr(-,root,root)
  192. %{_libdir}/libasm-%{version}.so
  193. %{_libdir}/libasm.so.*
  194. %{_libdir}/libdw-%{version}.so
  195. %{_libdir}/libdw.so.*
  196. %dir %{_libdir}/elfutils
  197. %{_libdir}/elfutils/lib*.so
  198. %files devel
  199. %defattr(-,root,root)
  200. %{_includedir}/dwarf.h
  201. %dir %{_includedir}/elfutils
  202. %{_includedir}/elfutils/elf-knowledge.h
  203. %{_includedir}/elfutils/known-dwarf.h
  204. %{_includedir}/elfutils/libasm.h
  205. %{_includedir}/elfutils/libebl.h
  206. %{_includedir}/elfutils/libdw.h
  207. %{_includedir}/elfutils/libdwelf.h
  208. %{_includedir}/elfutils/libdwfl.h
  209. %{_includedir}/elfutils/version.h
  210. %{_libdir}/libebl.a
  211. %{_libdir}/libasm.so
  212. %{_libdir}/libdw.so
  213. %{_libdir}/pkgconfig/libdw.pc
  214. %files devel-static
  215. %defattr(-,root,root)
  216. %{_libdir}/libasm.a
  217. %{_libdir}/libdw.a
  218. %files libelf
  219. %defattr(-,root,root)
  220. %{_libdir}/libelf-%{version}.so
  221. %{_libdir}/libelf.so.*
  222. %files libelf-devel
  223. %defattr(-,root,root)
  224. %{_includedir}/libelf.h
  225. %{_includedir}/gelf.h
  226. %{_includedir}/nlist.h
  227. %{_libdir}/libelf.so
  228. %{_libdir}/pkgconfig/libelf.pc
  229. %files libelf-devel-static
  230. %defattr(-,root,root)
  231. %{_libdir}/libelf.a
  232. %if %{build_compat32}
  233. %files -n compat32-%{name}-libelf
  234. %defattr(-,root,root)
  235. %{_libdir}/libelf-%{version}.so
  236. %{_libdir}/libelf.so.*
  237. %endif
  238. %changelog
  239. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
  240. - rebuilt
  241. - 2vl7 was skipped (used for vl6)
  242. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  243. - updated to 0.170.
  244. - dropped all patches.
  245. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  246. - rebuild with gcc-5.4.0
  247. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  248. - create compat32-elfutils-libelf subpackage
  249. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  250. - update to 0.161
  251. - added Japanese summary
  252. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  253. - update to 0.157
  254. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  255. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  256. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  257. - update to 0.152
  258. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  259. - elfutils-libs: changed Group to System Environment/Libraries
  260. - elfutils-libelf: changed Group to System Environment/Libraries
  261. - elfutils-devel: changed Group to Development/Libraries
  262. - elfutils-devel-static: changed Group to Development/Libraries
  263. - elfutils-libelf-devel: changed Group to Development/Libraries
  264. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  265. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  266. - merged with Fedora 9 0.135-1
  267. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  268. - applied new versioning policy
  269. - added elfutils-0.131-readelf_c.patch
  270. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  271. - new upstream release
  272. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  273. - remove Obsoletes: libelf, libelf-devel from elfutils
  274. - add Obsoletes: libelf to elfutils-libelf
  275. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  276. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  277. - Update to 0.135
  278. - libdwfl: bug fixes
  279. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  280. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  281. - Update to 0.134
  282. - elflint: backend improvements for sparc, alpha (#204170)
  283. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  284. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  285. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  286. - Update to 0.133
  287. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  288. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  289. - libdwfl: bug fixes and optimization in relocation handling
  290. - elfcmp: bug fix for non-allocated section handling
  291. - ld: implement newer features of binutils linker.
  292. - Install eu-objdump and libasm, now has limited disassembler support.
  293. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  294. - Update to 0.132
  295. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  296. - eu-readelf: Fix handling of ET_REL files in archives.
  297. - libcpu: Implement x86 and x86-64 disassembler.
  298. - libasm: Add interface for disassembler.
  299. - all programs: add debugging of branch prediction.
  300. - libelf: new function elf_scnshndx.
  301. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  302. - Update to 0.131
  303. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  304. bug fixes for oddly-formatted DWARF
  305. - libdwfl: bug fixes in offline archive support, symbol table handling;
  306. apply partial relocations for dwfl_module_address_section on ET_REL
  307. - libebl: powerpc backend support for Altivec registers
  308. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  309. - Fix ET_REL support.
  310. - Fix odd indentation in eu-readelf -x output.
  311. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  312. - Update to 0.130
  313. - eu-readelf -p option can take an argument like -x for one section
  314. - eu-readelf --archive-index (or -c)
  315. - eu-readelf -n improved output for core dumps
  316. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  317. - eu-elflint: ditto
  318. - eu-elflint: stricter checks on debug sections
  319. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  320. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  321. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  322. - libebl: backend improvements (#324031)
  323. - libdwfl: build_id support, new functions for it
  324. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  325. - libdwfl offline archive support, new script eu-make-debug-archive
  326. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  327. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  328. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  329. - Update to 0.129
  330. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  331. - addr2line: new option --symbols (or -S)
  332. - libdw: dwarf_getscopes fixes (#230235)
  333. - libdwfl: dwfl_module_addrsym fixes (#249490)
  334. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  335. - Update to 0.128
  336. - new program: unstrip
  337. - elfcmp: new option --hash-inexact
  338. - Replace Conflicts: with Provides/Requires using -arch
  339. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  340. - Update to 0.127
  341. - libdw: new function dwarf_getsrcdirs
  342. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  343. dwfl_module_address_section
  344. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  345. - Update to 0.126
  346. - New program eu-ar.
  347. - libdw: fix missing dwarf_getelf (#227206)
  348. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  349. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  350. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  351. - Fix overeager warn_unused_result build failures.
  352. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  353. - Update to 0.125
  354. - elflint: Compare DT_GNU_HASH tests.
  355. - move archives into -static RPMs
  356. - libelf, elflint: better support for core file handling
  357. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  358. - Resolves: RHBZ #220817, RHBZ #213792
  359. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  360. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  361. - Update to 0.124
  362. - libebl: fix ia64 reloc support (#206981)
  363. - libebl: sparc backend support for return value location
  364. - libebl, libdwfl: backend register name support extended with more info
  365. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  366. - readelf, elflint: trivial bugs fixed
  367. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  368. - Update to 0.123
  369. - libebl: Backend build fixes, thanks to Stepan Kasal.
  370. - libebl: ia64 backend support for register names, return value location
  371. - libdwfl: Handle truncated linux kernel module section names.
  372. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  373. - elflint: Fix checks to permit --hash-style=gnu format.
  374. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  375. - Fix warnings in elflint compilation.
  376. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  377. - Update to 0.122
  378. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  379. - libebl: add function to test for relative relocation
  380. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  381. - elflint, readelf: add support for DT_GNU_HASH
  382. - libelf: add elf_gnu_hash
  383. - elflint, readelf: add support for 64-bit SysV-style hash tables
  384. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  385. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  386. - Update to 0.121
  387. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  388. - make all installed headers usable in C++ code (#193153).
  389. - eu-readelf: better output format.
  390. - eu-elflint: fix tests of dynamic section content.
  391. - libdw, libdwfl: handle files without aranges info.
  392. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  393. - rebuild to pick up -devel deps
  394. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  395. - Update to 0.120
  396. - License changed to GPL, with some exceptions for using
  397. the libelf, libebl, libdw, and libdwfl library interfaces.
  398. Red Hat elfutils is an included package of the Open Invention Network.
  399. - dwarf.h updated for DWARF 3.0 final specification.
  400. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  401. - libdwfl: New function dwfl_version; fixes for offline.
  402. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  403. - bump again for double-long bug on ppc(64)
  404. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  405. - rebuilt for new gcc4.1 snapshot and glibc changes
  406. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  407. - update to 0.119
  408. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  409. - rebuilt
  410. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  411. - update to 0.118
  412. - elflint: more tests.
  413. - libdwfl: New function dwfl_module_register_names.
  414. - libebl: New backend hook for register names.
  415. - Make sure -fexceptions is always in CFLAGS.
  416. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  417. - update to 0.117
  418. - libdwfl: New function dwfl_module_return_value_location (#166118)
  419. - libebl: Backend improvements for several CPUs
  420. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  421. - update to 0.116
  422. - libdw fixes, API changes and additions
  423. - libdwfl fixes (#169672)
  424. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  425. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  426. - Update requires/conflicts for better biarch update behavior.
  427. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  428. - update to 0.115
  429. - New program eu-strings.
  430. - libdw: New function dwarf_getscopes_die.
  431. - libelf: speed-ups of non-mmap reading.
  432. - Implement --enable-gcov option for configure.
  433. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  434. - update to 0.114
  435. - new program eu-ranlib
  436. - libdw: new calls for inlines
  437. - libdwfl: new calls for offline modules
  438. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  439. - update to 0.113
  440. - elflint: relax a bit. Allow version definitions for defined symbols
  441. against DSO versions also for symbols in nobits sections.
  442. Allow .rodata section to have STRINGS and MERGE flag set.
  443. - strip: add some more compatibility with binutils.
  444. - libdwfl: bug fixes.
  445. - Separate libdw et al into elfutils-libs subpackage.
  446. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  447. - update to 0.112
  448. - elfcmp: some more relaxation.
  449. - elflint: many more tests, especially regarding to symbol versioning.
  450. - libelf: Add elfXX_offscn and gelf_offscn.
  451. - libasm: asm_begin interface changes.
  452. - libebl: Add three new interfaces to directly access machine, class,
  453. and data encoding information.
  454. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  455. - update portability patch
  456. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  457. - update to 0.111
  458. - libdwfl library now merged into libdw
  459. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  460. - update to 0.110
  461. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  462. - update to 0.109
  463. - verify that libebl modules are from the same build
  464. - new eu-elflint checks on copy relocations
  465. - new program eu-elfcmp
  466. - new experimental libdwfl library
  467. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  468. - robustification of eu-strip and eu-readelf
  469. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  470. - more robustification
  471. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  472. - robustification
  473. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  474. - update to 0.108
  475. - merge strip fixes
  476. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  477. - update elf.h from glibc
  478. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  479. - fix strip -f byte-swapping bug
  480. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  481. - update to 0.107
  482. - readelf: improve DWARF output format
  483. - elflint: -d option to support checking separate debuginfo files
  484. - strip: fix ET_REL debuginfo files (#156341)
  485. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  486. - fix some bugs in new code, reenable make check
  487. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  488. - disable make check for most arches, for now
  489. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  490. - update to 0.106
  491. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  492. - update to 0.104
  493. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  494. - update to 0.103
  495. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  496. - update to 0.101.
  497. - use %%configure macro to get CFLAGS etc. right
  498. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  499. - upgrade to 0.99.
  500. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  501. - upgrade to 0.97.
  502. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  503. - upgrade to 0.96.
  504. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  505. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  506. warning
  507. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  508. - rebuilt
  509. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  510. - upgrade to 0.95.
  511. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  512. - rebuilt
  513. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  514. - rebuilt
  515. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  516. - upgrade to 0.94
  517. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  518. - upgrade to 0.93
  519. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  520. - full version
  521. - macroized spec file for GPL or OSL builds
  522. - include only libelf under GPL plus wrapper scripts
  523. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  524. - macroized spec file for GPL or OSL builds
  525. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  526. - split elfutils-devel into two packages.
  527. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  528. - include only libelf under GPL plus wrapper scripts
  529. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  530. - readelf, not readline, in %%description (#111214).
  531. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  532. - update to 0.89 (fix eu-strip)
  533. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  534. - update to 0.86 (fix eu-strip on s390x/alpha)
  535. - libebl is an archive now; remove references to DSO
  536. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  537. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  538. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  539. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  540. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  541. - upgrade to 0.82 (strip tests fixed on big-endian).
  542. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  543. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  544. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  545. - upgrade to 0.80 (debugedit changes for kernel in progress).
  546. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  547. - rebuilt
  548. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  549. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  550. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  551. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  552. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  553. - debuginfo rebuild
  554. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  555. - use the correct way of identifying the section via the sh_info link.
  556. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  557. - update to 0.75 (eu-strip -g fix)
  558. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  559. - update to 0.74 (fix for writing with some non-dirty sections)
  560. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  561. - another -0.73 update (with sparc fixes).
  562. - do "make check" in %%check, not %%install, section.
  563. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  564. - update to 0.73 (with s390 fixes).
  565. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  566. - rebuilt
  567. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  568. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  569. - fix other warnings
  570. - reenable checks on s390x
  571. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  572. - temporarily disable checks on s390x, until someone has
  573. time to look at it
  574. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  575. - update to 0.72
  576. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  577. - update to 0.71
  578. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  579. - update to 0.69.
  580. - add "make check" and segfault avoidance patch.
  581. - elfutils-libelf needs to run ldconfig.
  582. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  583. - update to 0.68.
  584. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  585. - update to 0.67.
  586. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  587. - update to 0.65.
  588. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  589. - update to 0.64.
  590. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  591. - split packages further into elfutils-libelf
  592. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  593. - update to 0.63.
  594. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  595. - Adjust for dropping libtool
  596. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  597. - update to 0.59
  598. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  599. - update to 0.56
  600. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  601. - update to 0.54
  602. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  603. - update to 0.53
  604. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  605. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  606. - get beehive to punch a rhpkg generated package.
  607. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  608. - build in 8.0.1.
  609. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  610. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  611. - Add libelf-devel to conflicts for elfutils-devel
  612. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  613. - Split into runtime and devel package
  614. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  615. - integrate into official sources
  616. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  617. - Swaddle.