notification-daemon-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. %define gtk2_version 2.10.0
  2. %define glib2_version 2.8.0
  3. %define dbus_version 0.60
  4. %define libnotify_version 0.4.0
  5. Summary: Notification Daemon
  6. Name: notification-daemon
  7. Version: 0.4.0
  8. Release: 8%{?_dist_release}
  9. URL: http://www.galago-project.org/specs/notification/
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Source0: %{name}-%{version}.tar.bz2
  13. Source1: notification-daemon-0.4.0-ja.po
  14. Patch1: notification-daemon-0.4.0-ja.patch
  15. # patches from ubuntu
  16. Patch103: notification-daemon-0.4.0-fix-xinerama-stack.patch
  17. Patch104: notification-daemon-0.4.0-dont-crash-on-critical-warnings.patch
  18. Patch105: notification-daemon-0.4.0-spacing.patch
  19. Patch107: notification-daemon-0.4.0-memleak-daemon.patch
  20. Patch109: notification-daemon-0.4.0-change-themes-crash-rev1.patch
  21. # vine theme (based on coco) and vine5 theme (old theme)
  22. # http://github.com/tatofoo/notification-daemon-engine-coco
  23. Source200: notification-daemon-engine-vine.tar.bz2
  24. # Vine patch
  25. # use gvfs-open instead of gnome-open
  26. Patch300: notification-daemon-0.4.0-browser.patch
  27. # dirty hack to change notification bubble position.
  28. Patch310: notification-daemon-0.4.0-position.patch
  29. # add vine and vine5 theme
  30. Patch320: notification-daemon-0.4.0-vine-theme.patch
  31. # change default to slider
  32. Patch330: notification-daemon-0.4.0-default-theme.patch
  33. # change default notify location to TOP_RIGHT
  34. Patch340: notification-daemon-0.4.0-location.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. Requires: dbus >= %{dbus_version}
  37. Requires: dbus-glib >= %{dbus_version}
  38. Requires(post): GConf2
  39. BuildRequires: glib2-devel >= %{glib2_version}
  40. BuildRequires: dbus-devel >= %{dbus_version}
  41. BuildRequires: dbus-glib-devel >= %{dbus_version}
  42. BuildRequires: libnotify-devel >= %{libnotify_version}
  43. BuildRequires: libsexy-devel
  44. BuildRequires: libwnck-devel
  45. BuildRequires: GConf2-devel
  46. BuildRequires: libglade2-devel
  47. %description
  48. notification-daemon is the server implementation of the freedesktop.org
  49. desktop notification specification.
  50. Vendor: Project Vine
  51. Distribution: Vine Linux
  52. Packager: daisuke
  53. %prep
  54. %setup -q -a 200
  55. %patch1 -p1 -b .ja
  56. %patch103 -p1
  57. %patch104 -p1
  58. %patch105 -p0
  59. %patch107 -p1
  60. %patch109 -p1
  61. %patch300 -p1
  62. %patch310 -p1
  63. %patch320 -p1
  64. %patch330 -p1
  65. %patch340 -p1
  66. # install japanese message catalog
  67. %{__cp} %{SOURCE1} po/ja.po
  68. %build
  69. autoreconf -f -i
  70. %configure --disable-schemas-install
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  75. %find_lang %name
  76. # remove unpackaged files
  77. rm -f $RPM_BUILD_ROOT%{_libdir}/notification-daemon-1.0/engines/*.{a,la}
  78. # install desktop file
  79. desktop-file-install --delete-original \
  80. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  81. --add-category DesktopSettings \
  82. ${RPM_BUILD_ROOT}%{_datadir}/applications/notification-properties.desktop
  83. %pre
  84. if [ "$1" -gt 1 ]; then
  85. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  86. gconftool-2 --makefile-uninstall-rule \
  87. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  88. fi
  89. %post
  90. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  91. gconftool-2 --makefile-install-rule \
  92. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  93. touch --no-create %{_datadir}/icons/hicolor
  94. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  95. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  96. fi
  97. %preun
  98. if [ "$1" -eq 0 ]; then
  99. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  100. gconftool-2 --makefile-uninstall-rule \
  101. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  102. fi
  103. %postun
  104. touch --no-create %{_datadir}/icons/hicolor
  105. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  106. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  107. fi
  108. %clean
  109. rm -rf %{buildroot}
  110. %files -f %{name}.lang
  111. %defattr(-,root,root)
  112. %doc COPYING ChangeLog NEWS
  113. %{_bindir}/notification-properties
  114. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  115. %dir %{_libdir}/notification-daemon-1.0
  116. %dir %{_libdir}/notification-daemon-1.0/engines
  117. %{_libdir}/notification-daemon-1.0/engines/*.so
  118. %{_libexecdir}/notification-daemon
  119. %{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
  120. %{_datadir}/applications/notification-properties.desktop
  121. %{_datadir}/icons/hicolor/16x16/apps/notification-properties.png
  122. %{_datadir}/icons/hicolor/22x22/apps/notification-properties.png
  123. %{_datadir}/icons/hicolor/24x24/apps/notification-properties.png
  124. %{_datadir}/icons/hicolor/32x32/apps/notification-properties.png
  125. %{_datadir}/icons/hicolor/48x48/apps/notification-properties.png
  126. %{_datadir}/icons/hicolor/scalable/apps/notification-properties.svg
  127. %{_datadir}/notification-daemon/notification-properties.glade
  128. %changelog
  129. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-8
  130. - add missing BuildRequires: GConf2-devel, libglade2-devel
  131. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7
  132. - rebuilt with rpm-4.8.1-3
  133. * Sun May 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-6
  134. - update Source201
  135. * Sat May 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-5
  136. - rebuild with new toolchain
  137. - update Source201 (add modified coco theme as new default)
  138. - add patch300 to use gvfs-open instead of gnome-open
  139. - add patch310 to change notification bubble position
  140. - add patch320 to add new vine theme
  141. - add patch340 to change default notification localtion to top_right.
  142. - add BR: libwnck-devel
  143. * Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-4
  144. - add Categories=DesktopSettings for notification-properties.desktop
  145. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0-3
  146. - add Source200, Patch200,201
  147. - add vine theme engine based on ubuntu engine.
  148. - add patch101-109 from ubuntu
  149. - Patch103: fix xinerama stack
  150. - Patch104: dont crash on critical warnings
  151. - Patch105: fix notification spacing
  152. - Patch107: fix memleak
  153. - Patch109: fix crash on theme changing
  154. * Sat Mar 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-2
  155. - add japanese translation (Source1 and Patch1)
  156. - prperly install/uninstall gconf schemas
  157. - update gtk icon cache with %%post, %%postun
  158. * Fri Mar 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1
  159. - new upstream release
  160. - change required gtk2 version to 2.10.0
  161. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-1
  162. - applied new versioning policy
  163. * Tue Dec 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl2
  164. - rebuilt with libwnck 2.20.2
  165. * Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.7-0vl1
  166. - new upstream release
  167. - rebuilt with libsexy 0.1.10
  168. - added BuildRequores: libsexy-devel
  169. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.5-0vl1
  170. - new upstream release
  171. * Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4-0vl1
  172. - initial build for Vine Linux partialy based on FC package.
  173. * Wed Mar 08 2006 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-9
  174. - Add patch to fix struct handling in the dbus glib binding for dbus 0.61
  175. so image data works again
  176. * Tue Feb 14 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-8
  177. - BuildRequires love, for all you lovers out there.
  178. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-7.1
  179. - bump again for double-long bug on ppc(64)
  180. * Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
  181. - remove empty scripts from .spec file
  182. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.1-6.1
  183. - rebuilt for new gcc4.1 snapshot and glibc changes
  184. * Fri Feb 3 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-6
  185. - Add patch to determine whether a compositing manager is running
  186. when drawing a new notification bubble, as long as the CM grabs
  187. the appropriate XSelection.
  188. * Fri Jan 20 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-5
  189. - Make it so that marked-up messages appear with markup
  190. * Thu Jan 12 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-4
  191. - Provide desktop-notification-daemon, since libnotify requires a
  192. notification deamon, but not this specific one. Other notification
  193. daemons can exist on the system so long as they meet the provides
  194. (and the API of course).
  195. * Mon Jan 9 2006 Christopher Aillon <caillon@redhat.com> - 0.3.1-3
  196. - Fix positioning of the notification bubble to not draw off-screen
  197. * Wed Dec 14 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  198. - Actuall release of 0.3.1
  199. * Thu Nov 17 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-1
  200. - Upgrade to upstream 0.3.1
  201. * Tue Nov 15 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.0-1
  202. - inital build