libsndfile-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define OCT_SITE_D %{_datadir}/octave/site/m
  3. Summary: A library to handle various audio file formats.
  4. Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
  5. Name: libsndfile
  6. Version: 1.0.25
  7. Release: 1%{?_dist_release}
  8. Source: http://www.mega-nerd.com/libsndfile/%{name}-%{version}.tar.gz
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://www.mega-nerd.com/libsndfile/
  12. # security fix
  13. # Patch100: libsndfile-1.0.16_CVE-2007-4974.patch
  14. # Patch110: libsndfile-1.0.20_fix-dev-by-zero.patch
  15. Patch100: libsndfile-1.0.21_CVE-2011-2696.patch
  16. Requires: alsa-lib
  17. BuildRequires: alsa-lib-devel
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. libsndfile is a C library for reading and writing sound files such as
  23. AIFF, AU and WAV files through one standard interface. It can currently
  24. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  25. point WAV files and a number of compressed formats.
  26. %description -l ja
  27. libsndfile is a C library for reading and writing sound files such as
  28. AIFF, AU and WAV files through one standard interface. It can currently
  29. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  30. point WAV files and a number of compressed formats.
  31. %package devel
  32. Summary: Libraries, includes, etc to develop libsndfile applications
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. Libraries, include files, etc you can use to develop libsndfile applications.
  37. %description devel -l ja
  38. Libraries, include files, etc you can use to develop libsndfile applications.
  39. # compat32
  40. %package -n compat32-%{name}
  41. Summary: A library to handle various audio file formats.
  42. Summary(ja): さまざまなフォーマットの音声ファイルを扱うライブラリ
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. libsndfile is a C library for reading and writing sound files such as
  46. AIFF, AU and WAV files through one standard interface. It can currently
  47. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  48. point WAV files and a number of compressed formats.
  49. %description -n compat32-%{name} -l ja
  50. libsndfile is a C library for reading and writing sound files such as
  51. AIFF, AU and WAV files through one standard interface. It can currently
  52. read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
  53. point WAV files and a number of compressed formats.
  54. %package -n compat32-%{name}-devel
  55. Summary: Libraries, includes, etc to develop libsndfile applications
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. %description -n compat32-%{name}-devel
  60. Libraries, include files, etc you can use to develop libsndfile applications.
  61. %description -n compat32-%{name}-devel -l ja
  62. Libraries, include files, etc you can use to develop libsndfile applications.
  63. %prep
  64. %setup -q
  65. # security fix
  66. # %patch100 -p1 -b .CVE-2007-4974
  67. # %patch110 -p0 -b .dev-by-zero
  68. %patch100 -p1 -b .CVE-2011-2696
  69. %build
  70. %configure --disable-sqlite --disable-external-libs --disable-octave
  71. %__make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. # htmldir=$RPM_BUILD_ROOT\$\(htmldocdir\) libsndfile1-dev
  75. %makeinstall \
  76. htmldir=$RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
  77. rm -rf html
  78. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev html
  79. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libsndfile1-dev
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %post -n compat32-%{name} -p /sbin/ldconfig
  86. %postun -n compat32-%{name} -p /sbin/ldconfig
  87. %files
  88. %defattr(-,root,root)
  89. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README html
  90. %{_libdir}/libsndfile.so.*
  91. %{_bindir}/*
  92. %{_mandir}/man1/*
  93. # %{_datadir}/octave/site/m/*
  94. %files devel
  95. %defattr(-,root,root)
  96. %{_libdir}/libsndfile.so
  97. %{_includedir}/*
  98. %{_libdir}/pkgconfig/sndfile.pc
  99. # compat32
  100. %if %{build_compat32}
  101. %files -n compat32-%{name}
  102. %defattr(-,root,root)
  103. %{_libdir}/libsndfile.so.*
  104. %files -n compat32-%{name}-devel
  105. %defattr(-,root,root)
  106. %{_libdir}/libsndfile.so
  107. %{_libdir}/pkgconfig/sndfile.pc
  108. %endif
  109. %changelog
  110. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.25-1
  111. - new upstream release
  112. * Sun Jul 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-3
  113. - change spec filename (-vl)
  114. * Sat Jul 30 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.0.21-2
  115. - add patch100 for fix CVE-2011-2696 (IOF) from debian, thanks.
  116. * Wed Sep 22 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21-1
  117. - new upstream release
  118. - built with rpm-4.8.1-1
  119. * Mon Jun 1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.20-1vl5
  120. - new upstream release with security fix (CVE-2009-1788, 1791)
  121. - add patch110 to fix devide by 0 issues
  122. - drop patch100 (is included in new release)
  123. - change configure option to fix new release
  124. - revome "TODO" file from file list
  125. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.17-3
  126. - added compat32 package for x86_64 arch support
  127. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-2
  128. - spec in utf-8
  129. - remove static lib
  130. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-1vl5
  131. - applied new versioning policy
  132. - removed lib*.la file from devel package
  133. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl2
  134. - rebuild for VineSeed
  135. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.17-0vl1
  136. - new upstream release
  137. * Mon Oct 22 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.16-0vl3.1
  138. - add patch100 for fix CVE-2007-4974 (PCM Data Handling Buffer Overflow)
  139. - built for VinePlus 4.x
  140. * Fri Nov 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.16-0vl3
  141. - add BuildRequires: alsa-lib-devel
  142. - add '--disable-sqlite --disable-flac' options to %%configure
  143. * Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl2
  144. - rebuilt for VineSeed Plus
  145. * Mon May 01 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-0vl1
  146. - new upstream release
  147. - fixed Japanese summary
  148. * Wed Feb 08 2006 Atsushi SHICHI <ats7@a.email.ne.jp> 1.0.13-1vl1
  149. - initial build for VinePlus/3.0
  150. - modified spec file
  151. * Sun May 15 2005 Erik de Castro Lopo <erikd@mega-nerd.com>
  152. - Add html files to the files section.
  153. * Tue Sep 16 2003 Erik de Castro Lopo <erikd@mega-nerd.com>
  154. - Apply corrections from Andrew Schultz.
  155. * Mon Oct 21 2002 Erik de Castro Lopo <erikd@mega-nerd.com>
  156. - Force installation of sndfile.pc file.
  157. * Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
  158. - Created libsndfile.spec.in
  159. # end of file