PyQt4-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.5)
  5. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  6. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  7. %define qt4qmake %{_qt4_prefix}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.10.4
  12. Release: 1%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: Development/Languages
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. Patch1: PyQt-x11-gpl-4.10.4-64bit.patch
  19. # HACK! FIXME: ping upstream why this isn't working right. -- Rex
  20. Patch2: PyQt-x11-gpl-4.5.2-QT_SHARED.patch
  21. Patch4: PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: dbus-devel dbus-python-devel
  26. BuildRequires: findutils
  27. BuildRequires: libXext-devel
  28. BuildRequires: phonon-devel
  29. BuildRequires: python-devel
  30. # beware of PyQt4/qscintilla bootstap issues
  31. #BuildRequires: qscintilla
  32. BuildRequires: qt4-devel >= 4.5.0
  33. BuildRequires: qt-assistant-adp-devel
  34. BuildRequires: sip-devel >= 4.13.1
  35. Requires: sip >= 4.13.1
  36. Requires: dbus-python
  37. Requires: qt4
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= 4.5.0
  45. Requires: qt-assistant-adp-devel
  46. Requires: sip-devel >= 4.13.1
  47. %description devel
  48. Files needed to build other bindings for C++ classes that inherit from any
  49. of the Qt4 classes (e.g. KDE or your own).
  50. %prep
  51. %setup -q -n PyQt-x11-gpl-%{version}
  52. %ifarch x86_64
  53. %patch1 -p1 -b .64bit
  54. %endif
  55. %patch2 -p1 -b .QT_SHARED
  56. #patch100 -p1 -b .phononpath_vine
  57. ## permissions
  58. # mark examples non-executable
  59. find examples/ -name "*.py" | xargs chmod a-x
  60. chmod a+rx pyuic/uic/pyuic.py
  61. %build
  62. CFLAGS="${CFLAGS:-%optflags}" \
  63. CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
  64. sed -i "s|0x040f00|0x040e07|" configure.py
  65. sed -i "s|4.15|4.14.7|" configure-ng.py
  66. %{__python} configure.py \
  67. --confirm-license \
  68. --qmake=%{qt4qmake} \
  69. --no-qsci-api \
  70. --verbose
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  75. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  76. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  77. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  78. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  79. ln -s %{_bindir}/pyuic4 \
  80. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc NEWS README
  86. %doc OPENSOURCE-NOTICE.TXT
  87. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  88. %doc LICENSE.GPL3
  89. %{python_sitearch}/PyQt4/
  90. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  91. # fixme? -> sitearch? -- Rex
  92. %{python_sitelib}/dbus/mainloop/qt.so
  93. %{_qt4_plugindir}/designer/*
  94. %files devel
  95. %defattr(-,root,root,-)
  96. %doc doc/*
  97. %doc examples/
  98. %{_bindir}/pylupdate4
  99. %{_bindir}/pyrcc4
  100. %{_bindir}/pyuic4
  101. %{python_sitearch}/PyQt4/uic/pyuic.py*
  102. %{_datadir}/sip/PyQt4/
  103. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  104. %changelog
  105. * Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
  106. - new upstream release
  107. - update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
  108. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
  109. - new upstream release
  110. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
  111. - new upstream release
  112. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
  113. - new upstream release
  114. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
  115. - new upstream release
  116. - update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
  117. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
  118. - rebuild with python-2.7.2
  119. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
  120. - new upstream release
  121. - aaded BR: qt-assistant-adp-devel
  122. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
  123. - update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
  124. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
  125. - new upstream release
  126. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
  127. - re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
  128. - remove %%sip_ver
  129. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
  130. - rebuilt with qt4-4.7.2
  131. * Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
  132. - update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
  133. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  134. - new upstream release
  135. - built with sip-4.12.1 and qt4-4.7.1
  136. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  137. - rebuild with qt4-4.6.3
  138. - fix %qtver (from 4.6.1 to 4.6.3)
  139. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  140. - new upstream release
  141. - rebuilt with sip-4.10.5 and qt4-4.6.3
  142. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  143. - new upstream release
  144. - updated Patch100
  145. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  146. - updated Patch100 to build phonon module
  147. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  148. - new upstream release
  149. - rebuilt with python-2.6.4
  150. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  151. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  152. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  153. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  154. - new upstream release
  155. - added BR: libXext-devel
  156. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  157. - added Patch100 for building phonon modules
  158. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  159. - Initial build for Vine
  160. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  161. - PyQt4-4.5.4
  162. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  164. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  165. - PyQt4-4.5.2
  166. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  167. - fix build with qt-4.5.2
  168. - PyQt4-devel multilib conflict (#509415)
  169. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  170. - PyQt-4.5.1
  171. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  172. - PyQt-4.5
  173. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  174. - fix generation of sip_ver
  175. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  176. - PyQt-4.5-snapshot-20090520
  177. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  178. - rebuild for phonon bindings (#497680)
  179. * Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  180. - move designer plugins to main/runtime (#487622)
  181. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  183. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  184. - rebuild against qt-4.5rc1
  185. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  186. - Rebuild for Python 2.6
  187. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  188. - PyQt-4.4.4
  189. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  190. - PyQt-4.4.3
  191. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  192. - PyQt4 is built without QtWebKit support (#451490)
  193. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  194. - PyQt-4.4.2
  195. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  196. - PyQt-4.4
  197. - License: GPLv3 or GPLv2 with exceptions
  198. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  199. - respin (gcc43)
  200. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  201. - PyQt-4.3.3
  202. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  203. - dbus support (#395741)
  204. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  205. - PyQt-4.3.1
  206. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  207. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  208. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  209. - fix QtDesigner plugin install
  210. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  211. - 64bit QtDesigner patch
  212. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  213. - -devel: Requires: qt4-devel
  214. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  215. - use %%python_sitearch
  216. - License: GPLv2
  217. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  218. - fix python_sitelib typo (wrt chrpath call)
  219. - move %%_bindir stuff to -devel
  220. - mark %%doc examples non-executable
  221. - add shebang to %%_bindir/pyuic4
  222. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  223. - remove rpath from QtDesigner.so
  224. - BR: qt4-devel > 4.3.0-8
  225. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  226. - PyQt4-4.2
  227. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  228. - fix build against multilib'd qt4
  229. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  230. - PyQt4-4.1.1
  231. - BR: sip-devel >= 4.5.1
  232. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  233. - PyQt4-4.1
  234. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  235. - don't own %%_datadir/sip (bug #206633)
  236. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  237. - BR: qt4-devel < 4.2
  238. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  239. - fix reference(s) to qmake(4)
  240. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  241. - PyQt-4.0.1
  242. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  243. - PyQt-4.0(final)
  244. - BR: sip-devel >= 4.4.4 (see bug #199430)
  245. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  246. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  247. - drop usage of (undefined) %%sip_min
  248. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  249. - cleanup for Extras
  250. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  251. - 4.0beta1
  252. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  253. - respin for sip-4.4.3
  254. - use sip-abi, sip-abi-min
  255. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  256. - 20060421 snapshot
  257. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  258. - first try, using 20060417 snapshot